Loading ...
Sorry, an error occurred while loading the content.
 

Re: [PBML] Installing Perl Nert::SSH

Expand Messages
  • vidhut singh
    looks like there is a conflict between 32 bit and 64 bits perl libs . is it 64 bit m/c ? ... From: Dukelow, Don Subject: [PBML] Installing
    Message 1 of 6 , Nov 24 7:40 AM
      looks like there is a conflict between 32 bit and 64 bits perl libs . is it 64 bit m/c ?


      --- On Sun, 23/11/08, Dukelow, Don <dukelow@...> wrote:
      From: Dukelow, Don <dukelow@...>
      Subject: [PBML] Installing Perl Nert::SSH
      To: "perl-beginner@yahoogroups.com" <perl-beginner@yahoogroups.com>
      Date: Sunday, 23 November, 2008, 11:18 PM











      I'm trying to install Perl Net::SSH on a Sun Solaris 10 systen with Perl version 10. I keep gettinh the following erropr when I try to install the GMP library. Can anyone help?



      ld: fatal: file /usr/lib/libc. so: wrong ELF class: ELFCLASS32

      ld: fatal: file /usr/ucblib/ libucb.so: wrong ELF class: ELFCLASS32

      ld: fatal: file /usr/lib/libresolv. so: wrong ELF class: ELFCLASS32

      ld: fatal: file /usr/lib/libsocket. so: wrong ELF class: ELFCLASS32

      ld: fatal: file /usr/lib/libnsl. so: wrong ELF class: ELFCLASS32

      ld: fatal: file /usr/lib/libelf. so: wrong ELF class: ELFCLASS32

      ld: fatal: File processing errors. No output written to .libs/libgmp. so.3.4.4

      *** Error code 1

      make: Fatal error: Command failed for target `libgmp.la'

      Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4

      *** Error code 1

      The following command caused the error:

      set fnord $MAKEFLAGS; amf=$2; \

      dot_seen=no; \

      target=`echo all-recursive | sed s/-recursive/ /`; \ list='tests mpn mpz mpq mpf printf scanf cxx mpbsd demos tune doc'; for subdir in $list; do \

      echo "Making $target in $subdir"; \

      if test "$subdir" = "."; then \

      dot_seen=yes; \

      local_target= "$target- am"; \

      else \

      local_target= "$target" ; \

      fi; \

      (cd $subdir && make $local_target) \

      || case "$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \ done; \ if test "$dot_seen" = "no"; then \

      make "$target-am" || exit 1; \

      fi; test -z "$fail"

      make: Fatal error: Command failed for target `all-recursive'

      Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4

      *** Error code 1

      make: Fatal error: Command failed for target `all'



      -----

      Don Dukelow

      HP/GM GSC33 License Team

      e-mail: dukelow@...

























      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

      [Non-text portions of this message have been removed]
    • Dukelow, Don
      The Solaris 10 is all 64 bit and I thought was using all 64 bit programs, I guess not. What do you mean by 64 bit m/c? ... Don Dukelow HP/GM GSC33 License
      Message 2 of 6 , Nov 24 7:47 AM
        The Solaris 10 is all 64 bit and I thought was using all 64 bit programs, I guess not. What do you mean by 64 bit m/c?


        -----
        Don Dukelow
        HP/GM GSC33 License Team
        Tel: 810-728-3388
        e-mail: dukelow@...



        ________________________________
        From: perl-beginner@yahoogroups.com [mailto:perl-beginner@yahoogroups.com] On Behalf Of vidhut singh
        Sent: Monday, November 24, 2008 10:41 AM
        To: perl-beginner@yahoogroups.com
        Subject: Re: [PBML] Installing Perl Nert::SSH


        looks like there is a conflict between 32 bit and 64 bits perl libs . is it 64 bit m/c ?

        --- On Sun, 23/11/08, Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com>> wrote:
        From: Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com>>
        Subject: [PBML] Installing Perl Nert::SSH
        To: "perl-beginner@yahoogroups.com<mailto:perl-beginner%40yahoogroups.com>" <perl-beginner@yahoogroups.com<mailto:perl-beginner%40yahoogroups.com>>
        Date: Sunday, 23 November, 2008, 11:18 PM

        I'm trying to install Perl Net::SSH on a Sun Solaris 10 systen with Perl version 10. I keep gettinh the following erropr when I try to install the GMP library. Can anyone help?

        ld: fatal: file /usr/lib/libc. so: wrong ELF class: ELFCLASS32

        ld: fatal: file /usr/ucblib/ libucb.so: wrong ELF class: ELFCLASS32

        ld: fatal: file /usr/lib/libresolv. so: wrong ELF class: ELFCLASS32

        ld: fatal: file /usr/lib/libsocket. so: wrong ELF class: ELFCLASS32

        ld: fatal: file /usr/lib/libnsl. so: wrong ELF class: ELFCLASS32

        ld: fatal: file /usr/lib/libelf. so: wrong ELF class: ELFCLASS32

        ld: fatal: File processing errors. No output written to .libs/libgmp. so.3.4.4

        *** Error code 1

        make: Fatal error: Command failed for target `libgmp.la'

        Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4

        *** Error code 1

        The following command caused the error:

        set fnord $MAKEFLAGS; amf=$2; \

        dot_seen=no; \

        target=`echo all-recursive | sed s/-recursive/ /`; \ list='tests mpn mpz mpq mpf printf scanf cxx mpbsd demos tune doc'; for subdir in $list; do \

        echo "Making $target in $subdir"; \

        if test "$subdir" = "."; then \

        dot_seen=yes; \

        local_target= "$target- am"; \

        else \

        local_target= "$target" ; \

        fi; \

        (cd $subdir && make $local_target) \

        || case "$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \ done; \ if test "$dot_seen" = "no"; then \

        make "$target-am" || exit 1; \

        fi; test -z "$fail"

        make: Fatal error: Command failed for target `all-recursive'

        Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4

        *** Error code 1

        make: Fatal error: Command failed for target `all'

        -----

        Don Dukelow

        HP/GM GSC33 License Team

        e-mail: dukelow@...<mailto:dukelow%40hp.com>











        Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

        [Non-text portions of this message have been removed]





        [Non-text portions of this message have been removed]
      • vidhut singh
        seems like the Nert:SSH libs that you downloaded is 32 bit and hence its giving the problem in shared lib creation which is getting compiled by 64 bit gcc /
        Message 3 of 6 , Nov 24 7:55 AM
          seems like the Nert:SSH libs that you downloaded is 32 bit and hence its giving the problem in shared lib creation which is getting compiled by 64 bit gcc / cc.  have you installed 32 bit perl on solaris 10 ?

          --- On Mon, 24/11/08, Dukelow, Don <dukelow@...> wrote:
          From: Dukelow, Don <dukelow@...>
          Subject: RE: [PBML] Installing Perl Nert::SSH
          To: "perl-beginner@yahoogroups.com" <perl-beginner@yahoogroups.com>
          Date: Monday, 24 November, 2008, 9:17 PM











          The Solaris 10 is all 64 bit and I thought was using all 64 bit programs, I guess not. What do you mean by 64 bit m/c?



          -----

          Don Dukelow

          HP/GM GSC33 License Team

          Tel: 810-728-3388

          e-mail: dukelow@...



          ____________ _________ _________ __

          From: perl-beginner@ yahoogroups. com [mailto:perl-beginner@ yahoogroups. com] On Behalf Of vidhut singh

          Sent: Monday, November 24, 2008 10:41 AM

          To: perl-beginner@ yahoogroups. com

          Subject: Re: [PBML] Installing Perl Nert::SSH



          looks like there is a conflict between 32 bit and 64 bits perl libs . is it 64 bit m/c ?



          --- On Sun, 23/11/08, Dukelow, Don <dukelow@...<mailto:dukelow% 40hp.com> > wrote:

          From: Dukelow, Don <dukelow@...<mailto:dukelow% 40hp.com> >

          Subject: [PBML] Installing Perl Nert::SSH

          To: "perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups. com>" <perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups.. com>>

          Date: Sunday, 23 November, 2008, 11:18 PM



          I'm trying to install Perl Net::SSH on a Sun Solaris 10 systen with Perl version 10. I keep gettinh the following erropr when I try to install the GMP library. Can anyone help?



          ld: fatal: file /usr/lib/libc. so: wrong ELF class: ELFCLASS32



          ld: fatal: file /usr/ucblib/ libucb.so: wrong ELF class: ELFCLASS32



          ld: fatal: file /usr/lib/libresolv. so: wrong ELF class: ELFCLASS32



          ld: fatal: file /usr/lib/libsocket. so: wrong ELF class: ELFCLASS32



          ld: fatal: file /usr/lib/libnsl. so: wrong ELF class: ELFCLASS32



          ld: fatal: file /usr/lib/libelf. so: wrong ELF class: ELFCLASS32



          ld: fatal: File processing errors. No output written to .libs/libgmp. so.3.4.4



          *** Error code 1



          make: Fatal error: Command failed for target `libgmp.la'



          Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4



          *** Error code 1



          The following command caused the error:



          set fnord $MAKEFLAGS; amf=$2; \



          dot_seen=no; \



          target=`echo all-recursive | sed s/-recursive/ /`; \ list='tests mpn mpz mpq mpf printf scanf cxx mpbsd demos tune doc'; for subdir in $list; do \



          echo "Making $target in $subdir"; \



          if test "$subdir" = "."; then \



          dot_seen=yes; \



          local_target= "$target- am"; \



          else \



          local_target= "$target" ; \



          fi; \



          (cd $subdir && make $local_target) \



          || case "$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \ done; \ if test "$dot_seen" = "no"; then \



          make "$target-am" || exit 1; \



          fi; test -z "$fail"



          make: Fatal error: Command failed for target `all-recursive'



          Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4



          *** Error code 1



          make: Fatal error: Command failed for target `all'



          -----



          Don Dukelow



          HP/GM GSC33 License Team



          e-mail: dukelow@...<mailto:dukelow% 40hp.com>



          Add more friends to your messenger and enjoy! Go to http://messenger. yahoo..com/ invite/



          [Non-text portions of this message have been removed]



          [Non-text portions of this message have been removed]



























          Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

          [Non-text portions of this message have been removed]
        • Dukelow, Don
          I got it to work by adding different library paths to the LD_LIBRARY_PATH variabe ubtill it worked. Thank You! ... Don Dukelow HP/GM GSC33 License Team Tel:
          Message 4 of 6 , Nov 25 9:58 AM
            I got it to work by adding different library paths to the LD_LIBRARY_PATH variabe ubtill it worked.


            Thank You!


            -----
            Don Dukelow
            HP/GM GSC33 License Team
            Tel: 810-728-3388
            e-mail: dukelow@...



            ________________________________
            From: perl-beginner@yahoogroups.com [mailto:perl-beginner@yahoogroups.com] On Behalf Of vidhut singh
            Sent: Monday, November 24, 2008 10:55 AM
            To: perl-beginner@yahoogroups.com
            Subject: RE: [PBML] Installing Perl Nert::SSH


            seems like the Nert:SSH libs that you downloaded is 32 bit and hence its giving the problem in shared lib creation which is getting compiled by 64 bit gcc / cc. have you installed 32 bit perl on solaris 10 ?

            --- On Mon, 24/11/08, Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com>> wrote:
            From: Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com>>
            Subject: RE: [PBML] Installing Perl Nert::SSH
            To: "perl-beginner@yahoogroups.com<mailto:perl-beginner%40yahoogroups.com>" <perl-beginner@yahoogroups.com<mailto:perl-beginner%40yahoogroups.com>>
            Date: Monday, 24 November, 2008, 9:17 PM

            The Solaris 10 is all 64 bit and I thought was using all 64 bit programs, I guess not. What do you mean by 64 bit m/c?

            -----

            Don Dukelow

            HP/GM GSC33 License Team

            Tel: 810-728-3388

            e-mail: dukelow@...<mailto:dukelow%40hp.com>

            ____________ _________ _________ __

            From: perl-beginner@ yahoogroups. com [mailto:perl-beginner@ yahoogroups. com] On Behalf Of vidhut singh

            Sent: Monday, November 24, 2008 10:41 AM

            To: perl-beginner@ yahoogroups. com

            Subject: Re: [PBML] Installing Perl Nert::SSH

            looks like there is a conflict between 32 bit and 64 bits perl libs . is it 64 bit m/c ?

            --- On Sun, 23/11/08, Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com><mailto:dukelow% 40hp.com> > wrote:

            From: Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com><mailto:dukelow% 40hp.com> >

            Subject: [PBML] Installing Perl Nert::SSH

            To: "perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups. com>" <perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups.. com>>

            Date: Sunday, 23 November, 2008, 11:18 PM

            I'm trying to install Perl Net::SSH on a Sun Solaris 10 systen with Perl version 10. I keep gettinh the following erropr when I try to install the GMP library. Can anyone help?

            ld: fatal: file /usr/lib/libc. so: wrong ELF class: ELFCLASS32

            ld: fatal: file /usr/ucblib/ libucb.so: wrong ELF class: ELFCLASS32

            ld: fatal: file /usr/lib/libresolv. so: wrong ELF class: ELFCLASS32

            ld: fatal: file /usr/lib/libsocket. so: wrong ELF class: ELFCLASS32

            ld: fatal: file /usr/lib/libnsl. so: wrong ELF class: ELFCLASS32

            ld: fatal: file /usr/lib/libelf. so: wrong ELF class: ELFCLASS32

            ld: fatal: File processing errors. No output written to .libs/libgmp. so.3.4.4

            *** Error code 1

            make: Fatal error: Command failed for target `libgmp.la'

            Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4

            *** Error code 1

            The following command caused the error:

            set fnord $MAKEFLAGS; amf=$2; \

            dot_seen=no; \

            target=`echo all-recursive | sed s/-recursive/ /`; \ list='tests mpn mpz mpq mpf printf scanf cxx mpbsd demos tune doc'; for subdir in $list; do \

            echo "Making $target in $subdir"; \

            if test "$subdir" = "."; then \

            dot_seen=yes; \

            local_target= "$target- am"; \

            else \

            local_target= "$target" ; \

            fi; \

            (cd $subdir && make $local_target) \

            || case "$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \ done; \ if test "$dot_seen" = "no"; then \

            make "$target-am" || exit 1; \

            fi; test -z "$fail"

            make: Fatal error: Command failed for target `all-recursive'

            Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4

            *** Error code 1

            make: Fatal error: Command failed for target `all'

            -----

            Don Dukelow

            HP/GM GSC33 License Team

            e-mail: dukelow@...<mailto:dukelow%40hp.com><mailto:dukelow% 40hp.com>

            Add more friends to your messenger and enjoy! Go to http://messenger. yahoo..com/ invite/

            [Non-text portions of this message have been removed]

            [Non-text portions of this message have been removed]











            Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

            [Non-text portions of this message have been removed]





            [Non-text portions of this message have been removed]
          • vidhut singh
            oh great ..... you are welcome ! :) ... From: Dukelow, Don Subject: RE: [PBML] Installing Perl Nert::SSH To: perl-beginner@yahoogroups.com
            Message 5 of 6 , Nov 25 9:13 PM
              oh great ..... you are welcome ! :)

              --- On Tue, 25/11/08, Dukelow, Don <dukelow@...> wrote:
              From: Dukelow, Don <dukelow@...>
              Subject: RE: [PBML] Installing Perl Nert::SSH
              To: "perl-beginner@yahoogroups.com" <perl-beginner@yahoogroups.com>
              Date: Tuesday, 25 November, 2008, 11:28 PM











              I got it to work by adding different library paths to the LD_LIBRARY_PATH variabe ubtill it worked.



              Thank You!



              -----

              Don Dukelow

              HP/GM GSC33 License Team

              Tel: 810-728-3388

              e-mail: dukelow@...



              ____________ _________ _________ __

              From: perl-beginner@ yahoogroups. com [mailto:perl-beginner@ yahoogroups. com] On Behalf Of vidhut singh

              Sent: Monday, November 24, 2008 10:55 AM

              To: perl-beginner@ yahoogroups. com

              Subject: RE: [PBML] Installing Perl Nert::SSH



              seems like the Nert:SSH libs that you downloaded is 32 bit and hence its giving the problem in shared lib creation which is getting compiled by 64 bit gcc / cc. have you installed 32 bit perl on solaris 10 ?



              --- On Mon, 24/11/08, Dukelow, Don <dukelow@...<mailto:dukelow% 40hp.com> > wrote:

              From: Dukelow, Don <dukelow@...<mailto:dukelow% 40hp.com> >

              Subject: RE: [PBML] Installing Perl Nert::SSH

              To: "perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups. com>" <perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups.. com>>

              Date: Monday, 24 November, 2008, 9:17 PM



              The Solaris 10 is all 64 bit and I thought was using all 64 bit programs, I guess not. What do you mean by 64 bit m/c?



              -----



              Don Dukelow



              HP/GM GSC33 License Team



              Tel: 810-728-3388



              e-mail: dukelow@...<mailto:dukelow% 40hp.com>



              ____________ _________ _________ __



              From: perl-beginner@ yahoogroups. com [mailto:perl- beginner@ yahoogroups. com] On Behalf Of vidhut singh



              Sent: Monday, November 24, 2008 10:41 AM



              To: perl-beginner@ yahoogroups. com



              Subject: Re: [PBML] Installing Perl Nert::SSH



              looks like there is a conflict between 32 bit and 64 bits perl libs . is it 64 bit m/c ?



              --- On Sun, 23/11/08, Dukelow, Don <dukelow@...<mailto:dukelow% 40hp.com> <mailto:dukelow% 40hp.com> > wrote:



              From: Dukelow, Don <dukelow@...<mailto:dukelow% 40hp.com> <mailto:dukelow% 40hp.com> >



              Subject: [PBML] Installing Perl Nert::SSH



              To: "perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups. com>" <perl-beginner@ yahoogroups. com<mailto:perl- beginner% 40yahoogroups.. . com>>



              Date: Sunday, 23 November, 2008, 11:18 PM



              I'm trying to install Perl Net::SSH on a Sun Solaris 10 systen with Perl version 10. I keep gettinh the following erropr when I try to install the GMP library. Can anyone help?



              ld: fatal: file /usr/lib/libc. so: wrong ELF class: ELFCLASS32



              ld: fatal: file /usr/ucblib/ libucb.so: wrong ELF class: ELFCLASS32



              ld: fatal: file /usr/lib/libresolv. so: wrong ELF class: ELFCLASS32



              ld: fatal: file /usr/lib/libsocket. so: wrong ELF class: ELFCLASS32



              ld: fatal: file /usr/lib/libnsl. so: wrong ELF class: ELFCLASS32



              ld: fatal: file /usr/lib/libelf. so: wrong ELF class: ELFCLASS32



              ld: fatal: File processing errors. No output written to .libs/libgmp. so.3.4.4



              *** Error code 1



              make: Fatal error: Command failed for target `libgmp.la'



              Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4



              *** Error code 1



              The following command caused the error:



              set fnord $MAKEFLAGS; amf=$2; \



              dot_seen=no; \



              target=`echo all-recursive | sed s/-recursive/ /`; \ list='tests mpn mpz mpq mpf printf scanf cxx mpbsd demos tune doc'; for subdir in $list; do \



              echo "Making $target in $subdir"; \



              if test "$subdir" = "."; then \



              dot_seen=yes; \



              local_target= "$target- am"; \



              else \



              local_target= "$target" ; \



              fi; \



              (cd $subdir && make $local_target) \



              || case "$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \ done; \ if test "$dot_seen" = "no"; then \



              make "$target-am" || exit 1; \



              fi; test -z "$fail"



              make: Fatal error: Command failed for target `all-recursive'



              Current working directory /home/dciproj/ tmp/pm/gmp- 4.2.4



              *** Error code 1



              make: Fatal error: Command failed for target `all'



              -----



              Don Dukelow



              HP/GM GSC33 License Team



              e-mail: dukelow@...<mailto:dukelow% 40hp.com> <mailto:dukelow% 40hp.com>



              Add more friends to your messenger and enjoy! Go to http://messenger. yahoo...com/ invite/



              [Non-text portions of this message have been removed]



              [Non-text portions of this message have been removed]



              Add more friends to your messenger and enjoy! Go to http://messenger. yahoo..com/ invite/



              [Non-text portions of this message have been removed]



              [Non-text portions of this message have been removed]



























              Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

              [Non-text portions of this message have been removed]
            Your message has been successfully submitted and would be delivered to recipients shortly.