Loading ...
Sorry, an error occurred while loading the content.

Re: [PBML] /usr/ucb/cc: language optional software package not installed

Expand Messages
  • merlyn@stonehenge.com
    ... Dukelow I m trying to install Perl SSH on a Sun Solaris 10 system with Perl Dukelow version 8.5.4. When ever I do the make command for the install I
    Message 1 of 2 , Nov 19, 2008
    View Source
    • 0 Attachment
      >>>>> "Dukelow" == Dukelow, Don <dukelow@...> writes:

      Dukelow> I'm trying to install Perl SSH on a Sun Solaris 10 system with Perl
      Dukelow> version 8.5.4. When ever I do the "make" command for the install I
      Dukelow> get "/usr/ucb/cc: language optional software package not installed"
      Dukelow> error. I don't believe the Sun's C compiler is all there, but the
      Dukelow> GNU gcc compiler is. How can I get the "perl Makefile.PL" to use the
      Dukelow> gcc compiler.

      You don't. You should always build Perl extensions with the same C that
      built Perl itself.

      So either install Solaris cc, or rebuild Perl with gcc, being careful to put
      it into a separate location.

      --
      Randal L. Schwartz - Stonehenge Consulting Services, Inc. - +1 503 777 0095
      <merlyn@...> <URL:http://www.stonehenge.com/merlyn/>
      Smalltalk/Perl/Unix consulting, Technical writing, Comedy, etc. etc.
      See http://methodsandmessages.vox.com/ for Smalltalk and Seaside discussion
    Your message has been successfully submitted and would be delivered to recipients shortly.