Loading ...
Sorry, an error occurred while loading the content.

RE: [PBML] Nwt::SSH::perl running slow

Expand Messages
  • Dukelow, Don
    Your correct, I was testing between two different systems. One of them has SSH set up with no pass fhrase and I forgot to change. Dumm me!!!! ... Don Dukelow
    Message 1 of 3 , Apr 3, 2008
    • 0 Attachment
      Your correct, I was testing between two different systems. One of them has SSH set up with no pass fhrase and I forgot to change. Dumm me!!!!


      -----
      Don Dukelow
      HP License Team
      Hewlett-Packard Company
      Tel: 810-728-3388
      e-mail: dukelow@...



      ________________________________
      From: perl-beginner@yahoogroups.com [mailto:perl-beginner@yahoogroups.com] On Behalf Of david wright
      Sent: Thursday, April 03, 2008 1:52 PM
      To: perl-beginner@yahoogroups.com
      Subject: Re: [PBML] Nwt::SSH::perl running slow


      > my $ssh = Net::SSH::Perl->new($host, protocol =>
      > '2', debug => 1);
      > $ssh->login($user);
      >
      > my($stdout, $stderr, $exit) = $ssh->cmd($cmd);
      > close $ssh;

      $ssh->login($user, $pass);

      --- On Thu, 4/3/08, Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com>> wrote:

      > From: Dukelow, Don <dukelow@...<mailto:dukelow%40hp.com>>
      > Subject: [PBML] Nwt::SSH::perl running slow
      > To: "perl-beginner@yahoogroups.com<mailto:perl-beginner%40yahoogroups.com>" <perl-beginner@yahoogroups.com<mailto:perl-beginner%40yahoogroups.com>>
      > Date: Thursday, April 3, 2008, 10:51 AM
      > I've had this out there for two days now so this mooring
      > I went to Goggle and did some searches and found out the
      > Perl modules Math::BigInt, Math::BigInt::GMP and YAML
      > needed to be installed to speed thing up. It was a problem
      > with some big math calculations. Two of these modules
      > skipped some "make test" runs because some test
      > modules needed to be loaded so I loaded them.
      > Although it was slow before, it doesn't work at all
      > now because of "Too many authentication
      > failures". I also changed script to only use SSH2
      > protocol.
      >
      > #!/usr/bin/perl
      > use warnings;
      > use strict;
      > use Net::SSH::Perl;
      >
      > my $user = 'lms';
      > my $host = 'vmcdlb33';
      > my $pass = 'XXXXXX';
      > my $cmd = "uname -a";
      >
      > my $ssh = Net::SSH::Perl->new($host, protocol =>
      > '2',
      > debug => 1);
      > $ssh->login($user);
      >
      > my($stdout, $stderr, $exit) = $ssh->cmd($cmd);
      > close $ssh;
      >
      > print "### $stdout";
      >
      > Here is debug log, does anyone have any ideas?
      >
      > edssm050.naeng.gm.com: Reading configuration data
      > /home/oracle/.ssh/config
      > edssm050.naeng.gm.com: Reading configuration data
      > /etc/ssh_config
      > edssm050.naeng.gm.com: Connecting to vmcdlb33, port 22.
      > edssm050.naeng.gm.com: Remote version string:
      > SSH-2.0-Sun_SSH_1.1
      >
      > edssm050.naeng.gm.com: Remote protocol version 2.0, remote
      > software version Sun_SSH_1.1
      > edssm050.naeng.gm.com: Net::SSH::Perl Version 1.30,
      > protocol version 2.0.
      > edssm050.naeng.gm.com: No compat match: Sun_SSH_1.1.
      > edssm050.naeng.gm.com: Connection established.
      > edssm050.naeng.gm.com: Sent key-exchange init (KEXINIT),
      > wait response.
      > edssm050.naeng.gm.com: Algorithms, c->s: 3des-cbc
      > hmac-sha1 none
      > edssm050.naeng.gm.com: Algorithms, s->c: 3des-cbc
      > hmac-sha1 none
      > edssm050.naeng.gm.com: Entering Diffie-Hellman Group 1 key
      > exchange.
      > edssm050.naeng.gm.com: Sent DH public key, waiting for
      > reply.
      > edssm050.naeng.gm.com: Received host key, type
      > 'ssh-dss'.
      > edssm050.naeng.gm.com: Host 'vmcdlb33' is known and
      > matches the host key.
      > edssm050.naeng.gm.com: Computing shared secret key.
      > edssm050.naeng.gm.com: Verifying server signature.
      > edssm050.naeng.gm.com: Waiting for NEWKEYS message.
      > edssm050.naeng.gm.com: Enabling incoming
      > encryption/MAC/compression.
      > edssm050.naeng.gm.com: Send NEWKEYS, enable outgoing
      > encryption/MAC/compression.
      > edssm050.naeng.gm.com: Sending request for
      > user-authentication service.
      > edssm050.naeng.gm.com: Service accepted: ssh-userauth.
      > edssm050.naeng.gm.com: Trying empty user-authentication
      > request.
      > edssm050.naeng.gm.com: Authentication methods that can
      > continue:
      > gssapi-keyex,gssapi-with-mic,publickey,password,keyboard-interactive.
      > edssm050.naeng.gm.com: Next method to try is publickey.
      > edssm050.naeng.gm.com: Trying pubkey authentication with
      > key file '/home/oracle/.ssh/id_dsa'
      > edssm050.naeng.gm.com: Authentication methods that can
      > continue:
      > gssapi-keyex,gssapi-with-mic,publickey,password,keyboard-interactive.
      > edssm050.naeng.gm.com: Next method to try is publickey.
      > edssm050.naeng.gm.com: Next method to try is password.
      > edssm050.naeng.gm.com: Trying password authentication.
      > edssm050.naeng.gm.com: Will not query passphrase in batch
      > mode.
      > edssm050.naeng.gm.com: Authentication methods that can
      > continue:
      > gssapi-keyex,gssapi-with-mic,publickey,password,keyboard-interactive.
      > edssm050.naeng.gm.com: Next method to try is publickey.
      > edssm050.naeng.gm.com: Trying pubkey authentication with
      > key file '/home/oracle/.ssh/id_dsa'
      > edssm050.naeng.gm.com: Authentication methods that can
      > continue:
      > gssapi-keyex,gssapi-with-mic,publickey,password,keyboard-interactive.
      > edssm050.naeng.gm.com: Next method to try is publickey.
      > edssm050.naeng.gm.com: Next method to try is password.
      > edssm050.naeng.gm.com: Trying password authentication.
      > edssm050.naeng.gm.com: Will not query passphrase in batch
      > mode.
      > edssm050.naeng.gm.com: Authentication methods that can
      > continue:
      > gssapi-keyex,gssapi-with-mic,publickey,password,keyboard-interactive.
      > edssm050.naeng.gm.com: Next method to try is publickey.
      > edssm050.naeng.gm.com: Trying pubkey authentication with
      > key file '/home/oracle/.ssh/id_dsa'
      > edssm050.naeng.gm.com: Authentication methods that can
      > continue:
      > gssapi-keyex,gssapi-with-mic,publickey,password,keyboard-interactive.
      > edssm050.naeng.gm.com: Next method to try is publickey.
      > edssm050.naeng.gm.com: Next method to try is password.
      > edssm050.naeng.gm.com: Trying password authentication.
      > edssm050.naeng.gm.com: Will not query passphrase in batch
      > mode.
      > edssm050.naeng.gm.com: Authentication methods that can
      > continue:
      > gssapi-keyex,gssapi-with-mic,publickey,password,keyboard-interactive.
      > edssm050.naeng.gm.com: Next method to try is publickey.
      > edssm050.naeng.gm.com: Trying pubkey authentication with
      > key file '/home/oracle/.ssh/id_dsa'
      > Received disconnect message: Too many authentication
      > failures for lmsadmin
      > at /usr/lib/perl5/site_perl/5.8.5/Net/SSH/Perl/AuthMgr.pm
      > line 142
      >
      >
      > -----
      > Don Dukelow
      > HP License Team
      > Hewlett-Packard Company
      > Tel: 810-728-3388
      > e-mail: dukelow@...<mailto:dukelow%40hp.com>
      >
      > ------------------------------------
      >
      > Unsubscribing info is here:
      > http://help.yahoo.com/help/us/groups/groups-32.htmlYahoo!
      > Groups Links
      >
      >
      >




      [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.