Loading ...
Sorry, an error occurred while loading the content.

gd error message

Expand Messages
  • joshypy
    hello friends while i`m running the perl program code below: use GD; my($im) = new GD::Image(100,50); my $black = $im- colorAllocate(0, 0, 0); my $white =
    Message 1 of 1 , Jan 20, 2006
    • 0 Attachment
      hello friends while i`m running the perl program code below:

      use GD;


      my($im) = new GD::Image(100,50);

      my $black = $im->colorAllocate(0, 0, 0);
      my $white = $im->colorAllocate(255, 255, 255);
      my $red = $im->colorAllocate(255, 0, 0);
      my $blue = $im->colorAllocate(0,0,255);

      $im->arc(50, 25, 98, 48, 0, 360, $white);
      $im->fill(50, 21, $red);
      print $im->png;

      I`m getting the error message:

      C:\Perl\bin>perl joss.pl
      GD object version 2.30 does not match $GD::VERSION 2.11 at
      C:/Perl/lib/DynaLoader.pm line 253.
      Compilation failed in require at joss.pl line 3.
      BEGIN failed--compilation aborted at joss.pl line 3.

      What should i do for solve this problem.

      joshy
    Your message has been successfully submitted and would be delivered to recipients shortly.