Loading ...
Sorry, an error occurred while loading the content.

Re: [PBML] problem with cgi programming

Expand Messages
  • aditi gupta
    hello everybody, I have tried configuring as advised by the group but still it is displying the message page cannot b displayed . Start Settings Control Panel
    Message 1 of 8 , Aug 2, 2005
    • 0 Attachment
      hello everybody,

      I have tried configuring as advised by the group but still it is displying the message 'page cannot b displayed'.

      Start
      Settings
      Control Panel
      Administrative tools
      Computer Management
      Services & Applications
      Internet Information Services
      Default Web Site
      Properties
      Home Directory
      Configuration

      the extensions .pl and .plx were mentioned with their paths (C:\Perl\bin\perl.exe "%s" %s and one dll path for .plx ) but still giving the same page cannot be displayed error. Then I read the Perl documentation and it said to create a new virtual directory and to give execute permissions as besides read permission. I also gave the path where the perl cgi scripts are stored, but of no avail. http://localhost is giving the test page but http://localhost/scripts/first.pl is still giving 'page cannot be displayed'.
      In my system, Inetpub and Perl are in different drives. Is the cgi script not executed because of this?

      please help,
      Thanks in advance

      Aditi

      rohit gole <rohitgole2003@...> wrote:
      hi,
      I think this may help you.........
      you can configure by following .....

      Start
      Settings
      Control Panel
      Administrative tools
      Computer Management
      Services & Applications
      Internet Information Services
      Default Web Site
      Properties
      Home Directory
      Configuration

      rohit singh
      Biological Sciences and Bio-Engineering
      B-tech
      IIT Kanpur



      aditi gupta wrote:
      Hello everybody,

      I'm new to cgi programming in perl. I'm working on WIndows XP. IIS as server and Activestate Perl.
      I've written a 'hello world' program default.htm, and saved it in location Inetpub/wwwroot. When i type http://localhost in browser then it is displaying the hello world message. But when i wrote my first cgi script 'cgihello.pl' and typed http://localhost/scripts/cgihello.pl in the address bar of the browser then it showed 'Page cannot be displayed'. I've saved the cgi script in 'scripts' directory of InetPub as given in the book 'Beginning Perl ' by Simon Cozens. Please tell me whats going wrong..

      Thanks in advance
      With regards
      Aditi


      ---------------------------------
      Free antispam, antivirus and 1GB to save all your messages
      Only in Yahoo! Mail: http://in.mail.yahoo.com

      [Non-text portions of this message have been removed]



      Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html



      SPONSORED LINKS
      C programming language Computer programming languages The c programming language C programming language List of programming languages Programming languages

      ---------------------------------
      YAHOO! GROUPS LINKS


      Visit your group "perl-beginner" on the web.

      To unsubscribe from this group, send an email to:
      perl-beginner-unsubscribe@yahoogroups.com

      Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


      ---------------------------------




      ---------------------------------
      How much free photo storage do you get? Store your friends n family photos for FREE with Yahoo! Photos.
      http://in.photos.yahoo.com

      [Non-text portions of this message have been removed]




      Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html
      Yahoo! Groups Links










      ---------------------------------
      Free antispam, antivirus and 1GB to save all your messages
      Only in Yahoo! Mail: http://in.mail.yahoo.com

      [Non-text portions of this message have been removed]
    • Ken Shail
      Don t forget that you have to access your script via a browser. If you simply use my computer or windoze explorer and click on the web page it will not run
      Message 2 of 8 , Aug 2, 2005
      • 0 Attachment
        Don't forget that you have to access your script via a browser.
        If you simply use "my computer" or windoze explorer and click on the web page it will not run the script.

        Just use the url http://localhost/<filename_path relative to \inetpub\wwwroot>

        ----- Original Message -----
        From: aditi gupta
        To: perl-beginner@yahoogroups.com
        Sent: Tuesday, August 02, 2005 9:56 AM
        Subject: Re: [PBML] problem with cgi programming


        hello everybody,

        I have tried configuring as advised by the group but still it is displying the message 'page cannot b displayed'.

        Start
        Settings
        Control Panel
        Administrative tools
        Computer Management
        Services & Applications
        Internet Information Services
        Default Web Site
        Properties
        Home Directory
        Configuration

        the extensions .pl and .plx were mentioned with their paths (C:\Perl\bin\perl.exe "%s" %s and one dll path for .plx ) but still giving the same page cannot be displayed error. Then I read the Perl documentation and it said to create a new virtual directory and to give execute permissions as besides read permission. I also gave the path where the perl cgi scripts are stored, but of no avail. http://localhost is giving the test page but http://localhost/scripts/first.pl is still giving 'page cannot be displayed'.
        In my system, Inetpub and Perl are in different drives. Is the cgi script not executed because of this?

        please help,
        Thanks in advance

        Aditi

        rohit gole <rohitgole2003@...> wrote:
        hi,
        I think this may help you.........
        you can configure by following .....

        Start
        Settings
        Control Panel
        Administrative tools
        Computer Management
        Services & Applications
        Internet Information Services
        Default Web Site
        Properties
        Home Directory
        Configuration

        rohit singh
        Biological Sciences and Bio-Engineering
        B-tech
        IIT Kanpur



        aditi gupta wrote:
        Hello everybody,

        I'm new to cgi programming in perl. I'm working on WIndows XP. IIS as server and Activestate Perl.
        I've written a 'hello world' program default.htm, and saved it in location Inetpub/wwwroot. When i type http://localhost in browser then it is displaying the hello world message. But when i wrote my first cgi script 'cgihello.pl' and typed http://localhost/scripts/cgihello.pl in the address bar of the browser then it showed 'Page cannot be displayed'. I've saved the cgi script in 'scripts' directory of InetPub as given in the book 'Beginning Perl ' by Simon Cozens. Please tell me whats going wrong..

        Thanks in advance
        With regards
        Aditi


        ---------------------------------
        Free antispam, antivirus and 1GB to save all your messages
        Only in Yahoo! Mail: http://in.mail.yahoo.com

        [Non-text portions of this message have been removed]



        Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html



        SPONSORED LINKS
        C programming language Computer programming languages The c programming language C programming language List of programming languages Programming languages

        ---------------------------------
        YAHOO! GROUPS LINKS


        Visit your group "perl-beginner" on the web.

        To unsubscribe from this group, send an email to:
        perl-beginner-unsubscribe@yahoogroups.com

        Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


        ---------------------------------




        ---------------------------------
        How much free photo storage do you get? Store your friends n family photos for FREE with Yahoo! Photos.
        http://in.photos.yahoo.com

        [Non-text portions of this message have been removed]




        Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html
        Yahoo! Groups Links










        ---------------------------------
        Free antispam, antivirus and 1GB to save all your messages
        Only in Yahoo! Mail: http://in.mail.yahoo.com

        [Non-text portions of this message have been removed]



        Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html



        ------------------------------------------------------------------------------
        YAHOO! GROUPS LINKS

        a.. Visit your group "perl-beginner" on the web.

        b.. To unsubscribe from this group, send an email to:
        perl-beginner-unsubscribe@yahoogroups.com

        c.. Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


        ------------------------------------------------------------------------------



        [Non-text portions of this message have been removed]
      • Ken Shail
        Forget my earlier email on this thread. I just made a test and got similar similar results to you with my scripts (that are in c: Intepub wwwroot) because in
        Message 3 of 8 , Aug 2, 2005
        • 0 Attachment
          Forget my earlier email on this thread.
          I just made a test and got similar similar results to you with my scripts (that are in c:\Intepub\wwwroot) because in the past I had changed the home directory to point at a simple HTML page that was elsewhere, without associated scripts.

          To change it do as follows.

          start
          settings
          control panel
          administrative tools
          Internet services
          Click on computer name
          click on Default web site
          right-click
          properties
          home directory tab
          Local path

          I changed it back to c:\Intepub\wwwroot and everything sprang back in to life including the perl scripts that were in c:\Intepub\wwwroot
          It appears that the scripts have to be in that directory or a relative path to it like ./ or .//cgi-bin.

          I hope this helps.




          ----- Original Message -----
          From: aditi gupta
          To: perl-beginner@yahoogroups.com
          Sent: Tuesday, August 02, 2005 9:56 AM
          Subject: Re: [PBML] problem with cgi programming


          hello everybody,

          I have tried configuring as advised by the group but still it is displying the message 'page cannot b displayed'.

          Start
          Settings
          Control Panel
          Administrative tools
          Computer Management
          Services & Applications
          Internet Information Services
          Default Web Site
          Properties
          Home Directory
          Configuration

          the extensions .pl and .plx were mentioned with their paths (C:\Perl\bin\perl.exe "%s" %s and one dll path for .plx ) but still giving the same page cannot be displayed error. Then I read the Perl documentation and it said to create a new virtual directory and to give execute permissions as besides read permission. I also gave the path where the perl cgi scripts are stored, but of no avail. http://localhost is giving the test page but http://localhost/scripts/first.pl is still giving 'page cannot be displayed'.
          In my system, Inetpub and Perl are in different drives. Is the cgi script not executed because of this?

          please help,
          Thanks in advance

          Aditi

          rohit gole <rohitgole2003@...> wrote:
          hi,
          I think this may help you.........
          you can configure by following .....

          Start
          Settings
          Control Panel
          Administrative tools
          Computer Management
          Services & Applications
          Internet Information Services
          Default Web Site
          Properties
          Home Directory
          Configuration

          rohit singh
          Biological Sciences and Bio-Engineering
          B-tech
          IIT Kanpur



          aditi gupta wrote:
          Hello everybody,

          I'm new to cgi programming in perl. I'm working on WIndows XP. IIS as server and Activestate Perl.
          I've written a 'hello world' program default.htm, and saved it in location Inetpub/wwwroot. When i type http://localhost in browser then it is displaying the hello world message. But when i wrote my first cgi script 'cgihello.pl' and typed http://localhost/scripts/cgihello.pl in the address bar of the browser then it showed 'Page cannot be displayed'. I've saved the cgi script in 'scripts' directory of InetPub as given in the book 'Beginning Perl ' by Simon Cozens. Please tell me whats going wrong..

          Thanks in advance
          With regards
          Aditi


          ---------------------------------
          Free antispam, antivirus and 1GB to save all your messages
          Only in Yahoo! Mail: http://in.mail.yahoo.com

          [Non-text portions of this message have been removed]



          Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html



          SPONSORED LINKS
          C programming language Computer programming languages The c programming language C programming language List of programming languages Programming languages

          ---------------------------------
          YAHOO! GROUPS LINKS


          Visit your group "perl-beginner" on the web.

          To unsubscribe from this group, send an email to:
          perl-beginner-unsubscribe@yahoogroups.com

          Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


          ---------------------------------




          ---------------------------------
          How much free photo storage do you get? Store your friends n family photos for FREE with Yahoo! Photos.
          http://in.photos.yahoo.com

          [Non-text portions of this message have been removed]




          Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html
          Yahoo! Groups Links










          ---------------------------------
          Free antispam, antivirus and 1GB to save all your messages
          Only in Yahoo! Mail: http://in.mail.yahoo.com

          [Non-text portions of this message have been removed]



          Unsubscribing info is here: http://help.yahoo.com/help/us/groups/groups-32.html



          ------------------------------------------------------------------------------
          YAHOO! GROUPS LINKS

          a.. Visit your group "perl-beginner" on the web.

          b.. To unsubscribe from this group, send an email to:
          perl-beginner-unsubscribe@yahoogroups.com

          c.. Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.


          ------------------------------------------------------------------------------



          [Non-text portions of this message have been removed]
        Your message has been successfully submitted and would be delivered to recipients shortly.