Loading ...
Sorry, an error occurred while loading the content.

Re: [PBML] Re: problems installing DBI and MySQL on Fedora

Expand Messages
  • sleepy groups
    Actually it might not be a problem with make. I installed DBI alright and DBD::CSV and got the following: Writing Makefile for DBD::CSV cp
    Message 1 of 5 , Jun 30, 2005
    • 0 Attachment
      Actually it might not be a problem with make. I installed DBI alright and
      DBD::CSV and got the following:

      Writing Makefile for DBD::CSV
      cp lib/Bundle/DBD/CSV.pm blib/lib/Bundle/DBD/CSV.pm
      cp lib/DBD/CSV.pm blib/lib/DBD/CSV.pm
      Manifying blib/man3/DBD::CSV.3pm
      Manifying blib/man3/Bundle::DBD::CSV.3pm
      -=-=-=-=-=-=-=-=-=-=-=-=-
      /usr/bin/make -- OK
      -=-=-=-=-=-=--=-=-=--=-=-=
      Running make test
      PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
      "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
      t/00base...........1.14 at t/00base.t line 15.
      t/00base...........ok
      t/10dsnlist........ok
      t/20createdrop.....ok
      t/30insertfetch....ok
      t/40bindparam......ok
      t/40blobs..........ok
      t/40listfields.....ok
      t/40nulls..........ok
      t/40numrows........ok
      t/50chopblanks.....ok
      t/50commit.........ok
      t/ak-dbd...........ok
      t/csv..............ok
      t/dbdadmin.........ok
      All tests successful.
      Files=14, Tests=243, 2 wallclock secs ( 2.13 cusr + 0.12 csys = 2.25 CPU)

      /usr/bin/make test -- OK

      Running make install
      Installing /usr/share/man/man3/DBD::CSV.3pm
      Installing /usr/share/man/man3/Bundle::DBD::CSV.3pm
      Writing
      /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi/auto/DBD/CSV/.packlist
      Appending installation info to
      /usr/lib/perl5/5.8.1/i386-linux-thread-multi/perllocal.pod

      /usr/bin/make install -- OK

      but still when I try to run a CSV DBI called listcsv.pl I get the following
      errors:
      install_driver(CSV) failed: Can't locate loadable object for module DBD::CSV
      in @INC (@INC contains: /usr/lib/perl5/5.8.1/i386-linux-thread-multi
      /usr/lib/perl5/5.8.1 /usr/lib/perl5/vendor_perl/5.8.1
      /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
      /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
      /usr/lib/perl5/5.8.1/i386-linux-thread-multi /usr/lib/perl5/5.8.1 .) at
      (eval 1) line 3
      Compilation failed in require at (eval 1) line 3.
      Perhaps a module that DBD::CSV requires hasn't been fully installed

      -----------------------------------------------------------
      That's weird since I thought all you need is DBI and DBD::CSV to handle DBI
      database scripts. So I went back and tried to install the Bundle::DBI from
      CPAN:
      perl -MCPAN -e 'install Bundle::DBI

      and got the error:
      /usr/bin/make -- NOT OK

      BUT beforethat, I saw this error:

      running make test
      PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
      "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
      t/base..........ok
      t/config........ok
      t/fork..........ok

      t/forkm.........make: *** [test_dynamic] Interrupt
      /usr/bin/make test -- NOT OK

      Running make install
      make test had returned bad status, won't install without force

      So
      1. Does anyone know why Make worked for DBI installation and not
      Bundle::DBI?
      2. Does anyone know what tforkm is and what that might indicate if it gives
      an error during install?

      Thanks!







      On 6/30/05, sleepy groups <sleepygroups@...> wrote:
      > thanks for the reply, my questions are listed below
      >
      > On 6/29/05, Damien Carbery <daymobrew@...> wrote:
      > > --- In perl-beginner@yahoogroups.com, "live4zz" <sleepygroups@g...>
      wrote:
      > > > Hi,
      > > >
      > > > I'm trying to install DBI and MySQL on Fedora (as root). When I type
      > > > in the install commmands:
      > > >
      > > > perl -MCPAN -e 'install DBI'
      > > > perl -MCPAN -e 'install DBD::mysql'
      > > >
      > > >
      > > > I get these error messages:
      > > >
      > > > make: *** [dbdimp.o] Error 127
      > > > /usr/bin/make -- NOT OK
      > >
      > > > /bin/sh: line 1: gcc: command not found
      > > > make: *** [dbdimp.o] Error 127
      > >
      > > It looks like you have (at least) two issues: no /usr/bin/make and no
      > > gcc compiler. Both are available as part of Fedora.
      > > /usr/bin/make is in the make-3.80-3 rpm (in Fedora Core 2, numbers may
      > > be different if you are on a different FC release)
      > > /usr/bin/gcc is part of gcc-3.3.3-7 rpm.
      > > You may also need gcc-c++-3.3.3.
      > >
      > >
      > -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
      > I tried to install gcc-3.3 by downloading the module, saving it on my
      > /usr/lib/perl5/5.8.1 directory and typed the following commands:
      > [root@stevenwork 5.8.1]# gzip -d gcc-3.3.tar.gz
      > [root@stevenwork 5.8.1]# tar -xof gcc-3.3.tar
      > [root@stevenwork 5.8.1]# perl Makefile.PL
      > Can't open perl script "Makefile.PL": No such file or directory
      >
      >
      > Do you know why I get this error, and how do I download and install
      > these packages..and where?
      >
      > Also I looked for "Make" and "make-3.80-3" on Redhat.com<http://Redhat.com>but couldn't
      > find it. Where is Fedora Core 2, I tried to look it up but couldn't
      > find it. I'm just a novice.
      >
      >
      > Thanks a lot!
      >


      [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.