Loading ...
Sorry, an error occurred while loading the content.

Help required in telnetting to a remote host through CGI

Expand Messages
  • amitabh20j
    Hi, I am using Net::Telnet to telnet to another machine on the intranet fromm a CGI program. I have Tomcat server installed on my machine which has been
    Message 1 of 2 , Jan 8, 2004
    • 0 Attachment
      Hi,
      I am using Net::Telnet to telnet to another machine on the intranet
      fromm a CGI program. I have Tomcat server installed on my machine
      which has been configured as http server as well.

      The problem is if I telnet to the other machine from the
      console(outside the web application) it works absolutely fine. But
      through the cgi program it returns an error : Unknown Remote host. It
      seems its unable to resolve hostnames. But even if I give the ip
      address of the remote machine it throws socket connection error.
      Basically the cgi is unable to access the intranet.

      I request any help in server configuration or otherwise to be able to
      get my program to work.

      Thanks and Regards,
      Amitabh
    • daymobrew@yahoo.com
      ... Have you looked to see if the web server logs provide any information? You should be able to run the CGI script from the console to help determine if the
      Message 2 of 2 , Jan 8, 2004
      • 0 Attachment
        --- In perl-beginner@yahoogroups.com, "amitabh20j" <amitabh_rs@y...>
        wrote:
        > Hi,
        > I am using Net::Telnet to telnet to another machine on the intranet
        > fromm a CGI program. I have Tomcat server installed on my machine
        > which has been configured as http server as well.
        >
        > The problem is if I telnet to the other machine from the
        > console(outside the web application) it works absolutely fine. But
        > through the cgi program it returns an error : Unknown Remote host. It
        > seems its unable to resolve hostnames. But even if I give the ip
        > address of the remote machine it throws socket connection error.
        > Basically the cgi is unable to access the intranet.
        >
        > I request any help in server configuration or otherwise to be able to
        > get my program to work.
        >
        > Thanks and Regards,
        > Amitabh

        Have you looked to see if the web server logs provide any information?
        You should be able to run the CGI script from the console to help
        determine if the issue is with the web server process or the script.
      Your message has been successfully submitted and would be delivered to recipients shortly.