Loading ...
Sorry, an error occurred while loading the content.
 

Help required

Expand Messages
  • Praveen Jain
    hi i m having problem while running my perl scripts on window.I m using Apache HTTP server to host a website on my system.when i access the cgi from the web
    Message 1 of 3 , Oct 7, 2003
      hi
      i m having problem while running my perl scripts on window.I m using
      Apache HTTP server to host a website on my system.when i access the
      cgi from the web page then the script instead of execution is
      returned to me in text format.how should i make it execute when i
      press the 'submit' button of my web page.
      plz help
      thanks
      praveen
    • praveen jain
      ... __________________________________ Do you Yahoo!? The New Yahoo! Shopping - with improved product search http://shopping.yahoo.com
      Message 2 of 3 , Oct 8, 2003
        >
        > hi
        > i m having problem while running my perl scripts on
        > window.I m using
        > Apache HTTP server to host a website on my
        > system.when i access the
        > cgi from the web page then the script instead of
        > execution is
        > returned to me in text format.how should i make it
        > execute when i
        > press the 'submit' button of my web page.
        > plz help
        > thanks
        > praveen
        >
        >
        >


        __________________________________
        Do you Yahoo!?
        The New Yahoo! Shopping - with improved product search
        http://shopping.yahoo.com
      • Damien Carbery
        ... Have you read the Apache docs for enabling CGI access? http://httpd.apache.org/docs/howto/cgi.html#configuringapachetopermitcgi Have you checked the error
        Message 3 of 3 , Oct 8, 2003
          --- In perl-beginner@yahoogroups.com, "Praveen Jain"
          <praveenjain20@y...> wrote:
          > hi
          > i m having problem while running my perl scripts on window.I m using
          > Apache HTTP server to host a website on my system.when i access the
          > cgi from the web page then the script instead of execution is
          > returned to me in text format.how should i make it execute when i
          > press the 'submit' button of my web page.
          > plz help
          > thanks
          > praveen

          Have you read the Apache docs for enabling CGI access?
          http://httpd.apache.org/docs/howto/cgi.html#configuringapachetopermitcgi
          Have you checked the error log??
          Is the first line of your script correctly pointing to the perl.exe
          binary?

          Try to get the supplied 'printenv' script working first. It is in the
          'cgi-bin' directory.
        Your message has been successfully submitted and would be delivered to recipients shortly.