Loading ...
Sorry, an error occurred while loading the content.

CGI problem with Apache

Expand Messages
  • Bernard Golden
    I am trying to get up and running on perl cgi scripts. I have tried to execute a test program and get a 500 error. In the error log it says: [Thu Apr 03
    Message 1 of 3 , Apr 3, 2003
    • 0 Attachment
      I am trying to get up and running on perl cgi scripts. I have tried to
      execute a test program and get a 500 error. In the error log it says:

      [Thu Apr 03 16:44:36 2003] [error] [client 127.0.0.1] couldn't spawn child
      process: c:/apache/cgi-bin/cgivariable.cgi

      I'm not sure what to do and thought I'd ask for some help.

      TIA

      Bernard Golden


      [Non-text portions of this message have been removed]
    • Damien Carbery
      ... tried to ... spawn child ... Check the hash-bang path. If my script starts with: #!/usr/bin/perl I get this error. Change it to something like:
      Message 2 of 3 , Apr 4, 2003
      • 0 Attachment
        --- In perl-beginner@yahoogroups.com, Bernard Golden <bgolden@p...>
        wrote:
        > I am trying to get up and running on perl cgi scripts. I have
        tried to
        > execute a test program and get a 500 error. In the error log it
        says:
        >
        > [Thu Apr 03 16:44:36 2003] [error] [client 127.0.0.1] couldn't
        spawn child
        > process: c:/apache/cgi-bin/cgivariable.cgi
        >
        > I'm not sure what to do and thought I'd ask for some help.
        >
        > TIA
        >
        > Bernard Golden
        >
        >

        > couldn't spawn child process:
        Check the hash-bang path. If my script starts with:
        #!/usr/bin/perl
        I get this error.
        Change it to something like:
        #!c:/perl/bin/perl
        or wherever perl.exe is on your machine.
        If it is in a path with a space use the short name version.

        I think you can change the way Apache locates perl via a setting in
        httpd.conf. It can either support the #! path or use the registry.
      • Bernard Golden
        Many thanks for the advice. The script came up just fine. The path issue is obvious, once you think about it. Bernard Golden ... From: Damien Carbery
        Message 3 of 3 , Apr 4, 2003
        • 0 Attachment
          Many thanks for the advice. The script came up just fine. The path issue
          is obvious, once you think about it.

          Bernard Golden


          -----Original Message-----
          From: Damien Carbery [mailto:daymobrew@...]
          Sent: Friday, April 04, 2003 1:28 AM
          To: perl-beginner@yahoogroups.com
          Subject: [PBML] Re: CGI problem with Apache


          --- In perl-beginner@yahoogroups.com, Bernard Golden <bgolden@p...>
          wrote:
          > I am trying to get up and running on perl cgi scripts. I have
          tried to
          > execute a test program and get a 500 error. In the error log it
          says:
          >
          > [Thu Apr 03 16:44:36 2003] [error] [client 127.0.0.1] couldn't
          spawn child
          > process: c:/apache/cgi-bin/cgivariable.cgi
          >
          > I'm not sure what to do and thought I'd ask for some help.
          >
          > TIA
          >
          > Bernard Golden
          >
          >

          > couldn't spawn child process:
          Check the hash-bang path. If my script starts with:
          #!/usr/bin/perl
          I get this error.
          Change it to something like:
          #!c:/perl/bin/perl
          or wherever perl.exe is on your machine.
          If it is in a path with a space use the short name version.

          I think you can change the way Apache locates perl via a setting in
          httpd.conf. It can either support the #! path or use the registry.




          Unsubscribing info is here:
          http://help.yahoo.com/help/us/groups/groups-32.html

          Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        Your message has been successfully submitted and would be delivered to recipients shortly.