Loading ...
Sorry, an error occurred while loading the content.

Windows 2000 + Perl + Apache + MySQL

Expand Messages
  • Octavian Rasnita
    Hello, Could someone tell me what versions of Perl and Apache for Windows should I use to make all these programs work together? I have problems because: The
    Message 1 of 3 , Jan 1, 2003
    • 0 Attachment
      Hello,

      Could someone tell me what versions of Perl and Apache for Windows should I
      use to make all these programs work together?

      I have problems because:

      The LWP module works well in Perl 5.8 but it doesn't work well in Perl 5.6.1
      I can't install the DBD::mysql for Perl 5.8 using ppm because there is no
      such a package available yet, so I cannot use MySQL with Perl 5.8.

      I can use Perl 5.6.1 with MySQL but the LWP module installed with ppm is not
      working with this version of perl.

      It seems that I should choose to work with LWP only or with MySQL only.

      Thank you for any help.

      Teddy,
      Teddy's Center: http://teddy.fcc.ro/
      Email: orasnita@...
    • Vineet Agrawal
      hi, I am using Apache2 & have also installed Perl 5.8.0 lately & they seem to be working fine in conjunction.I faced similar problem looking for a dbi & dbd s
      Message 2 of 3 , Jan 1, 2003
      • 0 Attachment
        hi,
        I am using Apache2 & have also installed Perl 5.8.0
        lately & they seem to be working fine in conjunction.I
        faced similar problem looking for a dbi & dbd's for
        mysql,albeit for a different reason.As a workaround i
        have installed myodbc which is a dbd for mysql.
        i havent tested the odbc & myodbc part yet.
        hope that helps.
        vineet
        --- Octavian Rasnita <orasnita@...> wrote:
        > Hello,
        >
        > Could someone tell me what versions of Perl and
        > Apache for Windows should I
        > use to make all these programs work together?
        >
        > I have problems because:
        >
        > The LWP module works well in Perl 5.8 but it doesn't
        > work well in Perl 5.6.1
        > I can't install the DBD::mysql for Perl 5.8 using
        > ppm because there is no
        > such a package available yet, so I cannot use MySQL
        > with Perl 5.8.
        >
        > I can use Perl 5.6.1 with MySQL but the LWP module
        > installed with ppm is not
        > working with this version of perl.
        >
        > It seems that I should choose to work with LWP only
        > or with MySQL only.
        >
        > Thank you for any help.
        >
        > Teddy,
        > Teddy's Center: http://teddy.fcc.ro/
        > Email: orasnita@...
        >
        >
        >


        =====
        Vineet Agrawal

        __________________________________________________
        Do you Yahoo!?
        Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
        http://mailplus.yahoo.com
      • Octavian Rasnita
        Thank you for telling me about myodbc. I ve finally installed Visual Studio and I ve compiled DBD::mysql. Under Perl 5.8.0 DBD::mysqlPP can be installed with
        Message 3 of 3 , Jan 1, 2003
        • 0 Attachment
          Thank you for telling me about myodbc.

          I've finally installed Visual Studio and I've compiled DBD::mysql.

          Under Perl 5.8.0 DBD::mysqlPP can be installed with ppm and it works exactly
          like DBD::mysql but it doesn't have all the functions available, ... and
          some of them are giving errors.

          That's why I've finally prefered to use DBD::mysql because I am thinking
          that other modules might also have problems.

          Teddy,
          Teddy's Center: http://teddy.fcc.ro/
          Email: orasnita@...

          ----- Original Message -----
          From: "Vineet Agrawal" <vineet_agar@...>
          To: <perl-beginner@yahoogroups.com>
          Sent: Wednesday, January 01, 2003 7:54 PM
          Subject: Re: [PBML] Windows 2000 + Perl + Apache + MySQL


          hi,
          I am using Apache2 & have also installed Perl 5.8.0
          lately & they seem to be working fine in conjunction.I
          faced similar problem looking for a dbi & dbd's for
          mysql,albeit for a different reason.As a workaround i
          have installed myodbc which is a dbd for mysql.
          i havent tested the odbc & myodbc part yet.
          hope that helps.
          vineet
          --- Octavian Rasnita <orasnita@...> wrote:
          > Hello,
          >
          > Could someone tell me what versions of Perl and
          > Apache for Windows should I
          > use to make all these programs work together?
          >
          > I have problems because:
          >
          > The LWP module works well in Perl 5.8 but it doesn't
          > work well in Perl 5.6.1
          > I can't install the DBD::mysql for Perl 5.8 using
          > ppm because there is no
          > such a package available yet, so I cannot use MySQL
          > with Perl 5.8.
          >
          > I can use Perl 5.6.1 with MySQL but the LWP module
          > installed with ppm is not
          > working with this version of perl.
          >
          > It seems that I should choose to work with LWP only
          > or with MySQL only.
          >
          > Thank you for any help.
          >
          > Teddy,
          > Teddy's Center: http://teddy.fcc.ro/
          > Email: orasnita@...
          >
          >
          >


          =====
          Vineet Agrawal

          __________________________________________________
          Do you Yahoo!?
          Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
          http://mailplus.yahoo.com


          Unsubscribing info is here:
          http://help.yahoo.com/help/us/groups/groups-32.html

          Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        Your message has been successfully submitted and would be delivered to recipients shortly.