Loading ...
Sorry, an error occurred while loading the content.

one of my pScripts quit working.

Expand Messages
  • Greg Sparks
    I had configured pToolset to run a pScript to launch a calculator named One+One. The pScript is as follows: pScript_01 {One+One::/&launch[@@One+One@@]} I had
    Message 1 of 18 , May 13, 2006
    • 0 Attachment
      I had configured pToolset to run a pScript to launch a calculator named
      One+One. The pScript is as follows:

      pScript_01 {One+One::/&launch[@@One+One@@]}

      I had assigned a tap to run this since I did not see any other way to
      easily launch the calculator. This worked fine for months and months.
      Recently thetap stpped working. when I tap the spot now I get a screen
      called "New 4k Memo Vitals".

      Can anyone help me restore the functionality of the pScript and
      pToolset tap combination.

      I am using the same versions of pEdit and pToolset (8.03, I think)

      Greg
    • Paul Nevai
      # I had configured pToolset to run a pScript to launch a calculator named # One+One. The pScript is as follows: # # pScript_01
      Message 2 of 18 , May 13, 2006
      • 0 Attachment
        # I had configured pToolset to run a pScript to launch a calculator named
        # One+One. The pScript is as follows:
        #
        # pScript_01 {One+One::/&launch[@@One+One@@]}
        #
        # I had assigned a tap to run this since I did not see any other way to
        # easily launch the calculator. This worked fine for months and months.
        # Recently thetap stpped working. when I tap the spot now I get a screen
        # called "New 4k Memo Vitals".
        #
        # Can anyone help me restore the functionality of the pScript and
        # pToolset tap combination.
        #
        # I am using the same versions of pEdit and pToolset (8.03, I think)

        Hi Greg:

        This is impossible unless you have another pScript with the same name
        "One+One..." positioned before the above.

        Just in case, although I don't know why, you could do a pin-reset of the
        Palm. This fixes stuff occasionally. It's woodoo palmologic.

        Best regards, Paul
      • John Markley
        ... Greg-- Paul s reply is by far the most likely, ie cross-talk between your One+One script and some other PScript in your pad. However: 1) Has the number
        Message 3 of 18 , May 13, 2006
        • 0 Attachment
          Quoting Greg Sparks <gsparks2@...>:

          > I had configured pToolset to run a pScript to launch a calculator
          > named
          > One+One. The pScript is as follows:
          >
          > pScript_01 {One+One::/&launch[@@One+One@@]}
          >
          > I had assigned a tap to run this since I did not see any other way to
          >
          > easily launch the calculator. This worked fine for months and
          > months.
          > Recently thetap stpped working. when I tap the spot now I get a
          > screen
          > called "New 4k Memo Vitals".
          >
          > Can anyone help me restore the functionality of the pScript and
          > pToolset tap combination.
          >
          > I am using the same versions of pEdit and pToolset (8.03, I think)
          >
          > Greg


          Greg--

          Paul's reply is by far the most likely, ie cross-talk between your
          One+One script and some other PScript in your pad. However:

          1) Has the number in pScript_01 gotten changes somehow to _XX ?
          2) Have you recently changed to a different handheld?
          3) Has your screen orientation changed?
          4) Are you by any chance using TealScript?

          ~ John
        • Greg Sparks
          ... way to ... your ... I have done multiple pin resets. I have only two pScripts, the one mentioned before and: pScript_02 {dia::/&tap [150.233]} I have
          Message 4 of 18 , May 13, 2006
          • 0 Attachment
            --- In peditors@yahoogroups.com, John Markley <jmmjr@...> wrote:
            >
            > Quoting Greg Sparks <gsparks2@...>:
            >
            > > I had configured pToolset to run a pScript to launch a calculator
            > > named
            > > One+One. The pScript is as follows:
            > >
            > > pScript_01 {One+One::/&launch[@@One+One@@]}
            > >
            > > I had assigned a tap to run this since I did not see any other
            way to
            > >
            > > easily launch the calculator. This worked fine for months and
            > > months.
            > > Recently thetap stpped working. when I tap the spot now I get a
            > > screen
            > > called "New 4k Memo Vitals".
            > >
            > > Can anyone help me restore the functionality of the pScript and
            > > pToolset tap combination.
            > >
            > > I am using the same versions of pEdit and pToolset (8.03, I think)
            > >
            > > Greg
            >
            >
            > Greg--
            >
            > Paul's reply is by far the most likely, ie cross-talk between
            your
            > One+One script and some other PScript in your pad. However:
            >
            > 1) Has the number in pScript_01 gotten changes somehow to _XX ?
            > 2) Have you recently changed to a different handheld?
            > 3) Has your screen orientation changed?
            > 4) Are you by any chance using TealScript?
            >
            > ~ John
            >
            I have done multiple pin resets. I have only two pScripts, the one
            mentioned before and:
            pScript_02 {dia::/&tap [150.233]}

            I have changed from right handed to left handed and portrait and
            landscape and back. The original configuration was portrait and left
            handed.
            I am not using TealScript.
            I just tried pin reset after swapping from right handed to
            lefthanded. I had the same results.

            I did do a hard reset and restore using BackupBuddyVFS a few weeks
            ago, but reinstalled pEdit and pToolset afresh.

            Thanks!
          • John Markley
            ... OK. Suggest you try the following- 1) Using FileZ or similar utility if you have such, check to make sure of the exact proper name for One+One (unlikely
            Message 5 of 18 , May 13, 2006
            • 0 Attachment
              >>
              > I have done multiple pin resets. I have only two pScripts, the one
              > mentioned before and:
              > pScript_02 {dia::/&tap [150.233]}
              >
              > I have changed from right handed to left handed and portrait and
              > landscape and back. The original configuration was portrait and left
              >
              > handed.
              > I am not using TealScript.
              > I just tried pin reset after swapping from right handed to
              > lefthanded. I had the same results.
              >
              > I did do a hard reset and restore using BackupBuddyVFS a few weeks
              > ago, but reinstalled pEdit and pToolset afresh.
              >
              > Thanks!

              OK. Suggest you try the following-

              1) Using FileZ or similar utility if you have such, check to make
              sure of the exact proper name for One+One (unlikely its changed, but
              we're searching here).
              2) Then, completely trash, delete, obliterate your lovely old
              pScript, and write a new one with a different pScript_xx, and assign
              that one to your tap zone of choice with pMasterTool and see what
              happens.
              ~ John
            • John Markley
              ... Greg- Following my own advice, I downloaded One plus One, installed it, and queried FileZ. Its app name is One_One rather than One+One. I wrote your
              Message 6 of 18 , May 13, 2006
              • 0 Attachment
                Quoting John Markley <jmmjr@...>:

                >
                > OK. Suggest you try the following-
                >
                > 1) Using FileZ or similar utility if you have such, check to make
                > sure of the exact proper name for One+One (unlikely its changed, but
                > we're searching here).
                > 2) Then, completely trash, delete, obliterate your lovely old
                > pScript, and write a new one with a different pScript_xx, and assign
                > that one to your tap zone of choice with pMasterTool and see what
                > happens.
                > ~ John

                Greg-
                Following my own advice, I downloaded One plus One, installed it, and
                queried FileZ. Its app name is One_One rather than One+One. I wrote
                your script, but with "_" instead of "+", assigned it to a tap zone,
                and it runs properly (Palm TX).
                ~ John
              • Greg Sparks
                ... make ... but ... assign ... and ... wrote ... zone, ... Ok, I had changed the pScript name of the application from One_One to One+One as part of my
                Message 7 of 18 , May 13, 2006
                • 0 Attachment
                  --- In peditors@yahoogroups.com, John Markley <jmmjr@...> wrote:
                  >
                  > Quoting John Markley <jmmjr@...>:
                  >
                  > >
                  > > OK. Suggest you try the following-
                  > >
                  > > 1) Using FileZ or similar utility if you have such, check to
                  make
                  > > sure of the exact proper name for One+One (unlikely its changed,
                  but
                  > > we're searching here).
                  > > 2) Then, completely trash, delete, obliterate your lovely old
                  > > pScript, and write a new one with a different pScript_xx, and
                  assign
                  > > that one to your tap zone of choice with pMasterTool and see what
                  > > happens.
                  > > ~ John
                  >
                  > Greg-
                  > Following my own advice, I downloaded One plus One, installed it,
                  and
                  > queried FileZ. Its app name is One_One rather than One+One. I
                  wrote
                  > your script, but with "_" instead of "+", assigned it to a tap
                  zone,
                  > and it runs properly (Palm TX).
                  > ~ John
                  >
                  Ok, I had changed the pScript name of the application from One_One to
                  One+One as part of my troubleshooting before I posted my query. I
                  deleted all of my pScripts and rebuilt them using the One_One as you
                  did. I am still getting the 4k Memo Vitals. It does so no matter
                  where I place the tap location.

                  Another wierd thing I noticed, I had pFindTool mapped to a tap in the
                  upper left corner. It no longer works either. I have tried
                  recalibrating the touchscreen but it had no effect.

                  I may try deleting all of pEdit and pTools and all preferences I can
                  find then reinstall and see if that works.

                  Thanks for trying to help me with this, John.

                  Greg
                • Greg Sparks
                  ... make ... but ... assign ... and ... wrote ... zone, ... Ok, I had changed the pScript name of the application from One_One to One+One as part of my
                  Message 8 of 18 , May 13, 2006
                  • 0 Attachment
                    --- In peditors@yahoogroups.com, John Markley <jmmjr@...> wrote:
                    >
                    > Quoting John Markley <jmmjr@...>:
                    >
                    > >
                    > > OK. Suggest you try the following-
                    > >
                    > > 1) Using FileZ or similar utility if you have such, check to
                    make
                    > > sure of the exact proper name for One+One (unlikely its changed,
                    but
                    > > we're searching here).
                    > > 2) Then, completely trash, delete, obliterate your lovely old
                    > > pScript, and write a new one with a different pScript_xx, and
                    assign
                    > > that one to your tap zone of choice with pMasterTool and see what
                    > > happens.
                    > > ~ John
                    >
                    > Greg-
                    > Following my own advice, I downloaded One plus One, installed it,
                    and
                    > queried FileZ. Its app name is One_One rather than One+One. I
                    wrote
                    > your script, but with "_" instead of "+", assigned it to a tap
                    zone,
                    > and it runs properly (Palm TX).
                    > ~ John
                    >
                    Ok, I had changed the pScript name of the application from One_One to
                    One+One as part of my troubleshooting before I posted my query. I
                    deleted all of my pScripts and rebuilt them using the One_One as you
                    did. I am still getting the 4k Memo Vitals. It does so no matter
                    where I place the tap location.

                    Another wierd thing I noticed, I had pFindTool mapped to a tap in the
                    upper left corner. It no longer works either. I have tried
                    recalibrating the touchscreen but it had no effect.

                    I may try deleting all of pEdit and pTools and all preferences I can
                    find then reinstall and see if that works.

                    Thanks for trying to help me with this, John.

                    Greg
                  • Greg Sparks
                    ... I used the pToolZapper and deleted all pToolset modules and preferences then reinstalled fresh and everything is working as it should now, launching
                    Message 9 of 18 , May 13, 2006
                    • 0 Attachment
                      > I may try deleting all of pEdit and pTools and all preferences I can
                      > find then reinstall and see if that works.
                      >
                      > Thanks for trying to help me with this, John.
                      >
                      > Greg
                      >
                      I used the pToolZapper and deleted all pToolset modules and preferences
                      then reinstalled fresh and everything is working as it should now,
                      launching One+One and pFindTool as I wanted.

                      Something must have been corrupted in the preferences or the modules.

                      Thanks for your time and effort John and Paul!

                      Remember, patience is a virtue but persistence to the point of success
                      is a blessing!

                      Greg
                    • Paul Nevai
                      # I used the pToolZapper and deleted all pToolset modules and preferences # then reinstalled fresh and everything is working as it should now, # launching
                      Message 10 of 18 , May 14, 2006
                      • 0 Attachment
                        # I used the pToolZapper and deleted all pToolset modules and preferences
                        # then reinstalled fresh and everything is working as it should now,
                        # launching One+One and pFindTool as I wanted.

                        Next time, first just delete the tools and keep the prefs. Delete the prefs
                        only as a last resort. Of course, the prefs might not hold anything valuable
                        and then it's OK to delete them. All=my=best, Paul
                      • John Markley
                        ... Yay, hurrah, and good, too. Now you can just enjoy the island. ~ John
                        Message 11 of 18 , May 14, 2006
                        • 0 Attachment
                          Quoting Greg Sparks <gsparks2@...>:


                          > I used the pToolZapper and deleted all pToolset modules and
                          > preferences
                          > then reinstalled fresh and everything is working as it should now,
                          > launching One+One and pFindTool as I wanted.
                          >
                          > Something must have been corrupted in the preferences or the modules.

                          Yay, hurrah, and good, too. Now you can just enjoy the island.
                          ~ John
                        • John Markley
                          ... Ooops. Got confused with another thread... delete the part about the island :p ~ John
                          Message 12 of 18 , May 14, 2006
                          • 0 Attachment
                            Quoting John Markley <jmmjr@...>:

                            > Yay, hurrah, and good, too. Now you can just enjoy the island.
                            > ~ John

                            Ooops. Got confused with another thread... delete the part about the
                            island :p
                            ~ John
                          • Paul Nevai
                            # Ooops. Got confused with another thread... delete the part about the # island :p Confusion or not, there could be an island too. /Paul
                            Message 13 of 18 , May 14, 2006
                            • 0 Attachment
                              # Ooops. Got confused with another thread... delete the part about the
                              # island :p

                              Confusion or not, there could be an island too. /Paul
                            • Steve Kunkel
                              When it comes time to make your new One_One script, remember to use the automatic pscript-maker thingy in the pLaunchTool menu Actions Create pScript. What is
                              Message 14 of 18 , May 14, 2006
                              • 0 Attachment
                                When it comes time to make your new One_One script, remember to use the
                                automatic pscript-maker thingy in the pLaunchTool menu>Actions>Create
                                pScript.

                                What is the '4k memo vitals?' I'm not familiar with it... but I wonder if
                                it's some pedit advanced feature. Like maybe you accidently tapped some
                                option to 'create short-cut to 4k vitals' and it defaulted to assigning it
                                to 'pScript_01." Then, because _01 was manually set (by you) for that
                                particular screen tap ... well you get the idea...

                                --
                                Steve
                                =========================
                                This messsage has ben spell checked.


                                [Non-text portions of this message have been removed]
                              • Paul Nevai
                                # What is the 4k memo vitals? I m not familiar with it... but I wonder if This pMemoTool. /Paul
                                Message 15 of 18 , May 14, 2006
                                • 0 Attachment
                                  # What is the '4k memo vitals?' I'm not familiar with it... but I wonder if

                                  This pMemoTool. /Paul
                                • Greg Sparks
                                  ... the ... Yes, my island is a nice place, landlocked, it s true, but everyone knows me here and seems to like me.......
                                  Message 16 of 18 , May 14, 2006
                                  • 0 Attachment
                                    --- In peditors@yahoogroups.com, Paul Nevai <nevai@...> wrote:
                                    >
                                    > # Ooops. Got confused with another thread... delete the part about
                                    the
                                    > # island :p
                                    >
                                    > Confusion or not, there could be an island too. /Paul
                                    >
                                    Yes, my island is a nice place, landlocked, it's true, but everyone
                                    knows me here and seems to like me.......
                                  • John Markley
                                    ... No doubt your island has at least one Palm on it....... ~ John
                                    Message 17 of 18 , May 14, 2006
                                    • 0 Attachment
                                      Quoting Greg Sparks <gsparks2@...>:

                                      > --- In peditors@yahoogroups.com, Paul Nevai <nevai@...> wrote:
                                      >>
                                      >> # Ooops. Got confused with another thread... delete the part about
                                      >
                                      > the
                                      >> # island :p
                                      >>
                                      >> Confusion or not, there could be an island too. /Paul
                                      >>
                                      > Yes, my island is a nice place, landlocked, it's true, but everyone
                                      > knows me here and seems to like me.......


                                      No doubt your island has at least one Palm on it.......
                                      ~ John
                                    • Greg Sparks
                                      ... about ... everyone ... Ah, yes!!!!
                                      Message 18 of 18 , May 14, 2006
                                      • 0 Attachment
                                        --- In peditors@yahoogroups.com, John Markley <jmmjr@...> wrote:
                                        >
                                        > Quoting Greg Sparks <gsparks2@...>:
                                        >
                                        > > --- In peditors@yahoogroups.com, Paul Nevai <nevai@> wrote:
                                        > >>
                                        > >> # Ooops. Got confused with another thread... delete the part
                                        about
                                        > >
                                        > > the
                                        > >> # island :p
                                        > >>
                                        > >> Confusion or not, there could be an island too. /Paul
                                        > >>
                                        > > Yes, my island is a nice place, landlocked, it's true, but
                                        everyone
                                        > > knows me here and seems to like me.......
                                        >
                                        >
                                        > No doubt your island has at least one Palm on it.......
                                        > ~ John
                                        >
                                        Ah, yes!!!!
                                      Your message has been successfully submitted and would be delivered to recipients shortly.