Loading ...
Sorry, an error occurred while loading the content.

PRExxx evaluation and Temporary bonuses

Expand Messages
  • Tir Gwaith
    I m trying to do a Temp Bonus from a spell, but have it not stack with any bonuses from equipmods. I ve currently done it with
    Message 1 of 3 , Feb 16, 2010
    • 0 Attachment
      I'm trying to do a Temp Bonus from a spell, but have it not stack with
      any bonuses from equipmods.

      I've currently done it with
      BONUS:COMBAT|AC|formula|PREAPPLY:Armor|PRETYPE:1,Plus1 (which is
      granted by equipmod)

      The PRETYPE evaluation that is happening is based on the Global
      PRETYPE tag, which looks at TYPE in race for character. Which makes
      sense, except from my logic that I'm attaching it to a piece of
      equipment, not the character. Which I guess while it looks like it is
      attached to a particular piece of equipment, it really isn't.

      Am I going about this the wrong way? Is this the method we want to
      evaluate Temp Bonuses? How hard would it be to change? Etc. I'm
      trying to find a nice resolution to the "Magic Vestment" bug, and
      figuring out if a particular armor / Shield has a particular bonus to
      AC from an equipmod is eluding me.

      --
      Tir Gwaith
      PCGen LST Chimp
    • karianna03
      *Bump*
      Message 2 of 3 , Mar 5, 2010
      • 0 Attachment
        *Bump*

        --- In pcgen_developers@yahoogroups.com, Tir Gwaith <Tir.Gwaith@...> wrote:
        >
        > I'm trying to do a Temp Bonus from a spell, but have it not stack with
        > any bonuses from equipmods.
        >
        > I've currently done it with
        > BONUS:COMBAT|AC|formula|PREAPPLY:Armor|PRETYPE:1,Plus1 (which is
        > granted by equipmod)
        >
        > The PRETYPE evaluation that is happening is based on the Global
        > PRETYPE tag, which looks at TYPE in race for character. Which makes
        > sense, except from my logic that I'm attaching it to a piece of
        > equipment, not the character. Which I guess while it looks like it is
        > attached to a particular piece of equipment, it really isn't.
        >
        > Am I going about this the wrong way? Is this the method we want to
        > evaluate Temp Bonuses? How hard would it be to change? Etc. I'm
        > trying to find a nice resolution to the "Magic Vestment" bug, and
        > figuring out if a particular armor / Shield has a particular bonus to
        > AC from an equipmod is eluding me.
        >
        > --
        > Tir Gwaith
        > PCGen LST Chimp
        >
      • Tir Gwaith
        I figured a way around it, basically undocumented feature in PREEQUIP, which does multiple types via TYPE:blah.blah2. I believe that has be trackered. ... --
        Message 3 of 3 , Mar 5, 2010
        • 0 Attachment
          I figured a way around it, basically undocumented feature in PREEQUIP,
          which does multiple types via TYPE:blah.blah2. I believe that has be
          trackered.

          On Fri, Mar 5, 2010 at 4:44 AM, karianna03 <martijnverburg@...> wrote:
          > *Bump*

          --
          Tir Gwaith
          PCGen LST Chimp
        Your message has been successfully submitted and would be delivered to recipients shortly.