Loading ...
Sorry, an error occurred while loading the content.

Re: [pcgen_developers] UI Build Dies

Expand Messages
  • James Dempsey
    Hi Andrew, That would indicate that now that the program is compiled with Java 1.6 you need to run it with Java 1.6 or later. Could you check that your runtime
    Message 1 of 4 , Sep 10, 2011
    • 0 Attachment
      Hi Andrew,

      That would indicate that now that the program is compiled with Java 1.6 you need to run it with Java 1.6 or later. Could you check that your runtime config is using Java 1.6  or Java 1.7

      Cheers,
      James.

      On 11/09/2011 11:08 AM Andrew wrote
      Hi,

      Tried to use the new UI building from Connor's latest updates (And switching to Java 1.6 jdk)

      Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
              at java.lang.ClassLoader.defineClass1(Native Method)
              at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
              at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
              at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
              at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
              at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
              at java.security.AccessController.doPrivileged(Native Method)
              at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
              at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
              at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

      And then it quits completely.
      --
      Andrew Maitland (LegacyKing)

    • Andrew
      Hi, As far as I can tell it is, JAVA_HOME is set to the jdk for 1.6, and the other paths have the JRE. Is there a way to config it?
      Message 2 of 4 , Sep 10, 2011
      • 0 Attachment
        Hi,

        As far as I can tell it is, JAVA_HOME is set to the jdk for 1.6, and the other paths have the JRE. Is there a way to config it?

        On 9/10/2011 6:44 PM, James Dempsey wrote:
      • Andrew
        Hi, It was in the CLASSPATH, got it.
        Message 3 of 4 , Sep 10, 2011
        • 0 Attachment
          Hi,

          It was in the CLASSPATH, got it.

          On 9/10/2011 7:33 PM, Andrew wrote:
          Hi,

          As far as I can tell it is, JAVA_HOME is set to the jdk for 1.6, and the other paths have the JRE. Is there a way to config it?

          On 9/10/2011 6:44 PM, James Dempsey wrote:
          --
          Andrew Maitland (LegacyKing)
          Admin Silverback - PCGen Board of Directors
          Data 2nd, Docs Tamarin, OS Lemur
          Unique Title "Quick-Silverback Tracker Monkey"
          Unique Title "The Torturer of PCGen"
        Your message has been successfully submitted and would be delivered to recipients shortly.