Loading ...
Sorry, an error occurred while loading the content.

Re: Problems in Vista

Expand Messages
  • thaldorf
    ... I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of
    Message 1 of 16 , Apr 1 2:13 PM
    • 0 Attachment
      --- In pcgen@yahoogroups.com, "magus_knightcrawler" <magus_knightcrawler@...> wrote:
      >
      > Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
      >
      > Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
      >
      > Knightcrawler
      > Former, Data Ape
      >


      I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.
    • Brad Stiles
      ... I ve heard of this behavior with other programs in Vista, 32 and 64. Windows 7 is supposed to have the same issue. Access to the Program Files tree is
      Message 2 of 16 , Apr 2 5:02 AM
      • 0 Attachment
        > Got it running in Vista 64 by reinstalling most recent Java.  But again won't save.  Console gave some of this.
        >
        > java.io.FileNotFoundException: C:\Program Files\PCGen\PCGen5141\characters\Lusur.pcg (Access is denied)
        > at java.io.FileOutputStream.open(Native Method)
        > at java.io.FileOutputStream.<init>(Unknown Source)
        >
        > followed by about 60-70 lines that all end with (Unknown Source).  Wouldn't let me copy paste the entire thing in.
        > Also tried installing abosultely newest Java but no change.

        I've heard of this behavior with other programs in Vista, 32 and 64.
        Windows 7 is supposed to have the same issue. Access to the Program
        Files tree is fairly seriously restricted (even for administrators,
        depending on the program), and so programs that expect to be able to
        write data there don't always work the way they should. This includes
        things like INI, or other configuration, files that the program
        expects to be able to change.

        The most successful solution is to simply install PCGen somewhere
        else. No other directory tree has the same type of restriction on it.

        Other solutions, ones which involve putting parts of PCGen in one
        place and other parts in another, might also work, but aren't,
        IMNECTHO, worth the extra effort.

        Brad
      • Sean Riley
        Can you give a link to that for us? Thanks, Sean Riley ... From: thaldorf To: pcgen@yahoogroups.com Sent: Wednesday, April 01, 2009 5:13 PM Subject: [pcgen]
        Message 3 of 16 , Apr 3 7:04 AM
        • 0 Attachment
          Can you give a link to that for us?

          Thanks,

          Sean Riley

          ----- Original Message -----
          From: thaldorf
          To: pcgen@yahoogroups.com
          Sent: Wednesday, April 01, 2009 5:13 PM
          Subject: [pcgen] Re: Problems in Vista

          I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.

          [Non-text portions of this message have been removed]
        • magus_knightcrawler
          ... The newest version of Java has specific support for 64. But make sure you get it directly from the Java site. PCGen now works but we can still not save.
          Message 4 of 16 , Apr 4 11:53 AM
          • 0 Attachment
            --- In pcgen@yahoogroups.com, "thaldorf" <thaldorf@...> wrote:
            >
            > --- In pcgen@yahoogroups.com, "magus_knightcrawler" <magus_knightcrawler@> wrote:
            > >
            > > Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
            > >
            > > Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
            > >
            > > Knightcrawler
            > > Former, Data Ape
            > >
            >
            >
            > I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.
            >

            The newest version of Java has specific support for 64. But make sure you get it directly from the Java site. PCGen now works but we can still not save. I'm going to try uninstalling and reinstalling within my documents folder.

            Knightcrawler
            Former Data Ape
          • James Dempsey
            Hi Knightcrawler, On 5/04/2009 4:53 AM magus_knightcrawler wrote ... Another option is to change your saved characters folder in preferences to a folder under
            Message 5 of 16 , Apr 4 1:54 PM
            • 0 Attachment
              Hi Knightcrawler,

              On 5/04/2009 4:53 AM magus_knightcrawler wrote
              > --- In pcgen@yahoogroups.com, "thaldorf" <thaldorf@...> wrote:
              >
              >> --- In pcgen@yahoogroups.com, "magus_knightcrawler" <magus_knightcrawler@> wrote:
              >>
              >>> Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
              >>>
              >>> Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
              >>>
              >>> Knightcrawler
              >>> Former, Data Ape
              >>>
              >>>
              >> I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.
              >>
              >>
              >
              > The newest version of Java has specific support for 64. But make sure you get it directly from the Java site. PCGen now works but we can still not save. I'm going to try uninstalling and reinstalling within my documents folder.
              >
              >
              Another option is to change your saved characters folder in preferences
              to a folder under My Documents. I think we might have to make this the
              default so that it works "out of the box". A similar thing would need to
              be done with the custom sources folder.

              Cheers,
              James Dempsey
              PCGen Code SB
            • magus_knightcrawler
              ... I unistalled it and reinstalled it within My Documents. Seems to work now. Perhaps moving the folders might work. But you d have to move any folder to
              Message 6 of 16 , Apr 4 2:49 PM
              • 0 Attachment
                --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:

                > >
                > >
                > Another option is to change your saved characters folder in preferences
                > to a folder under My Documents. I think we might have to make this the
                > default so that it works "out of the box". A similar thing would need to
                > be done with the custom sources folder.
                >
                > Cheers,
                > James Dempsey
                > PCGen Code SB
                >

                I unistalled it and reinstalled it within My Documents. Seems to work now. Perhaps moving the folders might work. But you'd have to move any folder to which something would be saved. I did try modifying the permissions on the whole PCGen folder but that did not seem to work. The simplest seems to be to just install it to My Documents.

                Knightcrawler
                Former Data Ape
              • Brad Stiles
                ... You d also need to do it for any other file to which the program can write, such as the INI files. Far simpler, IMAO, to just to advise people to not use
                Message 7 of 16 , Apr 5 6:16 AM
                • 0 Attachment
                  > Another option is to change your saved characters folder in
                  > preferences to a folder under My Documents. I think we might
                  > have to make this the default so that it works "out of the box".
                  > A similar thing would need to be done with the custom sources folder.

                  You'd also need to do it for any other file to which the program can
                  write, such as the INI files.

                  Far simpler, IMAO, to just to advise people to not use the "Program
                  Files" tree at all, and install it someplace else.

                  Brad
                • James Dempsey
                  Hi Brad, On 5/04/2009 11:16 PM Brad Stiles wrote ... The INI files already default to the user s home directory, so I think it is just the two settings. If I
                  Message 8 of 16 , Apr 5 3:25 PM
                  • 0 Attachment
                    Hi Brad,

                    On 5/04/2009 11:16 PM Brad Stiles wrote
                    >> Another option is to change your saved characters folder in
                    >> preferences to a folder under My Documents. I think we might
                    >> have to make this the default so that it works "out of the box".
                    >> A similar thing would need to be done with the custom sources folder.
                    >>
                    >
                    > You'd also need to do it for any other file to which the program can
                    > write, such as the INI files.
                    >
                    > Far simpler, IMAO, to just to advise people to not use the "Program
                    > Files" tree at all, and install it someplace else.
                    >
                    >
                    The INI files already default to the user's home directory, so I think
                    it is just the two settings. If I created a test installer would someone
                    be willing to give it a try?

                    Cheers,
                    James.
                  Your message has been successfully submitted and would be delivered to recipients shortly.