Loading ...
Sorry, an error occurred while loading the content.
 

Re: [pcgen] Re: Problems in Vista

Expand Messages
  • Sean Riley
    Here is the path file that I needed before. With each new Java version, I ve had to update the Path. Here s what worked for Vista x64: PCGen should be
    Message 1 of 16 , Mar 31, 2009
      Here is the path file that I needed before. With each new Java version, I've had to update the Path.


      Here's what worked for Vista x64:

      PCGen should be installed in the C:\Program Files (x86) folder

      The .bat command line in the .bat file needs to be changed and should be:
      "C:\Program Files (x86)\Java\jre1.6.0_06\bin\java" -Dswing.aatext=true -Xms128m -Xmx256m -jar pcgen.jar

      The path in the system\advanced properties\... should be:
      ;C:\Program Files (x86)\Java\jre1.6.0_06\bin
      Then Restart the computer, because that is ultimately what reset the path...

      Using the .bat file then works.

      You do not need to enter the command in the command prompt manually.

      Thanks for all of the help!!!!

      I look forward to continued use of PCGen!!!!

      Sean

      ----- Original Message -----
      From: Andrew Maitland
      To: pcgen@yahoogroups.com
      Sent: Tuesday, March 31, 2009 3:28 PM
      Subject: Re: [pcgen] Re: Problems in Vista


      Hm, interesting. We need to open a bug report then.

      Also, permissions to directories is an issue IIRC for vista.

      My directories are not the standard. Try changing the save directory and
      see if that has any effect.

      Can you post the majority of the error msg so the coders can see it please.

      Thanks,

      -Andrew

      magus_knightcrawler wrote:
      > Got it running in Vista 64 by reinstalling most recent Java. But again won't save. Console gave some of this.
      >
      > java.io.FileNotFoundException: C:\Program Files\PCGen\PCGen5141\characters\Lusur.pcg (Access is denied)
      > at java.io.FileOutputStream.open(Native Method)
      > at java.io.FileOutputStream.<init>(Unknown Source)
      >
      > followed by about 60-70 lines that all end with (Unknown Source). Wouldn't let me copy paste the entire thing in. Also tried installing abosultely newest Java but no change.
      >
      > Knightcrawler
      > Confused Ex-Data Ape
      >
      >
      >
      > --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...> wrote:
      >
      >> Hi Magus Knightcrawler,
      >>
      >> Welcome back.
      >>
      >> I personally use PCGen on a Windows Vista Home Premium (Laptop) without
      >> any issues. However, I haven't been trying to save any characters for
      >> awhile, so something may have gotten broken since i last tried.
      >>
      >> Can you post any error messages in the console window. Something like
      >> Out Of Memory could be the issue.
      >>
      >> As to the Bat file. Open one of them up and double the values 128 >
      >> 256 | 256 > 512 That normally solves any memory issues.
      >>
      >> The two I can remember are Low Mem and the regular PCGen bat.
      >>
      >> Hope that helps, if not please post specific details so we can get to
      >> the root of the problem.
      >>
      >> Andrew Maitland (LegacyKing)
      >> Admin Silverback, PCGen Board of Directors
      >> Data Chimp, Docs Tamarin
      >> Unique Title "Quick-Silverback Tracker Monkey"
      >>
      >>
      >>
      >> magus_knightcrawler wrote:
      >>
      >>> Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
      >>>
      >>> Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
      >>>
      >>> Knightcrawler
      >>> Former, Data Ape
      >>>
      >>>
      >>>
      >>>


      [Non-text portions of this message have been removed]
    • Andrew Maitland
      Thanks much Sean. Eric, do we have a note like this in the FAQ part of the docs? If not I can add a tracker for it s inclusion. Andrew Maitland (LegacyKing)
      Message 2 of 16 , Apr 1, 2009
        Thanks much Sean.

        Eric, do we have a note like this in the FAQ part of the docs?

        If not I can add a tracker for it's inclusion.

        Andrew Maitland (LegacyKing)
        Admin Silverback, PCGen Board of Directors
        Data Chimp, Docs Tamarin
        Unique Title "Quick-Silverback Tracker Monkey"



        Sean Riley wrote:
        > Here is the path file that I needed before. With each new Java version, I've had to update the Path.
        >
        >
        > Here's what worked for Vista x64:
        >
        > PCGen should be installed in the C:\Program Files (x86) folder
        >
        > The .bat command line in the .bat file needs to be changed and should be:
        > "C:\Program Files (x86)\Java\jre1.6.0_06\bin\java" -Dswing.aatext=true -Xms128m -Xmx256m -jar pcgen.jar
        >
        > The path in the system\advanced properties\... should be:
        > ;C:\Program Files (x86)\Java\jre1.6.0_06\bin
        > Then Restart the computer, because that is ultimately what reset the path...
        >
        > Using the .bat file then works.
        >
        > You do not need to enter the command in the command prompt manually.
        >
        > Thanks for all of the help!!!!
        >
        > I look forward to continued use of PCGen!!!!
        >
        > Sean
        >
        > ----- Original Message -----
        > From: Andrew Maitland
        > To: pcgen@yahoogroups.com
        > Sent: Tuesday, March 31, 2009 3:28 PM
        > Subject: Re: [pcgen] Re: Problems in Vista
        >
        >
        > Hm, interesting. We need to open a bug report then.
        >
        > Also, permissions to directories is an issue IIRC for vista.
        >
        > My directories are not the standard. Try changing the save directory and
        > see if that has any effect.
        >
        > Can you post the majority of the error msg so the coders can see it please.
        >
        > Thanks,
        >
        > -Andrew
        >
        > magus_knightcrawler wrote:
        > > Got it running in Vista 64 by reinstalling most recent Java. But again won't save. Console gave some of this.
        > >
        > > java.io.FileNotFoundException: C:\Program Files\PCGen\PCGen5141\characters\Lusur.pcg (Access is denied)
        > > at java.io.FileOutputStream.open(Native Method)
        > > at java.io.FileOutputStream.<init>(Unknown Source)
        > >
        > > followed by about 60-70 lines that all end with (Unknown Source). Wouldn't let me copy paste the entire thing in. Also tried installing abosultely newest Java but no change.
        > >
        > > Knightcrawler
        > > Confused Ex-Data Ape
        > >
        > >
        > >
        > > --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...> wrote:
        > >
        > >> Hi Magus Knightcrawler,
        > >>
        > >> Welcome back.
        > >>
        > >> I personally use PCGen on a Windows Vista Home Premium (Laptop) without
        > >> any issues. However, I haven't been trying to save any characters for
        > >> awhile, so something may have gotten broken since i last tried.
        > >>
        > >> Can you post any error messages in the console window. Something like
        > >> Out Of Memory could be the issue.
        > >>
        > >> As to the Bat file. Open one of them up and double the values 128 >
        > >> 256 | 256 > 512 That normally solves any memory issues.
        > >>
        > >> The two I can remember are Low Mem and the regular PCGen bat.
        > >>
        > >> Hope that helps, if not please post specific details so we can get to
        > >> the root of the problem.
        > >>
        > >> Andrew Maitland (LegacyKing)
        > >> Admin Silverback, PCGen Board of Directors
        > >> Data Chimp, Docs Tamarin
        > >> Unique Title "Quick-Silverback Tracker Monkey"
        > >>
        > >>
        > >>
        > >> magus_knightcrawler wrote:
        > >>
        > >>> Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
        > >>>
        > >>> Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
        > >>>
        > >>> Knightcrawler
        > >>> Former, Data Ape
        > >>>
        > >>>
        > >>>
        > >>>
        >
        >
        > [Non-text portions of this message have been removed]
        >
        >
        >
        > ------------------------------------
        >
        > PCGen's Release site: http://pcgen.sourceforge.net
        > PCGen's Wiki: http://pcgen.wiki.sourceforge.net/
        > PCGen's Roadmap: http://pcgen.wiki.sourceforge.net/Roadmap
        > PCGen's Alpha Build: http://pcgen.sourceforge.net/07_autobuilds.php
        > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
        > PCGen's Data Help Grp: http://tech.groups.yahoo.com/group/PCGenListFileHelp/Yahoo! Groups Links
        >
        >
        >
        >
        >
      • Eric C Smith
        There is a similar solution in the FAQ except that iot places the command line in the.cmd file instead of the .bat file. Not being a PC person, I assume these
        Message 3 of 16 , Apr 1, 2009
          There is a similar solution in the FAQ except that iot places the
          command line in the.cmd file instead of the .bat file. Not being a PC
          person, I assume these files are separate files. If the statement is
          placed in the ,bat file, do we need it in the .cmd file? Does this
          represent an additional solution to getting PCGen running under Vista
          or XP64?

          Also, the FAQ lists minimummemory of 768MB. Is this the minimum? Or
          the minimum recommended?

          Eric C. Smith
          Doc 2nd

          On Apr 1, 2009, at 11:57 AM, Andrew Maitland wrote:

          > Thanks much Sean.
          >
          > Eric, do we have a note like this in the FAQ part of the docs?
          >
          > If not I can add a tracker for it's inclusion.
          >
          > Andrew Maitland (LegacyKing)
          > Admin Silverback, PCGen Board of Directors
          > Data Chimp, Docs Tamarin
          > Unique Title "Quick-Silverback Tracker Monkey"
          >
          > Sean Riley wrote:
          > > Here is the path file that I needed before. With each new Java
          > version, I've had to update the Path.
          > >
          > >
          > > Here's what worked for Vista x64:
          > >
          > > PCGen should be installed in the C:\Program Files (x86) folder
          > >
          > > The .bat command line in the .bat file needs to be changed and
          > should be:
          > > "C:\Program Files (x86)\Java\jre1.6.0_06\bin\java" -
          > Dswing.aatext=true -Xms128m -Xmx256m -jar pcgen.jar
          > >
          > > The path in the system\advanced properties\... should be:
          > > ;C:\Program Files (x86)\Java\jre1.6.0_06\bin
          > > Then Restart the computer, because that is ultimately what reset
          > the path...
          > >
          > > Using the .bat file then works.
          > >
          > > You do not need to enter the command in the command prompt manually.
          > >
          > > Thanks for all of the help!!!!
          > >
          > > I look forward to continued use of PCGen!!!!
          > >
          > > Sean
          > >
          > > ----- Original Message -----
          > > From: Andrew Maitland
          > > To: pcgen@yahoogroups.com
          > > Sent: Tuesday, March 31, 2009 3:28 PM
          > > Subject: Re: [pcgen] Re: Problems in Vista
          > >
          > >
          > > Hm, interesting. We need to open a bug report then.
          > >
          > > Also, permissions to directories is an issue IIRC for vista.
          > >
          > > My directories are not the standard. Try changing the save
          > directory and
          > > see if that has any effect.
          > >
          > > Can you post the majority of the error msg so the coders can see
          > it please.
          > >
          > > Thanks,
          > >
          > > -Andrew
          > >
          > > magus_knightcrawler wrote:
          > > > Got it running in Vista 64 by reinstalling most recent Java.
          > But again won't save. Console gave some of this.
          > > >
          > > > java.io.FileNotFoundException: C:\Program Files\PCGen\PCGen5141
          > \characters\Lusur.pcg (Access is denied)
          > > > at java.io.FileOutputStream.open(Native Method)
          > > > at java.io.FileOutputStream.<init>(Unknown Source)
          > > >
          > > > followed by about 60-70 lines that all end with (Unknown
          > Source). Wouldn't let me copy paste the entire thing in. Also tried
          > installing abosultely newest Java but no change.
          > > >
          > > > Knightcrawler
          > > > Confused Ex-Data Ape
          > > >
          > > >
          > > >
          > > > --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...>
          > wrote:
          > > >
          > > >> Hi Magus Knightcrawler,
          > > >>
          > > >> Welcome back.
          > > >>
          > > >> I personally use PCGen on a Windows Vista Home Premium
          > (Laptop) without
          > > >> any issues. However, I haven't been trying to save any
          > characters for
          > > >> awhile, so something may have gotten broken since i last tried.
          > > >>
          > > >> Can you post any error messages in the console window.
          > Something like
          > > >> Out Of Memory could be the issue.
          > > >>
          > > >> As to the Bat file. Open one of them up and double the values
          > 128 >
          > > >> 256 | 256 > 512 That normally solves any memory issues.
          > > >>
          > > >> The two I can remember are Low Mem and the regular PCGen bat.
          > > >>
          > > >> Hope that helps, if not please post specific details so we can
          > get to
          > > >> the root of the problem.
          > > >>
          > > >> Andrew Maitland (LegacyKing)
          > > >> Admin Silverback, PCGen Board of Directors
          > > >> Data Chimp, Docs Tamarin
          > > >> Unique Title "Quick-Silverback Tracker Monkey"
          > > >>
          > > >>
          > > >>
          > > >> magus_knightcrawler wrote:
          > > >>
          > > >>> Been away for a long, long time. Started using PCGen again.
          > Have had several problems in Vista. First I just installed PCGen on
          > my new Vista Home Premium laptop and it won't let me save any
          > created characters. I've checked all the directories and they all
          > look correct.
          > > >>>
          > > >>> Also we haven't been able to run it at all on a Vista x64
          > machine and the FAQ's about this are a little to vague. As to
          > what .bat file we are supposed to edit and what we are supposed to
          > add or delete. Thanks for any help.
          > > >>>
          > > >>> Knightcrawler
          > > >>> Former, Data Ape
          >
        • Andrew Maitland
          Oh good questions... Well, the command line is reached by the .bat file in windows, so all these should be placed in the .bat file. There is no cmd file... to
          Message 4 of 16 , Apr 1, 2009
            Oh good questions...

            Well, the command line is reached by the .bat file in windows, so all
            these should be placed in the .bat file.

            There is no cmd file... to reach a manual command line one accesses it
            with the 'cmd' command in Vista (Earlier versions used the longer
            'command.exe' IIRC). And the command line is really a dos layout...
            which the bat file does an extremely good job of handling.

            512 is sufficient for me, though I do have a higher setting when I need
            to load a lot of sets. My normal average memory usage is 400 - 500. So
            512 is decent, 768 is just a nice buffer.

            Andrew Maitland (LegacyKing)
            Admin Silverback, PCGen Board of Directors
            Data Chimp, Docs Tamarin
            Unique Title "Quick-Silverback Tracker Monkey"



            Eric C Smith wrote:
            > There is a similar solution in the FAQ except that iot places the
            > command line in the.cmd file instead of the .bat file. Not being a PC
            > person, I assume these files are separate files. If the statement is
            > placed in the ,bat file, do we need it in the .cmd file? Does this
            > represent an additional solution to getting PCGen running under Vista
            > or XP64?
            >
            > Also, the FAQ lists minimummemory of 768MB. Is this the minimum? Or
            > the minimum recommended?
            >
            > Eric C. Smith
            > Doc 2nd
            >
            > On Apr 1, 2009, at 11:57 AM, Andrew Maitland wrote:
            >
            >
            >> Thanks much Sean.
            >>
            >> Eric, do we have a note like this in the FAQ part of the docs?
            >>
            >> If not I can add a tracker for it's inclusion.
            >>
            >> Andrew Maitland (LegacyKing)
            >> Admin Silverback, PCGen Board of Directors
            >> Data Chimp, Docs Tamarin
            >> Unique Title "Quick-Silverback Tracker Monkey"
            >>
            >> Sean Riley wrote:
            >>
            >>> Here is the path file that I needed before. With each new Java
            >>>
            >> version, I've had to update the Path.
            >>
            >>> Here's what worked for Vista x64:
            >>>
            >>> PCGen should be installed in the C:\Program Files (x86) folder
            >>>
            >>> The .bat command line in the .bat file needs to be changed and
            >>>
            >> should be:
            >>
            >>> "C:\Program Files (x86)\Java\jre1.6.0_06\bin\java" -
            >>>
            >> Dswing.aatext=true -Xms128m -Xmx256m -jar pcgen.jar
            >>
            >>> The path in the system\advanced properties\... should be:
            >>> ;C:\Program Files (x86)\Java\jre1.6.0_06\bin
            >>> Then Restart the computer, because that is ultimately what reset
            >>>
            >> the path...
            >>
            >>> Using the .bat file then works.
            >>>
            >>> You do not need to enter the command in the command prompt manually.
            >>>
            >>> Thanks for all of the help!!!!
            >>>
            >>> I look forward to continued use of PCGen!!!!
            >>>
            >>> Sean
            >>>
            >>> ----- Original Message -----
            >>> From: Andrew Maitland
            >>> To: pcgen@yahoogroups.com
            >>> Sent: Tuesday, March 31, 2009 3:28 PM
            >>> Subject: Re: [pcgen] Re: Problems in Vista
            >>>
            >>>
            >>> Hm, interesting. We need to open a bug report then.
            >>>
            >>> Also, permissions to directories is an issue IIRC for vista.
            >>>
            >>> My directories are not the standard. Try changing the save
            >>>
            >> directory and
            >>
            >>> see if that has any effect.
            >>>
            >>> Can you post the majority of the error msg so the coders can see
            >>>
            >> it please.
            >>
            >>> Thanks,
            >>>
            >>> -Andrew
            >>>
            >>> magus_knightcrawler wrote:
            >>>
            >>>> Got it running in Vista 64 by reinstalling most recent Java.
            >>>>
            >> But again won't save. Console gave some of this.
            >>
            >>>> java.io.FileNotFoundException: C:\Program Files\PCGen\PCGen5141
            >>>>
            >> \characters\Lusur.pcg (Access is denied)
            >>
            >>>> at java.io.FileOutputStream.open(Native Method)
            >>>> at java.io.FileOutputStream.<init>(Unknown Source)
            >>>>
            >>>> followed by about 60-70 lines that all end with (Unknown
            >>>>
            >> Source). Wouldn't let me copy paste the entire thing in. Also tried
            >> installing abosultely newest Java but no change.
            >>
            >>>> Knightcrawler
            >>>> Confused Ex-Data Ape
            >>>>
            >>>>
            >>>>
            >>>> --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...>
            >>>>
            >> wrote:
            >>
            >>>>> Hi Magus Knightcrawler,
            >>>>>
            >>>>> Welcome back.
            >>>>>
            >>>>> I personally use PCGen on a Windows Vista Home Premium
            >>>>>
            >> (Laptop) without
            >>
            >>>>> any issues. However, I haven't been trying to save any
            >>>>>
            >> characters for
            >>
            >>>>> awhile, so something may have gotten broken since i last tried.
            >>>>>
            >>>>> Can you post any error messages in the console window.
            >>>>>
            >> Something like
            >>
            >>>>> Out Of Memory could be the issue.
            >>>>>
            >>>>> As to the Bat file. Open one of them up and double the values
            >>>>>
            >> 128 >
            >>
            >>>>> 256 | 256 > 512 That normally solves any memory issues.
            >>>>>
            >>>>> The two I can remember are Low Mem and the regular PCGen bat.
            >>>>>
            >>>>> Hope that helps, if not please post specific details so we can
            >>>>>
            >> get to
            >>
            >>>>> the root of the problem.
            >>>>>
            >>>>> Andrew Maitland (LegacyKing)
            >>>>> Admin Silverback, PCGen Board of Directors
            >>>>> Data Chimp, Docs Tamarin
            >>>>> Unique Title "Quick-Silverback Tracker Monkey"
            >>>>>
            >>>>>
            >>>>>
            >>>>> magus_knightcrawler wrote:
            >>>>>
            >>>>>
            >>>>>> Been away for a long, long time. Started using PCGen again.
            >>>>>>
            >> Have had several problems in Vista. First I just installed PCGen on
            >> my new Vista Home Premium laptop and it won't let me save any
            >> created characters. I've checked all the directories and they all
            >> look correct.
            >>
            >>>>>> Also we haven't been able to run it at all on a Vista x64
            >>>>>>
            >> machine and the FAQ's about this are a little to vague. As to
            >> what .bat file we are supposed to edit and what we are supposed to
            >> add or delete. Thanks for any help.
            >>
            >>>>>> Knightcrawler
            >>>>>> Former, Data Ape
            >>>>>>
            >
            >
            >
            >
            > ------------------------------------
            >
            > PCGen's Release site: http://pcgen.sourceforge.net
            > PCGen's Wiki: http://pcgen.wiki.sourceforge.net/
            > PCGen's Roadmap: http://pcgen.wiki.sourceforge.net/Roadmap
            > PCGen's Alpha Build: http://pcgen.sourceforge.net/07_autobuilds.php
            > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
            > PCGen's Data Help Grp: http://tech.groups.yahoo.com/group/PCGenListFileHelp/Yahoo! Groups Links
            >
            >
            >
            >
            >


            [Non-text portions of this message have been removed]
          • thaldorf
            ... I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of
            Message 5 of 16 , Apr 1, 2009
              --- In pcgen@yahoogroups.com, "magus_knightcrawler" <magus_knightcrawler@...> wrote:
              >
              > Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
              >
              > Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
              >
              > Knightcrawler
              > Former, Data Ape
              >


              I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.
            • Brad Stiles
              ... I ve heard of this behavior with other programs in Vista, 32 and 64. Windows 7 is supposed to have the same issue. Access to the Program Files tree is
              Message 6 of 16 , Apr 2, 2009
                > Got it running in Vista 64 by reinstalling most recent Java.  But again won't save.  Console gave some of this.
                >
                > java.io.FileNotFoundException: C:\Program Files\PCGen\PCGen5141\characters\Lusur.pcg (Access is denied)
                > at java.io.FileOutputStream.open(Native Method)
                > at java.io.FileOutputStream.<init>(Unknown Source)
                >
                > followed by about 60-70 lines that all end with (Unknown Source).  Wouldn't let me copy paste the entire thing in.
                > Also tried installing abosultely newest Java but no change.

                I've heard of this behavior with other programs in Vista, 32 and 64.
                Windows 7 is supposed to have the same issue. Access to the Program
                Files tree is fairly seriously restricted (even for administrators,
                depending on the program), and so programs that expect to be able to
                write data there don't always work the way they should. This includes
                things like INI, or other configuration, files that the program
                expects to be able to change.

                The most successful solution is to simply install PCGen somewhere
                else. No other directory tree has the same type of restriction on it.

                Other solutions, ones which involve putting parts of PCGen in one
                place and other parts in another, might also work, but aren't,
                IMNECTHO, worth the extra effort.

                Brad
              • Sean Riley
                Can you give a link to that for us? Thanks, Sean Riley ... From: thaldorf To: pcgen@yahoogroups.com Sent: Wednesday, April 01, 2009 5:13 PM Subject: [pcgen]
                Message 7 of 16 , Apr 3, 2009
                  Can you give a link to that for us?

                  Thanks,

                  Sean Riley

                  ----- Original Message -----
                  From: thaldorf
                  To: pcgen@yahoogroups.com
                  Sent: Wednesday, April 01, 2009 5:13 PM
                  Subject: [pcgen] Re: Problems in Vista

                  I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.

                  [Non-text portions of this message have been removed]
                • magus_knightcrawler
                  ... The newest version of Java has specific support for 64. But make sure you get it directly from the Java site. PCGen now works but we can still not save.
                  Message 8 of 16 , Apr 4, 2009
                    --- In pcgen@yahoogroups.com, "thaldorf" <thaldorf@...> wrote:
                    >
                    > --- In pcgen@yahoogroups.com, "magus_knightcrawler" <magus_knightcrawler@> wrote:
                    > >
                    > > Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
                    > >
                    > > Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
                    > >
                    > > Knightcrawler
                    > > Former, Data Ape
                    > >
                    >
                    >
                    > I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.
                    >

                    The newest version of Java has specific support for 64. But make sure you get it directly from the Java site. PCGen now works but we can still not save. I'm going to try uninstalling and reinstalling within my documents folder.

                    Knightcrawler
                    Former Data Ape
                  • James Dempsey
                    Hi Knightcrawler, On 5/04/2009 4:53 AM magus_knightcrawler wrote ... Another option is to change your saved characters folder in preferences to a folder under
                    Message 9 of 16 , Apr 4, 2009
                      Hi Knightcrawler,

                      On 5/04/2009 4:53 AM magus_knightcrawler wrote
                      > --- In pcgen@yahoogroups.com, "thaldorf" <thaldorf@...> wrote:
                      >
                      >> --- In pcgen@yahoogroups.com, "magus_knightcrawler" <magus_knightcrawler@> wrote:
                      >>
                      >>> Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
                      >>>
                      >>> Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
                      >>>
                      >>> Knightcrawler
                      >>> Former, Data Ape
                      >>>
                      >>>
                      >> I used Vista 64 for a long time, now I am using Windows 7 64bit and had the same problems as you. What was the solution? simple, to install a 64 version of Java.
                      >>
                      >>
                      >
                      > The newest version of Java has specific support for 64. But make sure you get it directly from the Java site. PCGen now works but we can still not save. I'm going to try uninstalling and reinstalling within my documents folder.
                      >
                      >
                      Another option is to change your saved characters folder in preferences
                      to a folder under My Documents. I think we might have to make this the
                      default so that it works "out of the box". A similar thing would need to
                      be done with the custom sources folder.

                      Cheers,
                      James Dempsey
                      PCGen Code SB
                    • magus_knightcrawler
                      ... I unistalled it and reinstalled it within My Documents. Seems to work now. Perhaps moving the folders might work. But you d have to move any folder to
                      Message 10 of 16 , Apr 4, 2009
                        --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:

                        > >
                        > >
                        > Another option is to change your saved characters folder in preferences
                        > to a folder under My Documents. I think we might have to make this the
                        > default so that it works "out of the box". A similar thing would need to
                        > be done with the custom sources folder.
                        >
                        > Cheers,
                        > James Dempsey
                        > PCGen Code SB
                        >

                        I unistalled it and reinstalled it within My Documents. Seems to work now. Perhaps moving the folders might work. But you'd have to move any folder to which something would be saved. I did try modifying the permissions on the whole PCGen folder but that did not seem to work. The simplest seems to be to just install it to My Documents.

                        Knightcrawler
                        Former Data Ape
                      • Brad Stiles
                        ... You d also need to do it for any other file to which the program can write, such as the INI files. Far simpler, IMAO, to just to advise people to not use
                        Message 11 of 16 , Apr 5, 2009
                          > Another option is to change your saved characters folder in
                          > preferences to a folder under My Documents. I think we might
                          > have to make this the default so that it works "out of the box".
                          > A similar thing would need to be done with the custom sources folder.

                          You'd also need to do it for any other file to which the program can
                          write, such as the INI files.

                          Far simpler, IMAO, to just to advise people to not use the "Program
                          Files" tree at all, and install it someplace else.

                          Brad
                        • James Dempsey
                          Hi Brad, On 5/04/2009 11:16 PM Brad Stiles wrote ... The INI files already default to the user s home directory, so I think it is just the two settings. If I
                          Message 12 of 16 , Apr 5, 2009
                            Hi Brad,

                            On 5/04/2009 11:16 PM Brad Stiles wrote
                            >> Another option is to change your saved characters folder in
                            >> preferences to a folder under My Documents. I think we might
                            >> have to make this the default so that it works "out of the box".
                            >> A similar thing would need to be done with the custom sources folder.
                            >>
                            >
                            > You'd also need to do it for any other file to which the program can
                            > write, such as the INI files.
                            >
                            > Far simpler, IMAO, to just to advise people to not use the "Program
                            > Files" tree at all, and install it someplace else.
                            >
                            >
                            The INI files already default to the user's home directory, so I think
                            it is just the two settings. If I created a test installer would someone
                            be willing to give it a try?

                            Cheers,
                            James.
                          Your message has been successfully submitted and would be delivered to recipients shortly.