Loading ...
Sorry, an error occurred while loading the content.

[Vista] Uninstall Problem . . .

Expand Messages
  • Eric C. Smith
    Hi Folks! One of my players is using PCGen on her Vista pack n Laptop and has had little problem getting it to run until she went to uninstall in preparation
    Message 1 of 4 , Jan 5, 2009
    • 0 Attachment
      Hi Folks!

      One of my players is using PCGen on her Vista pack'n
      Laptop and has had little problem getting it to run until
      she went to uninstall in preparation for a total reconfig-
      uration of the gamefiles I use in my campaign.

      The following is her description of the problem:

      > It's hard to pin it on PCGen because what's happening
      > is that when I try to reboot after uninstalling, it freq-
      > uently hangs shutting down & then hangs a lot or takes
      > an extraordinary amount of time to come back up. Some-
      > where in the midst of one of those occasions I lost my
      > iTunes library (but was able to recreate it - I didn't lose
      > any files). It's just that I haven't done anything else with
      > the computer, although I do get automatic Microsoft
      > updates pretty much weekly. So, from my perspective it
      > seems like PCGen, but could easily be some quirky Micro-
      > soft update.
      >
      > Also, I continue to see the weird effect that the PCGen
      > folder is completly gone after uninstalling, but the pcg
      > files magically reappear when I re-install. It may be some
      > unheralded/unrealized Vista "feature". At one point I was
      > going to try running a defrag after the uninstall, but I just
      > didn't have the time to wait on it.

      Where does PCGen store the preferences on Windows?

      Thanks
    • Andrew Maitland
      Hi Eric, Mine is setup as so... c:/users/ /.pcgen program default install location is: c/program files/pcgen/pcgenxxxx/ Andrew Maitland
      Message 2 of 4 , Jan 5, 2009
      • 0 Attachment
        Hi Eric,

        Mine is setup as so...
        c:/users/<windows user name>/.pcgen

        program default install location is:
        c/program files/pcgen/pcgenxxxx/

        Andrew Maitland (LegacyKing)
        Admin Silverback, PCGen Board of Directors
        Data Chimp, Docs Tamarin
        Unique Title "Quick-Silverback Tracker Monkey"



        Eric C. Smith wrote:
        > Hi Folks!
        >
        > One of my players is using PCGen on her Vista pack'n
        > Laptop and has had little problem getting it to run until
        > she went to uninstall in preparation for a total reconfig-
        > uration of the gamefiles I use in my campaign.
        >
        > The following is her description of the problem:
        >
        >
        >> It's hard to pin it on PCGen because what's happening
        >> is that when I try to reboot after uninstalling, it freq-
        >> uently hangs shutting down & then hangs a lot or takes
        >> an extraordinary amount of time to come back up. Some-
        >> where in the midst of one of those occasions I lost my
        >> iTunes library (but was able to recreate it - I didn't lose
        >> any files). It's just that I haven't done anything else with
        >> the computer, although I do get automatic Microsoft
        >> updates pretty much weekly. So, from my perspective it
        >> seems like PCGen, but could easily be some quirky Micro-
        >> soft update.
        >>
        >> Also, I continue to see the weird effect that the PCGen
        >> folder is completly gone after uninstalling, but the pcg
        >> files magically reappear when I re-install. It may be some
        >> unheralded/unrealized Vista "feature". At one point I was
        >> going to try running a defrag after the uninstall, but I just
        >> didn't have the time to wait on it.
        >>
        >
        > Where does PCGen store the preferences on Windows?
        >
        > Thanks
        >
        >
        > ------------------------------------
        >
        > PCGen's Release site: http://pcgen.sourceforge.net
        > PCGen's Wiki: http://pcgen.wiki.sourceforge.net/
        > PCGen's Roadmap: http://pcgen.wiki.sourceforge.net/Roadmap
        > PCGen's Alpha Build: http://pcgen.sourceforge.net/07_autobuilds.php
        > PCGen's Online Docs: http://pcgen.sourceforge.net/autobuilds/pcgen-docs/
        > PCGen's Data Help Grp: http://tech.groups.yahoo.com/group/PCGenListFileHelp/Yahoo! Groups Links
        >
        >
        >
        >
        >


        [Non-text portions of this message have been removed]
      • Eric C. Smith
        Hi Folks! ... In the default install configuration, is c:/program files/pcgen/pcgenxxxx/ , and thus the settings preferrences, removed when Uninstall is run?
        Message 3 of 4 , Jan 6, 2009
        • 0 Attachment
          Hi Folks!

          Andrew wrote:
          >
          > Mine is setup as so...
          > c:/users/<windows user name>/.pcgen
          >
          > program default install location is:
          > c/program files/pcgen/pcgenxxxx/

          In the default install configuration, is "c:/program
          files/pcgen/pcgenxxxx/", and thus the settings preferrences,
          removed when Uninstall is run?

          We use a custom dataset that was originally installed through
          PCGen's Data Install feature, with the data being placed in the
          data folder. My player has verified that after running uninstall,
          the PCGen folder is removed, including the custom gamemode,
          campaign and data files, as you would expect. After reinstall-
          ing PCGen, but NOT the custom_dataset_install file, she launches
          PCGen and finds that the custom gamemode has returned, as
          has all of the associated campaign and data files.

          Has anyone else run into this problem? Or have any suggestion
          as to what we can do to fix it?

          > Eric C. Smith wrote:
          > > Hi Folks!
          > >
          > > One of my players is using PCGen on her Vista pack'n
          > > Laptop and has had little problem getting it to run until
          > > she went to uninstall in preparation for a total reconfig-
          > > uration of the gamefiles I use in my campaign.
          > >
          > > The following is her description of the problem:
          > >
          > >
          > >> It's hard to pin it on PCGen because what's happening
          > >> is that when I try to reboot after uninstalling, it freq-
          > >> uently hangs shutting down & then hangs a lot or takes
          > >> an extraordinary amount of time to come back up. Some-
          > >> where in the midst of one of those occasions I lost my
          > >> iTunes library (but was able to recreate it - I didn't lose
          > >> any files). It's just that I haven't done anything else with
          > >> the computer, although I do get automatic Microsoft
          > >> updates pretty much weekly. So, from my perspective it
          > >> seems like PCGen, but could easily be some quirky Micro-
          > >> soft update.
          > >>
          > >> Also, I continue to see the weird effect that the PCGen
          > >> folder is completly gone after uninstalling, but the pcg
          > >> files magically reappear when I re-install. It may be some
          > >> unheralded/unrealized Vista "feature". At one point I was
          > >> going to try running a defrag after the uninstall, but I just
          > >> didn't have the time to wait on it.
          > >>
          > >
          > > Where does PCGen store the preferences on Windows?
          > >
          > > Thanks
        • James Dempsey
          Hi, On 7/01/2009 2:47 AM Eric C. Smith wrote ... Actually that s no longer the case. In response to a number of user requests, the default is to have the
          Message 4 of 4 , Jan 6, 2009
          • 0 Attachment
            Hi,

            On 7/01/2009 2:47 AM Eric C. Smith wrote
            > Hi Folks!
            >
            > Andrew wrote:
            >
            >> Mine is setup as so...
            >> c:/users/<windows user name>/.pcgen
            >>
            >> program default install location is:
            >> c/program files/pcgen/pcgenxxxx/
            >>
            >
            >
            Actually that's no longer the case. In response to a number of user
            requests, the default is to have the preferences stored in the user's
            home directory. On windows, that is C:\Documents and Settings\<user
            name>\.pcgen (on XP anyway). You can override this by either deleting
            the filepaths.ini file in the pcgen install folder, or changing it in
            preferences.

            > In the default install configuration, is "c:/program
            > files/pcgen/pcgenxxxx/", and thus the settings preferrences,
            > removed when Uninstall is run?
            >
            >
            No, the settings are not removed when uninstalling. We should add this
            in really as an option.

            > We use a custom dataset that was originally installed through
            > PCGen's Data Install feature, with the data being placed in the
            > data folder. My player has verified that after running uninstall,
            > the PCGen folder is removed, including the custom gamemode,
            > campaign and data files, as you would expect. After reinstall-
            > ing PCGen, but NOT the custom_dataset_install file, she launches
            > PCGen and finds that the custom gamemode has returned, as
            > has all of the associated campaign and data files.
            >
            > Has anyone else run into this problem? Or have any suggestion
            > as to what we can do to fix it?
            >
            >
            That is very odd - I could see how the dataset could reappear, if it
            were in the vendordata folder and that were not deleted when you
            uninstalled and deleted last time. However the system folder where the
            game modes are kept really should have been uninstalled and thus the
            game mode not come back. I'd check your preferences to see if the system
            folder is set to somewhere non standard. Note that the uninstaller
            doesn't read the options, so it will only uninstall the data and system
            stuff that it installed originally.

            With respect to your original issue, I'd see it as very unlikely that
            PCGen would cause reboot issues for a PC - it just isn't working at that
            level of the operating system. I'd recommend scanning for viruses and
            malware. If you already use these sorts of tools, try out a new one just
            in case (Windows Defender, Avast anti virus, spybot etc are decent free
            options).
            >> Eric C. Smith wrote:
            >>
            >>> Hi Folks!
            >>>
            >>> One of my players is using PCGen on her Vista pack'n
            >>> Laptop and has had little problem getting it to run until
            >>> she went to uninstall in preparation for a total reconfig-
            >>> uration of the gamefiles I use in my campaign.
            >>>
            >>> The following is her description of the problem:
            >>>
            >>>
            >>>
            >>>> It's hard to pin it on PCGen because what's happening
            >>>> is that when I try to reboot after uninstalling, it freq-
            >>>> uently hangs shutting down & then hangs a lot or takes
            >>>> an extraordinary amount of time to come back up. Some-
            >>>> where in the midst of one of those occasions I lost my
            >>>> iTunes library (but was able to recreate it - I didn't lose
            >>>> any files). It's just that I haven't done anything else with
            >>>> the computer, although I do get automatic Microsoft
            >>>> updates pretty much weekly. So, from my perspective it
            >>>> seems like PCGen, but could easily be some quirky Micro-
            >>>> soft update.
            >>>>
            >>>> Also, I continue to see the weird effect that the PCGen
            >>>> folder is completly gone after uninstalling, but the pcg
            >>>> files magically reappear when I re-install. It may be some
            >>>> unheralded/unrealized Vista "feature". At one point I was
            >>>> going to try running a defrag after the uninstall, but I just
            >>>> didn't have the time to wait on it.
            >>>>
            >>>>
            >>> Where does PCGen store the preferences on Windows?
            >>>
            >>> Thanks
            >>>
            Cheers,
            James.
          Your message has been successfully submitted and would be delivered to recipients shortly.