Loading ...
Sorry, an error occurred while loading the content.

Re: [pcgen] [CODE] I'm seeing this in my smoke test of 5.15.5

Expand Messages
  • Eddy Anthony
    ... These are known issues, the Wealth feature needs to be broken out into parent and child categories. The rest are a case of the data being ahead of code (so
    Message 1 of 5 , Oct 13, 2008
    View Source
    • 0 Attachment
      Andrew Maitland wrote:
      > Okay, yeah logging was off - didn't see the end part about skills, so no
      > worries there.
      >
      > RSRD and SRD are clean.
      >
      > Though I did discover this testing the MSRD:
      >

      These are known issues, the Wealth feature needs to be broken out into
      parent and child categories. The rest are a case of the data being ahead
      of code (so the code work has something to test against) and will be
      resolved with this tracker:

      [ 2034599 ] CHOOSE:ABILITY needs to be usable in abilities
      https://sourceforge.net/tracker/?func=detail&aid=2034599&group_id=25576&atid=384722

      So no worries for this release.

      > LSTERROR TYPE is not valid in 'parent' category Wealth of
      > file:/D:/eclipse/release/pcgen5154_full/data/d20ogl/msrd/basics/modern_basics/modernbasics_ability_categories_core.lst.
      > LSTWARN Error parsing CHOOSE, invalid SubToken: ABILITY in Signature
      > Spell of
      > file:/D:/eclipse/release/pcgen5154_full/data/d20ogl/msrd/arcana/basics/arcanabasics_feats.lst
      > LSTERROR Illegal Token 'CHOOSE' 'ABILITY|Special Ability|Spell Mastery'
      > for pcgen.core.Ability Signature Spell
      > LSTWARN Error parsing CHOOSE, invalid SubToken: ABILITY in Increased
      > Weapon Critical of
      > file:/D:/eclipse/release/pcgen5154_full/data/d20ogl/msrd/basics/modern_basics/modernbasics_abilities_class.lst
      > LSTERROR Illegal Token 'CHOOSE' 'ABILITY|Special Ability|Weapon
      > Specialization' for pcgen.core.Ability Increased Weapon Critical
      > LSTWARN Error parsing CHOOSE, invalid SubToken: ABILITY in Greater
      > Weapon Specialization of
      > file:/D:/eclipse/release/pcgen5154_full/data/d20ogl/msrd/basics/modern_basics/modernbasics_abilities_class.lst
      > LSTERROR Illegal Token 'CHOOSE' 'ABILITY|Special Ability|Weapon
      > Specialization' for pcgen.core.Ability Greater Weapon Specialization
      > LSTWARN Error parsing CHOOSE, invalid SubToken: ABILITY in Improved
      > Critical of
      > file:/D:/eclipse/release/pcgen5154_full/data/d20ogl/msrd/basics/modern_basics/modernbasics_abilities_class.lst
      > LSTERROR Illegal Token 'CHOOSE' 'ABILITY|Special Ability|Weapon
      > Specialization' for pcgen.core.Ability Improved Critical
      > All Done
      >
      --

      ~ Eddy Anthony (MoSaT)
      ~ Chair Second, PCGen Board of Directors
      ~ Data Content Second, Doc Chimp, OS Tamarin
    Your message has been successfully submitted and would be delivered to recipients shortly.