Loading ...
Sorry, an error occurred while loading the content.
 

How to Improve Performance

Expand Messages
  • Niilo Van Steinburg
    Hello everyone, I m a big fan of PCGen, but lately I ve been getting quite frustrated with its speed. It s gotten to the point where I can t use it during game
    Message 1 of 8 , Jul 26, 2008
      Hello everyone,

      I'm a big fan of PCGen, but lately I've been getting quite frustrated
      with its speed. It's gotten to the point where I can't use it during
      game sessions anymore because it is too slow (which is very
      unfortunate since I loved using GMGen's initiative tool). Outside of
      slowness, when I tried using it along with MapTool (another Java app)
      it would not start at all.

      Now, even outside of sessions, the slowness is really debilitating.
      Changing tabs between characters or even closing a character takes a
      couple dozen seconds.

      Any ideas on what can be done to allow me to use this awesome program
      again?

      My Specs:
      WinXP SP2
      AMD Athlon 64 3500+ 2.21 Ghz
      2 GB RAM
      Java build 1.6.0_07-b06

      Right now I'm using PCGen 5141. I recently tried giving PCGen more
      memory to work with (-Xms256m -Xmx512m).

      Thanks for your time.

      - Niilo
    • Barak
      ... Turn off the equipment auto-generation and only load those sources you need. Barak
      Message 2 of 8 , Jul 27, 2008
        > -----Original Message-----
        > Any ideas on what can be done to allow me to use this awesome program
        > again?

        Turn off the equipment auto-generation and only load those sources you need.

        Barak
      • Niilo Van Steinburg
        ... you need. ... Thanks for the help, Barak. Unfortunately, there is no change in the performance. I turned off the equipment auto-generation and I reduced my
        Message 3 of 8 , Jul 28, 2008
          --- In pcgen@yahoogroups.com, "Barak" <barak@...> wrote:
          > Turn off the equipment auto-generation and only load those sources
          you need.
          >
          > Barak
          >

          Thanks for the help, Barak. Unfortunately, there is no change in the
          performance. I turned off the equipment auto-generation and I reduced
          my load of the SRD to just the core rulebooks. Rebooted my computer
          (for another reason) and it still took a very long time to load
          characters, change tabs, and open up GMGen (and change tabs within that).

          - Niilo
        • wizard_thoarin
          Have you tried allocating more memory to Java then the default? Edit the PCGen.bat file and up the default memory allocation, provided you have enough memory.
          Message 4 of 8 , Jul 28, 2008
            Have you tried allocating more memory to Java then the default? Edit
            the PCGen.bat file and up the default memory allocation, provided you
            have enough memory. Then make sure you launch PCGen from the bat
            file. I've got 2GB of RAM so I upped mine to 512m for the first
            number and 1024 for the second.


            --- In pcgen@yahoogroups.com, "Niilo Van Steinburg" <niilo@...> wrote:
            >
            > --- In pcgen@yahoogroups.com, "Barak" <barak@> wrote:
            > > Turn off the equipment auto-generation and only load those sources
            > you need.
            > >
            > > Barak
            > >
            >
            > Thanks for the help, Barak. Unfortunately, there is no change in the
            > performance. I turned off the equipment auto-generation and I reduced
            > my load of the SRD to just the core rulebooks. Rebooted my computer
            > (for another reason) and it still took a very long time to load
            > characters, change tabs, and open up GMGen (and change tabs within
            that).
            >
            > - Niilo
            >
          • Tom Parker
            ... that). Can you describe a little more of what you re doing? Specifically: How many sources are loaded? Are the sources from CMP or distributed by PCGen?
            Message 5 of 8 , Jul 28, 2008
              --- In pcgen@yahoogroups.com, "Niilo Van Steinburg" <niilo@...> wrote:
              > Thanks for the help, Barak. Unfortunately, there is no change in the
              > performance. I turned off the equipment auto-generation and I reduced
              > my load of the SRD to just the core rulebooks. Rebooted my computer
              > (for another reason) and it still took a very long time to load
              > characters, change tabs, and open up GMGen (and change tabs within
              that).

              Can you describe a little more of what you're doing?

              Specifically:
              How many sources are loaded?
              Are the sources from CMP or distributed by PCGen?
              How many PCs are open?
              What levels are the PCs?

              TP.
            • Susan Dittmar
              ... Perhaps the sources are still loaded. If I remember correctly, the sources needed are written into the character file, so they can be loaded with the
              Message 6 of 8 , Jul 28, 2008
                Quoting Niilo Van Steinburg (niilo@...):
                > --- In pcgen@yahoogroups.com, "Barak" <barak@...> wrote:
                > > Turn off the equipment auto-generation and only load those sources you
                > > need.
                >
                > Thanks for the help, Barak. Unfortunately, there is no change in the
                > performance. I turned off the equipment auto-generation and I reduced
                > my load of the SRD to just the core rulebooks. Rebooted my computer
                > (for another reason) and it still took a very long time to load
                > characters, change tabs, and open up GMGen (and change tabs within that).

                Perhaps the sources are still loaded. If I remember correctly, the sources
                needed are written into the character file, so they can be loaded with the
                characters. A while ago I had problems with that (it caused double
                loading), and I had to manually remove them from those files. Unfortunately
                I cannot look up the tags you would have to check. Surely someone else can
                give you more information.

                Susan


                [Non-text portions of this message have been removed]
              • Eddy Anthony
                ... Pretty easy to check, if you go back to the sources tab after loading the PC and there are more sources loaded than what you started with then this option
                Message 7 of 8 , Jul 29, 2008
                  Susan Dittmar wrote:
                  > Quoting Niilo Van Steinburg (niilo@...):
                  >
                  >> --- In pcgen@yahoogroups.com, "Barak" <barak@...> wrote:
                  >>
                  >>> Turn off the equipment auto-generation and only load those sources you
                  >>> need.
                  >>>
                  >> Thanks for the help, Barak. Unfortunately, there is no change in the
                  >> performance. I turned off the equipment auto-generation and I reduced
                  >> my load of the SRD to just the core rulebooks. Rebooted my computer
                  >> (for another reason) and it still took a very long time to load
                  >> characters, change tabs, and open up GMGen (and change tabs within that).
                  >>
                  >
                  > Perhaps the sources are still loaded. If I remember correctly, the sources
                  > needed are written into the character file, so they can be loaded with the
                  > characters. A while ago I had problems with that (it caused double
                  > loading), and I had to manually remove them from those files. Unfortunately
                  > I cannot look up the tags you would have to check. Surely someone else can
                  > give you more information.
                  >
                  > Susan
                  >

                  Pretty easy to check, if you go back to the sources tab after loading
                  the PC and there are more sources loaded than what you started with then
                  this option is enabled. This is set in the preferences, go to
                  Preferences/Sources and uncheck "Load Sources with characters".

                  --
                  ~ Eddy Anthony (MoSaT)
                  ~ Chair Second, PCGen Board of Directors
                  ~ Data Content Second, Doc Chimp, OS Tamarin
                • Niilo Van Steinburg
                  Thanks, wizard_thoarin. This has helped quite a bit. I had previously bumped up my allocation to 256 / 512. Doubling that, as per your suggestion, has reduced
                  Message 8 of 8 , Jul 31, 2008
                    Thanks, wizard_thoarin. This has helped quite a bit. I had previously
                    bumped up my allocation to 256 / 512. Doubling that, as per your
                    suggestion, has reduced my waiting time enough to make the program
                    usable again.

                    However, I am still unhappy with the speed of using this program. I
                    don't see why switching a tab should take 5 or more seconds. Here are
                    my answers to questions Tom Parker asked me in regards to this issue:

                    > How many sources are loaded?

                    Normally, only the RSRD(?) for D&D 3.5. I've since reduced this to the
                    RSRD source that excludes Psionics.

                    > Are the sources from CMP or distributed by PCGen?

                    I don't know what CMP is. I haven't added any sources to PCGen, if
                    that answers the question.

                    > How many PCs are open?

                    Sometimes one, sometimes a dozen. My general slowness is experienced
                    with just one PC open, though I do notice a significant increase in
                    that slowness for more than 4 characters.

                    > What levels are the PCs?

                    Usually from 1st to 3rd level.

                    I'm still hesitant to use DMGen again during a playing session. It
                    takes a long time to load (I typically do so with 3 or 4 PCs open),
                    and it takes a long time to switch tabs.

                    Thanks to everyone for your help.

                    - Niilo


                    --- In pcgen@yahoogroups.com, "wizard_thoarin" <bnielsen93230@...> wrote:
                    >
                    > Have you tried allocating more memory to Java then the default? Edit
                    > the PCGen.bat file and up the default memory allocation, provided you
                    > have enough memory. Then make sure you launch PCGen from the bat
                    > file. I've got 2GB of RAM so I upped mine to 512m for the first
                    > number and 1024 for the second.
                  Your message has been successfully submitted and would be delivered to recipients shortly.