Loading ...
Sorry, an error occurred while loading the content.

Re: [pcgen] Re: Working on a Custom Equipment bug, need input.

Expand Messages
  • Andrew Wilson
    ... Hmm, isn t that just going to result in delting all those items when we rewrite the file and don t write them out? andrew
    Message 1 of 13 , Feb 12, 2008
    • 0 Attachment
      On Tue, Feb 12, 2008 at 08:39:38AM -0000, Martijn Verburg wrote:
      > Hi all,
      >> Why I finally just turned the custom eq file off and store custom
      >> equipment only in the pcg files now.
      >>
      >> This problem is very old (VERY) and was one of those things set
      >> aside to fix when the editors were fixed (although I'm not sure
      >> it's listed at SF or in the docs). The gamemode issue was fixed
      >> during one round of editor updates but the same-gamemode different-
      >> sources problem wasn't. Admitted, there were (and still are) far
      >> more important issues and this has a very simple work around - turn
      >> off the custom equipment file.
      >
      > OK, what I'm going to do is investigate Tom's suggestion of simply not
      > loading the custom equipment if it's not supported by the loaded data
      > sets. I'll post any findings in the tracker - K

      Hmm, isn't that just going to result in delting all those items when we
      rewrite the file and don't write them out?

      andrew
    • Martijn Verburg
      ... Yeah, that s my thought as well, I m investigating if that will be the case. We might be alright due to the order of how things are loaded (loading is
      Message 2 of 13 , Feb 12, 2008
      • 0 Attachment
        > > OK, what I'm going to do is investigate Tom's suggestion of simply
        > > not loading the custom equipment if it's not supported by the
        > > loaded data sets. I'll post any findings in the tracker - K
        >
        > Hmm, isn't that just going to result in delting all those items when
        > we rewrite the file and don't write them out?

        Yeah, that's my thought as well, I'm investigating if that will be the
        case. We might be alright due to the order of how things are loaded
        (loading is separated from adding to the equipment list as far as I
        can tell). I'm hoping to prove it either way today, if it does
        'delete' the item then we'll have to think of something new. - K
      • taluroniscandar
        ... simply ... when ... Check the pcg file first. You may find that the custom eq is saved there also. If not, then open the appropriate character (with proper
        Message 3 of 13 , Feb 12, 2008
        • 0 Attachment
          --- In pcgen@yahoogroups.com, "Martijn Verburg" <martijnverburg@...>
          wrote:
          >
          > > > OK, what I'm going to do is investigate Tom's suggestion of
          simply
          > > > not loading the custom equipment if it's not supported by the
          > > > loaded data sets. I'll post any findings in the tracker - K
          > >
          > > Hmm, isn't that just going to result in delting all those items
          when
          > > we rewrite the file and don't write them out?
          >
          > Yeah, that's my thought as well, I'm investigating if that will be the
          > case. We might be alright due to the order of how things are loaded
          > (loading is separated from adding to the equipment list as far as I
          > can tell). I'm hoping to prove it either way today, if it does
          > 'delete' the item then we'll have to think of something new. - K
          >

          Check the pcg file first. You may find that the custom eq is saved
          there also.
          If not, then open the appropriate character (with proper sources
          loaded), turn off custom eq file in pref and resave the char.

          That should put the equipment in the char (pcg) file.
        • Andrew Wilson
          ... Deleteing objects that we can t find references for from custom items is what s causing the problem. Instead of deleting the objects, we could mark the
          Message 4 of 13 , Feb 12, 2008
          • 0 Attachment
            On Tue, Feb 12, 2008 at 12:45:59PM -0000, Martijn Verburg wrote:
            > > > OK, what I'm going to do is investigate Tom's suggestion of simply
            > > > not loading the custom equipment if it's not supported by the
            > > > loaded data sets. I'll post any findings in the tracker - K
            > >
            > > Hmm, isn't that just going to result in delting all those items when
            > > we rewrite the file and don't write them out?
            >
            > Yeah, that's my thought as well, I'm investigating if that will be the
            > case. We might be alright due to the order of how things are loaded
            > (loading is separated from adding to the equipment list as far as I
            > can tell). I'm hoping to prove it either way today, if it does
            > 'delete' the item then we'll have to think of something new. - K

            Deleteing objects that we can't find references for from custom items is
            what's causing the problem. Instead of deleting the objects, we could
            mark the custom items they're attached to as broken and put them in
            different storage from normal items. Then we could have a pane on the
            GUI that lets us see "broken items" with a button beside each to fix it
            (i.e. delete the reference like we currently do) and add it to the
            equipment list. Anything not "fixed" should just be written out again
            "as is" when we rewrite the custom data. That gives the ability to deal
            with changed data, and data that just isn't currently loaded should just
            work when we do load the correct set(s).

            Really flash would be to open the item customiser for it and let us
            replace the broken thing with something else.

            Just my 2d.

            andrew
          • taluroniscandar
            ... That would make the item, er, um, odd, yes, odd when you loaded the campaign and sources that it was actually created in. Hey, my +1 Kitbash sword is now
            Message 5 of 13 , Feb 12, 2008
            • 0 Attachment
              > Really flash would be to open the item customiser for it and let us
              > replace the broken thing with something else.
              >
              > Just my 2d.
              >
              > andrew
              >
              That would make the item, er, um, odd, yes, odd when you loaded the
              campaign and sources that it was actually created in.

              "Hey, my +1 Kitbash sword is now a +1 vorpal. COOOLLLL!"
            • Martijn Verburg
              Hi all, ... As this will require much thought and a spec, I ve moved this to be a 6.0 FREQ. Again we can only hope that CDOM makes this easier :) - K
              Message 6 of 13 , Feb 12, 2008
              • 0 Attachment
                Hi all,

                > > Really flash would be to open the item customiser for it and let us
                > > replace the broken thing with something else.
                > >
                > > Just my 2d.
                > >
                > > andrew
                > >
                > That would make the item, er, um, odd, yes, odd when you loaded the
                > campaign and sources that it was actually created in.
                >
                > "Hey, my +1 Kitbash sword is now a +1 vorpal. COOOLLLL!"

                As this will require much thought and a spec, I've moved this to be a
                6.0 FREQ. Again we can only hope that CDOM makes this easier :) - K
              Your message has been successfully submitted and would be delivered to recipients shortly.