Loading ...
Sorry, an error occurred while loading the content.

Re: [pcgen] [Bug] Weird effect with Bonus VAR and ability pools

Expand Messages
  • Tir Gwaith
    ... You realize you have a : in the SA tag? That used to cause problems in the past. Maybe not anymore, but my eyes let me know it is a potential problem. I
    Message 1 of 4 , Jan 1, 2008
    • 0 Attachment
      On 1/1/08, Andrew Maitland <drew0500@...> wrote:
      > Ok, this one is just plain odd.
      >
      > IN a ABILITY file:
      > Foo Feat
      > BONUS:ABILITYPOOL|Force Powers|ForceTrainingNumber
      > BONUS:VAR|ForceTrainingNumber|WIS
      > BONUS:VAR|ForceTrainingNumber|1|TYPE=Initial CHOOSE:NOCHOICE
      > MULT:YES
      > STACK:YES
      > (Can be no, but doesn't make a difference, I tried both ways)
      > SA:Force Powers Known: %|ForceTrainingNumber
      > DEFINE:ForceTrainingNumber|0
      >

      You realize you have a : in the SA tag? That used to cause problems
      in the past. Maybe not anymore, but my eyes let me know it is a
      potential problem.

      I hate the way BONUS in feats/abilities has flip-flopped on how it is
      processed. I get confused as to how it is interpreted by PCGen
      whenever I'm looking at this stuff.

      I much prefer
      BONUS:VAR|ForceTrainingNumber|(WIS*COUNT[FEATNAME=Foo Feat])

      (Very clear it is adding that every time the feat is taken.)

      --
      Tir Gwaith
      PCGen LST Chimp
    • Eddy Anthony
      Hi Andrew I think what is happening is that the BONUS:ABILITYPOOL is also being added for each time the ability is taken. Try moving BONUS:ABILITYPOOL|Force
      Message 2 of 4 , Jan 1, 2008
      • 0 Attachment
        Hi Andrew

        I think what is happening is that the BONUS:ABILITYPOOL is also being
        added for each time the ability is taken. Try moving BONUS:ABILITYPOOL|Force
        Powers|ForceTrainingNumber out of the ability and see if that fixes it.

        Andrew Maitland scribed:

        > Ok, this one is just plain odd.
        >
        > IN a ABILITY file:
        > Foo Feat
        > BONUS:ABILITYPOOL|Force Powers|ForceTrainingNumber
        > BONUS:VAR|ForceTrainingNumber|WIS
        > BONUS:VAR|ForceTrainingNumber|1|TYPE=Initial CHOOSE:NOCHOICE
        > MULT:YES
        > STACK:YES
        > (Can be no, but doesn't make a difference, I tried both ways)
        > SA:Force Powers Known: %|ForceTrainingNumber
        > DEFINE:ForceTrainingNumber|0
        >
        >
        > In ABILITYCATEGORY FILE (or miscinfo)
        > ABILITYCATEGORY:Force Powers
        > CATEGORY:Force Powers
        > TYPE:ForcePowers
        > VISIBLE:QUALIFY
        > DISPLAYLOCATION:Class Abilities
        > EDITABLE:YES
        > EDITPOOL:YES
        > FRACTIONALPOOL:NO
        >
        > ---
        > Now what SHOULD happen, first time you take the feat gain WISDOM bonus
        > +1, each additional time you gain another WISDOM modifier.
        >
        > Test with any Wisdom, preferably with 12 or higher...
        >
        > My results varied each time... I had Wis 12...
        > Feat Taken x1 = 2
        > Feat Taken x2 = 10
        > Wis =16
        > x1 =4
        > x2 =26
        >
        > Should have been: Wis 12 =1
        > Feat Taken x1 = 2 (Wis +1)
        > Feat Taken x2 = 3 (Wis + Wis +1)
        >
        > Wis 16
        > x1 =4
        > x2 =7
        > Strangely enough the console gave the proper number.
        >
        > I was encountering odd behavior with ABILITYPOOL as well, it will take a
        > Jep 'word' expression, but wouldn't take a direct formula
        >
        > BONUS:ABILITYPOOL|Foo Pool|INT+3 - wouldn't work, but
        > BONUS:ABILITYPOOL|Foo Pool|FooBarFormula
        >
        > DEFINE:FooBarFormula|0
        > BONUS:VAR|FooBarFormula|INT+3 would work.
        >
        > PCGEN = 5.13.6

        --
        ~ Eddy Anthony (MoSaT)
        ~ Chair Monkey, PCGen Board of Directors
        ~ Data Content Second, Doc Chimp, OS Tamarin
      • taluroniscandar
        ... At one point, this was the only way to get this to work. And the count had to be in a hidden feat that wasn t selected multiple times, although I believe
        Message 3 of 4 , Jan 2, 2008
        • 0 Attachment
          --- In pcgen@yahoogroups.com, "Tir Gwaith" <Tir.Gwaith@...> wrote:
          >
          > On 1/1/08, Andrew Maitland <drew0500@...> wrote:
          > > Ok, this one is just plain odd.
          > >
          > > IN a ABILITY file:
          > > Foo Feat
          > > BONUS:ABILITYPOOL|Force Powers|ForceTrainingNumber
          > > BONUS:VAR|ForceTrainingNumber|WIS
          > > BONUS:VAR|ForceTrainingNumber|1|TYPE=Initial CHOOSE:NOCHOICE
          > > MULT:YES
          > > STACK:YES
          > > (Can be no, but doesn't make a difference, I tried both ways)
          > > SA:Force Powers Known: %|ForceTrainingNumber
          > > DEFINE:ForceTrainingNumber|0
          > >
          >
          > You realize you have a : in the SA tag? That used to cause problems
          > in the past. Maybe not anymore, but my eyes let me know it is a
          > potential problem.
          >
          > I hate the way BONUS in feats/abilities has flip-flopped on how it is
          > processed. I get confused as to how it is interpreted by PCGen
          > whenever I'm looking at this stuff.
          >
          > I much prefer
          > BONUS:VAR|ForceTrainingNumber|(WIS*COUNT[FEATNAME=Foo Feat])
          >
          > (Very clear it is adding that every time the feat is taken.)
          >
          At one point, this was the only way to get this to work.
          And the count had to be in a hidden feat that wasn't selected multiple
          times, although I believe that limitation has been corrected.
          See Psionic Talent/Psionic Talent Power Points [rsrd] for an example
          feat/hidden feat created before this limitation was corrected.
        Your message has been successfully submitted and would be delivered to recipients shortly.