Loading ...
Sorry, an error occurred while loading the content.
 

Re: Memory Leaks

Expand Messages
  • Martijn Verburg
    It ll be interesting to see if these problems persists in 5.12.0, I know we closed some memory issues from 5.10.2. Does anyone have any memory leaks on
    Message 1 of 4 , Jun 26, 2007
      It'll be interesting to see if these problems persists in 5.12.0, I
      know we closed some memory issues from 5.10.2. Does anyone have any
      memory leaks on 5.12.0? - K

      > Hi,
      >
      > If you have the "display memory in status bar" option activated, does
      > this figure increase? Have you tried clicking on this to cause a
      > garbage collect? If so, does this improve performance?
      >
      > We have done a few passes to try and isolate and eliminate memory
      > leaks, but it sounds like there are still some present.
      >
      > However it may also be something windows specific - I know I have to
      > restart my Eclipse environment on Windows if I have left it idle for
      > too long.
      >
      > --
      > Cheers,
      > James Dempsey
      > PCGen Code SB
      >
      > On 26/06/07, Matthew LeBaron <matt.lebaron@...> wrote:
      > > For what it's worth, I see the same problem.
      > >
      > > WinXP SP2
      > > PCGen v5.10.2
      > > Java v1.6.0_01-b06
      > >
      > > Matt
      > >
      > > On 6/25/07, mattdt0 <mattdt0@...> wrote:
      > > >
      > > > Just a quick question. I tend to leave PCGen up in the
      background at
      > > > home so I can work on NPC's and such for my games in the few
      > > > infrequent bits of spare time I get (I work from home). However,
      I've
      > > > noticed that after leaving it up and running for 4 or more hours, it
      > > > seems to grow in memory size. My record was 84megs (took a week to
      > > > get up to that size) and my performance goes in the toilet after a
      > > > couple of hours and I have to save, restart. Is this PCGen, or the
      > > > Java VM? I've got the latest Sun JAVA VM (Version 5? Not at the
      > > > computer now to check). Basically, is this a known problem, am I the
      > > > only one that sees this, or what?
      > > >
      > > > As a note, when I have it up on my Ubuntu or Mint machine, I don't
      > > > have this problem, only in Windows.
      > > >
      > > > MDT
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.