Loading ...
Sorry, an error occurred while loading the content.
 

Newbie + stupid question = easy stupid answer (hopefully!)

Expand Messages
  • Dominick
    I ve just loaded PCGen v.5.10.0 and I just figured out how to create PCs but I have no idea if/what this program can/can t do. Can I or can I not use this
    Message 1 of 18 , Feb 19, 2007
      I've just loaded PCGen v.5.10.0 and I just figured out how to create
      PCs but I have no idea if/what this program can/can't do. Can I or can
      I not use this program w/out having to utilize the internet? If I do
      not need to use the internet with this program (which is what I'm
      hoping) how do I get the combat event screen to activate or show
      anything when I start combat? Shouldn't I be able to see hits and
      damage being done between the enemy and PC in the events window? If so
      what buttons should I press/not press? Thanks for any answer - stupid
      or otherwise! :-)
    • Tir Gwaith
      1) Once you ve got PCGen downloaded, you don t need the internet again (Assuming you have Sun s Java, otherwise you ll need it to grab that.) 2) Have
      Message 2 of 18 , Feb 19, 2007
        1) Once you've got PCGen downloaded, you don't need the internet again
        (Assuming you have Sun's Java, otherwise you'll need it to grab that.)

        2) Have characters loaded so they will show up in the GMGen combat
        screen. Start GMGen (little dice icon at the top) to view the combat
        screen screen, along with the encounter XP tracker, etc.

        3) for more information, go to the directory you installed PCGen into,
        /docs/index.html On the left bar, at the bottom, is GMGen
        documentation. A quick glimmer will show you what parts you want to
        read in more depth, and get you going.

        Enjoy!

        --
        Tir Gwaith
        PCGen LST Chimp
      • Dominick
        THANKS! ... again ... that.) ... combat ... into,
        Message 3 of 18 , Feb 19, 2007
          THANKS!

          --- In pcgen@yahoogroups.com, "Tir Gwaith" <Tir.Gwaith@...> wrote:
          >
          > 1) Once you've got PCGen downloaded, you don't need the internet
          again
          > (Assuming you have Sun's Java, otherwise you'll need it to grab
          that.)
          >
          > 2) Have characters loaded so they will show up in the GMGen combat
          > screen. Start GMGen (little dice icon at the top) to view the
          combat
          > screen screen, along with the encounter XP tracker, etc.
          >
          > 3) for more information, go to the directory you installed PCGen
          into,
          > /docs/index.html On the left bar, at the bottom, is GMGen
          > documentation. A quick glimmer will show you what parts you want to
          > read in more depth, and get you going.
          >
          > Enjoy!
          >
          > --
          > Tir Gwaith
          > PCGen LST Chimp
          >
        • Dominick
          Well...it looks like I m still needing some help. I believe I might have something wrong w/my computer because I get the following: C: Program
          Message 4 of 18 , Feb 19, 2007
            Well...it looks like I'm still needing some help. I believe I might
            have something wrong w/my computer because I get the following:

            C:\Program Files\PCGen\PCGen5100>REM PCGEN.BAT

            C:\Program Files\PCGen\PCGen5100>REM ==================

            C:\Program Files\PCGen\PCGen5100>REM

            C:\Program Files\PCGen\PCGen5100>REM This script should only be used
            if you have
            more than 256MB of RAM and if you

            C:\Program Files\PCGen\PCGen5100>REM don't mind committing at least
            128MB of the
            se to PCGEN.

            C:\Program Files\PCGen\PCGen5100>REM The value after -Xmx is the
            maximum amount
            of memory that PCGen will be allowed to use.

            C:\Program Files\PCGen\PCGen5100>REM It defaults to 64MB.

            C:\Program Files\PCGen\PCGen5100>REM The value after -Xms is the
            starting memory
            , using both then to speed up PCGEN.

            C:\Program Files\PCGen\PCGen5100>REM To load all sources takes more
            than the def
            ault 64MB.

            C:\Program Files\PCGen\PCGen5100>java -Xms128m -Xmx256m -jar pcgen.jar
            Exception while sending message on GMBus:null
            java.lang.NullPointerException
            at plugin.network.NetworkModel.refresh(NetworkModel.java:357)
            at plugin.network.NetworkPlugin.handleCombatRequestMessage
            (NetworkPlugin
            .java:128)
            at plugin.network.NetworkPlugin.handleMessage
            (NetworkPlugin.java:95)
            at gmgen.pluginmgr.GMBus.send(GMBus.java:127)
            at plugin.experience.ExperienceAdjusterPlugin.handleMessage
            (ExperienceAd
            justerPlugin.java:486)
            at gmgen.pluginmgr.GMBus.send(GMBus.java:127)
            at gmgen.GMGenSystem.stateUpdate(GMGenSystem.java:523)
            at gmgen.GMGenSystem.stateChanged(GMGenSystem.java:508)
            at javax.swing.JTabbedPane.fireStateChanged(Unknown Source)
            at javax.swing.JTabbedPane$ModelListener.stateChanged(Unknown
            Source)
            at javax.swing.DefaultSingleSelectionModel.fireStateChanged
            (Unknown Sour
            ce)
            at javax.swing.DefaultSingleSelectionModel.setSelectedIndex
            (Unknown Sour
            ce)
            at javax.swing.JTabbedPane.setSelectedIndexImpl(Unknown
            Source)
            at javax.swing.JTabbedPane.setSelectedIndex(Unknown Source)
            at
            javax.swing.plaf.basic.BasicTabbedPaneUI$Handler.mousePressed(Unknown
            Source)
            at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
            at java.awt.Component.processMouseEvent(Unknown Source)
            at javax.swing.JComponent.processMouseEvent(Unknown Source)
            at java.awt.Component.processEvent(Unknown Source)
            at java.awt.Container.processEvent(Unknown Source)
            at java.awt.Component.dispatchEventImpl(Unknown Source)
            at java.awt.Container.dispatchEventImpl(Unknown Source)
            at java.awt.Component.dispatchEvent(Unknown Source)
            at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown
            Source)
            at java.awt.LightweightDispatcher.processMouseEvent(Unknown
            Source)
            at java.awt.LightweightDispatcher.dispatchEvent(Unknown
            Source)
            at java.awt.Container.dispatchEventImpl(Unknown Source)
            at java.awt.Window.dispatchEventImpl(Unknown Source)
            at java.awt.Component.dispatchEvent(Unknown Source)
            at java.awt.EventQueue.dispatchEvent(Unknown Source)
            at pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent
            (PCGen_Frame
            1.java:3153)
            at java.awt.EventDispatchThread.pumpOneEventForHierarchy
            (Unknown Source)

            at java.awt.EventDispatchThread.pumpEventsForHierarchy
            (Unknown Source)
            at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
            at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
            at java.awt.EventDispatchThread.run(Unknown Source)

            I have no idea what this means. My computer is fairly new and has
            Java jre 1.5_05 1.5_06 yet I'm thinking it has something to do w/Java
            but I have no idea how to alter Java and make it work w/PCGen. I've
            downloaded the newer PCGen 5.10.1 and I'm thinking of uninstalling
            the old one I have and installing the newer version. I'm thinking
            though that if I have problems w/the old version and Java the new
            version of PCGen won't work either. Any advice would be appreciated.
            Thanks again for the previous quick response guys!:-)

            --- In pcgen@yahoogroups.com, "Tir Gwaith" <Tir.Gwaith@...> wrote:
            >
            > 1) Once you've got PCGen downloaded, you don't need the internet
            again
            > (Assuming you have Sun's Java, otherwise you'll need it to grab
            that.)
            >
            > 2) Have characters loaded so they will show up in the GMGen combat
            > screen. Start GMGen (little dice icon at the top) to view the
            combat
            > screen screen, along with the encounter XP tracker, etc.
            >
            > 3) for more information, go to the directory you installed PCGen
            into,
            > /docs/index.html On the left bar, at the bottom, is GMGen
            > documentation. A quick glimmer will show you what parts you want to
            > read in more depth, and get you going.
            >
            > Enjoy!
            >
            > --
            > Tir Gwaith
            > PCGen LST Chimp
            >
          • S L Raymond
            What causes the following problem? $ java -jar pcgen.jar Exception in thread main java.awt.AWTError: Cannot load AWT toolkit:
            Message 5 of 18 , Feb 19, 2007
              What causes the following problem?

              $ java -jar pcgen.jar
              Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit:
              gnu.java.awt.peer.gtk.GtkToolkit
              at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
              at pcgen.util.Logging.<clinit>(Logging.java:34)
              at java.lang.Class.initializeClass(libgcj.so.70)
              at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
              at pcgen.core.Main.main(Main.java:95)
              Caused by: java.lang.NoClassDefFoundError:
              gnu.java.awt.peer.gtk.GtkToolkit
              at java.lang.Class.initializeClass(libgcj.so.70)
              at java.lang.Class.forName(libgcj.so.70)
              at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
              ...4 more
            • christine@hutt-edv.de
              It seems like you have the Gnu Java Interpreter, and not Sun s Java JRE installed. I got the same problem when trying to run PCGen on Ubuntu. Here s a link
              Message 6 of 18 , Feb 19, 2007
                It seems like you have the Gnu Java Interpreter, and not Sun's Java JRE
                installed. I got the same problem when trying to run PCGen on Ubuntu.
                Here's a link that helped me with my problem (and solving it):
                http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html

                Hope that helps you too.

                Christine

                Zitat von S L Raymond <sly_raymond@...>:

                > What causes the following problem?
                >
                > $ java -jar pcgen.jar
                > Exception in thread "main" java.awt.AWTError: Cannot load AWT
                > toolkit:
                > gnu.java.awt.peer.gtk.GtkToolkit
                > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                > at pcgen.util.Logging.<clinit>(Logging.java:34)
                > at java.lang.Class.initializeClass(libgcj.so.70)
                > at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
                > at pcgen.core.Main.main(Main.java:95)
                > Caused by: java.lang.NoClassDefFoundError:
                > gnu.java.awt.peer.gtk.GtkToolkit
                > at java.lang.Class.initializeClass(libgcj.so.70)
                > at java.lang.Class.forName(libgcj.so.70)
                > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                > ...4 more
              • S L Raymond
                I assume the only section on the page in English is the one I should pay attention to?
                Message 7 of 18 , Feb 19, 2007
                  I assume the only section on the page in English is the one I should pay
                  attention to?

                  On Tue, 2007-02-20 at 08:05 +0100, christine@... wrote:
                  > It seems like you have the Gnu Java Interpreter, and not Sun's Java
                  > JRE
                  > installed. I got the same problem when trying to run PCGen on Ubuntu.
                  > Here's a link that helped me with my problem (and solving it):
                  > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                  >
                  > Hope that helps you too.
                  >
                  > Christine
                  >
                  > Zitat von S L Raymond <sly_raymond@...>:
                  >
                  > > What causes the following problem?
                  > >
                  > > $ java -jar pcgen.jar
                  > > Exception in thread "main" java.awt.AWTError: Cannot load AWT
                  > > toolkit:
                  > > gnu.java.awt.peer.gtk.GtkToolkit
                  > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                  > > at pcgen.util.Logging.<clinit>(Logging.java:34)
                  > > at java.lang.Class.initializeClass(libgcj.so.70)
                  > > at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
                  > > at pcgen.core.Main.main(Main.java:95)
                  > > Caused by: java.lang.NoClassDefFoundError:
                  > > gnu.java.awt.peer.gtk.GtkToolkit
                  > > at java.lang.Class.initializeClass(libgcj.so.70)
                  > > at java.lang.Class.forName(libgcj.so.70)
                  > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                  > > ...4 more
                  >
                  >
                  >
                  >
                  >
                • S L Raymond
                  That site didn t make any sense to me, so I installed Sun s JRE through Synaptic. Still, it doesn t work.
                  Message 8 of 18 , Feb 19, 2007
                    That site didn't make any sense to me, so I installed Sun's JRE through
                    Synaptic. Still, it doesn't work.

                    On Tue, 2007-02-20 at 08:05 +0100, christine@... wrote:
                    > It seems like you have the Gnu Java Interpreter, and not Sun's Java
                    > JRE
                    > installed. I got the same problem when trying to run PCGen on Ubuntu.
                    > Here's a link that helped me with my problem (and solving it):
                    > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                    >
                    > Hope that helps you too.
                    >
                    > Christine
                    >
                    > Zitat von S L Raymond <sly_raymond@...>:
                    >
                    > > What causes the following problem?
                    > >
                    > > $ java -jar pcgen.jar
                    > > Exception in thread "main" java.awt.AWTError: Cannot load AWT
                    > > toolkit:
                    > > gnu.java.awt.peer.gtk.GtkToolkit
                    > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                    > > at pcgen.util.Logging.<clinit>(Logging.java:34)
                    > > at java.lang.Class.initializeClass(libgcj.so.70)
                    > > at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
                    > > at pcgen.core.Main.main(Main.java:95)
                    > > Caused by: java.lang.NoClassDefFoundError:
                    > > gnu.java.awt.peer.gtk.GtkToolkit
                    > > at java.lang.Class.initializeClass(libgcj.so.70)
                    > > at java.lang.Class.forName(libgcj.so.70)
                    > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                    > > ...4 more
                    >
                    >
                    >
                    >
                    >
                  • christine@hutt-edv.de
                    Sorry, I didn t notice that the page is only in german and you probably can t understand it. *blush* I ll try to translate it. Installing Sun s JRE was the
                    Message 9 of 18 , Feb 19, 2007
                      Sorry, I didn't notice that the page is only in german and you probably
                      can't understand it. *blush*
                      I'll try to translate it.
                      Installing Sun's JRE was the first right step. Now you need to tell
                      Ubuntu to use Sun's JRE when executing the command java.
                      You can change that with a simple script.
                      Here's the script:

                      1. # copies the path to java into the variable
                      2. j=`which java`
                      3. # renaming the file
                      4. sudo mv $j $j"gij"
                      5. # set symbolic link
                      6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j

                      You need to set the right path to your installation of the JRE instead
                      of "/pathToJDK/jdk1.5.0_09/jre/bin/java "

                      Copy the script into a file, make it executable and execute it (on the
                      commandline mit sh ./script).

                      That should do the trick.

                      Christine

                      Zitat von S L Raymond <sly_raymond@...>:

                      > That site didn't make any sense to me, so I installed Sun's JRE
                      > through
                      > Synaptic. Still, it doesn't work.
                      >
                      > On Tue, 2007-02-20 at 08:05 +0100, christine@... wrote:
                      > > It seems like you have the Gnu Java Interpreter, and not Sun's Java
                      > > JRE
                      > > installed. I got the same problem when trying to run PCGen on
                      > Ubuntu.
                      > > Here's a link that helped me with my problem (and solving it):
                      > >
                      >
                      http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                      > >
                      > > Hope that helps you too.
                      > >
                      > > Christine
                      > >
                      > > Zitat von S L Raymond <sly_raymond@...>:
                      > >
                      > > > What causes the following problem?
                      > > >
                      > > > $ java -jar pcgen.jar
                      > > > Exception in thread "main" java.awt.AWTError: Cannot load AWT
                      > > > toolkit:
                      > > > gnu.java.awt.peer.gtk.GtkToolkit
                      > > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                      > > > at pcgen.util.Logging.<clinit>(Logging.java:34)
                      > > > at java.lang.Class.initializeClass(libgcj.so.70)
                      > > > at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
                      > > > at pcgen.core.Main.main(Main.java:95)
                      > > > Caused by: java.lang.NoClassDefFoundError:
                      > > > gnu.java.awt.peer.gtk.GtkToolkit
                      > > > at java.lang.Class.initializeClass(libgcj.so.70)
                      > > > at java.lang.Class.forName(libgcj.so.70)
                      > > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                      > > > ...4 more
                      > >
                      > >
                      > >
                      > >
                      > >
                      >
                      >
                      >
                      > PCGen's Release site: http://pcgen.sourceforge.net
                      > PCGen's Wiki: http://www.legolas.org/pcgen/pytw/#Welcome
                      > PCGen's Roadmap: http://www.legolas.org/pcgen/pytw/#Roadmap
                      > PCGen's Alpha Build: http://pcgen.sourceforge.net/07_autobuilds.php
                      > PCGen's Online Docs:
                      > http://pcgen.sourceforge.net/autobuilds/pcgen-docs/
                      > Yahoo! Groups Links
                      >
                      >
                      >
                      >
                    • Koen Van Daele
                      Not sure which version you are running, but here s the info on installing jre/jdk on Edgy:
                      Message 10 of 18 , Feb 20, 2007
                        Not sure which version you are running, but here's the info on installing
                        jre/jdk on Edgy:

                        http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins

                        There are other versions of the wiki for Dapper Drake and older releases.

                        If you've installed through synaptic you might want to have a look at
                        /etc/jvm. First line there should point to the sun java (in my case
                        /usr/lib/jvm/java-1.5.0-sun).
                        You might also try:
                        $ sudo update-alternatives --config java

                        This command gives a list of available java versions and allows you to
                        choose one.

                        Koen

                        > That site didn't make any sense to me, so I installed Sun's JRE through
                        > Synaptic. Still, it doesn't work.
                        >
                        > On Tue, 2007-02-20 at 08:05 +0100, christine@... wrote:
                        >> It seems like you have the Gnu Java Interpreter, and not Sun's Java
                        >> JRE
                        >> installed. I got the same problem when trying to run PCGen on Ubuntu.
                        >> Here's a link that helped me with my problem (and solving it):
                        >> http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                        >>
                        >> Hope that helps you too.
                        >>
                        >> Christine
                        >>
                        >> Zitat von S L Raymond <sly_raymond@...>:
                        >>
                        >> > What causes the following problem?
                        >> >
                        >> > $ java -jar pcgen.jar
                        >> > Exception in thread "main" java.awt.AWTError: Cannot load AWT
                        >> > toolkit:
                        >> > gnu.java.awt.peer.gtk.GtkToolkit
                        >> > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                        >> > at pcgen.util.Logging.<clinit>(Logging.java:34)
                        >> > at java.lang.Class.initializeClass(libgcj.so.70)
                        >> > at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
                        >> > at pcgen.core.Main.main(Main.java:95)
                        >> > Caused by: java.lang.NoClassDefFoundError:
                        >> > gnu.java.awt.peer.gtk.GtkToolkit
                        >> > at java.lang.Class.initializeClass(libgcj.so.70)
                        >> > at java.lang.Class.forName(libgcj.so.70)
                        >> > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                        >> > ...4 more
                        >>
                        >>
                        >>
                        >>
                        >>
                        >
                        >
                      • S L Raymond
                        I did exactly the following: 1. I saved the following script as use_Sun.sh in my bin directory: # copies the path to java into the variable j=`which java` #
                        Message 11 of 18 , Feb 20, 2007
                          I did exactly the following:

                          1. I saved the following script as use_Sun.sh in my bin directory:
                          # copies the path to java into the variable
                          j=`which java`
                          # renaming the file
                          sudo mv $j $j"gij"
                          # set symbolic link
                          sudo ln -s /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre/bin/java $j

                          2. I chmoded the file to 755.

                          3. I ran the script. No error report.

                          4. After navigating to the PCGen directory and once again trying both
                          "java -jar pcgen.jar" and "./pcgen.sh", I continue to get the same
                          error.

                          On Tue, 2007-02-20 at 08:56 +0100, christine@... wrote:
                          > Sorry, I didn't notice that the page is only in german and you
                          > probably
                          > can't understand it. *blush*
                          > I'll try to translate it.
                          > Installing Sun's JRE was the first right step. Now you need to tell
                          > Ubuntu to use Sun's JRE when executing the command java.
                          > You can change that with a simple script.
                          > Here's the script:
                          >
                          > 1. # copies the path to java into the variable
                          > 2. j=`which java`
                          > 3. # renaming the file
                          > 4. sudo mv $j $j"gij"
                          > 5. # set symbolic link
                          > 6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j
                          >
                          > You need to set the right path to your installation of the JRE instead
                          > of "/pathToJDK/jdk1.5.0_09/jre/bin/java "
                          >
                          > Copy the script into a file, make it executable and execute it (on the
                          > commandline mit sh ./script).
                          >
                          > That should do the trick.
                          >
                          > Christine
                          >
                          > Zitat von S L Raymond <sly_raymond@...>:
                          >
                          > > That site didn't make any sense to me, so I installed Sun's JRE
                          > > through
                          > > Synaptic. Still, it doesn't work.
                          > >
                          > > On Tue, 2007-02-20 at 08:05 +0100, christine@... wrote:
                          > > > It seems like you have the Gnu Java Interpreter, and not Sun's
                          > Java
                          > > > JRE
                          > > > installed. I got the same problem when trying to run PCGen on
                          > > Ubuntu.
                          > > > Here's a link that helped me with my problem (and solving it):
                          > > >
                          > >
                          > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                          > > >
                          > > > Hope that helps you too.
                          > > >
                          > > > Christine
                          > > >
                          > > > Zitat von S L Raymond <sly_raymond@...>:
                          > > >
                          > > > > What causes the following problem?
                          > > > >
                          > > > > $ java -jar pcgen.jar
                          > > > > Exception in thread "main" java.awt.AWTError: Cannot load AWT
                          > > > > toolkit:
                          > > > > gnu.java.awt.peer.gtk.GtkToolkit
                          > > > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                          > > > > at pcgen.util.Logging.<clinit>(Logging.java:34)
                          > > > > at java.lang.Class.initializeClass(libgcj.so.70)
                          > > > > at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
                          > > > > at pcgen.core.Main.main(Main.java:95)
                          > > > > Caused by: java.lang.NoClassDefFoundError:
                          > > > > gnu.java.awt.peer.gtk.GtkToolkit
                          > > > > at java.lang.Class.initializeClass(libgcj.so.70)
                          > > > > at java.lang.Class.forName(libgcj.so.70)
                          > > > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                          > > > > ...4 more
                          > > >
                          > > >
                          > > >
                          > > >
                          > > >
                          > >
                          > >
                          > >
                          > > PCGen's Release site: http://pcgen.sourceforge.net
                          > > PCGen's Wiki: http://www.legolas.org/pcgen/pytw/#Welcome
                          > > PCGen's Roadmap: http://www.legolas.org/pcgen/pytw/#Roadmap
                          > > PCGen's Alpha Build: http://pcgen.sourceforge.net/07_autobuilds.php
                          > > PCGen's Online Docs:
                          > > http://pcgen.sourceforge.net/autobuilds/pcgen-docs/
                          > > Yahoo! Groups Links
                          > >
                          > >
                          > >
                          > >
                          >
                          >
                          >
                          >
                          >
                        • Steven Gilroy
                          At a command prompt type: java - version You should get something like the following: java version 1.5.0_10 Java(TM) 2 Runtime Environment, Standard Edition
                          Message 12 of 18 , Feb 20, 2007
                            At a command prompt type:
                            java - version

                            You should get something like the following:
                            java version "1.5.0_10"
                            Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
                            Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode, sharing)

                            If you don't then you are still running the virtual machine that came
                            with Ubuntu instead of Sun's Java. In that case you may need to remove
                            /usr/bin/java and then everything will work fine. If you have java in
                            more than one path it will prefer the standard path's over later added ones.

                            Steven Gilroy
                            http://www.ourcrazyjunk.com
                            "In a world without fences, who needs GATES?"



                            S L Raymond wrote:
                            >
                            > I did exactly the following:
                            >
                            > 1. I saved the following script as use_Sun.sh in my bin directory:
                            > # copies the path to java into the variable
                            > j=`which java`
                            > # renaming the file
                            > sudo mv $j $j"gij"
                            > # set symbolic link
                            > sudo ln -s /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre/bin/java $j
                            >
                            > 2. I chmoded the file to 755.
                            >
                            > 3. I ran the script. No error report.
                            >
                            > 4. After navigating to the PCGen directory and once again trying both
                            > "java -jar pcgen.jar" and "./pcgen.sh", I continue to get the same
                            > error.
                            >
                            > On Tue, 2007-02-20 at 08:56 +0100, christine@...
                            > <mailto:christine%40hutt-edv.de> wrote:
                            > > Sorry, I didn't notice that the page is only in german and you
                            > > probably
                            > > can't understand it. *blush*
                            > > I'll try to translate it.
                            > > Installing Sun's JRE was the first right step. Now you need to tell
                            > > Ubuntu to use Sun's JRE when executing the command java.
                            > > You can change that with a simple script.
                            > > Here's the script:
                            > >
                            > > 1. # copies the path to java into the variable
                            > > 2. j=`which java`
                            > > 3. # renaming the file
                            > > 4. sudo mv $j $j"gij"
                            > > 5. # set symbolic link
                            > > 6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j
                            > >
                            > > You need to set the right path to your installation of the JRE instead
                            > > of "/pathToJDK/jdk1.5.0_09/jre/bin/java "
                            > >
                            > > Copy the script into a file, make it executable and execute it (on the
                            > > commandline mit sh ./script).
                            > >
                            > > That should do the trick.
                            > >
                            > > Christine
                            > >
                            > > Zitat von S L Raymond <sly_raymond@...
                            > <mailto:sly_raymond%40charter.net>>:
                            > >
                            > > > That site didn't make any sense to me, so I installed Sun's JRE
                            > > > through
                            > > > Synaptic. Still, it doesn't work.
                            > > >
                            > > > On Tue, 2007-02-20 at 08:05 +0100, christine@...
                            > <mailto:christine%40hutt-edv.de> wrote:
                            > > > > It seems like you have the Gnu Java Interpreter, and not Sun's
                            > > Java
                            > > > > JRE
                            > > > > installed. I got the same problem when trying to run PCGen on
                            > > > Ubuntu.
                            > > > > Here's a link that helped me with my problem (and solving it):
                            > > > >
                            > > >
                            > >
                            > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                            > <http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html>
                            > > > >
                            > > > > Hope that helps you too.
                            > > > >
                            > > > > Christine
                            > > > >
                            > > > > Zitat von S L Raymond <sly_raymond@...
                            > <mailto:sly_raymond%40charter.net>>:
                            > > > >
                            > > > > > What causes the following problem?
                            > > > > >
                            > > > > > $ java -jar pcgen.jar
                            > > > > > Exception in thread "main" java.awt.AWTError: Cannot load AWT
                            > > > > > toolkit:
                            > > > > > gnu.java.awt.peer.gtk.GtkToolkit
                            > > > > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                            > > > > > at pcgen.util.Logging.<clinit>(Logging.java:34)
                            > > > > > at java.lang.Class.initializeClass(libgcj.so.70)
                            > > > > > at pcgen.core.Main.dieWithBadEntryPoint(Main.java:102)
                            > > > > > at pcgen.core.Main.main(Main.java:95)
                            > > > > > Caused by: java.lang.NoClassDefFoundError:
                            > > > > > gnu.java.awt.peer.gtk.GtkToolkit
                            > > > > > at java.lang.Class.initializeClass(libgcj.so.70)
                            > > > > > at java.lang.Class.forName(libgcj.so.70)
                            > > > > > at java.awt.Toolkit.getDefaultToolkit(libgcj.so.70)
                            > > > > > ...4 more
                            > > > >
                            > > > >
                            > > > >
                            > > > >
                            > > > >
                            > > >
                            > > >
                            > > >
                            > > > PCGen's Release site: http://pcgen.sourceforge.net
                            > <http://pcgen.sourceforge.net>
                            > > > PCGen's Wiki: http://www.legolas.org/pcgen/pytw/#Welcome
                            > <http://www.legolas.org/pcgen/pytw/#Welcome>
                            > > > PCGen's Roadmap: http://www.legolas.org/pcgen/pytw/#Roadmap
                            > <http://www.legolas.org/pcgen/pytw/#Roadmap>
                            > > > PCGen's Alpha Build:
                            > http://pcgen.sourceforge.net/07_autobuilds.php
                            > <http://pcgen.sourceforge.net/07_autobuilds.php>
                            > > > PCGen's Online Docs:
                            > > > http://pcgen.sourceforge.net/autobuilds/pcgen-docs/
                            > <http://pcgen.sourceforge.net/autobuilds/pcgen-docs/>
                            > > > Yahoo! Groups Links
                            > > >
                            > > >
                            > > >
                            > > >
                            > >
                            > >
                            > >
                            > >
                            > >
                            >
                            >
                          • EAW
                            ... Koen has it right. Follow the update-alternatives line with: $ sudo update-alternatives --set java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java and you
                            Message 13 of 18 , Feb 20, 2007
                              On Tue, 2007-02-20 at 09:50 +0100, Koen Van Daele wrote:
                              > Not sure which version you are running, but here's the info on installing
                              > jre/jdk on Edgy:
                              >
                              > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                              >
                              > There are other versions of the wiki for Dapper Drake and older releases.
                              >
                              > If you've installed through synaptic you might want to have a look at
                              > /etc/jvm. First line there should point to the sun java (in my case
                              > /usr/lib/jvm/java-1.5.0-sun).
                              > You might also try:
                              > $ sudo update-alternatives --config java


                              Koen has it right. Follow the update-alternatives line with:

                              $ sudo update-alternatives --set \
                              java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

                              and you should be all set. This will take care of all the path
                              parameters and other bits that need to be set. No need to muck about
                              editing files or anything of that sort.

                              e.
                              --
                              ericw@...

                              "If the answer isn't violence, neither is your silence!"
                              -- Pop Will Eat Itself, "Ich Bin Ein Auslander"
                            • Terry FitzSimons
                              I am planning on adding the following to the FAQ section to document the Installation of Ubuntu. BTW, does anyone have command-line switches that they use,
                              Message 14 of 18 , Feb 27, 2007
                                I am planning on adding the following to the FAQ section to document the
                                Installation of Ubuntu.

                                BTW, does anyone have command-line switches that they use, that they wish
                                to have documented? For any OS?

                                Any correction would be appreciated.

                                christine is located in Germany, her commands might be in German, other
                                nations may need to convert to local language.

                                S L Raymond I think is in the USA. [commandline mit sh ./script)] from
                                christine's scrip might be in German and was not converted to the English
                                version by S L Raymond, but I run a Windows XP SP2 system and have no idea.

                                The following web page is in German, but it might be of assistance. Other
                                language pages will be added as found:
                                http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html

                                From: christine

                                Installing Sun's JRE was the first right step. Get it from
                                http://www.sun.com/java

                                Now you need to tell Ubuntu to use Sun's JRE when executing the command
                                java.
                                You can change that with a simple script.
                                Here's the script:

                                1. # copies the path to java into the variable
                                2. j=`which java`
                                3. # renaming the file
                                4. sudo mv $j $j"gij"
                                5. # set symbolic link
                                6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j

                                You need to set the right path to your installation of the JRE instead of
                                "/pathToJDK/jdk1.5.0_09/jre/bin/java "

                                Copy the script into a file, make it executable and execute it (on the
                                commandline mit sh ./script).

                                From: S L Raymond

                                I did exactly the following:

                                1. I saved the following script as use_Sun.sh in my bin directory:
                                # copies the path to java into the variable
                                j=`which java`
                                # renaming the file
                                sudo mv $j $j"gij"
                                # set symbolic link
                                sudo ln -s /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre/bin/java $j

                                2. I chmoded the file to 755.

                                3. I ran the script. No error report.

                                4. After navigating to the PCGen directory and once again trying both
                                "java -jar pcgen.jar" and "./pcgen.sh", I continue to get the same error.

                                From: Steven Gilroy

                                At a command prompt type:
                                java - version

                                You should get something like the following:
                                java version "1.5.0_10"
                                Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
                                Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode, sharing)

                                If you don't then you are still running the virtual machine that came with
                                Ubuntu instead of Sun's Java. In that case you may need to remove
                                /usr/bin/java and then everything will work fine. If you have java in more
                                than one path it will prefer the standard path's over later added ones.

                                From: Koen Van Daele

                                Not sure which version you are running, but here's the info on installing
                                jre/jdk on Edgy:

                                http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins

                                There are other versions of the wiki for Dapper Drake and older releases.

                                If you've installed through synaptic you might want to have a look at
                                /etc/jvm. First line there should point to the sun java (in my case
                                /usr/lib/jvm/java-1.5.0-sun).
                                You might also try:
                                $ sudo update-alternatives --config java

                                This command gives a list of available java versions and allows you to
                                choose one.

                                From: EAW

                                On Tue, 2007-02-20 at 09:50 +0100, Koen Van Daele wrote:
                                > Not sure which version you are running, but here's the info on installing
                                > jre/jdk on Edgy:
                                >
                                > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                >
                                > There are other versions of the wiki for Dapper Drake and older releases.
                                >
                                > If you've installed through synaptic you might want to have a look at
                                > /etc/jvm. First line there should point to the sun java (in my case
                                > /usr/lib/jvm/java-1.5.0-sun).
                                > You might also try:
                                > $ sudo update-alternatives --config java

                                Koen has it right. Follow the update-alternatives line with:

                                $ sudo update-alternatives --set \
                                java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

                                and you should be all set. This will take care of all the path parameters
                                and other bits that need to be set. No need to muck about editing files or
                                anything of that sort.

                                Terry
                                --

                                Terry FitzSimons
                                FITZSIMONS@...(Small Letters Only)

                                Data Lemur, Docs Gibbon
                              • Koen Van Daele
                                Hi, I think adding everything makes it needlessly complicated. I think the interesting info in these mails is: You need to run sun java. You can check this
                                Message 15 of 18 , Feb 28, 2007
                                  Hi,

                                  I think adding everything makes it needlessly complicated. I think the
                                  interesting info in these mails is:
                                  You need to run sun java. You can check this with:
                                  $ java -version
                                  If not, you might need to install Sun JRE from the repositories (see the
                                  Ubuntu wiki for help)
                                  If Sun java is installed but not run, you need to update the default java
                                  by using:
                                  $ sudo update-alternatives --config java
                                  or
                                  $ sudo update-alternatives --set \
                                  java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                  I think both these command do the same thing (with the first command you
                                  get a list of possible java's and are asked to choose).

                                  Manually moving files and placing symbolic links might get the job done
                                  but is probably bad for the long-term health of your system. I think
                                  things might break with an update.

                                  Greetings,
                                  Koen

                                  > I am planning on adding the following to the FAQ section to document the
                                  > Installation of Ubuntu.
                                  >
                                  > BTW, does anyone have command-line switches that they use, that they wish
                                  > to have documented? For any OS?
                                  >
                                  > Any correction would be appreciated.
                                  >
                                  > christine is located in Germany, her commands might be in German, other
                                  > nations may need to convert to local language.
                                  >
                                  > S L Raymond I think is in the USA. [commandline mit sh ./script)] from
                                  > christine's scrip might be in German and was not converted to the English
                                  > version by S L Raymond, but I run a Windows XP SP2 system and have no
                                  > idea.
                                  >
                                  > The following web page is in German, but it might be of assistance. Other
                                  > language pages will be added as found:
                                  > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                                  >
                                  > From: christine
                                  >
                                  > Installing Sun's JRE was the first right step. Get it from
                                  > http://www.sun.com/java
                                  >
                                  > Now you need to tell Ubuntu to use Sun's JRE when executing the command
                                  > java.
                                  > You can change that with a simple script.
                                  > Here's the script:
                                  >
                                  > 1. # copies the path to java into the variable
                                  > 2. j=`which java`
                                  > 3. # renaming the file
                                  > 4. sudo mv $j $j"gij"
                                  > 5. # set symbolic link
                                  > 6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j
                                  >
                                  > You need to set the right path to your installation of the JRE instead of
                                  > "/pathToJDK/jdk1.5.0_09/jre/bin/java "
                                  >
                                  > Copy the script into a file, make it executable and execute it (on the
                                  > commandline mit sh ./script).
                                  >
                                  > From: S L Raymond
                                  >
                                  > I did exactly the following:
                                  >
                                  > 1. I saved the following script as use_Sun.sh in my bin directory:
                                  > # copies the path to java into the variable
                                  > j=`which java`
                                  > # renaming the file
                                  > sudo mv $j $j"gij"
                                  > # set symbolic link
                                  > sudo ln -s /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre/bin/java $j
                                  >
                                  > 2. I chmoded the file to 755.
                                  >
                                  > 3. I ran the script. No error report.
                                  >
                                  > 4. After navigating to the PCGen directory and once again trying both
                                  > "java -jar pcgen.jar" and "./pcgen.sh", I continue to get the same error.
                                  >
                                  > From: Steven Gilroy
                                  >
                                  > At a command prompt type:
                                  > java - version
                                  >
                                  > You should get something like the following:
                                  > java version "1.5.0_10"
                                  > Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
                                  > Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode, sharing)
                                  >
                                  > If you don't then you are still running the virtual machine that came with
                                  > Ubuntu instead of Sun's Java. In that case you may need to remove
                                  > /usr/bin/java and then everything will work fine. If you have java in
                                  > more
                                  > than one path it will prefer the standard path's over later added ones.
                                  >
                                  > From: Koen Van Daele
                                  >
                                  > Not sure which version you are running, but here's the info on installing
                                  > jre/jdk on Edgy:
                                  >
                                  > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                  >
                                  > There are other versions of the wiki for Dapper Drake and older releases.
                                  >
                                  > If you've installed through synaptic you might want to have a look at
                                  > /etc/jvm. First line there should point to the sun java (in my case
                                  > /usr/lib/jvm/java-1.5.0-sun).
                                  > You might also try:
                                  > $ sudo update-alternatives --config java
                                  >
                                  > This command gives a list of available java versions and allows you to
                                  > choose one.
                                  >
                                  > From: EAW
                                  >
                                  > On Tue, 2007-02-20 at 09:50 +0100, Koen Van Daele wrote:
                                  >> Not sure which version you are running, but here's the info on
                                  >> installing
                                  >> jre/jdk on Edgy:
                                  >>
                                  >> http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                  >>
                                  >> There are other versions of the wiki for Dapper Drake and older
                                  >> releases.
                                  >>
                                  >> If you've installed through synaptic you might want to have a look at
                                  >> /etc/jvm. First line there should point to the sun java (in my case
                                  >> /usr/lib/jvm/java-1.5.0-sun).
                                  >> You might also try:
                                  >> $ sudo update-alternatives --config java
                                  >
                                  > Koen has it right. Follow the update-alternatives line with:
                                  >
                                  > $ sudo update-alternatives --set \
                                  > java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                  >
                                  > and you should be all set. This will take care of all the path parameters
                                  > and other bits that need to be set. No need to muck about editing files
                                  > or
                                  > anything of that sort.
                                  >
                                  > Terry
                                  > --
                                  >
                                  > Terry FitzSimons
                                  > FITZSIMONS@...(Small Letters Only)
                                  >
                                  > Data Lemur, Docs Gibbon
                                  >
                                  >
                                • Rene
                                  I have since made the updates to Java as recommended and my system was accessing the incorrect Java. Sadly I am still experiencing the isssue. $java -version
                                  Message 16 of 18 , Mar 1, 2007
                                    I have since made the updates to Java as recommended and my system was
                                    accessing the incorrect Java. Sadly I am still experiencing the isssue.
                                    $java -version
                                    java version "1.5.0_06"
                                    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
                                    Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)


                                    Koen Van Daele wrote:
                                    >
                                    > Hi,
                                    >
                                    > I think adding everything makes it needlessly complicated. I think the
                                    > interesting info in these mails is:
                                    > You need to run sun java. You can check this with:
                                    > $ java -version
                                    > If not, you might need to install Sun JRE from the repositories (see the
                                    > Ubuntu wiki for help)
                                    > If Sun java is installed but not run, you need to update the default java
                                    > by using:
                                    > $ sudo update-alternatives --config java
                                    > or
                                    > $ sudo update-alternatives --set \
                                    > java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                    > I think both these command do the same thing (with the first command you
                                    > get a list of possible java's and are asked to choose).
                                    >
                                    > Manually moving files and placing symbolic links might get the job done
                                    > but is probably bad for the long-term health of your system. I think
                                    > things might break with an update.
                                    >
                                    > Greetings,
                                    > Koen
                                    >
                                    > > I am planning on adding the following to the FAQ section to document the
                                    > > Installation of Ubuntu.
                                    > >
                                    > > BTW, does anyone have command-line switches that they use, that they
                                    > wish
                                    > > to have documented? For any OS?
                                    > >
                                    > > Any correction would be appreciated.
                                    > >
                                    > > christine is located in Germany, her commands might be in German, other
                                    > > nations may need to convert to local language.
                                    > >
                                    > > S L Raymond I think is in the USA. [commandline mit sh ./script)] from
                                    > > christine's scrip might be in German and was not converted to the
                                    > English
                                    > > version by S L Raymond, but I run a Windows XP SP2 system and have no
                                    > > idea.
                                    > >
                                    > > The following web page is in German, but it might be of assistance.
                                    > Other
                                    > > language pages will be added as found:
                                    > >
                                    > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                                    > <http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html>
                                    > >
                                    > > From: christine
                                    > >
                                    > > Installing Sun's JRE was the first right step. Get it from
                                    > > http://www.sun.com/java <http://www.sun.com/java>
                                    > >
                                    > > Now you need to tell Ubuntu to use Sun's JRE when executing the command
                                    > > java.
                                    > > You can change that with a simple script.
                                    > > Here's the script:
                                    > >
                                    > > 1. # copies the path to java into the variable
                                    > > 2. j=`which java`
                                    > > 3. # renaming the file
                                    > > 4. sudo mv $j $j"gij"
                                    > > 5. # set symbolic link
                                    > > 6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j
                                    > >
                                    > > You need to set the right path to your installation of the JRE
                                    > instead of
                                    > > "/pathToJDK/jdk1.5.0_09/jre/bin/java "
                                    > >
                                    > > Copy the script into a file, make it executable and execute it (on the
                                    > > commandline mit sh ./script).
                                    > >
                                    > > From: S L Raymond
                                    > >
                                    > > I did exactly the following:
                                    > >
                                    > > 1. I saved the following script as use_Sun.sh in my bin directory:
                                    > > # copies the path to java into the variable
                                    > > j=`which java`
                                    > > # renaming the file
                                    > > sudo mv $j $j"gij"
                                    > > # set symbolic link
                                    > > sudo ln -s /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre/bin/java $j
                                    > >
                                    > > 2. I chmoded the file to 755.
                                    > >
                                    > > 3. I ran the script. No error report.
                                    > >
                                    > > 4. After navigating to the PCGen directory and once again trying both
                                    > > "java -jar pcgen.jar" and "./pcgen.sh", I continue to get the same
                                    > error.
                                    > >
                                    > > From: Steven Gilroy
                                    > >
                                    > > At a command prompt type:
                                    > > java - version
                                    > >
                                    > > You should get something like the following:
                                    > > java version "1.5.0_10"
                                    > > Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_10-b03)
                                    > > Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode, sharing)
                                    > >
                                    > > If you don't then you are still running the virtual machine that
                                    > came with
                                    > > Ubuntu instead of Sun's Java. In that case you may need to remove
                                    > > /usr/bin/java and then everything will work fine. If you have java in
                                    > > more
                                    > > than one path it will prefer the standard path's over later added ones.
                                    > >
                                    > > From: Koen Van Daele
                                    > >
                                    > > Not sure which version you are running, but here's the info on
                                    > installing
                                    > > jre/jdk on Edgy:
                                    > >
                                    > >
                                    > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                    > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>
                                    > >
                                    > > There are other versions of the wiki for Dapper Drake and older
                                    > releases.
                                    > >
                                    > > If you've installed through synaptic you might want to have a look at
                                    > > /etc/jvm. First line there should point to the sun java (in my case
                                    > > /usr/lib/jvm/java-1.5.0-sun).
                                    > > You might also try:
                                    > > $ sudo update-alternatives --config java
                                    > >
                                    > > This command gives a list of available java versions and allows you to
                                    > > choose one.
                                    > >
                                    > > From: EAW
                                    > >
                                    > > On Tue, 2007-02-20 at 09:50 +0100, Koen Van Daele wrote:
                                    > >> Not sure which version you are running, but here's the info on
                                    > >> installing
                                    > >> jre/jdk on Edgy:
                                    > >>
                                    > >>
                                    > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                    > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>
                                    > >>
                                    > >> There are other versions of the wiki for Dapper Drake and older
                                    > >> releases.
                                    > >>
                                    > >> If you've installed through synaptic you might want to have a look at
                                    > >> /etc/jvm. First line there should point to the sun java (in my case
                                    > >> /usr/lib/jvm/java-1.5.0-sun).
                                    > >> You might also try:
                                    > >> $ sudo update-alternatives --config java
                                    > >
                                    > > Koen has it right. Follow the update-alternatives line with:
                                    > >
                                    > > $ sudo update-alternatives --set \
                                    > > java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                    > >
                                    > > and you should be all set. This will take care of all the path
                                    > parameters
                                    > > and other bits that need to be set. No need to muck about editing files
                                    > > or
                                    > > anything of that sort.
                                    > >
                                    > > Terry
                                    > > --
                                    > >
                                    > > Terry FitzSimons
                                    > > FITZSIMONS@... <mailto:FITZSIMONS%40MINTEL.NET>(Small Letters
                                    > Only)
                                    > >
                                    > > Data Lemur, Docs Gibbon
                                    > >
                                    > >
                                    >
                                    >




                                    [Non-text portions of this message have been removed]
                                  • Koen Van Daele
                                    So, now that you re running the correct Java, what errors do you get? What version of Ubuntu are you running, where did you install and how do you try to start
                                    Message 17 of 18 , Mar 4, 2007
                                      So, now that you're running the correct Java, what errors do you get?
                                      What version of Ubuntu are you running, where did you install and how do
                                      you try to start the program?
                                      Sorry if you've given this info before, but I couldn't find it.

                                      Koen

                                      Op donderdag 01-03-2007 om 19:03 uur [tijdzone -0700], schreef Rene:
                                      > I have since made the updates to Java as recommended and my system
                                      > was
                                      > accessing the incorrect Java. Sadly I am still experiencing the
                                      > isssue.
                                      > $java -version
                                      > java version "1.5.0_06"
                                      > Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
                                      > Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)
                                      >
                                      > Koen Van Daele wrote:
                                      > >
                                      > > Hi,
                                      > >
                                      > > I think adding everything makes it needlessly complicated. I think
                                      > the
                                      > > interesting info in these mails is:
                                      > > You need to run sun java. You can check this with:
                                      > > $ java -version
                                      > > If not, you might need to install Sun JRE from the repositories (see
                                      > the
                                      > > Ubuntu wiki for help)
                                      > > If Sun java is installed but not run, you need to update the default
                                      > java
                                      > > by using:
                                      > > $ sudo update-alternatives --config java
                                      > > or
                                      > > $ sudo update-alternatives --set \
                                      > > java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                      > > I think both these command do the same thing (with the first command
                                      > you
                                      > > get a list of possible java's and are asked to choose).
                                      > >
                                      > > Manually moving files and placing symbolic links might get the job
                                      > done
                                      > > but is probably bad for the long-term health of your system. I think
                                      > > things might break with an update.
                                      > >
                                      > > Greetings,
                                      > > Koen
                                      > >
                                      > > > I am planning on adding the following to the FAQ section to
                                      > document the
                                      > > > Installation of Ubuntu.
                                      > > >
                                      > > > BTW, does anyone have command-line switches that they use, that
                                      > they
                                      > > wish
                                      > > > to have documented? For any OS?
                                      > > >
                                      > > > Any correction would be appreciated.
                                      > > >
                                      > > > christine is located in Germany, her commands might be in German,
                                      > other
                                      > > > nations may need to convert to local language.
                                      > > >
                                      > > > S L Raymond I think is in the USA. [commandline mit sh ./script)]
                                      > from
                                      > > > christine's scrip might be in German and was not converted to the
                                      > > English
                                      > > > version by S L Raymond, but I run a Windows XP SP2 system and have
                                      > no
                                      > > > idea.
                                      > > >
                                      > > > The following web page is in German, but it might be of
                                      > assistance.
                                      > > Other
                                      > > > language pages will be added as found:
                                      > > >
                                      > >
                                      > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                                      > >
                                      > <http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html>
                                      > > >
                                      > > > From: christine
                                      > > >
                                      > > > Installing Sun's JRE was the first right step. Get it from
                                      > > > http://www.sun.com/java <http://www.sun.com/java>
                                      > > >
                                      > > > Now you need to tell Ubuntu to use Sun's JRE when executing the
                                      > command
                                      > > > java.
                                      > > > You can change that with a simple script.
                                      > > > Here's the script:
                                      > > >
                                      > > > 1. # copies the path to java into the variable
                                      > > > 2. j=`which java`
                                      > > > 3. # renaming the file
                                      > > > 4. sudo mv $j $j"gij"
                                      > > > 5. # set symbolic link
                                      > > > 6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j
                                      > > >
                                      > > > You need to set the right path to your installation of the JRE
                                      > > instead of
                                      > > > "/pathToJDK/jdk1.5.0_09/jre/bin/java "
                                      > > >
                                      > > > Copy the script into a file, make it executable and execute it (on
                                      > the
                                      > > > commandline mit sh ./script).
                                      > > >
                                      > > > From: S L Raymond
                                      > > >
                                      > > > I did exactly the following:
                                      > > >
                                      > > > 1. I saved the following script as use_Sun.sh in my bin directory:
                                      > > > # copies the path to java into the variable
                                      > > > j=`which java`
                                      > > > # renaming the file
                                      > > > sudo mv $j $j"gij"
                                      > > > # set symbolic link
                                      > > > sudo ln -s /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre/bin/java $j
                                      > > >
                                      > > > 2. I chmoded the file to 755.
                                      > > >
                                      > > > 3. I ran the script. No error report.
                                      > > >
                                      > > > 4. After navigating to the PCGen directory and once again trying
                                      > both
                                      > > > "java -jar pcgen.jar" and "./pcgen.sh", I continue to get the
                                      > same
                                      > > error.
                                      > > >
                                      > > > From: Steven Gilroy
                                      > > >
                                      > > > At a command prompt type:
                                      > > > java - version
                                      > > >
                                      > > > You should get something like the following:
                                      > > > java version "1.5.0_10"
                                      > > > Java(TM) 2 Runtime Environment, Standard Edition (build
                                      > 1.5.0_10-b03)
                                      > > > Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode,
                                      > sharing)
                                      > > >
                                      > > > If you don't then you are still running the virtual machine that
                                      > > came with
                                      > > > Ubuntu instead of Sun's Java. In that case you may need to remove
                                      > > > /usr/bin/java and then everything will work fine. If you have java
                                      > in
                                      > > > more
                                      > > > than one path it will prefer the standard path's over later added
                                      > ones.
                                      > > >
                                      > > > From: Koen Van Daele
                                      > > >
                                      > > > Not sure which version you are running, but here's the info on
                                      > > installing
                                      > > > jre/jdk on Edgy:
                                      > > >
                                      > > >
                                      > >
                                      > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                      > >
                                      > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>
                                      > > >
                                      > > > There are other versions of the wiki for Dapper Drake and older
                                      > > releases.
                                      > > >
                                      > > > If you've installed through synaptic you might want to have a look
                                      > at
                                      > > > /etc/jvm. First line there should point to the sun java (in my
                                      > case
                                      > > > /usr/lib/jvm/java-1.5.0-sun).
                                      > > > You might also try:
                                      > > > $ sudo update-alternatives --config java
                                      > > >
                                      > > > This command gives a list of available java versions and allows
                                      > you to
                                      > > > choose one.
                                      > > >
                                      > > > From: EAW
                                      > > >
                                      > > > On Tue, 2007-02-20 at 09:50 +0100, Koen Van Daele wrote:
                                      > > >> Not sure which version you are running, but here's the info on
                                      > > >> installing
                                      > > >> jre/jdk on Edgy:
                                      > > >>
                                      > > >>
                                      > >
                                      > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                      > >
                                      > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>
                                      > > >>
                                      > > >> There are other versions of the wiki for Dapper Drake and older
                                      > > >> releases.
                                      > > >>
                                      > > >> If you've installed through synaptic you might want to have a
                                      > look at
                                      > > >> /etc/jvm. First line there should point to the sun java (in my
                                      > case
                                      > > >> /usr/lib/jvm/java-1.5.0-sun).
                                      > > >> You might also try:
                                      > > >> $ sudo update-alternatives --config java
                                      > > >
                                      > > > Koen has it right. Follow the update-alternatives line with:
                                      > > >
                                      > > > $ sudo update-alternatives --set \
                                      > > > java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                      > > >
                                      > > > and you should be all set. This will take care of all the path
                                      > > parameters
                                      > > > and other bits that need to be set. No need to muck about editing
                                      > files
                                      > > > or
                                      > > > anything of that sort.
                                      > > >
                                      > > > Terry
                                      > > > --
                                      > > >
                                      > > > Terry FitzSimons
                                      > > > FITZSIMONS@... <mailto:FITZSIMONS%40MINTEL.NET>(Small
                                      > Letters
                                      > > Only)
                                      > > >
                                      > > > Data Lemur, Docs Gibbon
                                      > > >
                                      > > >
                                      > >
                                      > >
                                      >
                                      > [Non-text portions of this message have been removed]
                                      >
                                      >
                                      >
                                      >
                                      >
                                    • Rene
                                      My apologies for the reply taking so long I was away for the weekend. Ubuntu 6.06 LTS - the Dapper Drake - released in June 2006. /home/rene/pcgen5101 I start
                                      Message 18 of 18 , Mar 5, 2007
                                        My apologies for the reply taking so long I was away for the weekend.
                                        Ubuntu 6.06 LTS - the Dapper Drake - released in June 2006.
                                        /home/rene/pcgen5101
                                        I start the program by launching this file pcgen.jar using sun java 5.0
                                        runtime
                                        on intial launch I get this
                                        launch screen shot
                                        main window

                                        Settings -> Game mode/campaign will not have any selections located
                                        within it.

                                        I got to Settings -> preferences ->location
                                        preference pic

                                        Since it will not find the files here I change path to read
                                        (at this point my options.ini file is 4.9 KB)
                                        changed

                                        I created the folders vendor and port as they were not there and no
                                        obvious folders exist.
                                        I click ok and there is no change to the options available
                                        I exit the program (at this point my options.ini file is 4.9 KB)
                                        after restart

                                        Game mode/campaign is now missing from the menu
                                        exiting again now makes my options.ini file 6.5 KB
                                        reboot is the same issue


                                        Your assistance is much appreciated.

                                        Also the first time this issue manifested I would get an error my ini
                                        was correct after the third reboot and that I had to delete it. I was
                                        unablt to replecate this error this morning.


                                        Koen Van Daele wrote:
                                        >
                                        > So, now that you're running the correct Java, what errors do you get?
                                        > What version of Ubuntu are you running, where did you install and how do
                                        > you try to start the program?
                                        > Sorry if you've given this info before, but I couldn't find it.
                                        >
                                        > Koen
                                        >
                                        > Op donderdag 01-03-2007 om 19:03 uur [tijdzone -0700], schreef Rene:
                                        > > I have since made the updates to Java as recommended and my system
                                        > > was
                                        > > accessing the incorrect Java. Sadly I am still experiencing the
                                        > > isssue.
                                        > > $java -version
                                        > > java version "1.5.0_06"
                                        > > Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
                                        > > Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)
                                        > >
                                        > > Koen Van Daele wrote:
                                        > > >
                                        > > > Hi,
                                        > > >
                                        > > > I think adding everything makes it needlessly complicated. I think
                                        > > the
                                        > > > interesting info in these mails is:
                                        > > > You need to run sun java. You can check this with:
                                        > > > $ java -version
                                        > > > If not, you might need to install Sun JRE from the repositories (see
                                        > > the
                                        > > > Ubuntu wiki for help)
                                        > > > If Sun java is installed but not run, you need to update the default
                                        > > java
                                        > > > by using:
                                        > > > $ sudo update-alternatives --config java
                                        > > > or
                                        > > > $ sudo update-alternatives --set \
                                        > > > java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                        > > > I think both these command do the same thing (with the first command
                                        > > you
                                        > > > get a list of possible java's and are asked to choose).
                                        > > >
                                        > > > Manually moving files and placing symbolic links might get the job
                                        > > done
                                        > > > but is probably bad for the long-term health of your system. I think
                                        > > > things might break with an update.
                                        > > >
                                        > > > Greetings,
                                        > > > Koen
                                        > > >
                                        > > > > I am planning on adding the following to the FAQ section to
                                        > > document the
                                        > > > > Installation of Ubuntu.
                                        > > > >
                                        > > > > BTW, does anyone have command-line switches that they use, that
                                        > > they
                                        > > > wish
                                        > > > > to have documented? For any OS?
                                        > > > >
                                        > > > > Any correction would be appreciated.
                                        > > > >
                                        > > > > christine is located in Germany, her commands might be in German,
                                        > > other
                                        > > > > nations may need to convert to local language.
                                        > > > >
                                        > > > > S L Raymond I think is in the USA. [commandline mit sh ./script)]
                                        > > from
                                        > > > > christine's scrip might be in German and was not converted to the
                                        > > > English
                                        > > > > version by S L Raymond, but I run a Windows XP SP2 system and have
                                        > > no
                                        > > > > idea.
                                        > > > >
                                        > > > > The following web page is in German, but it might be of
                                        > > assistance.
                                        > > > Other
                                        > > > > language pages will be added as found:
                                        > > > >
                                        > > >
                                        > >
                                        > http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                                        > <http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html>
                                        >
                                        > > >
                                        > >
                                        > <http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html
                                        > <http://www.entwickler-blog.de/archiv/150-java.awt.AWTError-Cannot-load-AWT-toolkit-gnu.java.awt.peer.gtk.GtkToolkit.html>>
                                        > > > >
                                        > > > > From: christine
                                        > > > >
                                        > > > > Installing Sun's JRE was the first right step. Get it from
                                        > > > > http://www.sun.com/java <http://www.sun.com/java>
                                        > <http://www.sun.com/java <http://www.sun.com/java>>
                                        > > > >
                                        > > > > Now you need to tell Ubuntu to use Sun's JRE when executing the
                                        > > command
                                        > > > > java.
                                        > > > > You can change that with a simple script.
                                        > > > > Here's the script:
                                        > > > >
                                        > > > > 1. # copies the path to java into the variable
                                        > > > > 2. j=`which java`
                                        > > > > 3. # renaming the file
                                        > > > > 4. sudo mv $j $j"gij"
                                        > > > > 5. # set symbolic link
                                        > > > > 6. sudo ln -s /pathToJDK/jdk1.5.0_09/jre/bin/java $j
                                        > > > >
                                        > > > > You need to set the right path to your installation of the JRE
                                        > > > instead of
                                        > > > > "/pathToJDK/jdk1.5.0_09/jre/bin/java "
                                        > > > >
                                        > > > > Copy the script into a file, make it executable and execute it (on
                                        > > the
                                        > > > > commandline mit sh ./script).
                                        > > > >
                                        > > > > From: S L Raymond
                                        > > > >
                                        > > > > I did exactly the following:
                                        > > > >
                                        > > > > 1. I saved the following script as use_Sun.sh in my bin directory:
                                        > > > > # copies the path to java into the variable
                                        > > > > j=`which java`
                                        > > > > # renaming the file
                                        > > > > sudo mv $j $j"gij"
                                        > > > > # set symbolic link
                                        > > > > sudo ln -s /usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre/bin/java $j
                                        > > > >
                                        > > > > 2. I chmoded the file to 755.
                                        > > > >
                                        > > > > 3. I ran the script. No error report.
                                        > > > >
                                        > > > > 4. After navigating to the PCGen directory and once again trying
                                        > > both
                                        > > > > "java -jar pcgen.jar" and "./pcgen.sh", I continue to get the
                                        > > same
                                        > > > error.
                                        > > > >
                                        > > > > From: Steven Gilroy
                                        > > > >
                                        > > > > At a command prompt type:
                                        > > > > java - version
                                        > > > >
                                        > > > > You should get something like the following:
                                        > > > > java version "1.5.0_10"
                                        > > > > Java(TM) 2 Runtime Environment, Standard Edition (build
                                        > > 1.5.0_10-b03)
                                        > > > > Java HotSpot(TM) Client VM (build 1.5.0_10-b03, mixed mode,
                                        > > sharing)
                                        > > > >
                                        > > > > If you don't then you are still running the virtual machine that
                                        > > > came with
                                        > > > > Ubuntu instead of Sun's Java. In that case you may need to remove
                                        > > > > /usr/bin/java and then everything will work fine. If you have java
                                        > > in
                                        > > > > more
                                        > > > > than one path it will prefer the standard path's over later added
                                        > > ones.
                                        > > > >
                                        > > > > From: Koen Van Daele
                                        > > > >
                                        > > > > Not sure which version you are running, but here's the info on
                                        > > > installing
                                        > > > > jre/jdk on Edgy:
                                        > > > >
                                        > > > >
                                        > > >
                                        > >
                                        > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                        > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>
                                        >
                                        > > >
                                        > >
                                        > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                        > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>>
                                        > > > >
                                        > > > > There are other versions of the wiki for Dapper Drake and older
                                        > > > releases.
                                        > > > >
                                        > > > > If you've installed through synaptic you might want to have a look
                                        > > at
                                        > > > > /etc/jvm. First line there should point to the sun java (in my
                                        > > case
                                        > > > > /usr/lib/jvm/java-1.5.0-sun).
                                        > > > > You might also try:
                                        > > > > $ sudo update-alternatives --config java
                                        > > > >
                                        > > > > This command gives a list of available java versions and allows
                                        > > you to
                                        > > > > choose one.
                                        > > > >
                                        > > > > From: EAW
                                        > > > >
                                        > > > > On Tue, 2007-02-20 at 09:50 +0100, Koen Van Daele wrote:
                                        > > > >> Not sure which version you are running, but here's the info on
                                        > > > >> installing
                                        > > > >> jre/jdk on Edgy:
                                        > > > >>
                                        > > > >>
                                        > > >
                                        > >
                                        > http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                        > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>
                                        >
                                        > > >
                                        > >
                                        > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins
                                        > <http://ubuntuguide.org/wiki/Ubuntu_Edgy#Java_.26_Non-Media_Browser_Plug-ins>>
                                        > > > >>
                                        > > > >> There are other versions of the wiki for Dapper Drake and older
                                        > > > >> releases.
                                        > > > >>
                                        > > > >> If you've installed through synaptic you might want to have a
                                        > > look at
                                        > > > >> /etc/jvm. First line there should point to the sun java (in my
                                        > > case
                                        > > > >> /usr/lib/jvm/java-1.5.0-sun).
                                        > > > >> You might also try:
                                        > > > >> $ sudo update-alternatives --config java
                                        > > > >
                                        > > > > Koen has it right. Follow the update-alternatives line with:
                                        > > > >
                                        > > > > $ sudo update-alternatives --set \
                                        > > > > java /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                                        > > > >
                                        > > > > and you should be all set. This will take care of all the path
                                        > > > parameters
                                        > > > > and other bits that need to be set. No need to muck about editing
                                        > > files
                                        > > > > or
                                        > > > > anything of that sort.
                                        > > > >
                                        > > > > Terry
                                        > > > > --
                                        > > > >
                                        > > > > Terry FitzSimons
                                        > > > > FITZSIMONS@... <mailto:FITZSIMONS%40MINTEL.NET>
                                        > <mailto:FITZSIMONS%40MINTEL.NET>(Small
                                        > > Letters
                                        > > > Only)
                                        > > > >
                                        > > > > Data Lemur, Docs Gibbon
                                        > > > >
                                        > > > >
                                        > > >
                                        > > >
                                        > >
                                        > > [Non-text portions of this message have been removed]
                                        > >
                                        > >
                                        > >
                                        > >
                                        > >
                                        >
                                        >



                                        [Non-text portions of this message have been removed]
                                      Your message has been successfully submitted and would be delivered to recipients shortly.