Loading ...
Sorry, an error occurred while loading the content.

[5.11.5] Trying out ABILITY tags

Expand Messages
  • Jay
    Here are the things I m noticing so far in PCGen 5.11.5 (Mac OS X application bundle): 1) I cloned the 35e gamemode (foo_35e) and added ABILITYCATEGORY tags to
    Message 1 of 3 , Jan 2, 2007
    • 0 Attachment
      Here are the things I'm noticing so far in PCGen 5.11.5 (Mac OS X
      application bundle):

      1) I cloned the 35e gamemode (foo_35e) and added ABILITYCATEGORY tags
      to miscinfo.lst to create subtabs for Class
      Abilties, Special Attacks, and Special Qualities:

      ABILITYCATEGORY:Class Feature CATEGORY:ClassFeature
      DISPLAYNAME:Class Feature EDITABLE:No EDITPOOL:No FRACTIONALPOOL:No
      PLURAL:Class Features TYPE:ClassFeature VISIBLE:Yes
      ABILITYCATEGORY:Special Attack CATEGORY:SpecialAttack
      DISPLAYNAME:Special Attack EDITABLE:No EDITPOOL:No FRACTIONALPOOL:No
      PLURAL:Special Attacks TYPE:SpecialAttack VISIBLE:Yes
      ABILITYCATEGORY:Special Quality CATEGORY:SpecialQuality
      DISPLAYNAME:Special Quality EDITABLE:No EDITPOOL:No FRACTIONALPOOL:No
      PLURAL:Special Qualities TYPE:SpecialQuality VISIBLE:Yes

      2) I have a dataset I am modifying to use 5.11 features. (This is not
      an OGL dataset.) This dataset uses the foo_35e gamemode, and the
      foo_35e gamemode is selected in PCGen's preferences.
      3) This dataset uses the ABILITY tag in the .pcc file to load my feat
      and ability .lst files instead of FEAT.
      4) I have changed the TYPE tag on the feats to read
      "TYPE:Feat.General", "TYPE:Feat.Metamagic", et al.
      5) The class abilities I'm testing are of the type
      "TYPE:ClassFeature.SpecialQuality",
      "TYPE:ClassFeature.SpecialAttack.Supernatural", and have VISIBLE:DISPLAY.
      6) My class uses the ABILITY tag instead of FEATAUTO to load
      abilities, and is of the form
      "ABILITY:ClassFeature|VIRTUAL|<ability_bar>" and
      "ABILITY:ClassFeature|VIRTUAL|<ability_baz>"

      Here are the two things I'm hitting so far.

      * When I load my dataset, I get an error:

      Error parsing file file:/Applications/PCGen
      5.11.5.app/Contents/Resources/Java/data/dataset_bar/dataset_bar_class.lst
      line 9: plugin.lsttokens.AbilityLst: Invalid token format
      [ClassFeature|VIRTUAL|ability_bar]

      I have multiple ABILITY tags on the same class level line; however, I
      only get this error once for the first ABILITY tag on the class level
      line, ability_bar; swapping ability_bar and ability_baz causes the
      error to be thrown for ability_baz.

      * The feats show up fine in the Feats subtab; nothing shows
      up in my Class Features, Special Attacks, and Special Qualities subtabs.

      I want to experiment with the new ABILITY object type, but I
      don't necessarily want to bog the main group down with my questions.
      Is there a place where 5.11.x features are being discussed?
      Pcgen_experimental, maybe?
    • James Dempsey
      Hi Jay, On 3/01/2007 7:46 AM Jay wrote ... I found yesterday that this type of error is thrown if it cannot find the category name. Try changing the category
      Message 2 of 3 , Jan 2, 2007
      • 0 Attachment
        Hi Jay,

        On 3/01/2007 7:46 AM Jay wrote
        > * When I load my dataset, I get an error:
        >
        > Error parsing file file:/Applications/PCGen
        > 5.11.5.app/Contents/Resources/Java/data/dataset_bar/dataset_bar_class.lst
        > line 9: plugin.lsttokens.AbilityLst: Invalid token format
        > [ClassFeature|VIRTUAL|ability_bar]
        >
        > I have multiple ABILITY tags on the same class level line; however, I
        > only get this error once for the first ABILITY tag on the class level
        > line, ability_bar; swapping ability_bar and ability_baz causes the
        > error to be thrown for ability_baz.
        >
        I found yesterday that this type of error is thrown if it cannot find
        the category name. Try changing the category to have the same name as
        you use in the ability definition (not just the category tag, but the
        first tag also). I'll check in a fix for that directly. I'm not sure
        about the only giving an error on the first one - that sounds like a bug
        also.

        > * The feats show up fine in the Feats subtab; nothing shows
        > up in my Class Features, Special Attacks, and Special Qualities subtabs.
        >
        >
        This could be related to the name as mentioned above.

        > I want to experiment with the new ABILITY object type, but I
        > don't necessarily want to bog the main group down with my questions.
        > Is there a place where 5.11.x features are being discussed?
        > Pcgen_experimental, maybe?
        >
        >
        Yeah, experimental is probably the best place. :)

        --
        Cheers,
        James Dempsey
        PCGen Code SB
      • Andrew Maitland
        Hi Jay, Welcome to the club. The Experimental Group is the best place to ask and discuss anything new being done with your use of the code, tag usage or
        Message 3 of 3 , Jan 2, 2007
        • 0 Attachment
          Hi Jay,

          Welcome to the club. The Experimental Group is the best place to ask and
          discuss anything new being done with your use of the code, tag usage or
          anything else that doesn't necessarily pertain to lst help or generic
          questions.

          -Andrew

          Jay wrote:
          > Here are the things I'm noticing so far in PCGen 5.11.5 (Mac OS X
          > application bundle):
          >
          > 1) I cloned the 35e gamemode (foo_35e) and added ABILITYCATEGORY tags
          > to miscinfo.lst to create subtabs for Class
          > Abilties, Special Attacks, and Special Qualities:
          >
          > ABILITYCATEGORY:Class Feature CATEGORY:ClassFeature
          > DISPLAYNAME:Class Feature EDITABLE:No EDITPOOL:No FRACTIONALPOOL:No
          > PLURAL:Class Features TYPE:ClassFeature VISIBLE:Yes
          > ABILITYCATEGORY:Special Attack CATEGORY:SpecialAttack
          > DISPLAYNAME:Special Attack EDITABLE:No EDITPOOL:No FRACTIONALPOOL:No
          > PLURAL:Special Attacks TYPE:SpecialAttack VISIBLE:Yes
          > ABILITYCATEGORY:Special Quality CATEGORY:SpecialQuality
          > DISPLAYNAME:Special Quality EDITABLE:No EDITPOOL:No FRACTIONALPOOL:No
          > PLURAL:Special Qualities TYPE:SpecialQuality VISIBLE:Yes
          >
          > 2) I have a dataset I am modifying to use 5.11 features. (This is not
          > an OGL dataset.) This dataset uses the foo_35e gamemode, and the
          > foo_35e gamemode is selected in PCGen's preferences.
          > 3) This dataset uses the ABILITY tag in the .pcc file to load my feat
          > and ability .lst files instead of FEAT.
          > 4) I have changed the TYPE tag on the feats to read
          > "TYPE:Feat.General", "TYPE:Feat.Metamagic", et al.
          > 5) The class abilities I'm testing are of the type
          > "TYPE:ClassFeature.SpecialQuality",
          > "TYPE:ClassFeature.SpecialAttack.Supernatural", and have VISIBLE:DISPLAY.
          > 6) My class uses the ABILITY tag instead of FEATAUTO to load
          > abilities, and is of the form
          > "ABILITY:ClassFeature|VIRTUAL|<ability_bar>" and
          > "ABILITY:ClassFeature|VIRTUAL|<ability_baz>"
          >
          > Here are the two things I'm hitting so far.
          >
          > * When I load my dataset, I get an error:
          >
          > Error parsing file file:/Applications/PCGen
          > 5.11.5.app/Contents/Resources/Java/data/dataset_bar/dataset_bar_class.lst
          > line 9: plugin.lsttokens.AbilityLst: Invalid token format
          > [ClassFeature|VIRTUAL|ability_bar]
          >
          > I have multiple ABILITY tags on the same class level line; however, I
          > only get this error once for the first ABILITY tag on the class level
          > line, ability_bar; swapping ability_bar and ability_baz causes the
          > error to be thrown for ability_baz.
          >
          > * The feats show up fine in the Feats subtab; nothing shows
          > up in my Class Features, Special Attacks, and Special Qualities subtabs.
          >
          > I want to experiment with the new ABILITY object type, but I
          > don't necessarily want to bog the main group down with my questions.
          > Is there a place where 5.11.x features are being discussed?
          > Pcgen_experimental, maybe?
          >
          >
          >
          >
          > PCGen's Release site: http://pcgen.sourceforge.net
          > PCGen's Wiki: http://www.legolas.org/pcgen/pytw/#Welcome
          > PCGen's Roadmap: http://www.legolas.org/pcgen/pytw/#Roadmap
          > PCGen's Alpha Build: http://pcgen.sourceforge.net/07_autobuilds.php
          > PCGen's Online Docs: http://pcgen.sourceforge.net/autobuilds/pcgen-docs/
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.