Loading ...
Sorry, an error occurred while loading the content.

Re: [pcgen] Re: Doesn't load sources

Expand Messages
  • James Dempsey
    Hi, On 30/08/2006 2:19 AM tahl_liadon wrote ... My guess here is that when you had it in the pcgen directory (i.e. /home/username/pcgen/[pcgen contents] ) your
    Message 1 of 15 , Sep 2, 2006
    • 0 Attachment
      Hi,

      On 30/08/2006 2:19 AM tahl_liadon wrote
      > --- In pcgen@yahoogroups.com, "Lamune Baba" <Lamune_Baba@...> wrote:
      >
      > i'm not sure if this is the same issue that i'm having...
      >
      > i am using sun-java (1.5) with pcgen (5.81) in ubuntu on a 386.
      >
      > my sources wouldn't load; i just get a totally blank pcgen interface.
      > after moving things around, i discovered that i have to put everything
      > (the contents of the pcgen dir after unzip) right at the first level
      > of my user account (i.e. /home/user/[pcgen contents]).
      >
      > it wouldn't even work if i had the contents in a "pcgen" dir (i.e.
      > /home/user/pcgen/[pcgen contents]). i'm too frustrated to figure a
      > workaround right now. my user account is populated with pcgen files
      > and dirs, but i don't care. it works for now.
      >
      > hope this sheds some light.
      >
      >
      My guess here is that when you had it in the pcgen directory (i.e.
      /home/username/pcgen/[pcgen contents] ) your current directory when you
      were running the program was your home directory rather than the pcgen
      directory. When pcgen is run it needs to be able to find the plugins,
      the game mode info and the data. Once you get started you can configure
      this all up to specific locations. However, at least initially, you need
      to start pcgen with the current directory set to the pcgen directory.

      --
      Cheers,
      James Dempsey
      PCGen Code SB
    • James Dempsey
      Hi, On 3/09/2006 9:23 AM techwiz2000_2000 wrote ... My guess here is that your PCC file either does not have enough information included, or it is coded
      Message 2 of 15 , Sep 2, 2006
      • 0 Attachment
        Hi,

        On 3/09/2006 9:23 AM techwiz2000_2000 wrote
        > I just joined because I'm having a similar problem: I've created my
        > own campaign PCC file, and in it I've called all the parts of the RSRD
        > I actually want to show up (a handful of race and class files, the
        > equipment and stuff...). But when I load just that source, it acts as
        > though no sources are loaded. When I load that and the RSRD, in
        > addition to everything I didn't want showing up, none of my custom
        > races or classes show up at all!
        >
        >
        My guess here is that your PCC file either does not have enough
        information included, or it is coded incorrectly and not loading some
        information in the way you expect. If you load your source with the
        debug console open and the debug mode selected you will see some
        counters appear, like the following.

        Number of objects loaded. The following should all be greater than 0:
        Races=643
        Classes=128
        Skills=84
        Feats=696
        Equipment=2144
        WeaponProfs=133
        Kits=928
        Templates=365

        The results there, and any error messages you see may guide you in
        working out what is wrong with your PCC file.

        --
        Cheers,
        James Dempsey
        PCGen Code SB
      • techwiz2000_2000
        I can indeed load the RSRD complete, but nothing at all from my campaign shows up if I load both. It claims to load mine but won t let me make a char unless I
        Message 3 of 15 , Sep 3, 2006
        • 0 Attachment
          I can indeed load the RSRD complete, but nothing at all from my
          campaign shows up if I load both. It claims to load mine but won't let
          me make a char unless I load both

          --- In pcgen@yahoogroups.com, Edwin Holley <eholley@...> wrote:
          >
          > techwiz2000_2000 wrote:
          > > I just joined because I'm having a similar problem: I've created my
          > > own campaign PCC file, and in it I've called all the parts of the RSRD
          > > I actually want to show up (a handful of race and class files, the
          > > equipment and stuff...). But when I load just that source, it acts as
          > > though no sources are loaded. When I load that and the RSRD, in
          > > addition to everything I didn't want showing up, none of my custom
          > > races or classes show up at all!
          > >
          > Are you able to load one of the included sources, such as RSRD complete?
          > > --- In pcgen@yahoogroups.com, "tahl_liadon" <tahl@> wrote:
          > >
          > >> --- In pcgen@yahoogroups.com, "Lamune Baba" <Lamune_Baba@> wrote:
          > >>
          > >>> I was actually having this same problem, but I figured mine out...
          > >>> after poking at it for a few more minutes.
          > >>>
          > >>> I was only interested in SRD materials for an AD&D campaign, so
          I was
          > >>> only attempting to load PCGEN OGL entry. So when I attempted to
          start
          > >>> a new character, it was giving me the source error.
          > >>>
          > >>> It looks like all the actual game files are in RSRD (3.5e, or SRD in
          > >>> 3.0 mode.) As soon as I loaded that, everything worked great.
          > >>>
          > >>> Any chance of the same issue, OP?
          > >>>
          > >>>
          > >> i'm not sure if this is the same issue that i'm having...
          > >>
          > >> i am using sun-java (1.5) with pcgen (5.81) in ubuntu on a 386.
          > >>
          > Sun Java may be a problem ... some people are able to run it no problem.
          > >> my sources wouldn't load; i just get a totally blank pcgen interface.
          > >> after moving things around, i discovered that i have to put
          everything
          > >> (the contents of the pcgen dir after unzip) right at the first level
          > >> of my user account (i.e. /home/user/[pcgen contents]).
          > >>
          > >> it wouldn't even work if i had the contents in a "pcgen" dir (i.e.
          > >> /home/user/pcgen/[pcgen contents]). i'm too frustrated to figure a
          > >> workaround right now. my user account is populated with pcgen files
          > >> and dirs, but i don't care. it works for now.
          > >>
          > >> hope this sheds some light.
          > >>
          > You might want to move your stuff to the Vendor directory, or create
          > your own.
          > >>
          > >
          > >
          > >
          > >
          >
          >
          >
          > [Non-text portions of this message have been removed]
          >
        • techwiz2000_2000
          wow... I did something VERY wrong Illegal Race Tag on all of my custom races, looks like, and errors on my classes.... *cries*
          Message 4 of 15 , Sep 3, 2006
          • 0 Attachment
            wow... I did something VERY wrong

            Illegal Race Tag on all of my custom races, looks like, and errors on
            my classes.... *cries*

            --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:
            >
            > Hi,
            >
            > On 3/09/2006 9:23 AM techwiz2000_2000 wrote
            > > I just joined because I'm having a similar problem: I've created my
            > > own campaign PCC file, and in it I've called all the parts of the RSRD
            > > I actually want to show up (a handful of race and class files, the
            > > equipment and stuff...). But when I load just that source, it acts as
            > > though no sources are loaded. When I load that and the RSRD, in
            > > addition to everything I didn't want showing up, none of my custom
            > > races or classes show up at all!
            > >
            > >
            > My guess here is that your PCC file either does not have enough
            > information included, or it is coded incorrectly and not loading some
            > information in the way you expect. If you load your source with the
            > debug console open and the debug mode selected you will see some
            > counters appear, like the following.
            >
            > Number of objects loaded. The following should all be greater than 0:
            > Races=643
            > Classes=128
            > Skills=84
            > Feats=696
            > Equipment=2144
            > WeaponProfs=133
            > Kits=928
            > Templates=365
            >
            > The results there, and any error messages you see may guide you in
            > working out what is wrong with your PCC file.
            >
            > --
            > Cheers,
            > James Dempsey
            > PCGen Code SB
            >
          • Edwin Holley
            ... Ok, try these steps 1)Start PCGen ;-) 2)Select Debug Debug Mode 3)Select Debug Console 4)Load only your source 5)Copy the contents of the debug to your
            Message 5 of 15 , Sep 3, 2006
            • 0 Attachment
              techwiz2000_2000 wrote:
              > I can indeed load the RSRD complete, but nothing at all from my
              > campaign shows up if I load both. It claims to load mine but won't let
              > me make a char unless I load both
              >
              > --- In pcgen@yahoogroups.com, Edwin Holley <eholley@...> wrote:
              Ok, try these steps

              1)Start PCGen ;-)
              2)Select Debug>Debug Mode
              3)Select Debug>Console
              4)Load only your source
              5)Copy the contents of the debug to your reply :-)

              hopefully this gives us some good info :-)

              --

              Edwin Charles Holley II
              GlassWalkerTheurge
              PCGen Windows Installer (Monkey)

              Mozilla Powered Open Source
              Expand Your E-Mail Get Thunderbird!
              <http://www.spreadfirefox.com/?q=affiliates&id=0&t=178>
              Expand Your Browsing Get Firefox!
              <http://www.spreadfirefox.com/?q=affiliates&id=0&t=85>
              Expand Your HTML Document made with Nvu <http://www.nvu.com>



              [Non-text portions of this message have been removed]
            • Edwin Holley
              ... I should have read following posts, sorry ;-). [Non-text portions of this message have been removed]
              Message 6 of 15 , Sep 3, 2006
              • 0 Attachment
                Edwin Holley wrote:
                > techwiz2000_2000 wrote:
                >
                >> I can indeed load the RSRD complete, but nothing at all from my
                >> campaign shows up if I load both. It claims to load mine but won't let
                >> me make a char unless I load both
                >>
                >> --- In pcgen@yahoogroups.com, Edwin Holley <eholley@...> wrote:
                >>
                > Ok, try these steps
                >
                > 1)Start PCGen ;-)
                > 2)Select Debug>Debug Mode
                > 3)Select Debug>Console
                > 4)Load only your source
                > 5)Copy the contents of the debug to your reply :-)
                >
                > hopefully this gives us some good info :-)
                >
                >
                I should have read following posts, sorry ;-).


                [Non-text portions of this message have been removed]
              • discnerd
                ... I am having a similar problem with 5.10.1 (straight from the zip) running on Java blackdown 1.4.2-02 on Ubuntu Linux. It dumps the following (several
                Message 7 of 15 , Sep 4, 2006
                • 0 Attachment
                  --- In pcgen@yahoogroups.com, "curseblad3" <curseblad3@...> wrote:
                  >
                  > Hey
                  >
                  > Just downloaded and unpacked the program. It loads up just fine but
                  > when i choose the sources,load them up and want to create a character
                  > it still says i havent loaded any sources.When i check the console
                  > almost every file has "error parsing file" wirtten on the left.
                  > The filepaths to the files are correct,im runing the newest java
                  > jre,windows xp sp2.
                  >


                  I am having a similar problem with 5.10.1 (straight from the zip)
                  running on Java blackdown 1.4.2-02 on Ubuntu Linux. It dumps the
                  following (several thousand times, but I figured once would be okay)
                  when I try to load the RSRD content:

                  Error parsing file
                  'file:~/srcs/pcgen5101/data/d20ogl/srd35/epic/rsrd_spells_epic.lst'
                  line '67': null
                  Ignoring error
                  java.lang.NoClassDefFoundError
                  at pcgen.core.spell.Spell.<init>(Spell.java:48)
                  at
                  pcgen.persistence.lst.SpellLoader.parseLine(SpellLoader.java:66)
                  at
                  pcgen.persistence.lst.LstObjectFileLoader.loadLstFile(LstObjectFileLoader.java:323)
                  at
                  pcgen.persistence.lst.LstObjectFileLoader.loadLstFiles(LstObjectFileLoader.java:110)
                  at
                  pcgen.persistence.lst.LstSystemLoader.loadCampaigns(LstSystemLoader.java:443)
                  at
                  pcgen.persistence.PersistenceManager.loadCampaigns(PersistenceManager.java:166)
                  at pcgen.gui.MainSource.loadCampaigns(MainSource.java:1048)
                  at pcgen.gui.MainSource.access$2000(MainSource.java:118)
                  at pcgen.gui.MainSource$18.construct(MainSource.java:1076)
                  at pcgen.util.SwingWorker$2.run(SwingWorker.java:113)
                  at java.lang.Thread.run(Thread.java:534)

                  I've looked at the .lst files and I can't distinguish why some lines
                  are causing problems and others don't. Some lines are simply
                  comments. Any ideas?
                Your message has been successfully submitted and would be delivered to recipients shortly.