Loading ...
Sorry, an error occurred while loading the content.

FEATS and PREVIEW tab don't display? OS X Intel

Expand Messages
  • R. Wolfgang Rumpf
    Is anyone else having this problem? I m using an Intel-based Mac, OS X 10.4. Happens with both 5.10.0 and 5.10.1. When I load up a character, using CPM AD&D
    Message 1 of 9 , Aug 24, 2006
    • 0 Attachment
      Is anyone else having this problem? I'm using an Intel-based Mac, OS
      X 10.4. Happens with both 5.10.0 and 5.10.1. When I load up a
      character, using CPM AD&D 3.5 ruleset (core books and Complete
      Warrior), everything seems to work fine except nothing gets displayed
      in the FEATS and PREVIEW panes. If I fiddle with resizing the app I
      can get the PREVIEW to refresh/display, but FEATS never does.

      Whacky.
    • James Dempsey
      Hi, ... The behaviour you describe sounds like there is a problem occurring when it is trying to display the list of feats. Try opening the debug console and
      Message 2 of 9 , Aug 24, 2006
      • 0 Attachment
        Hi,

        On 25/08/06, R. Wolfgang Rumpf <evildrbob@...> wrote:
        > Is anyone else having this problem? I'm using an Intel-based Mac, OS
        > X 10.4. Happens with both 5.10.0 and 5.10.1. When I load up a
        > character, using CPM AD&D 3.5 ruleset (core books and Complete
        > Warrior), everything seems to work fine except nothing gets displayed
        > in the FEATS and PREVIEW panes. If I fiddle with resizing the app I
        > can get the PREVIEW to refresh/display, but FEATS never does.
        >

        The behaviour you describe sounds like there is a problem occurring
        when it is trying to display the list of feats. Try opening the debug
        console and then switching to the feat or preview tab. You should get
        a long error message listing an error and a series of locations. If
        you could post that here it would assist us in tracking down the
        issue.

        The other thing to note is that CMP hasn't updated their data sets to
        work with the 5.10 series yet. As a result we cannot guarantee 5.10.1
        will work with them. Are you able to reproduce the same problem when
        using only datasets that ship with PCGen?

        --
        Cheers,
        James Dempsey
        PCGen Code SB
      • Lizard
        This might be a bug with all D20 Modern races; I just tested it on Dryads to duplicate what I noticed when preparing an NPC for a game I ran Wendesday. Using
        Message 3 of 9 , Aug 24, 2006
        • 0 Attachment
          This might be a bug with all D20 Modern races; I just tested it on
          Dryads to duplicate what I noticed when preparing an NPC for a game I
          ran Wendesday.

          Using 5.10.1, full MSRD, Windows XP

          To replicate:
          a)Create a dryad
          b)Add 3 levels of Charismatic hero and 2 levels of smart hero.
          c)Go to Feats tab. You will see the Dryad has 10(!) feats available to
          choose.

          It might be that the feats granted by the class levels aren't being
          correctly tallied, or something.
        • frank_kliewe
          ... You re right. I had to install a workaround for granting feats in the monster classes and obviously that doesn t work correct when adding PC classes. This
          Message 4 of 9 , Aug 24, 2006
          • 0 Attachment
            --- In pcgen@yahoogroups.com, Lizard <lizard@...> wrote:
            >
            > This might be a bug with all D20 Modern races; I just tested it on
            > Dryads to duplicate what I noticed when preparing an NPC for a game I
            > ran Wendesday.
            >
            > Using 5.10.1, full MSRD, Windows XP
            >
            > To replicate:
            > a)Create a dryad
            > b)Add 3 levels of Charismatic hero and 2 levels of smart hero.
            > c)Go to Feats tab. You will see the Dryad has 10(!) feats available to
            > choose.
            >
            > It might be that the feats granted by the class levels aren't being
            > correctly tallied, or something.
            >

            You're right. I had to install a workaround for granting feats in the
            monster classes and obviously that doesn't work correct when adding PC
            classes. This affects all monster types that grant feats in modern. :(

            Bug trackered here:
            [ 1546407 ] [MSRD] Dryads in D20 Modern have waaaay too many feats...
            http://sourceforge.net/tracker/index.php?func=detail&aid=1546407&group_id=25576&atid=750091

            Cheerio,

            Frank Kliewe
            PCGen Content Silverback

            --
            I don't think you understand. I didn't come to rescue Rambo from you.
            I came here to rescue you from him.
            (Col. Trautman in "First Blood", 1982)
          • R. Wolfgang Rumpf
            Here s an update - I repeated the test in both 5.10.0 and 5.10.1 with java 1.4, 1.5, and 1.6 - the error still occurs. Also: I ditched the CMP rulesets from my
            Message 5 of 9 , Sep 7, 2006
            • 0 Attachment
              Here's an update - I repeated the test in both 5.10.0 and 5.10.1 with
              java 1.4, 1.5, and 1.6 - the error still occurs.

              Also:

              I ditched the CMP rulesets from my 5.10.0 install and used the
              standard RSRD d20 rules. Had to make a new character, but...it worked
              fine. So it *looks* like it's the datasets but it *may* be the character?


              Re the debug mode, I did get some NPE's:

              java.lang.NullPointerException
              at
              pcgen.gui.tabs.InfoFeats$FeatModel.buildTreeSourceName(InfoFeats.java:2205)
              at pcgen.gui.tabs.InfoFeats$FeatModel.resetModel(InfoFeats.java:2329)
              at pcgen.gui.tabs.InfoFeats$FeatModel.<init>(InfoFeats.java:1517)
              at pcgen.gui.tabs.InfoFeats$FeatModel.<init>(InfoFeats.java:1476)
              at pcgen.gui.tabs.InfoFeats.createModelAvailable(InfoFeats.java:512)
              at pcgen.gui.tabs.InfoFeats.createModels(InfoFeats.java:547)
              at pcgen.gui.tabs.InfoFeats.initComponents(InfoFeats.java:1120)
              at pcgen.gui.tabs.InfoFeats.access$000(InfoFeats.java:129)
              at pcgen.gui.tabs.InfoFeats$1.run(InfoFeats.java:207)
              at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:189)
              at java.awt.EventQueue.dispatchEvent(EventQueue.java:478)
              at
              pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent(PCGen_Frame1.java:3153)
              at
              java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
              at
              java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
              at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
              at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
              at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
              java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=pcgen.gui.tabs.InfoFeats$1@e23281,notifier=null,catchExceptions=false,when=1157646731113]
              on apple.awt.CToolkit@61d1dd
              java.lang.NullPointerException
              at pcgen.gui.tabs.InfoFeats.updateAvailableModel(InfoFeats.java:1370)
              at pcgen.gui.tabs.InfoFeats.updateCharacterInfo(InfoFeats.java:1407)
              at pcgen.gui.tabs.InfoFeats.forceRefresh(InfoFeats.java:292)
              at pcgen.gui.tabs.InfoFeats.setPc(InfoFeats.java:219)
              at pcgen.gui.CharacterInfo$PcSetter.finished(CharacterInfo.java:478)
              at pcgen.util.SwingWorker$1.run(SwingWorker.java:107)
              at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:189)
              at java.awt.EventQueue.dispatchEvent(EventQueue.java:478)
              at
              pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent(PCGen_Frame1.java:3153)
              at
              java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
              at
              java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
              at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
              at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
              at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
              java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=pcgen.util.SwingWorker$1@f9a1af,notifier=null,catchExceptions=false,when=1157646731423]
              on apple.awt.CToolkit@61d1dd



              --- In pcgen@yahoogroups.com, "James Dempsey" <jdempsey@...> wrote:
              >
              > Hi,
              >
              > On 25/08/06, R. Wolfgang Rumpf <evildrbob@...> wrote:
              > > Is anyone else having this problem? I'm using an Intel-based Mac, OS
              > > X 10.4. Happens with both 5.10.0 and 5.10.1. When I load up a
              > > character, using CPM AD&D 3.5 ruleset (core books and Complete
              > > Warrior), everything seems to work fine except nothing gets displayed
              > > in the FEATS and PREVIEW panes. If I fiddle with resizing the app I
              > > can get the PREVIEW to refresh/display, but FEATS never does.
              > >
              >
              > The behaviour you describe sounds like there is a problem occurring
              > when it is trying to display the list of feats. Try opening the debug
              > console and then switching to the feat or preview tab. You should get
              > a long error message listing an error and a series of locations. If
              > you could post that here it would assist us in tracking down the
              > issue.
              >
              > The other thing to note is that CMP hasn't updated their data sets to
              > work with the 5.10 series yet. As a result we cannot guarantee 5.10.1
              > will work with them. Are you able to reproduce the same problem when
              > using only datasets that ship with PCGen?
              >
              > --
              > Cheers,
              > James Dempsey
              > PCGen Code SB
              >
            • Ludovic Fierville
              Not to ditch the question, but aren t CMP datasets for PCGen 5.8 ? ... -- ~ Tengoku de omachisi te imasu ~
              Message 6 of 9 , Sep 7, 2006
              • 0 Attachment
                Not to ditch the question, but aren't CMP datasets for PCGen 5.8 ?

                2006/9/7, R. Wolfgang Rumpf <evildrbob@...>:
                > Here's an update - I repeated the test in both 5.10.0 and 5.10.1 with
                > java 1.4, 1.5, and 1.6 - the error still occurs.
                >
                > Also:
                >
                > I ditched the CMP rulesets from my 5.10.0 install and used the
                > standard RSRD d20 rules. Had to make a new character, but...it worked
                > fine. So it *looks* like it's the datasets but it *may* be the character?
                >
                >
                > Re the debug mode, I did get some NPE's:
                >
                > java.lang.NullPointerException
                > at
                > pcgen.gui.tabs.InfoFeats$FeatModel.buildTreeSourceName(InfoFeats.java:2205)
                > at pcgen.gui.tabs.InfoFeats$FeatModel.resetModel(InfoFeats.java:2329)
                > at pcgen.gui.tabs.InfoFeats$FeatModel.<init>(InfoFeats.java:1517)
                > at pcgen.gui.tabs.InfoFeats$FeatModel.<init>(InfoFeats.java:1476)
                > at pcgen.gui.tabs.InfoFeats.createModelAvailable(InfoFeats.java:512)
                > at pcgen.gui.tabs.InfoFeats.createModels(InfoFeats.java:547)
                > at pcgen.gui.tabs.InfoFeats.initComponents(InfoFeats.java:1120)
                > at pcgen.gui.tabs.InfoFeats.access$000(InfoFeats.java:129)
                > at pcgen.gui.tabs.InfoFeats$1.run(InfoFeats.java:207)
                > at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:189)
                > at java.awt.EventQueue.dispatchEvent(EventQueue.java:478)
                > at
                > pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent(PCGen_Frame1.java:3153)
                > at
                > java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
                > at
                > java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
                > at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
                > at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
                > at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
                > java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=pcgen.gui.tabs.InfoFeats$1@e23281,notifier=null,catchExceptions=false,when=1157646731113]
                > on apple.awt.CToolkit@61d1dd
                > java.lang.NullPointerException
                > at pcgen.gui.tabs.InfoFeats.updateAvailableModel(InfoFeats.java:1370)
                > at pcgen.gui.tabs.InfoFeats.updateCharacterInfo(InfoFeats.java:1407)
                > at pcgen.gui.tabs.InfoFeats.forceRefresh(InfoFeats.java:292)
                > at pcgen.gui.tabs.InfoFeats.setPc(InfoFeats.java:219)
                > at pcgen.gui.CharacterInfo$PcSetter.finished(CharacterInfo.java:478)
                > at pcgen.util.SwingWorker$1.run(SwingWorker.java:107)
                > at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:189)
                > at java.awt.EventQueue.dispatchEvent(EventQueue.java:478)
                > at
                > pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent(PCGen_Frame1.java:3153)
                > at
                > java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:234)
                > at
                > java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:184)
                > at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:178)
                > at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:170)
                > at java.awt.EventDispatchThread.run(EventDispatchThread.java:100)
                > java.awt.event.InvocationEvent[INVOCATION_DEFAULT,runnable=pcgen.util.SwingWorker$1@f9a1af,notifier=null,catchExceptions=false,when=1157646731423]
                > on apple.awt.CToolkit@61d1dd
                >
                >
                >
                > --- In pcgen@yahoogroups.com, "James Dempsey" <jdempsey@...> wrote:
                > >
                > > Hi,
                > >
                > > On 25/08/06, R. Wolfgang Rumpf <evildrbob@...> wrote:
                > > > Is anyone else having this problem? I'm using an Intel-based Mac, OS
                > > > X 10.4. Happens with both 5.10.0 and 5.10.1. When I load up a
                > > > character, using CPM AD&D 3.5 ruleset (core books and Complete
                > > > Warrior), everything seems to work fine except nothing gets displayed
                > > > in the FEATS and PREVIEW panes. If I fiddle with resizing the app I
                > > > can get the PREVIEW to refresh/display, but FEATS never does.
                > > >
                > >
                > > The behaviour you describe sounds like there is a problem occurring
                > > when it is trying to display the list of feats. Try opening the debug
                > > console and then switching to the feat or preview tab. You should get
                > > a long error message listing an error and a series of locations. If
                > > you could post that here it would assist us in tracking down the
                > > issue.
                > >
                > > The other thing to note is that CMP hasn't updated their data sets to
                > > work with the 5.10 series yet. As a result we cannot guarantee 5.10.1
                > > will work with them. Are you able to reproduce the same problem when
                > > using only datasets that ship with PCGen?
                > >
                > > --
                > > Cheers,
                > > James Dempsey
                > > PCGen Code SB
                > >
                >
                >
                >
                >
                >
                >
                >
                >
                > PCGen's release site: http://pcgen.sourceforge.net
                > PCGen's Wiki: http://www.legolas.org/pcgen/pytw/#Welcome
                > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
                > PCGen's Online Docs: http://www.legolas.org/pcgen/docs/
                > Yahoo! Groups Links
                >
                >
                >
                >
                >
                >
                >
                >
                >
                >
                >


                --
                ~ Tengoku de omachisi te imasu ~
              • Paul W. King
                ... 5.8.1 to be exact. They haven t updated thier datasets to accomodate the code/data changes in 5.10.1 yet. Paul W. King PR SB, BoD
                Message 7 of 9 , Sep 7, 2006
                • 0 Attachment
                  > Not to ditch the question, but aren't CMP datasets for PCGen 5.8 ?

                  5.8.1 to be exact. They haven't updated thier datasets to accomodate
                  the code/data changes in 5.10.1 yet.

                  Paul W. King
                  PR SB, BoD
                • R. Wolfgang Rumpf
                  Well, I did discover this after posting those (numerous and lengthy) followups. mea culpa. But 5.10.x is so much *better* than 5.8.1 - here s hoping
                  Message 8 of 9 , Sep 8, 2006
                  • 0 Attachment
                    Well, I did discover this after posting those (numerous and lengthy)
                    followups. mea culpa.

                    <sigh> But 5.10.x is so much *better* than 5.8.1 - here's hoping that
                    the codemonkeys can update the datasets fairly quickly....

                    --- In pcgen@yahoogroups.com, "Paul W. King" <paulking.rhochi@...> wrote:
                    >
                    > > Not to ditch the question, but aren't CMP datasets for PCGen 5.8 ?
                    >
                    > 5.8.1 to be exact. They haven't updated thier datasets to accomodate
                    > the code/data changes in 5.10.1 yet.
                    >
                    > Paul W. King
                    > PR SB, BoD
                    >
                  • Paul W. King
                    ... That s their call. I know that 5.10.1 came out close to GenCon, so CMP was involved with GenCon preprarations instead of dataset version advancement. Paul
                    Message 9 of 9 , Sep 8, 2006
                    • 0 Attachment
                      > But 5.10.x is so much *better* than 5.8.1 - here's hoping that the
                      > codemonkeys can update the datasets fairly quickly....

                      That's their call. I know that 5.10.1 came out close to GenCon, so CMP
                      was involved with GenCon preprarations instead of dataset version
                      advancement.

                      Paul W. King
                      PR SB, BoD
                    Your message has been successfully submitted and would be delivered to recipients shortly.