Loading ...
Sorry, an error occurred while loading the content.

Re: [BUG] Inifiles in Seperate directories

Expand Messages
  • youwhooooooo
    I ve had the same problem! I set all my settings exactly as I wanted them, and bam! they never stay put. All my settings are back to the way they were prior to
    Message 1 of 20 , Jun 27, 2006
    • 0 Attachment
      I've had the same problem! I set all my settings exactly as I wanted them, and bam! they
      never stay put. All my settings are back to the way they were prior to my changes.

      Please help!

      --- In pcgen@yahoogroups.com, "Thomas Clegg" <TN_Clegg@...> wrote:
      >
      > Hi all!
      >
      > Installing just the latest autobuild (11-08), there's a problem with having
      > the Options.ini and Filter.ini in a different directory other than the PCGen
      > root directory. You can't do it.
      >
      > I had no options.ini or the filter.ini or filepaths.ini in the root pcgen
      > directory after I installed the autobuild. The window popped up asking if I
      > wanted to save it in the PCGen root, the disk root, or specify a directory.
      > I specified my PCGen Inifiles directory. It took it, I made all the changes
      > to the preferences that I wanted, then closed it. Ta-da! It saved in the
      > Inifiles directory.
      >
      > I opened PCGen once again, and it loaded the files properly, kept the
      > settings, etc. However, once I closed PCGen, it saved the Option, filter,
      > and filepath files back out to the PCGen root directory. It seems to change
      > the filepaths.ini file each time it opens.
      >
      > This is a bug that can be worked with, but really should be straightened out
      > sice it seems to have been around since 5.4.....
      >
      > Tom
      > Data/Code Su-Monster :)
      >
    • James Dempsey
      Hi, Wow, this context certainly has been dragged up from the past - November 2004! To assist us in helping you, please let us know a bit more on what you are
      Message 2 of 20 , Jun 28, 2006
      • 0 Attachment
        Hi,

        Wow, this context certainly has been dragged up from the past - November
        2004!

        To assist us in helping you, please let us know a bit more on what you
        are using. What version of pcgen are you running? What operating system
        are you using? What version of Java are you using? What directory are
        you trying to store your settings to, and do you have write privileges
        to that directory and any existing filepaths.ini and options.ini files
        in that directory? How are you exiting PCGen when you have finished
        changing the settings?

        Sorry about the raft of questions, but it all helps to get an idea of
        what is going on and possible solutions.

        Cheers,
        James Dempsey
        PCGen Code Gibbon

        On 28/06/2006 1:07 PM youwhooooooo wrote
        > I've had the same problem! I set all my settings exactly as I wanted them, and bam! they
        > never stay put. All my settings are back to the way they were prior to my changes.
        >
        > Please help!
        >
        > --- In pcgen@yahoogroups.com, "Thomas Clegg" <TN_Clegg@...> wrote:
        >
        >> Hi all!
        >>
        >> Installing just the latest autobuild (11-08), there's a problem with having
        >> the Options.ini and Filter.ini in a different directory other than the PCGen
        >> root directory. You can't do it.
        >>
        >> I had no options.ini or the filter.ini or filepaths.ini in the root pcgen
        >> directory after I installed the autobuild. The window popped up asking if I
        >> wanted to save it in the PCGen root, the disk root, or specify a directory.
        >> I specified my PCGen Inifiles directory. It took it, I made all the changes
        >> to the preferences that I wanted, then closed it. Ta-da! It saved in the
        >> Inifiles directory.
        >>
        >> I opened PCGen once again, and it loaded the files properly, kept the
        >> settings, etc. However, once I closed PCGen, it saved the Option, filter,
        >> and filepath files back out to the PCGen root directory. It seems to change
        >> the filepaths.ini file each time it opens.
        >>
        >> This is a bug that can be worked with, but really should be straightened out
        >> sice it seems to have been around since 5.4.....
        >>
        >> Tom
        >> Data/Code Su-Monster :)
        >>
      • Timothy
        Sorry for the long delay. I have been away from my computer due to health issues. Ok to answer your raft of questions... ... 5,8,1 ... Mac OS X 10.4.7 ... Oh
        Message 3 of 20 , Jul 9, 2006
        • 0 Attachment
          Sorry for the long delay. I have been away from my computer due to
          health issues.

          Ok to answer your raft of questions...

          > What version of pcgen are you running?

          5,8,1

          > What operating system are you using?

          Mac OS X 10.4.7

          > What version of Java are you using?

          Oh boy. Apple's updated all of it:
          Java Browser 2.2
          JDK 1.4.2
          J2SE 5.0 Release 3

          > What directory are you trying to store your settings to?

          They are saved inside of the Apple Shared folder (it is the folder
          that any user has read/write access to)
          Owner: System
          Access: read/write
          Group: Wheel
          Access: read/write
          Others: read/write

          I think it is important to know that I am using Apple's Security
          option for my hard drive. this makes a virtual drive of my user
          folder from which I run all my private data.

          > and do you have write privileges to that directory and any existing
          > filepaths.ini and options.ini files in that directory?

          See above privileges.

          > How are you exiting PCGen when you have finished changing the
          > settings?

          I am always selecting OK.


          On Jun 28, 2006, at 5:05 AM, James Dempsey wrote:

          > Hi,
          >
          > Wow, this context certainly has been dragged up from the past -
          > November
          > 2004!
          >
          > To assist us in helping you, please let us know a bit more on what you
          > are using. What version of pcgen are you running? What operating
          > system
          > are you using? What version of Java are you using? What directory are
          > you trying to store your settings to, and do you have write privileges
          > to that directory and any existing filepaths.ini and options.ini files
          > in that directory? How are you exiting PCGen when you have finished
          > changing the settings?
          >
          > Sorry about the raft of questions, but it all helps to get an idea of
          > what is going on and possible solutions.
          >
          > Cheers,
          > James Dempsey
          > PCGen Code Gibbon
          >
          > On 28/06/2006 1:07 PM youwhooooooo wrote
          >> I've had the same problem! I set all my settings exactly as I
          >> wanted them, and bam! they
          >> never stay put. All my settings are back to the way they were
          >> prior to my changes.
          >>
          >> Please help!
          >>
          >> --- In pcgen@yahoogroups.com, "Thomas Clegg" <TN_Clegg@...> wrote:
          >>
          >>> Hi all!
          >>>
          >>> Installing just the latest autobuild (11-08), there's a problem
          >>> with having
          >>> the Options.ini and Filter.ini in a different directory other
          >>> than the PCGen
          >>> root directory. You can't do it.
          >>>
          >>> I had no options.ini or the filter.ini or filepaths.ini in the
          >>> root pcgen
          >>> directory after I installed the autobuild. The window popped up
          >>> asking if I
          >>> wanted to save it in the PCGen root, the disk root, or specify a
          >>> directory.
          >>> I specified my PCGen Inifiles directory. It took it, I made all
          >>> the changes
          >>> to the preferences that I wanted, then closed it. Ta-da! It saved
          >>> in the
          >>> Inifiles directory.
          >>>
          >>> I opened PCGen once again, and it loaded the files properly, kept
          >>> the
          >>> settings, etc. However, once I closed PCGen, it saved the
          >>> Option, filter,
          >>> and filepath files back out to the PCGen root directory. It
          >>> seems to change
          >>> the filepaths.ini file each time it opens.
          >>>
          >>> This is a bug that can be worked with, but really should be
          >>> straightened out
          >>> sice it seems to have been around since 5.4.....
          >>>
          >>> Tom
          >>> Data/Code Su-Monster :)
          >>>
          >
          >
          >
          > ------------------------ Yahoo! Groups Sponsor --------------------
          > ~-->
          > Yahoo! Groups gets a make over. See the new email design.
          > http://us.click.yahoo.com/XISQkA/lOaOAA/yQLSAA/7tRolB/TM
          > --------------------------------------------------------------------
          > ~->
          >
          > PCGen's release site: http://pcgen.sourceforge.net
          > PCGen's Wiki: http://www.legolas.org/pcgen/pytw/#Welcome
          > PCGen's alpha build: http://www.legolas.org/pcgen/autobuilds
          > PCGen's Online Docs: http://www.legolas.org/pcgen/docs/
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.