Loading ...
Sorry, an error occurred while loading the content.
 

Re: [TM][FREQ]The old "&" problem

Expand Messages
  • Byngl
    Well, there are already files in place that are _supposed_ to set up what characters get filtered/modified (system/outputFilters). Perhaps they are no longer
    Message 1 of 4 , Feb 3, 2006
      Well, there are already files in place that are _supposed_ to set up
      what characters get filtered/modified (system/outputFilters). Perhaps
      they are no longer being used. I know at one time this did work, but
      its been around since v2.4.5 (Feb 2, 2002), so it is possible that it
      has become broken...

      Byngl

      --- In pcgen@yahoogroups.com, "Chuck Pint" <pcgen@...> wrote:
      >
      > Currently if you use an "&" in any PCGen text field, the PDF OS blow
      > up with a rather cryptic error. This is fixed in BIO by changing the
      > "&" to "& amp;". I'd like to propose that one of two possible code
      > fixes get done.
      >
      > First (and best IMHO), would be to filter all fields that a user can
      > type text into, so that it changes "&" to "& amp;" (without the
      space
      > of course). This would be the SPROP and NOTES from the various EQ
      > tokens, BIO, NOTE.x , CATCHPHRASE, COLOR.x, INTERESTS, LOCATION,
      > PERSONALITY.x, RESIDENCE, and perhaps a few more I missed. This has
      a
      > minor problem for purely text based OS. It would be fine for PDF
      and HTML.
      >
      > Second way of fixing this, (and second best) would be to pop up a
      > warning message when they typed an "&" into any text field in PCGen.
      >
      > Chuck
      > OS Chimp
      >
    • Tex James
      I believe that this may be the case. On 1/30 I had sent 2 messages to the group asking why I was getting a strange error, only to later discover (on my own)
      Message 2 of 4 , Feb 3, 2006
        I believe that this may be the case. On 1/30 I had sent 2 messages to the
        group asking why I was getting a strange error, only to later discover (on
        my own) that I had used the & in the Character sheet notes. I never
        received any messages saying that the & is not an allowed character.

        Tex James
        datexan@...
        dmntexn@...
        ICQ # 53512210

        -----Original Message-----
        From: pcgen@yahoogroups.com [mailto:pcgen@yahoogroups.com] On Behalf Of
        Byngl
        Sent: Friday, February 03, 2006 7:38 AM
        To: pcgen@yahoogroups.com
        Subject: [pcgen] Re: [TM][FREQ]The old "&" problem


        Well, there are already files in place that are _supposed_ to set up
        what characters get filtered/modified (system/outputFilters). Perhaps
        they are no longer being used. I know at one time this did work, but
        its been around since v2.4.5 (Feb 2, 2002), so it is possible that it
        has become broken...

        Byngl

        --- In pcgen@yahoogroups.com, "Chuck Pint" <pcgen@...> wrote:
        >
        > Currently if you use an "&" in any PCGen text field, the PDF OS blow
        > up with a rather cryptic error. This is fixed in BIO by changing the
        > "&" to "& amp;". I'd like to propose that one of two possible code
        > fixes get done.
        >
        > First (and best IMHO), would be to filter all fields that a user can
        > type text into, so that it changes "&" to "& amp;" (without the
        space
        > of course). This would be the SPROP and NOTES from the various EQ
        > tokens, BIO, NOTE.x , CATCHPHRASE, COLOR.x, INTERESTS, LOCATION,
        > PERSONALITY.x, RESIDENCE, and perhaps a few more I missed. This has
        a
        > minor problem for purely text based OS. It would be fine for PDF
        and HTML.
        >
        > Second way of fixing this, (and second best) would be to pop up a
        > warning message when they typed an "&" into any text field in PCGen.
        >
        > Chuck
        > OS Chimp
        >







        PCGen's release site: http://pcgen.sourceforge.net
        PCGen's alpha build: http://www.legolas.org/pcgen/autobuilds
        PCGen's FAQ:
        http://www.evilsoft.org/pcgen/docs/
        Yahoo! Groups Links
      • Paul W. King
        [ 1423448 ] The old & problem https://sourceforge.net/tracker/index.php?func=detail&aid=1423448&group_id=25576&atid=384719 Paul W. King OGL/PL/TM Chimp, Data
        Message 3 of 4 , Feb 3, 2006
          [ 1423448 ] The old "&" problem
          https://sourceforge.net/tracker/index.php?func=detail&aid=1423448&group_id=25576&atid=384719

          Paul W. King
          OGL/PL/TM Chimp, Data Gibbon
        Your message has been successfully submitted and would be delivered to recipients shortly.