Loading ...
Sorry, an error occurred while loading the content.

Re: [PCGen] [Bug] [Trackered] Celestial Template

Expand Messages
  • Eddy Anthony
    ... Trackered: [ 1406797 ] [RSRD] Celestial Template issues -- ~
    Message 1 of 2 , Jan 15, 2006
    • 0 Attachment
      Andrew Maitland scribed:

      > I created a creature and added the celestial template, upon doing so I
      > noticed a few things:
      > 1) No Template Celestial (Common) was found. I looked in the data set
      > and it is asking for a template called Celestial (Common).
      > 2) The HD modifiers are based not on the actual HD, but instead on the
      > abstract HD total, i.e. instead of 8 hd it's looking at another HD of
      > 12* This is a bug adding HD when the master is loaded in PCGen.***
      > See note below
      > 3) The HD:SA: tag is not showing in the OS nor the output
      > A little bit along the same lines I've noticed animal companions and
      > special mounts are getting an extra HD/LA based upon the extra HD
      > bestowed upon
      > them by being Animal Companions/Special Mounts. My test creature has a
      > base HD of 4 and then +4 from being a special mount is CL=8 but the TL
      > is 12 when the master is loaded, add the Celestial template and the
      > TL=12/LA=14. Looking at the Celestial SR it comes out to be 17 (so the
      > template "extra" HD coming from being a special mount is. Looking at the
      > PDF output, the creature is showing a TCL of 12 and TL of 14 with the +2 LA.
      > The SR should be 13 (=8+5) instead of 17 (=12+5).
      > -I found that if I load the creature without loading the Master the
      > extra LA/HD is removed leaving the correct number. Seeing as certain
      > templates rely on an accurate HD for bonuses this would appear to be a bug.

      [ 1406797 ] [RSRD] Celestial Template issues
      ~ Eddy Anthony (MoSaT)
      ~ PCGen Content Silverback
    Your message has been successfully submitted and would be delivered to recipients shortly.