Loading ...
Sorry, an error occurred while loading the content.

[BUG]5.9.4 PRESIZE in EQMODs broken?

Expand Messages
  • Frank Kliewe
    Using 5.9.4 with Java 1.5.0_04 on WinXP. Testing on Future Equipment I get a series of messages in the debug console and the EQMODs that have PRESIZE applied
    Message 1 of 7 , Nov 16, 2005
    • 0 Attachment
      Using 5.9.4 with Java 1.5.0_04 on WinXP.

      Testing on Future Equipment I get a series of messages in the debug console
      and the EQMODs that have PRESIZE applied do not show up in the customizer
      window.

      These are the messages I get:

      Error in PrerequisiteTest, failing test:
      pcgen.core.prereq.PrerequisiteException: pcgen.core.prereq.PreSize does not
      support prerequisites for Equipment.
      at
      pcgen.core.prereq.AbstractPrerequisiteTest.passes(AbstractPrerequisiteTest.j
      ava:97)
      at pcgen.core.prereq.PrereqHandler.passes(PrereqHandler.java:258)
      at pcgen.core.prereq.PrereqHandler.passesAll(PrereqHandler.java:150)
      at pcgen.core.PObject.passesPreReqToGain(PObject.java:3509)
      at pcgen.core.Equipment.isVisible(Equipment.java:3238)
      at
      pcgen.gui.EqBuilder$EquipmentModModel.setFilter(EqBuilder.java:2206)
      at
      pcgen.gui.EqBuilder$EquipmentModModel.access$000(EqBuilder.java:1987)
      at pcgen.gui.EqBuilder.setEquipment(EqBuilder.java:304)
      at pcgen.gui.EqBuilder.setEquipment(EqBuilder.java:153)
      at pcgen.gui.EQFrame.setEquipment(EQFrame.java:94)
      at pcgen.gui.tabs.InfoGear.openCustomizer(InfoGear.java:2065)
      at pcgen.gui.tabs.InfoGear.customizeButtonClick(InfoGear.java:1264)
      at pcgen.gui.tabs.InfoGear.access$4400(InfoGear.java:72)
      at pcgen.gui.tabs.InfoGear$17.actionPerformed(InfoGear.java:2451)
      at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
      at javax.swing.AbstractButton$Handler.actionPerformed(Unknown
      Source)
      at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown
      Source)
      at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
      at javax.swing.AbstractButton.doClick(Unknown Source)
      at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
      at
      javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
      at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
      at java.awt.Component.processMouseEvent(Unknown Source)
      at javax.swing.JComponent.processMouseEvent(Unknown Source)
      at java.awt.Component.processEvent(Unknown Source)
      at java.awt.Container.processEvent(Unknown Source)
      at java.awt.Component.dispatchEventImpl(Unknown Source)
      at java.awt.Container.dispatchEventImpl(Unknown Source)
      at java.awt.Component.dispatchEvent(Unknown Source)
      at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
      at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
      at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
      at java.awt.Container.dispatchEventImpl(Unknown Source)
      at java.awt.Window.dispatchEventImpl(Unknown Source)
      at java.awt.Component.dispatchEvent(Unknown Source)
      at java.awt.EventQueue.dispatchEvent(Unknown Source)
      at
      pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent(PCGen_Frame1.java:
      3131)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown
      Source)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
      Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.run(Unknown Source)

      To recreate this with data in the release, there is an EQMOD that uses
      PRESIZE in Alpha Datasets/Sellout Sourcebook. Use the Xcrawl gameMode to see
      that.

      Cheerio,

      Frank Kliewe
      PCGen Data Chimp & OS Lemur

      --
      I've no regrets. I've been everywhere and done everything. I've eaten caviar
      at Cannes, sausage rolls at the dogs. I've played baccarat at Biarritz and
      darts with the rural dean. What is there left for me but marriage?
      (Iris Henderson in "The Lady Vanishes", 1938)
    • Frank Kliewe
      *BUMP* This is still not functioning in 5.9.8, it is now used also in MSRD Future Equipment.
      Message 2 of 7 , Apr 4, 2006
      • 0 Attachment
        *BUMP* This is still not functioning in 5.9.8, it is now used also in MSRD
        Future Equipment.

        > -----Original Message-----
        > From: pcgen@yahoogroups.com [mailto:pcgen@yahoogroups.com] On
        > Behalf Of Frank Kliewe
        > Sent: Thursday, November 17, 2005 2:30 AM
        > To: pcgen@yahoogroups.com
        > Subject: [pcgen] [BUG]5.9.4 PRESIZE in EQMODs broken?
        >
        >
        > Using 5.9.4 with Java 1.5.0_04 on WinXP.
        >
        > Testing on Future Equipment I get a series of messages in the
        > debug console
        > and the EQMODs that have PRESIZE applied do not show up in
        > the customizer
        > window.
        >
        > These are the messages I get:
        >
        > Error in PrerequisiteTest, failing test:
        > pcgen.core.prereq.PrerequisiteException:
        > pcgen.core.prereq.PreSize does not
        > support prerequisites for Equipment.
        > at
        > pcgen.core.prereq.AbstractPrerequisiteTest.passes(AbstractPrer
        > equisiteTest.j
        > ava:97)
        > at
        > pcgen.core.prereq.PrereqHandler.passes(PrereqHandler.java:258)
        > at
        > pcgen.core.prereq.PrereqHandler.passesAll(PrereqHandler.java:150)
        > at pcgen.core.PObject.passesPreReqToGain(PObject.java:3509)
        > at pcgen.core.Equipment.isVisible(Equipment.java:3238)
        > at
        > pcgen.gui.EqBuilder$EquipmentModModel.setFilter(EqBuilder.java:2206)
        > at
        > pcgen.gui.EqBuilder$EquipmentModModel.access$000(EqBuilder.java:1987)
        > at pcgen.gui.EqBuilder.setEquipment(EqBuilder.java:304)
        > at pcgen.gui.EqBuilder.setEquipment(EqBuilder.java:153)
        > at pcgen.gui.EQFrame.setEquipment(EQFrame.java:94)
        > at pcgen.gui.tabs.InfoGear.openCustomizer(InfoGear.java:2065)
        > at
        > pcgen.gui.tabs.InfoGear.customizeButtonClick(InfoGear.java:1264)
        > at pcgen.gui.tabs.InfoGear.access$4400(InfoGear.java:72)
        > at
        > pcgen.gui.tabs.InfoGear$17.actionPerformed(InfoGear.java:2451)
        > at
        > javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
        > at javax.swing.AbstractButton$Handler.actionPerformed(Unknown
        > Source)
        > at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown
        > Source)
        > at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
        > at javax.swing.AbstractButton.doClick(Unknown Source)
        > at
        > javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
        > at
        > javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(U
        > nknown Source)
        > at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
        > at java.awt.Component.processMouseEvent(Unknown Source)
        > at javax.swing.JComponent.processMouseEvent(Unknown Source)
        > at java.awt.Component.processEvent(Unknown Source)
        > at java.awt.Container.processEvent(Unknown Source)
        > at java.awt.Component.dispatchEventImpl(Unknown Source)
        > at java.awt.Container.dispatchEventImpl(Unknown Source)
        > at java.awt.Component.dispatchEvent(Unknown Source)
        > at
        > java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
        > at
        > java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
        > at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
        > at java.awt.Container.dispatchEventImpl(Unknown Source)
        > at java.awt.Window.dispatchEventImpl(Unknown Source)
        > at java.awt.Component.dispatchEvent(Unknown Source)
        > at java.awt.EventQueue.dispatchEvent(Unknown Source)
        > at
        > pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent(PCGe
        n_Frame1.java:
        > 3131)
        > at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown
        > Source)
        > at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown
        > Source)
        > at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        > at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        > at java.awt.EventDispatchThread.run(Unknown Source)
        >
        > To recreate this with data in the release, there is an EQMOD that uses
        > PRESIZE in Alpha Datasets/Sellout Sourcebook. Use the Xcrawl
        > gameMode to see
        > that.
        >
        > Cheerio,
        >
        > Frank Kliewe
        > PCGen Data Chimp & OS Lemur
        >
        > --
        > I've no regrets. I've been everywhere and done everything.
        > I've eaten caviar
        > at Cannes, sausage rolls at the dogs. I've played baccarat at
        > Biarritz and
        > darts with the rural dean. What is there left for me but marriage?
        > (Iris Henderson in "The Lady Vanishes", 1938)
        >
        >
        >
        > ------------------------ Yahoo! Groups Sponsor
        > --------------------~-->
        > Get fast access to your favorite Yahoo! Groups. Make Yahoo!
        > your home page
        > http://us.click.yahoo.com/dpRU5A/wUILAA/yQLSAA/9rHolB/TM
        > --------------------------------------------------------------
        > ------~->
        >
        > PCGen's release site: http://pcgen.sourceforge.net
        > PCGen's alpha build: http://www.legolas.org/pcgen/autobuilds
        > PCGen's FAQ:
        > http://www.evilsoft.org/pcgen/docs/
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
        >
      • Paul W. King
        [ 1464635 ] 5.9.4 PRESIZE in EQMODs broken https://sourceforge.net/tracker/index.php?func=detail&aid=1464635&group_id=25576&atid=384719 Paul W. King PR SB, BoD
        Message 3 of 7 , Apr 4, 2006
        • 0 Attachment
          [ 1464635 ] 5.9.4 PRESIZE in EQMODs broken
          https://sourceforge.net/tracker/index.php?func=detail&aid=1464635&group_id=25576&atid=384719

          Paul W. King
          PR SB, BoD
        • boomer70
          ... Frank, I will try and explain what is going on here. Basically, every prereq has two methods that can be used to evaluate if it passes. One is used when
          Message 4 of 7 , Apr 4, 2006
          • 0 Attachment
            --- Frank Kliewe <fkliewe@...> wrote:

            > *BUMP* This is still not functioning in 5.9.8, it is
            > now used also in MSRD
            > Future Equipment.
            >

            Frank,

            I will try and explain what is going on here.
            Basically, every prereq has two methods that can be
            used to evaluate if it passes. One is used when the
            prereq is applied to a character the other is if it is
            applied to equipment.

            The error you are seeing is because PRESIZE doesn't
            implement the equipment version. If a PRE tag doesn't
            implement the equipment version it will try and use
            the character version. Unfortunately because the item
            customizer is not intended to customize items
            specifically for a character there is no character to
            use to evaluate the PRESIZE against.

            I am not really sure how you would want this to work.
            Without fundamentally changing the way the item
            customizer works there are only two solutions, always
            pass the prereq or never pass the prereq. Never
            passing puts you right back where you started (minus
            the error msgs). Always passing would always show the
            EQMOD. I am not sure what would happen if you then
            equipped the item to a character with this EQMOD. It
            may "work" in that if the prereq failed against the
            character its mods wouldn't be applied but I am not
            sure about that.

            Hopefully this explains what is going on and we can
            come up with some solution.

            -Aaron


            ----------------
            Aaron Divinsky
            PCGen Docs 2nd, Data Chimp, Code & Doc Tamarin

            __________________________________________________
            Do You Yahoo!?
            Tired of spam? Yahoo! Mail has the best spam protection around
            http://mail.yahoo.com
          • Eddy Anthony
            ... Not sure I follow, a PRESIZE tag in an EQMOD should be evaluated against the SIZE of the equipment it is being applied to. If the equipment has no SIZE tag
            Message 5 of 7 , Apr 4, 2006
            • 0 Attachment
              boomer70 scribed:

              > I am not really sure how you would want this to work.
              > Without fundamentally changing the way the item
              > customizer works there are only two solutions, always
              > pass the prereq or never pass the prereq. Never
              > passing puts you right back where you started (minus
              > the error msgs). Always passing would always show the
              > EQMOD. I am not sure what would happen if you then
              > equipped the item to a character with this EQMOD. It
              > may "work" in that if the prereq failed against the
              > character its mods wouldn't be applied but I am not
              > sure about that.

              Not sure I follow, a PRESIZE tag in an EQMOD should be evaluated against the
              SIZE of the equipment it is being applied to. If the equipment has no SIZE
              tag it is assumed to be medium, or at least I assume that is what it is
              assuming see as how that is the size shown in the equipment info pane in
              such cases.
              --
              ~ Eddy Anthony (MoSaT)
              ~ PCGen Content Silverback
            • boomer70
              ... OK thats more than a little confusing. However if that is what it is supposed to do it is easy to fix. I didn t see that in the documentation, did I miss
              Message 6 of 7 , Apr 5, 2006
              • 0 Attachment
                --- Eddy Anthony <eddyba@...> wrote:

                > boomer70 scribed:
                >
                > > I am not really sure how you would want this to
                > work.
                > > Without fundamentally changing the way the item
                > > customizer works there are only two solutions,
                > always
                > > pass the prereq or never pass the prereq. Never
                > > passing puts you right back where you started
                > (minus
                > > the error msgs). Always passing would always show
                > the
                > > EQMOD. I am not sure what would happen if you
                > then
                > > equipped the item to a character with this EQMOD.
                > It
                > > may "work" in that if the prereq failed against
                > the
                > > character its mods wouldn't be applied but I am
                > not
                > > sure about that.
                >
                > Not sure I follow, a PRESIZE tag in an EQMOD should
                > be evaluated against the
                > SIZE of the equipment it is being applied to. If the
                > equipment has no SIZE
                > tag it is assumed to be medium, or at least I assume
                > that is what it is
                > assuming see as how that is the size shown in the
                > equipment info pane in
                > such cases.

                OK thats more than a little confusing. However if
                that is what it is supposed to do it is easy to fix.
                I didn't see that in the documentation, did I miss it
                or do we need a doc tracker for it?

                -Aaron


                ----------------
                Aaron Divinsky
                PCGen Docs 2nd, Data Chimp, Code & Doc Tamarin

                __________________________________________________
                Do You Yahoo!?
                Tired of spam? Yahoo! Mail has the best spam protection around
                http://mail.yahoo.com
              • Byngl
                Shouldn t there be two different PRE s here? One for the size of equipment, and one for the size of a character? And since it looks like PRESIZE was never
                Message 7 of 7 , Apr 5, 2006
                • 0 Attachment
                  Shouldn't there be two different PRE's here? One for the size of
                  equipment, and one for the size of a character? And since it looks
                  like PRESIZE was never coded for equipment, something like
                  PREEQUIPSIZE might do.

                  Byngl

                  --- In pcgen@yahoogroups.com, boomer70 <boomer70@...> wrote:
                  >
                  >
                  >
                  > --- Eddy Anthony <eddyba@...> wrote:
                  >
                  > > boomer70 scribed:
                  > >
                  > > > I am not really sure how you would want this to
                  > > work.
                  > > > Without fundamentally changing the way the item
                  > > > customizer works there are only two solutions,
                  > > always
                  > > > pass the prereq or never pass the prereq. Never
                  > > > passing puts you right back where you started
                  > > (minus
                  > > > the error msgs). Always passing would always show
                  > > the
                  > > > EQMOD. I am not sure what would happen if you
                  > > then
                  > > > equipped the item to a character with this EQMOD.
                  > > It
                  > > > may "work" in that if the prereq failed against
                  > > the
                  > > > character its mods wouldn't be applied but I am
                  > > not
                  > > > sure about that.
                  > >
                  > > Not sure I follow, a PRESIZE tag in an EQMOD should
                  > > be evaluated against the
                  > > SIZE of the equipment it is being applied to. If the
                  > > equipment has no SIZE
                  > > tag it is assumed to be medium, or at least I assume
                  > > that is what it is
                  > > assuming see as how that is the size shown in the
                  > > equipment info pane in
                  > > such cases.
                  >
                  > OK thats more than a little confusing. However if
                  > that is what it is supposed to do it is easy to fix.
                  > I didn't see that in the documentation, did I miss it
                  > or do we need a doc tracker for it?
                  >
                  > -Aaron
                Your message has been successfully submitted and would be delivered to recipients shortly.