Loading ...
Sorry, an error occurred while loading the content.
 

Re: [pcgen] Re: Psicrystal error "Could not find class: Construct"

Expand Messages
  • Kevin Brown
    ... I would think that the Construct class would be part of the monster manual data (or the part of the RSRD that covers the monsters). So if you don t have
    Message 1 of 7 , Aug 31 8:54 AM
      > Hi all - I just realized that having the word "Resolved" in my
      > original message title might imply that the problem is resolved. It
      > is not resolved, I still get it. The word "Resolved" wan there
      > because I was picking the "Resolved" type of crystal. I still get the
      > "Could not find class: Construct" error every time I load the
      > Crystal.

      I would think that the Construct class would be part of the monster
      manual data (or the part of the RSRD that covers the monsters). So if
      you don't have the full RSRD dataset loaded then it might be missing
      because of that.

      > I do see some other errors relating to equipment sets. Am I supposed
      > to pick an equipment set before picking a "follower"?

      shouldn't need to set up equipsets before picking a follower.
    • skipaugur
      My normally loaded sets are 3.5 RSRD Complete plus 3.5 RSRD Psionics . I also loaded the 3.5 RSRD Monsters but it didn t make any difference. It s odd
      Message 2 of 7 , Sep 1, 2005
        My normally loaded sets are "3.5 RSRD Complete" plus "3.5 RSRD
        Psionics". I also loaded the "3.5 RSRD Monsters" but it didn't make
        any difference. It's odd that I get the error about 15 times but
        everythings still looks OK... The "Source" for the crystal says "RSRD
        Psionics, PsionicMonsters.rtf".

        --- In pcgen@yahoogroups.com, "Kevin Brown" <kevin_brown@q...> wrote:
        > > Hi all - I just realized that having the word "Resolved" in my
        > > original message title might imply that the problem is resolved. It
        > > is not resolved, I still get it. The word "Resolved" wan there
        > > because I was picking the "Resolved" type of crystal. I still get the
        > > "Could not find class: Construct" error every time I load the
        > > Crystal.
        >
        > I would think that the Construct class would be part of the monster
        > manual data (or the part of the RSRD that covers the monsters). So if
        > you don't have the full RSRD dataset loaded then it might be missing
        > because of that.
        >
        > > I do see some other errors relating to equipment sets. Am I supposed
        > > to pick an equipment set before picking a "follower"?
        >
        > shouldn't need to set up equipsets before picking a follower.
      • thoron-tir-gwaith@lycos.com
        RSRD Complete, plus the subsets? Ok, that will cause some weirdness. Couple Q s: Have you tried this with only the RSRD Complete loaded? Have you tried this
        Message 3 of 7 , Sep 1, 2005
          RSRD Complete, plus the subsets? Ok, that will cause some weirdness.

          Couple Q's:

          Have you tried this with only the RSRD Complete loaded?

          Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?

          Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD Monsters" loaded?

          I'm curious as to the results you are getting with those three conditions. That will help me figure out what calls are getting missed.

          Tir Gwaith
          LST Chimp

          > My normally loaded sets are "3.5 RSRD Complete" plus "3.5 RSRD
          > Psionics". I also loaded the "3.5 RSRD Monsters" but it didn't make
          > any difference. It's odd that I get the error about 15 times but
          > everythings still looks OK... The "Source" for the crystal says "RSRD
          > Psionics, PsionicMonsters.rtf".
        • skipaugur
          ... That may be my bad , as I thought I needed to load the Psionic package seperately, from back in the day when it was a separate set of files. At this
          Message 4 of 7 , Sep 2, 2005
            > RSRD Complete, plus the subsets? Ok, that will cause some weirdness.

            That may be "my bad", as I thought I needed to load the Psionic
            package seperately, from "back in the day" when it was a separate set
            of files. At this point, whenever I load my character, the RSRD
            Psionics gets automatically loaded. So I did the tests on a minimal
            new character witha 12 int, Chaotic Nuetral Human Egoist with
            PsiCrystal Affinity and random class skills.

            > Have you tried this with only the RSRD Complete loaded?

            Yes, I do get the error with "RSRD Complete"

            > Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?

            This does NOT give the error.

            >
            > Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD
            Monsters" loaded?

            This does NOT give the error.


            --- In pcgen@yahoogroups.com, thoron-tir-gwaith@l... wrote:
            > RSRD Complete, plus the subsets? Ok, that will cause some weirdness.
            >
            > Couple Q's:
            >
            > Have you tried this with only the RSRD Complete loaded?
            >
            > Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?
            >
            > Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD
            Monsters" loaded?
            >
            > I'm curious as to the results you are getting with those three
            conditions. That will help me figure out what calls are getting missed.
            >
            > Tir Gwaith
            > LST Chimp
            >
            > > My normally loaded sets are "3.5 RSRD Complete" plus "3.5 RSRD
            > > Psionics". I also loaded the "3.5 RSRD Monsters" but it didn't make
            > > any difference. It's odd that I get the error about 15 times but
            > > everythings still looks OK... The "Source" for the crystal says "RSRD
            > > Psionics, PsionicMonsters.rtf".
          • taluroniscandar
            ... That s strange. I checked the pcc files and the RSRD Complete (rsrd.pcc) simply calls the psionic pcc at the bottom (rsrd_psionics.pcc). Ah, this might be
            Message 5 of 7 , Sep 2, 2005
              >
              > > Have you tried this with only the RSRD Complete loaded?
              >
              > Yes, I do get the error with "RSRD Complete"
              >
              > > Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?
              >
              > This does NOT give the error.
              >
              > >
              > > Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD
              > Monsters" loaded?
              >
              > This does NOT give the error.
              >

              That's strange.
              I checked the pcc files and the RSRD Complete (rsrd.pcc) simply calls
              the psionic pcc at the bottom (rsrd_psionics.pcc).

              Ah, this might be the problem. Someone added these lines at the bottom
              of the rsrd_psionics.pcc files.

              # Stuff from the main RSRD that needs to be loaded for no error reports.
              FEAT:@/d20ogl/srd35/rsrd_feats_hidden.lst
              CLASS:@/d20ogl/srd35/rsrd_classes_monsters.lst

              pcc files don't like it when you double load and those lines are also
              in rsrd.pcc. Rather than calling rsrd_psionics.pcc perhaps the
              appropriate lines should be imported into rsrd.pcc.
            Your message has been successfully submitted and would be delivered to recipients shortly.