Loading ...
Sorry, an error occurred while loading the content.

Psicrystal / Resolved error "Could not find class: Construct"

Expand Messages
  • skipaugur
    Hi all - thanks for your guidance on creating a psicrystal. But, when I pick a Psicrystal, Resolved, I get a string of Warning: Could not find class:
    Message 1 of 7 , Aug 24 12:56 PM
    • 0 Attachment
      Hi all - thanks for your guidance on creating a psicrystal.

      But, when I pick a Psicrystal, Resolved, I get a string of "Warning:
      Could not find class: Construct" popups. Seems like it came up about
      20 times, and then the tab opened and looked OK. I get it when I
      reload the save "follower" though.

      There was also output in the Java "DOS Box" if that helps:

      C:\Program Files\PCGen\PCGen580>java -jar pcgen.jar
      addButton:race: Psicrystal (Resolved) -> Psicrystal
      Error: No EquipSet selected for output
      Error: No EquipSet selected for output
      Exception in thread "Thread-87" java.util.ConcurrentModificationException
      at java.util.AbstractList$Itr.checkForComodification(Unknown
      Source)
      at java.util.AbstractList$Itr.next(Unknown Source)
      at
      pcgen.core.PlayerCharacter.removeExcessSkills(PlayerCharacter.java:14
      077)
      at
      pcgen.core.PlayerCharacter.populateSkills(PlayerCharacter.java:9906)
      at
      plugin.charactersheet.gui.SkillsPane.refresh(SkillsPane.java:313)
      at
      plugin.charactersheet.gui.Page1Panel.refresh(Page1Panel.java:220)
      at
      plugin.charactersheet.gui.CharacterPanel$Refresher.refresh(CharacterP
      anel.java:494)
      at
      plugin.charactersheet.gui.CharacterPanel$Refresher.run(CharacterPanel
      .java:479)
    • skipaugur
      Hi all - I just realized that having the word Resolved in my original message title might imply that the problem is resolved. It is not resolved, I still get
      Message 2 of 7 , Aug 31 8:48 AM
      • 0 Attachment
        Hi all - I just realized that having the word "Resolved" in my
        original message title might imply that the problem is resolved. It is
        not resolved, I still get it. The word "Resolved" wan there because I
        was picking the "Resolved" type of crystal. I still get the "Could not
        find class: Construct" error every time I load the Crystal.

        I do see some other errors relating to equipment sets. Am I supposed
        to pick an equipment set before picking a "follower"?

        --- In pcgen@yahoogroups.com, "skipaugur" <WBA@a...> wrote:
        > Hi all - thanks for your guidance on creating a psicrystal.
        >
        > But, when I pick a Psicrystal, Resolved, I get a string of "Warning:
        > Could not find class: Construct" popups. Seems like it came up about
        > 20 times, and then the tab opened and looked OK. I get it when I
        > reload the save "follower" though.
        >
        > There was also output in the Java "DOS Box" if that helps:
        >
        > C:\Program Files\PCGen\PCGen580>java -jar pcgen.jar
        > addButton:race: Psicrystal (Resolved) -> Psicrystal
        > Error: No EquipSet selected for output
        > Error: No EquipSet selected for output
        > Exception in thread "Thread-87"
        java.util.ConcurrentModificationException
        > at java.util.AbstractList$Itr.checkForComodification(Unknown
        > Source)
        > at java.util.AbstractList$Itr.next(Unknown Source)
        > at
        > pcgen.core.PlayerCharacter.removeExcessSkills(PlayerCharacter.java:14
        > 077)
        > at
        > pcgen.core.PlayerCharacter.populateSkills(PlayerCharacter.java:9906)
        > at
        > plugin.charactersheet.gui.SkillsPane.refresh(SkillsPane.java:313)
        > at
        > plugin.charactersheet.gui.Page1Panel.refresh(Page1Panel.java:220)
        > at
        > plugin.charactersheet.gui.CharacterPanel$Refresher.refresh(CharacterP
        > anel.java:494)
        > at
        > plugin.charactersheet.gui.CharacterPanel$Refresher.run(CharacterPanel
        > .java:479)
      • Kevin Brown
        ... I would think that the Construct class would be part of the monster manual data (or the part of the RSRD that covers the monsters). So if you don t have
        Message 3 of 7 , Aug 31 8:54 AM
        • 0 Attachment
          > Hi all - I just realized that having the word "Resolved" in my
          > original message title might imply that the problem is resolved. It
          > is not resolved, I still get it. The word "Resolved" wan there
          > because I was picking the "Resolved" type of crystal. I still get the
          > "Could not find class: Construct" error every time I load the
          > Crystal.

          I would think that the Construct class would be part of the monster
          manual data (or the part of the RSRD that covers the monsters). So if
          you don't have the full RSRD dataset loaded then it might be missing
          because of that.

          > I do see some other errors relating to equipment sets. Am I supposed
          > to pick an equipment set before picking a "follower"?

          shouldn't need to set up equipsets before picking a follower.
        • skipaugur
          My normally loaded sets are 3.5 RSRD Complete plus 3.5 RSRD Psionics . I also loaded the 3.5 RSRD Monsters but it didn t make any difference. It s odd
          Message 4 of 7 , Sep 1, 2005
          • 0 Attachment
            My normally loaded sets are "3.5 RSRD Complete" plus "3.5 RSRD
            Psionics". I also loaded the "3.5 RSRD Monsters" but it didn't make
            any difference. It's odd that I get the error about 15 times but
            everythings still looks OK... The "Source" for the crystal says "RSRD
            Psionics, PsionicMonsters.rtf".

            --- In pcgen@yahoogroups.com, "Kevin Brown" <kevin_brown@q...> wrote:
            > > Hi all - I just realized that having the word "Resolved" in my
            > > original message title might imply that the problem is resolved. It
            > > is not resolved, I still get it. The word "Resolved" wan there
            > > because I was picking the "Resolved" type of crystal. I still get the
            > > "Could not find class: Construct" error every time I load the
            > > Crystal.
            >
            > I would think that the Construct class would be part of the monster
            > manual data (or the part of the RSRD that covers the monsters). So if
            > you don't have the full RSRD dataset loaded then it might be missing
            > because of that.
            >
            > > I do see some other errors relating to equipment sets. Am I supposed
            > > to pick an equipment set before picking a "follower"?
            >
            > shouldn't need to set up equipsets before picking a follower.
          • thoron-tir-gwaith@lycos.com
            RSRD Complete, plus the subsets? Ok, that will cause some weirdness. Couple Q s: Have you tried this with only the RSRD Complete loaded? Have you tried this
            Message 5 of 7 , Sep 1, 2005
            • 0 Attachment
              RSRD Complete, plus the subsets? Ok, that will cause some weirdness.

              Couple Q's:

              Have you tried this with only the RSRD Complete loaded?

              Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?

              Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD Monsters" loaded?

              I'm curious as to the results you are getting with those three conditions. That will help me figure out what calls are getting missed.

              Tir Gwaith
              LST Chimp

              > My normally loaded sets are "3.5 RSRD Complete" plus "3.5 RSRD
              > Psionics". I also loaded the "3.5 RSRD Monsters" but it didn't make
              > any difference. It's odd that I get the error about 15 times but
              > everythings still looks OK... The "Source" for the crystal says "RSRD
              > Psionics, PsionicMonsters.rtf".
            • skipaugur
              ... That may be my bad , as I thought I needed to load the Psionic package seperately, from back in the day when it was a separate set of files. At this
              Message 6 of 7 , Sep 2, 2005
              • 0 Attachment
                > RSRD Complete, plus the subsets? Ok, that will cause some weirdness.

                That may be "my bad", as I thought I needed to load the Psionic
                package seperately, from "back in the day" when it was a separate set
                of files. At this point, whenever I load my character, the RSRD
                Psionics gets automatically loaded. So I did the tests on a minimal
                new character witha 12 int, Chaotic Nuetral Human Egoist with
                PsiCrystal Affinity and random class skills.

                > Have you tried this with only the RSRD Complete loaded?

                Yes, I do get the error with "RSRD Complete"

                > Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?

                This does NOT give the error.

                >
                > Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD
                Monsters" loaded?

                This does NOT give the error.


                --- In pcgen@yahoogroups.com, thoron-tir-gwaith@l... wrote:
                > RSRD Complete, plus the subsets? Ok, that will cause some weirdness.
                >
                > Couple Q's:
                >
                > Have you tried this with only the RSRD Complete loaded?
                >
                > Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?
                >
                > Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD
                Monsters" loaded?
                >
                > I'm curious as to the results you are getting with those three
                conditions. That will help me figure out what calls are getting missed.
                >
                > Tir Gwaith
                > LST Chimp
                >
                > > My normally loaded sets are "3.5 RSRD Complete" plus "3.5 RSRD
                > > Psionics". I also loaded the "3.5 RSRD Monsters" but it didn't make
                > > any difference. It's odd that I get the error about 15 times but
                > > everythings still looks OK... The "Source" for the crystal says "RSRD
                > > Psionics, PsionicMonsters.rtf".
              • taluroniscandar
                ... That s strange. I checked the pcc files and the RSRD Complete (rsrd.pcc) simply calls the psionic pcc at the bottom (rsrd_psionics.pcc). Ah, this might be
                Message 7 of 7 , Sep 2, 2005
                • 0 Attachment
                  >
                  > > Have you tried this with only the RSRD Complete loaded?
                  >
                  > Yes, I do get the error with "RSRD Complete"
                  >
                  > > Have you tried this with "RSRD Basic" and "RSRD Psionics" only loaded?
                  >
                  > This does NOT give the error.
                  >
                  > >
                  > > Have you tried this with "RSRD Basic", "RSRD Psionics" and "RSRD
                  > Monsters" loaded?
                  >
                  > This does NOT give the error.
                  >

                  That's strange.
                  I checked the pcc files and the RSRD Complete (rsrd.pcc) simply calls
                  the psionic pcc at the bottom (rsrd_psionics.pcc).

                  Ah, this might be the problem. Someone added these lines at the bottom
                  of the rsrd_psionics.pcc files.

                  # Stuff from the main RSRD that needs to be loaded for no error reports.
                  FEAT:@/d20ogl/srd35/rsrd_feats_hidden.lst
                  CLASS:@/d20ogl/srd35/rsrd_classes_monsters.lst

                  pcc files don't like it when you double load and those lines are also
                  in rsrd.pcc. Rather than calling rsrd_psionics.pcc perhaps the
                  appropriate lines should be imported into rsrd.pcc.
                Your message has been successfully submitted and would be delivered to recipients shortly.