Loading ...
Sorry, an error occurred while loading the content.

error loading d20modern

Expand Messages
  • saeradon
    After a fresh install of java 1.42_5 and pcgen 5.7.6 I can t load the d20 modern files. When i load modern or modern without FX I get a popup saying: Unable to
    Message 1 of 7 , Sep 29, 2004
    • 0 Attachment
      After a fresh install of java 1.42_5 and pcgen 5.7.6 I can't load the
      d20 modern files.

      When i load modern or modern without FX I get a popup saying:

      Unable to parse a prerequisite: Can not parse 'PREALIGN:4': 4

      Have others noticed this? 3.0 works.

      greetings
      Jos
    • Eddy Anthony
      ... Confirmed. The problem is in the msrd_templates_creature.lst file. The Animal template has a PREALIGN tag in it. If you remove it that will fix things. A
      Message 2 of 7 , Sep 29, 2004
      • 0 Attachment
        On 9/29/04 9:30 AM, "saeradon" <saeradon@...> wrote:

        > After a fresh install of java 1.42_5 and pcgen 5.7.6 I can't load the
        > d20 modern files.
        >
        > When i load modern or modern without FX I get a popup saying:
        >
        > Unable to parse a prerequisite: Can not parse 'PREALIGN:4': 4
        >
        > Have others noticed this? 3.0 works.
        >
        > greetings
        > Jos

        Confirmed. The problem is in the msrd_templates_creature.lst file. The
        Animal template has a PREALIGN tag in it. If you remove it that will fix
        things.

        A second problem I noticed is that we have a lot of duplicate classes in the
        msrd_classes_advanced.lst file. These were transferred to another file but
        the file was not removed. Later the .pcc reference was re-added when it did
        not need to be.

        You should go into the .pcc file and comment out the reference to this file.
        --
        ~ Eddy Anthony (MoSaT)
        ~ PCGen Content Silverback
      • Eddy Anthony
        I was told for the PREALIGN tag update that if no Alignments are defined in the gamemode then PREALIGN should return true. This seems to indicate that this is
        Message 3 of 7 , Sep 29, 2004
        • 0 Attachment
          I was told for the PREALIGN tag update that if no Alignments are defined in
          the gamemode then PREALIGN should return true. This seems to indicate that
          this is not the case as the PREALIGN tag is preventing the source from
          loading altogether.

          On 9/29/04 9:54 AM, "Eddy Anthony" <eddyba@...> wrote:

          > On 9/29/04 9:30 AM, "saeradon" <saeradon@...> wrote:
          >
          >> After a fresh install of java 1.42_5 and pcgen 5.7.6 I can't load the
          >> d20 modern files.
          >>
          >> When i load modern or modern without FX I get a popup saying:
          >>
          >> Unable to parse a prerequisite: Can not parse 'PREALIGN:4': 4
          >>
          >> Have others noticed this? 3.0 works.
          >>
          >> greetings
          >> Jos
          >
          > Confirmed. The problem is in the msrd_templates_creature.lst file. The
          > Animal template has a PREALIGN tag in it. If you remove it that will fix
          > things.
          >
          > A second problem I noticed is that we have a lot of duplicate classes in the
          > msrd_classes_advanced.lst file. These were transferred to another file but
          > the file was not removed. Later the .pcc reference was re-added when it did
          > not need to be.
          >
          > You should go into the .pcc file and comment out the reference to this file.

          --
          ~ Eddy Anthony (MoSaT)
          ~ PCGen Content Silverback
        • Paul W. King
          [ 1037556 ] Modern and PREALIGN http://sourceforge.net/tracker/index.php?func=detail&aid=1037556&group_id=25 576&atid=384719 Paul W. King TM SB, OGL/PL Chimp,
          Message 4 of 7 , Sep 30, 2004
          • 0 Attachment
            [ 1037556 ] Modern and PREALIGN
            http://sourceforge.net/tracker/index.php?func=detail&aid=1037556&group_id=25
            576&atid=384719

            Paul W. King
            TM SB, OGL/PL Chimp, Data Tamarin, BoD
          • Paul W. King
            [ 1037561 ] [MSRD] Animal template has PREALIGN tag http://sourceforge.net/tracker/index.php?func=detail&aid=1037561&group_id=36 698&atid=417816
            Message 5 of 7 , Sep 30, 2004
            • 0 Attachment
              [ 1037561 ] [MSRD] Animal template has PREALIGN tag
              http://sourceforge.net/tracker/index.php?func=detail&aid=1037561&group_id=36
              698&atid=417816
            • saeradon
              I removed the animal entry from the msrd_templates_creature.lst file, commented the other file, and everything loads now. But after I have done this, the
              Message 6 of 7 , Oct 1, 2004
              • 0 Attachment
                I removed the animal entry from the msrd_templates_creature.lst file,
                commented the other file, and everything loads now.

                But after I have done this, the "create a new character" icon stays
                disbled. Altough the source material screen clearly states that the
                files are loaded.

                Just to test thing I switched game mode to 3.5 and there I can createa
                new character, the button (and menu option) is only disabled under d20
                modern mode.

                Is this because I deleted the animal template?

                greetings
                Jos

                > Confirmed. The problem is in the msrd_templates_creature.lst file. The
                > Animal template has a PREALIGN tag in it. If you remove it that will fix
                > things.
                >
                > A second problem I noticed is that we have a lot of duplicate
                classes in the
                > msrd_classes_advanced.lst file. These were transferred to another
                file but
                > the file was not removed. Later the .pcc reference was re-added when
                it did
                > not need to be.
                >
                > You should go into the .pcc file and comment out the reference to
                this file.
                > --
                > ~ Eddy Anthony (MoSaT)
                > ~ PCGen Content Silverback
              • Paul W. King
                All I did was remove the PREALIGN tag and I can create new character with no problem. Try putting the line back in, sans the PREALIGN tag, and see what
                Message 7 of 7 , Oct 2, 2004
                • 0 Attachment
                  All I did was remove the PREALIGN tag and I can create new character with no
                  problem. Try putting the line back in, sans the PREALIGN tag, and see what
                  happens.

                  Paul W. King
                  TM SB, OGL/PL Chimp, Data Tamarin, BoD
                Your message has been successfully submitted and would be delivered to recipients shortly.