Loading ...
Sorry, an error occurred while loading the content.

[BUG] Different "No Magic Items" bug, and temporary workarounds

Expand Messages
  • Nick Meredith
    I am getting the porevious No Magic Items bug, but am also getting a secondary (and possibly linked) bug when attempting to create custom items (largely to
    Message 1 of 3 , Mar 1 11:03 AM
    • 0 Attachment
      I am getting the porevious "No Magic Items" bug, but am also getting
      a secondary (and possibly linked) bug when attempting to create
      custom items (largely to get around the first No Magic Items bug).


      3.5e
      Java 1.4.1_01


      When I select a masterworked standard item,such as a weapon or a
      shield, to produce a custom item, the initial list does not include
      enhancement bonuses (+1 etc.). I am already selecting Masterworked
      items, so these should appear.


      If I then select "Add Type" and then immediately [Close] without
      adding a type, the list populates correctly, and includes the
      enhancvements to weapon or ammunition bonuses.


      Howeever, if I start with a non-masterworked item, and add masterwork
      from the list, the list also correctly populates witht he
      enhancements.


      So - the problem appears to be that items auto-generated with
      masterwork are not correctly populating with a list of enhancement
      bonuses when the "Create Custom Item" option is first selected.
    • jackalnz01
      Yes, I ve noticed that as well, but figured one thing at a time. ... getting ... masterwork
      Message 2 of 3 , Mar 1 11:18 AM
      • 0 Attachment
        Yes, I've noticed that as well, but figured one thing at a time.

        --- In pcgen@yahoogroups.com, "Nick Meredith" <nick@m...> wrote:
        > I am getting the porevious "No Magic Items" bug, but am also
        getting
        > a secondary (and possibly linked) bug when attempting to create
        > custom items (largely to get around the first No Magic Items bug).
        >
        >
        > 3.5e
        > Java 1.4.1_01
        >
        >
        > When I select a masterworked standard item,such as a weapon or a
        > shield, to produce a custom item, the initial list does not include
        > enhancement bonuses (+1 etc.). I am already selecting Masterworked
        > items, so these should appear.
        >
        >
        > If I then select "Add Type" and then immediately [Close] without
        > adding a type, the list populates correctly, and includes the
        > enhancvements to weapon or ammunition bonuses.
        >
        >
        > Howeever, if I start with a non-masterworked item, and add
        masterwork
        > from the list, the list also correctly populates witht he
        > enhancements.
        >
        >
        > So - the problem appears to be that items auto-generated with
        > masterwork are not correctly populating with a list of enhancement
        > bonuses when the "Create Custom Item" option is first selected.
      • tcowan20
        Can some one in the know look at the order of the list populates? If the list starts with adding Magic then masterwork to items... ... include ... Masterworked
        Message 3 of 3 , Mar 1 2:37 PM
        • 0 Attachment
          Can some one in the know look at the order of the list populates?
          If the list starts with adding Magic then masterwork to items...
          --- In pcgen@yahoogroups.com, "jackalnz01" <davidrowe@p...> wrote:
          > Yes, I've noticed that as well, but figured one thing at a time.
          >
          > --- In pcgen@yahoogroups.com, "Nick Meredith" <nick@m...> wrote:
          > > I am getting the porevious "No Magic Items" bug, but am also
          > getting
          > > a secondary (and possibly linked) bug when attempting to create
          > > custom items (largely to get around the first No Magic Items bug).
          > >
          > >
          > > 3.5e
          > > Java 1.4.1_01
          > >
          > >
          > > When I select a masterworked standard item,such as a weapon or a
          > > shield, to produce a custom item, the initial list does not
          include
          > > enhancement bonuses (+1 etc.). I am already selecting
          Masterworked
          > > items, so these should appear.
          > >
          > >
          > > If I then select "Add Type" and then immediately [Close] without
          > > adding a type, the list populates correctly, and includes the
          > > enhancvements to weapon or ammunition bonuses.
          > >
          > >
          > > Howeever, if I start with a non-masterworked item, and add
          > masterwork
          > > from the list, the list also correctly populates witht he
          > > enhancements.
          > >
          > >
          > > So - the problem appears to be that items auto-generated with
          > > masterwork are not correctly populating with a list of
          enhancement
          > > bonuses when the "Create Custom Item" option is first selected.
        Your message has been successfully submitted and would be delivered to recipients shortly.