Loading ...
Sorry, an error occurred while loading the content.

RSRD v18 - equipmod

Expand Messages
  • Seb
    Customizing weapon is MUCH better : magic (enhancement) bonus is now working. Unfortunately, I am still unable to add the Bane property (which is in the
    Message 1 of 13 , Sep 26, 2003
    • 0 Attachment
      Customizing weapon is MUCH better : magic (enhancement) bonus is now
      working. Unfortunately, I am still unable to add the 'Bane' property
      (which is in the rsrdequipmods.lst file but not in the customizing
      window). (tested with 5.3.10)

      Seb
    • Barak
      Maybe a silly question, but since I don t know your level of knowledge on PCGen.DnD, I ll ask anyway. Have you added at least +1 to the weapon? That s a
      Message 2 of 13 , Sep 26, 2003
      • 0 Attachment
        Maybe a silly question, but since I don't know your level of knowledge
        on PCGen.DnD, I'll ask anyway. Have you added at least +1 to the
        weapon? That's a prereq for any of the other enhancements.

        Barak
        ~PCGen BoD
        ~OS Silverback


        > -----Original Message-----
        > From: Seb [mailto:sebastien.peslin@...]
        >
        > Customizing weapon is MUCH better : magic (enhancement) bonus is now
        > working. Unfortunately, I am still unable to add the 'Bane' property
        > (which is in the rsrdequipmods.lst file but not in the customizing
        > window). (tested with 5.3.10)
        >
        > Seb
      • Seb
        Yes. Bane is not present in the list of properties (it should be present but red before adding enhancement bonuses). I tried again in rsrd v20, it is still
        Message 3 of 13 , Sep 27, 2003
        • 0 Attachment
          Yes. "Bane" is not present in the list of properties (it should be
          present but red before adding enhancement bonuses).
          I tried again in rsrd v20, it is still not working.

          Tir seems to know about this problem :
          http://groups.yahoo.com/group/pcgen/message/67058
          It looks like the same issue.

          Seb

          --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
          > Maybe a silly question, but since I don't know your level of
          knowledge
          > on PCGen.DnD, I'll ask anyway. Have you added at least +1 to the
          > weapon? That's a prereq for any of the other enhancements.
          >
          > Barak
          > ~PCGen BoD
          > ~OS Silverback
          >
          >
          > > -----Original Message-----
          > > From: Seb [mailto:sebastien.peslin@c...]
          > >
          > > Customizing weapon is MUCH better : magic (enhancement) bonus is
          now
          > > working. Unfortunately, I am still unable to add the 'Bane'
          property
          > > (which is in the rsrdequipmods.lst file but not in the
          customizing
          > > window). (tested with 5.3.10)
          > >
          > > Seb
        • Barak
          It s because there are two of them and no KEY defined. I don t understand why they have one for Weapons and one for Ranged... A ranged weapon is a weapon
          Message 4 of 13 , Sep 27, 2003
          • 0 Attachment
            It's because there are two of them and no KEY defined. I don't
            understand why they have one for Weapons and one for Ranged... A ranged
            weapon is a weapon after all.

            For the short term, I'd delete all the duplicates that had TYPE:Ranged
            in them. Or you could go ahead and create unique keys for them.

            ...

            Ok, I made changes and uploaded them to the file group. All the mods
            should show up now.

            Tir/Doug, wasn;t sure why the dupes for weapon and ranged, so I just
            nuked the ranged ones. Include or not as you see fit (but you might
            want to at least swipe the keys I did enter for those that needed it :)
            ).

            Barak
            ~PCGen BoD
            ~OS Silverback


            > -----Original Message-----
            > From: Seb [mailto:sebastien.peslin@...]
            > Sent: Saturday, September 27, 2003 4:25 PM
            > To: pcgen@yahoogroups.com
            > Subject: [pcgen] Re: RSRD v18 - equipmod
            >
            >
            > Yes. "Bane" is not present in the list of properties (it should be
            > present but red before adding enhancement bonuses).
            > I tried again in rsrd v20, it is still not working.
            >
            > Tir seems to know about this problem :
            > http://groups.yahoo.com/group/pcgen/message/67058
            > It looks like the same issue.
            >
            > Seb
            >
            > --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
            > > Maybe a silly question, but since I don't know your level of
            > knowledge
            > > on PCGen.DnD, I'll ask anyway. Have you added at least +1 to the
            > > weapon? That's a prereq for any of the other enhancements.
            > >
            > > Barak
            > > ~PCGen BoD
            > > ~OS Silverback
            > >
            > >
            > > > -----Original Message-----
            > > > From: Seb [mailto:sebastien.peslin@c...]
            > > >
            > > > Customizing weapon is MUCH better : magic (enhancement) bonus is
            > now
            > > > working. Unfortunately, I am still unable to add the 'Bane'
            > property
            > > > (which is in the rsrdequipmods.lst file but not in the
            > customizing
            > > > window). (tested with 5.3.10)
            > > >
            > > > Seb
            >
            >
            > ------------------------ Yahoo! Groups Sponsor
            > ---------------------~--> Buy Ink Cartridges or Refill Kits
            > for your HP, Epson, Canon or Lexmark Printer at MyInks.com.
            > Free s/h on orders $50 or more to the US & Canada.
            http://www.c1tracking.com/l.asp?cid=5511
            http://us.click.yahoo.com/mOAaAA/3exGAA/qnsNAA/9rHolB/TM
            ---------------------------------------------------------------------~->

            PCGen's release site: http://pcgen.sourceforge.net
            PCGen's alpha build: http://rpg.plambert.net/pcgen
            PCGen's FAQ:
            http://rpg.plambert.net/pcgen/current/_docs/
            To unsubscribe from this group, send an email to:
            pcgen-unsubscribe@egroups.com

            Your use of Yahoo! Groups is subject to
            http://docs.yahoo.com/info/terms/
          • Seb
            Nearly fixed ! Bane is now in the list but can t be taken as MagicalEnhancement prereq stays red even after adding Masterwork and +2 . Seb ... ranged ...
            Message 5 of 13 , Sep 27, 2003
            • 0 Attachment
              Nearly fixed !

              Bane is now in the list but can't be taken as MagicalEnhancement
              prereq stays red even after adding Masterwork and '+2'.

              Seb

              --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
              > It's because there are two of them and no KEY defined. I don't
              > understand why they have one for Weapons and one for Ranged... A
              ranged
              > weapon is a weapon after all.
              >
              > For the short term, I'd delete all the duplicates that had
              TYPE:Ranged
              > in them. Or you could go ahead and create unique keys for them.
              >
              > ...
              >
              > Ok, I made changes and uploaded them to the file group. All the
              mods
              > should show up now.
              >
              > Tir/Doug, wasn;t sure why the dupes for weapon and ranged, so I
              just
              > nuked the ranged ones. Include or not as you see fit (but you
              might
              > want to at least swipe the keys I did enter for those that needed
              it :)
              > ).
              >
              > Barak
              > ~PCGen BoD
              > ~OS Silverback
              >
              >
              > > -----Original Message-----
              > > From: Seb [mailto:sebastien.peslin@c...]
              > > Sent: Saturday, September 27, 2003 4:25 PM
              > > To: pcgen@yahoogroups.com
              > > Subject: [pcgen] Re: RSRD v18 - equipmod
              > >
              > >
              > > Yes. "Bane" is not present in the list of properties (it should
              be
              > > present but red before adding enhancement bonuses).
              > > I tried again in rsrd v20, it is still not working.
              > >
              > > Tir seems to know about this problem :
              > > http://groups.yahoo.com/group/pcgen/message/67058
              > > It looks like the same issue.
              > >
              > > Seb
              > >
              > > --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
              > > > Maybe a silly question, but since I don't know your level of
              > > knowledge
              > > > on PCGen.DnD, I'll ask anyway. Have you added at least +1 to
              the
              > > > weapon? That's a prereq for any of the other enhancements.
              > > >
              > > > Barak
              > > > ~PCGen BoD
              > > > ~OS Silverback
              > > >
              > > >
              > > > > -----Original Message-----
              > > > > From: Seb [mailto:sebastien.peslin@c...]
              > > > >
              > > > > Customizing weapon is MUCH better : magic (enhancement)
              bonus is
              > > now
              > > > > working. Unfortunately, I am still unable to add the 'Bane'
              > > property
              > > > > (which is in the rsrdequipmods.lst file but not in the
              > > customizing
              > > > > window). (tested with 5.3.10)
              > > > >
              > > > > Seb
              > >
              > >
              > > ------------------------ Yahoo! Groups Sponsor
              > > ---------------------~--> Buy Ink Cartridges or Refill Kits
              > > for your HP, Epson, Canon or Lexmark Printer at MyInks.com.
              > > Free s/h on orders $50 or more to the US & Canada.
              > http://www.c1tracking.com/l.asp?cid=5511
              > http://us.click.yahoo.com/mOAaAA/3exGAA/qnsNAA/9rHolB/TM
              > -------------------------------------------------------------------
              --~->
              >
              > PCGen's release site: http://pcgen.sourceforge.net
              > PCGen's alpha build: http://rpg.plambert.net/pcgen
              > PCGen's FAQ:
              > http://rpg.plambert.net/pcgen/current/_docs/
              > To unsubscribe from this group, send an email to:
              > pcgen-unsubscribe@egroups.com
              >
              > Your use of Yahoo! Groups is subject to
              > http://docs.yahoo.com/info/terms/
            • Barak
              Drat. Ok, change all the PRETYPE:MagicalEnhancement bits to PRETYPE:EQMODTYPE=MagicalEnhancement Or download the file I just uploaded. :p Barak ~PCGen BoD
              Message 6 of 13 , Sep 27, 2003
              • 0 Attachment
                Drat.

                Ok, change all the "PRETYPE:MagicalEnhancement" bits to
                "PRETYPE:EQMODTYPE=MagicalEnhancement"

                Or download the file I just uploaded. :p

                Barak
                ~PCGen BoD
                ~OS Silverback


                > -----Original Message-----
                > From: Seb [mailto:sebastien.peslin@...]
                >
                > Nearly fixed !
                >
                > Bane is now in the list but can't be taken as MagicalEnhancement
                > prereq stays red even after adding Masterwork and '+2'.
                >
                > Seb
                >
              • Seb
                Now it is working. Small remaining display issue : description says +2 attack bonus and does +2d6 bonus damage vs. %CHOICE on the OS. %CHOICE should be
                Message 7 of 13 , Sep 28, 2003
                • 0 Attachment
                  Now it is working.

                  Small remaining display issue : description says "+2 attack bonus
                  and does +2d6 bonus damage vs. %CHOICE" on the OS. %CHOICE should be
                  replaced by the selection. Name seems ok : "*Longsword +2 (Bane
                  (Giants))".

                  Seb

                  --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
                  > Drat.
                  >
                  > Ok, change all the "PRETYPE:MagicalEnhancement" bits to
                  > "PRETYPE:EQMODTYPE=MagicalEnhancement"
                  >
                  > Or download the file I just uploaded. :p
                  >
                  > Barak
                  > ~PCGen BoD
                  > ~OS Silverback
                  >
                  >
                  > > -----Original Message-----
                  > > From: Seb [mailto:sebastien.peslin@c...]
                  > >
                  > > Nearly fixed !
                  > >
                  > > Bane is now in the list but can't be taken as MagicalEnhancement
                  > > prereq stays red even after adding Masterwork and '+2'.
                  > >
                  > > Seb
                  > >
                • taluroniscandar
                  ... If no else has mentioned this, the %CHOICE in the ranger SA print-out for favored wenemies does the same thing. I ve compared it to the write up for the
                  Message 8 of 13 , Sep 29, 2003
                  • 0 Attachment
                    > Small remaining display issue : description says "+2 attack bonus
                    > and does +2d6 bonus damage vs. %CHOICE" on the OS. %CHOICE should be
                    > replaced by the selection. Name seems ok : "*Longsword +2 (Bane
                    > (Giants))".
                    >
                    If no else has mentioned this, the %CHOICE in the ranger SA print-out
                    for favored wenemies does the same thing. I've compared it to the
                    write up for the srd ranger and changed around the SA: tag trying to
                    get it to work. The best I could do was to get the bonus value (+2,
                    +4, etc) to print out. I tried simply copying the SA line from the srd
                    Ranger (which print out correctly and it still didn't print the
                    %CHOICE right on the OS.

                    There is some issue with %CHOICE in the rsrd lst files printing out on
                    the OS's.
                  • Felipe F. Diniz
                    ... be ... out ... srd ... on ... How does it show on the Abilities tab? The OSes just repeat what s in there... Felipe - OS & Code Gibbon
                    Message 9 of 13 , Sep 29, 2003
                    • 0 Attachment
                      --- In pcgen@yahoogroups.com, "taluroniscandar" <mhgj@e...> wrote:
                      > > Small remaining display issue : description says "+2 attack bonus
                      > > and does +2d6 bonus damage vs. %CHOICE" on the OS. %CHOICE should
                      be
                      > > replaced by the selection. Name seems ok : "*Longsword +2 (Bane
                      > > (Giants))".
                      > >
                      > If no else has mentioned this, the %CHOICE in the ranger SA print-
                      out
                      > for favored wenemies does the same thing. I've compared it to the
                      > write up for the srd ranger and changed around the SA: tag trying to
                      > get it to work. The best I could do was to get the bonus value (+2,
                      > +4, etc) to print out. I tried simply copying the SA line from the
                      srd
                      > Ranger (which print out correctly and it still didn't print the
                      > %CHOICE right on the OS.
                      >
                      > There is some issue with %CHOICE in the rsrd lst files printing out
                      on
                      > the OS's.

                      How does it show on the Abilities tab? The OSes just repeat what's in
                      there...


                      Felipe
                      - OS & Code Gibbon
                    • taluroniscandar
                      ... Hm, tried my Ranger in 5.3.10 with RSRDv20 and it prints correctly. Don t know about the Bane weapon. Don t have one.
                      Message 10 of 13 , Sep 30, 2003
                      • 0 Attachment
                        --- In pcgen@yahoogroups.com, "Felipe F. Diniz" <fdiniz@i...> wrote:
                        > --- In pcgen@yahoogroups.com, "taluroniscandar" <mhgj@e...> wrote:
                        > > > Small remaining display issue : description says "+2 attack bonus
                        > > > and does +2d6 bonus damage vs. %CHOICE" on the OS. %CHOICE should
                        > be
                        > > > replaced by the selection. Name seems ok : "*Longsword +2 (Bane
                        > > > (Giants))".
                        > > >
                        > > If no else has mentioned this, the %CHOICE in the ranger SA print-
                        > out
                        > > for favored wenemies does the same thing. I've compared it to the
                        > > write up for the srd ranger and changed around the SA: tag trying to
                        > > get it to work. The best I could do was to get the bonus value (+2,
                        > > +4, etc) to print out. I tried simply copying the SA line from the
                        > srd
                        > > Ranger (which print out correctly and it still didn't print the
                        > > %CHOICE right on the OS.
                        > >
                        > > There is some issue with %CHOICE in the rsrd lst files printing out
                        > on
                        > > the OS's.
                        >
                        > How does it show on the Abilities tab? The OSes just repeat what's in
                        > there...
                        >
                        Hm, tried my Ranger in 5.3.10 with RSRDv20 and it prints correctly.

                        Don't know about the Bane weapon. Don't have one.
                      • Seb
                        The problem is not completly solved in the new rsrdequipmods.lst : a number of modifiers (like skill bonus) needs to have :
                        Message 11 of 13 , Oct 2, 2003
                        • 0 Attachment
                          The problem is not completly solved in the new rsrdequipmods.lst :
                          a number of modifiers (like skill bonus) needs to have :
                          'PRETYPE:EQMODTYPE=MagicalEnhancement,Armor|MagicalEnhancement,Shield
                          |etc...'
                          changed into
                          'PRETYPE:EQMODTYPE=MagicalEnhancement,Armor|EQMODTYPE=MagicalEnhancem
                          ent,Shield|etc...'
                          (EQMODTYPE was added once where it should be added several times)

                          Seb

                          --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
                          > Drat.
                          >
                          > Ok, change all the "PRETYPE:MagicalEnhancement" bits to
                          > "PRETYPE:EQMODTYPE=MagicalEnhancement"
                          >
                          > Or download the file I just uploaded. :p
                          >
                          > Barak
                          > ~PCGen BoD
                          > ~OS Silverback
                          >
                          >
                          > > -----Original Message-----
                          > > From: Seb [mailto:sebastien.peslin@c...]
                          > >
                          > > Nearly fixed !
                          > >
                          > > Bane is now in the list but can't be taken as MagicalEnhancement
                          > > prereq stays red even after adding Masterwork and '+2'.
                          > >
                          > > Seb
                          > >
                        • Seb
                          Barak, Can you take care of it before v21 is released ? Seb ... d ... m ... MagicalEnhancement
                          Message 12 of 13 , Oct 6, 2003
                          • 0 Attachment
                            Barak,

                            Can you take care of it before v21 is released ?

                            Seb

                            --- In pcgen@yahoogroups.com, "Seb" <sebastien.peslin@c...> wrote:
                            > The problem is not completly solved in the new rsrdequipmods.lst :
                            > a number of modifiers (like skill bonus) needs to have :
                            > 'PRETYPE:EQMODTYPE=MagicalEnhancement,Armor|MagicalEnhancement,Shiel
                            d
                            > |etc...'
                            > changed into
                            > 'PRETYPE:EQMODTYPE=MagicalEnhancement,Armor|EQMODTYPE=MagicalEnhance
                            m
                            > ent,Shield|etc...'
                            > (EQMODTYPE was added once where it should be added several times)
                            >
                            > Seb
                            >
                            > --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
                            > > Drat.
                            > >
                            > > Ok, change all the "PRETYPE:MagicalEnhancement" bits to
                            > > "PRETYPE:EQMODTYPE=MagicalEnhancement"
                            > >
                            > > Or download the file I just uploaded. :p
                            > >
                            > > Barak
                            > > ~PCGen BoD
                            > > ~OS Silverback
                            > >
                            > >
                            > > > -----Original Message-----
                            > > > From: Seb [mailto:sebastien.peslin@c...]
                            > > >
                            > > > Nearly fixed !
                            > > >
                            > > > Bane is now in the list but can't be taken as
                            MagicalEnhancement
                            > > > prereq stays red even after adding Masterwork and '+2'.
                            > > >
                            > > > Seb
                            > > >
                          • Barak
                            It s done and on the yahoo group file area. Note that Tir is assembling the RSRD files and he may be taking the eqmods in a different direction when he gets
                            Message 13 of 13 , Oct 6, 2003
                            • 0 Attachment
                              It's done and on the yahoo group file area. Note that Tir is assembling
                              the RSRD files and he may be taking the eqmods in a different direction
                              when he gets some more time available to work on them.

                              What I've done is merely to keep things working in the old style for you
                              guys until the official sets are out. :)

                              Barak
                              ~PCGen BoD
                              ~OS Silverback


                              > -----Original Message-----
                              > From: Seb [mailto:sebastien.peslin@...]
                              >
                              > Barak,
                              >
                              > Can you take care of it before v21 is released ?
                              >
                              > Seb
                              >
                              > --- In pcgen@yahoogroups.com, "Seb" <sebastien.peslin@c...> wrote:
                              > > The problem is not completly solved in the new
                              > rsrdequipmods.lst : a
                              > > number of modifiers (like skill bonus) needs to have :
                              > > 'PRETYPE:EQMODTYPE=MagicalEnhancement,Armor|MagicalEnhancement,Shiel
                              > d
                              > > |etc...'
                              > > changed into
                              > > 'PRETYPE:EQMODTYPE=MagicalEnhancement,Armor|EQMODTYPE=MagicalEnhance
                              > m
                              > > ent,Shield|etc...'
                              > > (EQMODTYPE was added once where it should be added several times)
                              > >
                              > > Seb
                              > >
                              > > --- In pcgen@yahoogroups.com, "Barak" <barak@v...> wrote:
                              > > > Drat.
                              > > >
                              > > > Ok, change all the "PRETYPE:MagicalEnhancement" bits to
                              > > > "PRETYPE:EQMODTYPE=MagicalEnhancement"
                              > > >
                              > > > Or download the file I just uploaded. :p
                              > > >
                              > > > Barak
                              > > > ~PCGen BoD
                              > > > ~OS Silverback
                              > > >
                              > > >
                              > > > > -----Original Message-----
                              > > > > From: Seb [mailto:sebastien.peslin@c...]
                              > > > >
                              > > > > Nearly fixed !
                              > > > >
                              > > > > Bane is now in the list but can't be taken as
                              > MagicalEnhancement
                              > > > > prereq stays red even after adding Masterwork and '+2'.
                              > > > >
                              > > > > Seb
                              > > > >
                            Your message has been successfully submitted and would be delivered to recipients shortly.