Loading ...
Sorry, an error occurred while loading the content.

[pcgen] Re: [pcgen-output]xslt problem

Expand Messages
  • Luc Hermitte
    ... Note: I haven t checked what the xslt file actually contains. In my many months old attempt to define an xslt, I had my file start with:
    Message 1 of 14 , Mar 28, 2003
    • 0 Attachment
      * On Fri, Mar 28, 2003 at 07:42:55AM -0700, Rich Allen <rico@...> wrote:
      > ML doesn't support them. Maybe you could replace the standard
      > encoding in the XSLT with something like this:
      >
      > <?xml version="1.0" encoding="ISO-8859-1"?>
      >
      > I'm not sure if this will work in an XSLT. I know it works in
      > XML to enable latin characters (like the upside down ! and ?).

      Note: I haven't checked what the xslt file actually contains.

      In my many months old attempt to define an xslt, I had my file start
      with:
      <?xml version="1.0" ?>
      <xsl:stylesheet
      xmlns:xsl='http://www.w3.org/1999/XSL/Transform' version="1.0"
      xmlns:fo='http://www.w3.org/1999/XSL/Format'>
      <!-- <xsl:output method="xml" indent="yes" encoding="UTF-8"/> -->
      <xsl:output method="xml" indent="yes" encoding="ISO-8859-1"/>

      And the xml template had:
      <?xml version="1.0" encoding="ISO-8859-1"?>

      This way, I was able to use the French accentuated characters: é, à, è,
      etc.
      I guess something cleaner should be possible with utf-8 encoding, but I
      haven't explored this way much.

      HTH,


      --
      Luc Hermitte
    Your message has been successfully submitted and would be delivered to recipients shortly.