Loading ...
Sorry, an error occurred while loading the content.
 

RE: [pcgen] Re: Install help needed

Expand Messages
  • Stuart Updegrave
    You say you downloaded all three into the same directory. Did you actually extract them as well? What OS? Into a clean directory? If you did extract, you need
    Message 1 of 10 , Oct 1, 2002
      You say you downloaded all three into the same directory. Did you
      actually extract them as well? What OS? Into a clean directory?

      If you did extract, you need to ensure that you preserved directory
      structure in the extraction. If you didn't, none of the data files
      will be in their proper places.

      If you extracted correctly you should have the following files and
      folders in your root folder (assuming v.4.1.1):

      /characters
      /data
      /docs
      /lib
      /system
      /templates
      filter.ini
      options.ini
      pcgen.bat
      pcgen.jar
      pcgen.sh

      If you still have problems, please send as detailed repro steps as
      possible.

      > -----Original Message-----
      > From: scott_c_nolan [mailto:nolan@...]
      > Sent: Tuesday, October 01, 2002 7:21 AM
      > To: pcgen@yahoogroups.com
      > Subject: [pcgen] Re: Install help needed
      >
      >
      > Nope. I downloaded all three into the same directory. That's how I
      > was able to access the documents that clued me in to the fact that I
      > was doing something wrong...
      >
      > Please help.
      >
      > Scott
      >
      > --- In pcgen@y..., "James Dempsey" <jdempsey@a...> wrote:
      > > Hi Scott,
      > >
      > > Which of the zip files did you download? Generally it is
      recommended
      > that
      > > you get all 3 and extract them into the same directory. It sounds
      > like you
      > > might have only downloaded the first one.
      > >
      > >
      > > Cheers,
      > > -------------------------------------------
      > > James Dempsey
      > > JDempsey@a...
      > > ----- Original Message -----
      > > From: "scott_c_nolan" <nolan@e...>
      > > To: <pcgen@y...>
      > > Sent: Tuesday, October 01, 2002 5:16 PM
      > > Subject: [pcgen] Install help needed
      > >
      > >
      > > > Hi. I've just downloaded PCGen and I'm afraid I'm
      > already confused.
      > > > I've updated my Java, as suggested, and opened the
      > program. I don't
      > > > see the tree of source companies the walkthrough mentions. I
      also
      > > > note that I am supposed to "install" PCGEN, but don't see how to
      > do that.
      > > >
      > > > Clearly, this is a failure to comprehend on my part, but
      > could someone
      > > > nontheless clue me in to what I'm doing wrong? Thanks.
      > > >
      > > > Scott
      >
      >
      > ------------------------ Yahoo! Groups Sponsor
      > ---------------------~-->
      > Sell a Home for Top $
      > http://us.click.yahoo.com/RrPZMC/jTmEAA/MVfIAA/9rHolB/TM
      > --------------------------------------------------------------
      > -------~->
      >
      > PCGen's release site: http://pcgen.sourceforge.net
      > PCGen's FAQ: http://pedertest.officeline.no/PCGen
      > PCGen's alpha build: http://rpg.plambert.net/pcgen
      > To unsubscribe from this group, send an email to:
      > pcgen-unsubscribe@egroups.com
      >
      >
      >
      > Your use of Yahoo! Groups is subject to
      > http://docs.yahoo.com/info/terms/
      >
      >
      >
    • scott_c_nolan
      Well, there you have me. It seems to be a catch-22. I did this two ways, and neither worked. Let me elaborate: I am running Windows ME. Method One - 1) I
      Message 2 of 10 , Oct 1, 2002
        Well, there you have me. It seems to be a catch-22. I did this two
        ways, and neither worked. Let me elaborate:

        I am running Windows ME.

        Method One -

        1) I downloaded all three zip files into a folder called "PCGEN".
        2) I extracted all three zip files into folders with the names
        "PCGEN411_part1of3", "PCGEN411_part2of3" & "PCGEN411_part3of3".
        3) I went into "PCGEN411_part1of3", and clicked on PCGEN.jar.
        4) The program opened, but no list of sources.

        Method Two -

        1) I downloaded all three zip files into a folder called "PCGEN".
        2) I extracted all three zip files into folders with the names
        "PCGEN411_part1of3", "PCGEN411_part2of3" & "PCGEN411_part3of3".
        3) I moved the contents of all three folders into the main "PCGEN"
        folder. (In this method, I did have all the files and folders you
        mention in one folder.)
        4) I clicked on PCGen.jar, but got an error message, saying it could
        not find a file in the folder "PCGEN411_part3of3".

        So method two demonstrates that the program wants me to leave it
        spread across three folders, no?

        Now you know what I know.

        Can you offer any help?

        Thanks,

        Scott


        --- In pcgen@y..., "Stuart Updegrave" <stuart@m...> wrote:
        >
        > You say you downloaded all three into the same directory. Did you
        > actually extract them as well? What OS? Into a clean directory?
        >
        > If you did extract, you need to ensure that you preserved directory
        > structure in the extraction. If you didn't, none of the data files
        > will be in their proper places.
        >
        > If you extracted correctly you should have the following files and
        > folders in your root folder (assuming v.4.1.1):
        >
        > /characters
        > /data
        > /docs
        > /lib
        > /system
        > /templates
        > filter.ini
        > options.ini
        > pcgen.bat
        > pcgen.jar
        > pcgen.sh
        >
        > If you still have problems, please send as detailed repro steps as
        > possible.
        >
        > > -----Original Message-----
        > > From: scott_c_nolan [mailto:nolan@e...]
        > > Sent: Tuesday, October 01, 2002 7:21 AM
        > > To: pcgen@y...
        > > Subject: [pcgen] Re: Install help needed
        > >
        > >
        > > Nope. I downloaded all three into the same directory. That's how I
        > > was able to access the documents that clued me in to the fact that I
        > > was doing something wrong...
        > >
        > > Please help.
        > >
        > > Scott
        > >
        > > --- In pcgen@y..., "James Dempsey" <jdempsey@a...> wrote:
        > > > Hi Scott,
        > > >
        > > > Which of the zip files did you download? Generally it is
        > recommended
        > > that
        > > > you get all 3 and extract them into the same directory. It sounds
        > > like you
        > > > might have only downloaded the first one.
        > > >
        > > >
        > > > Cheers,
        > > > -------------------------------------------
        > > > James Dempsey
        > > > JDempsey@a...
        > > > ----- Original Message -----
        > > > From: "scott_c_nolan" <nolan@e...>
        > > > To: <pcgen@y...>
        > > > Sent: Tuesday, October 01, 2002 5:16 PM
        > > > Subject: [pcgen] Install help needed
        > > >
        > > >
        > > > > Hi. I've just downloaded PCGen and I'm afraid I'm
        > > already confused.
        > > > > I've updated my Java, as suggested, and opened the
        > > program. I don't
        > > > > see the tree of source companies the walkthrough mentions. I
        > also
        > > > > note that I am supposed to "install" PCGEN, but don't see how to
        > > do that.
        > > > >
        > > > > Clearly, this is a failure to comprehend on my part, but
        > > could someone
        > > > > nontheless clue me in to what I'm doing wrong? Thanks.
        > > > >
        > > > > Scott
        > >
        > >
        > > ------------------------ Yahoo! Groups Sponsor
        > > ---------------------~-->
        > > Sell a Home for Top $
        > > http://us.click.yahoo.com/RrPZMC/jTmEAA/MVfIAA/9rHolB/TM
        > > --------------------------------------------------------------
        > > -------~->
        > >
        > > PCGen's release site: http://pcgen.sourceforge.net
        > > PCGen's FAQ: http://pedertest.officeline.no/PCGen
        > > PCGen's alpha build: http://rpg.plambert.net/pcgen
        > > To unsubscribe from this group, send an email to:
        > > pcgen-unsubscribe@e...
        > >
        > >
        > >
        > > Your use of Yahoo! Groups is subject to
        > > http://docs.yahoo.com/info/terms/
        > >
        > >
        > >
      • Ian Dale
        Unzip each ZIP into your PCGEN directory, and it should work.... (Though moving should work as well, but maybe something got missed....) ... directory ...
        Message 3 of 10 , Oct 1, 2002
          Unzip each ZIP into your "PCGEN" directory, and it should work....
          (Though moving should work as well, but maybe something got
          missed....)

          --- In pcgen@y..., "scott_c_nolan" <nolan@e...> wrote:
          > Well, there you have me. It seems to be a catch-22. I did this two
          > ways, and neither worked. Let me elaborate:
          >
          > I am running Windows ME.
          >
          > Method One -
          >
          > 1) I downloaded all three zip files into a folder called "PCGEN".
          > 2) I extracted all three zip files into folders with the names
          > "PCGEN411_part1of3", "PCGEN411_part2of3" & "PCGEN411_part3of3".
          > 3) I went into "PCGEN411_part1of3", and clicked on PCGEN.jar.
          > 4) The program opened, but no list of sources.
          >
          > Method Two -
          >
          > 1) I downloaded all three zip files into a folder called "PCGEN".
          > 2) I extracted all three zip files into folders with the names
          > "PCGEN411_part1of3", "PCGEN411_part2of3" & "PCGEN411_part3of3".
          > 3) I moved the contents of all three folders into the main "PCGEN"
          > folder. (In this method, I did have all the files and folders you
          > mention in one folder.)
          > 4) I clicked on PCGen.jar, but got an error message, saying it could
          > not find a file in the folder "PCGEN411_part3of3".
          >
          > So method two demonstrates that the program wants me to leave it
          > spread across three folders, no?
          >
          > Now you know what I know.
          >
          > Can you offer any help?
          >
          > Thanks,
          >
          > Scott
          >
          >
          > --- In pcgen@y..., "Stuart Updegrave" <stuart@m...> wrote:
          > >
          > > You say you downloaded all three into the same directory. Did you
          > > actually extract them as well? What OS? Into a clean directory?
          > >
          > > If you did extract, you need to ensure that you preserved
          directory
          > > structure in the extraction. If you didn't, none of the data files
          > > will be in their proper places.
          > >
          > > If you extracted correctly you should have the following files and
          > > folders in your root folder (assuming v.4.1.1):
          > >
          > > /characters
          > > /data
          > > /docs
          > > /lib
          > > /system
          > > /templates
          > > filter.ini
          > > options.ini
          > > pcgen.bat
          > > pcgen.jar
          > > pcgen.sh
          > >
          > > If you still have problems, please send as detailed repro steps as
          > > possible.
          > >
          > > > -----Original Message-----
          > > > From: scott_c_nolan [mailto:nolan@e...]
          > > > Sent: Tuesday, October 01, 2002 7:21 AM
          > > > To: pcgen@y...
          > > > Subject: [pcgen] Re: Install help needed
          > > >
          > > >
          > > > Nope. I downloaded all three into the same directory. That's
          how I
          > > > was able to access the documents that clued me in to the fact
          that I
          > > > was doing something wrong...
          > > >
          > > > Please help.
          > > >
          > > > Scott
          > > >
          > > > --- In pcgen@y..., "James Dempsey" <jdempsey@a...> wrote:
          > > > > Hi Scott,
          > > > >
          > > > > Which of the zip files did you download? Generally it is
          > > recommended
          > > > that
          > > > > you get all 3 and extract them into the same directory. It
          sounds
          > > > like you
          > > > > might have only downloaded the first one.
          > > > >
          > > > >
          > > > > Cheers,
          > > > > -------------------------------------------
          > > > > James Dempsey
          > > > > JDempsey@a...
          > > > > ----- Original Message -----
          > > > > From: "scott_c_nolan" <nolan@e...>
          > > > > To: <pcgen@y...>
          > > > > Sent: Tuesday, October 01, 2002 5:16 PM
          > > > > Subject: [pcgen] Install help needed
          > > > >
          > > > >
          > > > > > Hi. I've just downloaded PCGen and I'm afraid I'm
          > > > already confused.
          > > > > > I've updated my Java, as suggested, and opened the
          > > > program. I don't
          > > > > > see the tree of source companies the walkthrough mentions.
          I
          > > also
          > > > > > note that I am supposed to "install" PCGEN, but don't see
          how to
          > > > do that.
          > > > > >
          > > > > > Clearly, this is a failure to comprehend on my part, but
          > > > could someone
          > > > > > nontheless clue me in to what I'm doing wrong? Thanks.
          > > > > >
          > > > > > Scott
          > > >
          > > >
          > > > ------------------------ Yahoo! Groups Sponsor
          > > > ---------------------~-->
          > > > Sell a Home for Top $
          > > > http://us.click.yahoo.com/RrPZMC/jTmEAA/MVfIAA/9rHolB/TM
          > > > --------------------------------------------------------------
          > > > -------~->
          > > >
          > > > PCGen's release site: http://pcgen.sourceforge.net
          > > > PCGen's FAQ: http://pedertest.officeline.no/PCGen
          > > > PCGen's alpha build: http://rpg.plambert.net/pcgen
          > > > To unsubscribe from this group, send an email to:
          > > > pcgen-unsubscribe@e...
          > > >
          > > >
          > > >
          > > > Your use of Yahoo! Groups is subject to
          > > > http://docs.yahoo.com/info/terms/
          > > >
          > > >
          > > >
        • Stuart Updegrave
          ... You should override the default extraction path at time of unzip. I personally have a /download/ directory where I store all d/l ed versions, then create
          Message 4 of 10 , Oct 1, 2002
            > From: scott_c_nolan [mailto:nolan@...]
            >
            >
            > Method One -
            >
            > 1) I downloaded all three zip files into a folder called "PCGEN".
            > 2) I extracted all three zip files into folders with the names
            > [...]
            >
            > Method Two -
            >
            > 1) I downloaded all three zip files into a folder called "PCGEN".
            > 2) I extracted all three zip files into folders with the names
            > "PCGEN411_part1of3", "PCGEN411_part2of3" & "PCGEN411_part3of3".
            > > [...]

            You should override the default extraction path at time of unzip. I
            personally have a /download/ directory where I store all d/l'ed
            versions, then create version-specific folders for extraction. Thus,
            v4.1.1 is extracted to \pcgen\4.1.1\.

            This is what works for me. Not saying it will work for you. Howerver,
            I do encourage you to extract all into the same target folder to start
            with.

            Good luck, Scott.

            cheers,
            ~stuart
          • scott_c_nolan
            Okay. Don t know -why- that worked, but it did. Thank you. Scott
            Message 5 of 10 , Oct 1, 2002
              Okay. Don't know -why- that worked, but it did. Thank you.

              Scott

              --- In pcgen@y..., "Ian Dale" <ian_dale@h...> wrote:
              > Unzip each ZIP into your "PCGEN" directory, and it should work....
              > (Though moving should work as well, but maybe something got
              > missed....)
              >
              > --- In pcgen@y..., "scott_c_nolan" <nolan@e...> wrote:
              > > Well, there you have me. It seems to be a catch-22. I did this two
              > > ways, and neither worked. Let me elaborate:
              > >
              > > I am running Windows ME.
              > >
              > > Method One -
              > >
              > > 1) I downloaded all three zip files into a folder called "PCGEN".
              > > 2) I extracted all three zip files into folders with the names
              > > "PCGEN411_part1of3", "PCGEN411_part2of3" & "PCGEN411_part3of3".
              > > 3) I went into "PCGEN411_part1of3", and clicked on PCGEN.jar.
              > > 4) The program opened, but no list of sources.
              > >
              > > Method Two -
              > >
              > > 1) I downloaded all three zip files into a folder called "PCGEN".
              > > 2) I extracted all three zip files into folders with the names
              > > "PCGEN411_part1of3", "PCGEN411_part2of3" & "PCGEN411_part3of3".
              > > 3) I moved the contents of all three folders into the main "PCGEN"
              > > folder. (In this method, I did have all the files and folders you
              > > mention in one folder.)
              > > 4) I clicked on PCGen.jar, but got an error message, saying it could
              > > not find a file in the folder "PCGEN411_part3of3".
              > >
              > > So method two demonstrates that the program wants me to leave it
              > > spread across three folders, no?
              > >
              > > Now you know what I know.
              > >
              > > Can you offer any help?
              > >
              > > Thanks,
              > >
              > > Scott
              > >
              > >
              > > --- In pcgen@y..., "Stuart Updegrave" <stuart@m...> wrote:
              > > >
              > > > You say you downloaded all three into the same directory. Did you
              > > > actually extract them as well? What OS? Into a clean directory?
              > > >
              > > > If you did extract, you need to ensure that you preserved
              > directory
              > > > structure in the extraction. If you didn't, none of the data files
              > > > will be in their proper places.
              > > >
              > > > If you extracted correctly you should have the following files and
              > > > folders in your root folder (assuming v.4.1.1):
              > > >
              > > > /characters
              > > > /data
              > > > /docs
              > > > /lib
              > > > /system
              > > > /templates
              > > > filter.ini
              > > > options.ini
              > > > pcgen.bat
              > > > pcgen.jar
              > > > pcgen.sh
              > > >
              > > > If you still have problems, please send as detailed repro steps as
              > > > possible.
              > > >
              > > > > -----Original Message-----
              > > > > From: scott_c_nolan [mailto:nolan@e...]
              > > > > Sent: Tuesday, October 01, 2002 7:21 AM
              > > > > To: pcgen@y...
              > > > > Subject: [pcgen] Re: Install help needed
              > > > >
              > > > >
              > > > > Nope. I downloaded all three into the same directory. That's
              > how I
              > > > > was able to access the documents that clued me in to the fact
              > that I
              > > > > was doing something wrong...
              > > > >
              > > > > Please help.
              > > > >
              > > > > Scott
              > > > >
              > > > > --- In pcgen@y..., "James Dempsey" <jdempsey@a...> wrote:
              > > > > > Hi Scott,
              > > > > >
              > > > > > Which of the zip files did you download? Generally it is
              > > > recommended
              > > > > that
              > > > > > you get all 3 and extract them into the same directory. It
              > sounds
              > > > > like you
              > > > > > might have only downloaded the first one.
              > > > > >
              > > > > >
              > > > > > Cheers,
              > > > > > -------------------------------------------
              > > > > > James Dempsey
              > > > > > JDempsey@a...
              > > > > > ----- Original Message -----
              > > > > > From: "scott_c_nolan" <nolan@e...>
              > > > > > To: <pcgen@y...>
              > > > > > Sent: Tuesday, October 01, 2002 5:16 PM
              > > > > > Subject: [pcgen] Install help needed
              > > > > >
              > > > > >
              > > > > > > Hi. I've just downloaded PCGen and I'm afraid I'm
              > > > > already confused.
              > > > > > > I've updated my Java, as suggested, and opened the
              > > > > program. I don't
              > > > > > > see the tree of source companies the walkthrough mentions.
              > I
              > > > also
              > > > > > > note that I am supposed to "install" PCGEN, but don't see
              > how to
              > > > > do that.
              > > > > > >
              > > > > > > Clearly, this is a failure to comprehend on my part, but
              > > > > could someone
              > > > > > > nontheless clue me in to what I'm doing wrong? Thanks.
              > > > > > >
              > > > > > > Scott
              > > > >
              > > > >
              > > > > ------------------------ Yahoo! Groups Sponsor
              > > > > ---------------------~-->
              > > > > Sell a Home for Top $
              > > > > http://us.click.yahoo.com/RrPZMC/jTmEAA/MVfIAA/9rHolB/TM
              > > > > --------------------------------------------------------------
              > > > > -------~->
              > > > >
              > > > > PCGen's release site: http://pcgen.sourceforge.net
              > > > > PCGen's FAQ: http://pedertest.officeline.no/PCGen
              > > > > PCGen's alpha build: http://rpg.plambert.net/pcgen
              > > > > To unsubscribe from this group, send an email to:
              > > > > pcgen-unsubscribe@e...
              > > > >
              > > > >
              > > > >
              > > > > Your use of Yahoo! Groups is subject to
              > > > > http://docs.yahoo.com/info/terms/
              > > > >
              > > > >
              > > > >
            • Ian Dale
              ... As long as it works, right? :) (I would have thought that your method #2 would have worked, but all I can figure is that either something got missed, or
              Message 6 of 10 , Oct 1, 2002
                --- In pcgen@y..., "scott_c_nolan" <nolan@e...> wrote:
                > Okay. Don't know -why- that worked, but it did. Thank you.
                >
                > Scott

                As long as it works, right? :) (I would have thought that your method
                #2 would have worked, but all I can figure is that either something
                got missed, or else somehow some path information got saved in the
                files when they got unzipped.)

                -Ian
              • James Dempsey
                The error was probably from the options.ini file which was created when the jar file from method #1 was started. It would still have references to the old
                Message 7 of 10 , Oct 1, 2002
                  The error was probably from the options.ini file which was created when the
                  jar file from method #1 was started. It would still have references to the
                  old location. If that was deleted, I reckon method #2 would have worked.

                  Cheers,
                  -------------------------------------------
                  James Dempsey
                  JDempsey@...
                  PCGEN Code Monkey

                  ----- Original Message -----
                  From: "Ian Dale" <ian_dale@...>
                  To: <pcgen@yahoogroups.com>
                  Sent: Wednesday, October 02, 2002 1:52 AM
                  Subject: [pcgen] Re: Install help needed


                  > --- In pcgen@y..., "scott_c_nolan" <nolan@e...> wrote:
                  > > Okay. Don't know -why- that worked, but it did. Thank you.
                  > >
                  > > Scott
                  >
                  > As long as it works, right? :) (I would have thought that your method
                  > #2 would have worked, but all I can figure is that either something
                  > got missed, or else somehow some path information got saved in the
                  > files when they got unzipped.)
                  >
                  > -Ian
                Your message has been successfully submitted and would be delivered to recipients shortly.