Loading ...
Sorry, an error occurred while loading the content.

PCGen Freezing, hidden dialogue popup windows

Expand Messages
  • thegrayronin
    I recently made the jump to Win8 and have had a bit of trouble with PCGen. The first issue is that the program freezes (refuses to respond to any attempted
    Message 1 of 5 , Aug 21 10:14 PM
    • 0 Attachment
      I recently made the jump to Win8 and have had a bit of trouble with PCGen.

      The first issue is that the program freezes (refuses to respond to any attempted interactions at all) after opening about 70% of the time. On the occasions when it doesn't freeze, it generally becomes impossible to functionally interact with; by that I mean that I can resize the window, I can use the minimize and maximize buttons, and I can click the close button but if I try to click on any links, buttons, tabs, or menus the program fails to respond.

      The second major issue I am facing stems from any attempts to close the program after it has frozen/become non-responsive. When I click the "X" close button, I can tell that at least one window pops up. However, before any details beyond general size can be discerned the new window immediately hides behind the main PCGen window. I have tried Alt+Tab'ing to the new window to no avail. I don't even know what the title bar of the window says so I can't really give any other details. The only way I've managed to get around this issue without force-closing the program is by hitting "Enter" after the window pops ups, at which point it appears to close and a second window opens behind the main PCGen window; hit "Enter" again, and PCGen closes. Again, I can't see any details beyond general window size before the second dialogue box disappears.


      If I am missing something, let me know. But I browsed through the issues on JIRA and the messages on here, and didn't see anything that seemed to indicate an issue like this. So I thought I would post this. I have tried this with all versions beyond 6.00.0, including alpha builds. Version 5164 works just fine, though. Let me know if you need more details.
    • Andrew
      Hi thegrayronin, ALT-TAB unfortunately won t work, since the pop ups are part of the program and not given an separate instance. I do find it disturbing the
      Message 2 of 5 , Aug 22 6:22 AM
      • 0 Attachment
        Hi thegrayronin,

        ALT-TAB unfortunately won't work, since the pop ups are part of the program and not given an
        separate instance. I do find it disturbing the pop dialog (Asking whatever) is hiding behind the
        main program.

        You mentioned Win 8, haven't had too many users on that. But let's see if we can narrow down the
        list of suspects.

        JAVA Version is 1.6 or 1.7? (Win 8 I would hope so by default)
        Install Location (anywhere other _than_ Users folder and Program Files folder)? - Windows has odd
        permission schemes regarding these locations.
        PCGen has permission to run? (No restrictive policies limiting it's ability to read/write)
        Allocated Memory high enough? (If you're still using a BAT file instead of the EXE file)
        Finally, any indications of an error? (Does F10 bring up the log? or grab the pcgen.log in the
        program install location)

        Cheers,


        On 8/21/2013 10:14 PM, thegrayronin wrote:
        > I recently made the jump to Win8 and have had a bit of trouble with PCGen.
        >
        > The first issue is that the program freezes (refuses to respond to any attempted interactions at all) after opening about 70% of the time. On the occasions when it doesn't freeze, it generally becomes impossible to functionally interact with; by that I mean that I can resize the window, I can use the minimize and maximize buttons, and I can click the close button but if I try to click on any links, buttons, tabs, or menus the program fails to respond.
        >
        > The second major issue I am facing stems from any attempts to close the program after it has frozen/become non-responsive. When I click the "X" close button, I can tell that at least one window pops up. However, before any details beyond general size can be discerned the new window immediately hides behind the main PCGen window. I have tried Alt+Tab'ing to the new window to no avail. I don't even know what the title bar of the window says so I can't really give any other details. The only way I've managed to get around this issue without force-closing the program is by hitting "Enter" after the window pops ups, at which point it appears to close and a second window opens behind the main PCGen window; hit "Enter" again, and PCGen closes. Again, I can't see any details beyond general window size before the second dialogue box disappears.
        >
        >
        > If I am missing something, let me know. But I browsed through the issues on JIRA and the messages on here, and didn't see anything that seemed to indicate an issue like this. So I thought I would post this. I have tried this with all versions beyond 6.00.0, including alpha builds. Version 5164 works just fine, though. Let me know if you need more details.
        >
        >
        >
        > ------------------------------------
        >
        > Related Lists
        > PCGen's release site: http://pcgen.sourceforge.net
        > PCGen's Mailing Lists and Links: http://wiki.pcgen.org/Mailing_Lists_and_PCGen_Links
        > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
        > PCGen's JIRA Tracker: http://jira.pcgen.org
        >
        >
        > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
        > (for assistance in creating new homebrew or official list files)
        >
        > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
        > (for new official data source development)
        > Yahoo! Groups Links
        >
        >
        >
        >
      • Barak
        What version of Java? What operating system? ... [Non-text portions of this message have been removed]
        Message 3 of 5 , Aug 22 7:08 AM
        • 0 Attachment
          What version of Java? What operating system?


          On Thu, Aug 22, 2013 at 1:14 AM, thegrayronin <gallopingpenguin@...>wrote:

          > **
          >
          >
          > I recently made the jump to Win8 and have had a bit of trouble with PCGen.
          >
          > The first issue is that the program freezes (refuses to respond to any
          > attempted interactions at all) after opening about 70% of the time. On the
          > occasions when it doesn't freeze, it generally becomes impossible to
          > functionally interact with; by that I mean that I can resize the window, I
          > can use the minimize and maximize buttons, and I can click the close button
          > but if I try to click on any links, buttons, tabs, or menus the program
          > fails to respond.
          >
          > The second major issue I am facing stems from any attempts to close the
          > program after it has frozen/become non-responsive. When I click the "X"
          > close button, I can tell that at least one window pops up. However, before
          > any details beyond general size can be discerned the new window immediately
          > hides behind the main PCGen window. I have tried Alt+Tab'ing to the new
          > window to no avail. I don't even know what the title bar of the window says
          > so I can't really give any other details. The only way I've managed to get
          > around this issue without force-closing the program is by hitting "Enter"
          > after the window pops ups, at which point it appears to close and a second
          > window opens behind the main PCGen window; hit "Enter" again, and PCGen
          > closes. Again, I can't see any details beyond general window size before
          > the second dialogue box disappears.
          >
          > If I am missing something, let me know. But I browsed through the issues
          > on JIRA and the messages on here, and didn't see anything that seemed to
          > indicate an issue like this. So I thought I would post this. I have tried
          > this with all versions beyond 6.00.0, including alpha builds. Version 5164
          > works just fine, though. Let me know if you need more details.
          >
          >
          >


          [Non-text portions of this message have been removed]
        • Darth Borehd
          I had trouble with PCGen slowing down to unresponsiveness on Windows 8. I found that it had something to do with having too many inventory items. I unchecked
          Message 4 of 5 , Aug 22 7:46 PM
          • 0 Attachment
            I had trouble with PCGen slowing down to unresponsiveness on Windows 8. I
            found that it had something to do with having too many inventory items. I
            unchecked all the boxes for automatically generating items, closed PCGen
            and relaunched it and it started working normally again. I found I didn't
            the automatically generated items that badly.


            On 21 August 2013 22:14, thegrayronin <gallopingpenguin@...> wrote:

            > **
            >
            >
            > I recently made the jump to Win8 and have had a bit of trouble with PCGen.
            >
            > The first issue is that the program freezes (refuses to respond to any
            > attempted interactions at all) after opening about 70% of the time. On the
            > occasions when it doesn't freeze, it generally becomes impossible to
            > functionally interact with; by that I mean that I can resize the window, I
            > can use the minimize and maximize buttons, and I can click the close button
            > but if I try to click on any links, buttons, tabs, or menus the program
            > fails to respond.
            >
            > The second major issue I am facing stems from any attempts to close the
            > program after it has frozen/become non-responsive. When I click the "X"
            > close button, I can tell that at least one window pops up. However, before
            > any details beyond general size can be discerned the new window immediately
            > hides behind the main PCGen window. I have tried Alt+Tab'ing to the new
            > window to no avail. I don't even know what the title bar of the window says
            > so I can't really give any other details. The only way I've managed to get
            > around this issue without force-closing the program is by hitting "Enter"
            > after the window pops ups, at which point it appears to close and a second
            > window opens behind the main PCGen window; hit "Enter" again, and PCGen
            > closes. Again, I can't see any details beyond general window size before
            > the second dialogue box disappears.
            >
            > If I am missing something, let me know. But I browsed through the issues
            > on JIRA and the messages on here, and didn't see anything that seemed to
            > indicate an issue like this. So I thought I would post this. I have tried
            > this with all versions beyond 6.00.0, including alpha builds. Version 5164
            > works just fine, though. Let me know if you need more details.
            >
            >
            >


            [Non-text portions of this message have been removed]
          • thegrayronin
            As you read through the following, know that in each instance I have tried this with every 6.x version of the software I could find to download in an effort to
            Message 5 of 5 , Aug 24 9:05 AM
            • 0 Attachment
              As you read through the following, know that in each instance I have tried this with every 6.x version of the software I could find to download in an effort to be as systematic as possible, with the exception of the newly released 6.00.1 which I just noticed this morning. I will give that a go next week when I have internet access. Also, this is a small book, so brace yourself...

              Java version 1.7, and I tried finding an older version to run on but didn't have much luck there.

              For instances where I have used the windows installer, I let it install to whatever directory it wanted to, which is :
              C:\Users\Justin\AppData\Local\PCGen\PCGen6xxx\
              I have also tried using the full zip file as well, and into Downloads, Documents, both Program Files folders (standard and x86).
              As to the settings directory, I have tried both the Default and the PCGenFolder options.

              I've given admin rights to the program to run, and am working on the admin profile for the computer. I looked around for any other settings that might restrict its ability to interact with the computer, but couldn't find anything suspect, though I will readily admit that Win8 settings are still taking some getting used to; I will say that I have used Google to the best of my ability to find anything that might indicated extra read/write permissions. I've also tried running it in Windows Compatibility mode for all the versions of windows it allows (XP SP3, Vista SP2, Win7) and got nowhere.

              I have tried selecting sources through the first screen that pops up, as well as x-ing that window out and selecting sources through the Menu to see if that helped. It didn't.

              I'm using the exe, and tried giving the program a full range of processing priority.

              I didn't know about F10, but I gave it a go and it did seem to provide some potential clues.
              Version 60105 - I let it open, cancel the new Source menu, and hit F10 to find two lines in the log indicating programi initialization. I then load sources from the menu (NOTEing that there is a yellow warning triangle in the bottom right corner of the window rather than the desired green check mark)to find a list of arguments surrounding the following
              -PREAPPLY on BONUS in BonusLst:67
              -DEFINE:LOCK in DefineLst:117
              -CHOOSE:USERINPUT in UserInputToken:66
              When I attempt to create a new character (either by hitting the NEW button, typing Ctrl+N, or by going to File>New, the program starts to slow until it becomes noninteractable (I can still move the window around, resize it, minimize, maximaze). F10 reveals no bugs or errors, just a new entry indicating a new character was being made. I did note that I could interact with the program for about 10-15 seconds before it became unresponsive.

              When I opened Version 6000 and avoided the new source screen and hit F10, there were no arguments; just a couple lines indicating program initialization had occurred. When I loaded the sources from the menu, they completed without error, giving me the desired green checkbox, at which point a couple unusual things happen.
              First...
              ...The sources load, and everything appears fine for a moment. But then the PCGen window starts flickering for about 30 seconds, as though another dialogue window is being opened and then closed. If during this time frame I click on the window of a different program (say, Chrome) while this process is taking place, the PCGen window will pop back and forth being the selected window and being an unselected window - again, as though dialogue windows for PCGen are opening and forcing it forward over whatever else the user is doing before finally (after ~30 seconds have passed) it resolves whatever issue it is having and falls back to being the unselected window.

              Second...
              ...once it appeared to resolve its attention tantrum, I noted that the Game Mode was still showing "none selected", and Source Materials was still "None". Also, the PCGen window appeared to not be the selected window even when I had the program selected, as though there was a hidden dialogue box. The window could not be moved, re-sized, max/min'd. However, when I hit Enter the window closed to reveal another PCGen window in exactly the same position/size which displayed the selected Game Mode and Source Materials. F10 reveals no errors. Attempting to load sources results in freezing/non-responsiveness.


              Now, the thing that made the program work...
              ...I extracted the zip the Program Files(x86). I'd previously been letting it extract to the Downloads, Documents, or User folders. I figured that if it Needed to be in the Program Files then it would have put itself there. Presumptuous of me, I know.

              When I'd been using the Installers, I was letting it install to the default directory, which for me is:
              C:\Users\Justin\AppData\Local\PCGen\PCGen6xxx\
              For the settings, I'd tried letting it go to the Default and PCGen Dir locations.



              So, thank you for drawing my attention back to the install directory. I have 6, and 60105 installed and appearing to work successfully from Programs Files (x86). I hope this helps. Let me know if you want me to try anything else for the sake of troubleshooting.



              --- In pcgen@yahoogroups.com, Andrew <drew0500@...> wrote:
              >
              > Hi thegrayronin,
              >
              > ALT-TAB unfortunately won't work, since the pop ups are part of the program and not given an
              > separate instance. I do find it disturbing the pop dialog (Asking whatever) is hiding behind the
              > main program.
              >
              > You mentioned Win 8, haven't had too many users on that. But let's see if we can narrow down the
              > list of suspects.
              >
              > JAVA Version is 1.6 or 1.7? (Win 8 I would hope so by default)
              > Install Location (anywhere other _than_ Users folder and Program Files folder)? - Windows has odd
              > permission schemes regarding these locations.
              > PCGen has permission to run? (No restrictive policies limiting it's ability to read/write)
              > Allocated Memory high enough? (If you're still using a BAT file instead of the EXE file)
              > Finally, any indications of an error? (Does F10 bring up the log? or grab the pcgen.log in the
              > program install location)
              >
              > Cheers,
              >
              >
              > On 8/21/2013 10:14 PM, thegrayronin wrote:
              > > I recently made the jump to Win8 and have had a bit of trouble with PCGen.
              > >
              > > The first issue is that the program freezes (refuses to respond to any attempted interactions at all) after opening about 70% of the time. On the occasions when it doesn't freeze, it generally becomes impossible to functionally interact with; by that I mean that I can resize the window, I can use the minimize and maximize buttons, and I can click the close button but if I try to click on any links, buttons, tabs, or menus the program fails to respond.
              > >
              > > The second major issue I am facing stems from any attempts to close the program after it has frozen/become non-responsive. When I click the "X" close button, I can tell that at least one window pops up. However, before any details beyond general size can be discerned the new window immediately hides behind the main PCGen window. I have tried Alt+Tab'ing to the new window to no avail. I don't even know what the title bar of the window says so I can't really give any other details. The only way I've managed to get around this issue without force-closing the program is by hitting "Enter" after the window pops ups, at which point it appears to close and a second window opens behind the main PCGen window; hit "Enter" again, and PCGen closes. Again, I can't see any details beyond general window size before the second dialogue box disappears.
              > >
              > >
              > > If I am missing something, let me know. But I browsed through the issues on JIRA and the messages on here, and didn't see anything that seemed to indicate an issue like this. So I thought I would post this. I have tried this with all versions beyond 6.00.0, including alpha builds. Version 5164 works just fine, though. Let me know if you need more details.
              > >
              > >
              > >
              > > ------------------------------------
              > >
              > > Related Lists
              > > PCGen's release site: http://pcgen.sourceforge.net
              > > PCGen's Mailing Lists and Links: http://wiki.pcgen.org/Mailing_Lists_and_PCGen_Links
              > > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
              > > PCGen's JIRA Tracker: http://jira.pcgen.org
              > >
              > >
              > > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
              > > (for assistance in creating new homebrew or official list files)
              > >
              > > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
              > > (for new official data source development)
              > > Yahoo! Groups Links
              > >
              > >
              > >
              > >
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.