Loading ...
Sorry, an error occurred while loading the content.

Using PERL on Windows 7?

Expand Messages
  • Andrew
    Hey folks, My faithful Laptop is acting up, meaning I m migrating to the Desktop which has Win7 and is a x64. I can t get PrettyLST to run on it. I installed
    Message 1 of 5 , Jun 8, 2013
    • 0 Attachment
      Hey folks,

      My faithful Laptop is acting up, meaning I'm migrating to the Desktop which has Win7 and is a x64. I
      can't get PrettyLST to run on it.

      I installed the latest ActiveState PERL. READONLY Module is automatically included in the latest
      release. What I am seeing is:
      "'perl' is not recognized as an internal or external command, operable program or batch file."

      Any help?
      --
      <html>
      <body>

      <font color="#000000 " size="+0" face="arial">
      Andrew Maitland (LegacyKing) <br>
      Admin Silverback - PCGen Board of Directors <br>
      Data 2nd, Docs Tamarin, OS Lemur <br>
      Unique Title "Quick-Silverback Tracker Monkey" <br>
      Unique Title "The Torturer of PCGen"
      </font>
      </body>
      </html>
    • David R. Bender
      Windows 7 stinks. It does not update the variable path that contains all the paths to all the programs that are installed. Also, it depends on whether it was
      Message 2 of 5 , Jun 8, 2013
      • 0 Attachment
        Windows 7 stinks. It does not update the variable "path" that contains
        all the paths to all the programs that are installed. Also, it depends
        on whether it was installed to "Program Files" or "Program Files (x86)".
        You can manually update the "path" variable and all should be well, or
        update the file and point directly to the perl module. I had to to this
        for java.

        -- david
        Papa.DRB

        My better half and me (jpg)
        <https://picasaweb.google.com/102726903532570043857/Family#slideshow/5533056948910114610>

        Love Me If You Can by Toby Keith (video)
        <http://www.youtube.com/watch?v=mhcfFekSbHQ&ob=av3e>
        Word of the Day (gif) <https://dl.dropbox.com/u/38647997/Exhaustipated.gif>

        Madness takes its toll - please have exact change.
        For those who believe, no proof is necessary, for those who don't
        believe, no proof is possible. (Stuart Chase 1888-1985)
        On 2013-06-08 05:30 PM, Andrew wrote:
        > Hey folks,
        >
        > My faithful Laptop is acting up, meaning I'm migrating to the Desktop which has Win7 and is a x64. I
        > can't get PrettyLST to run on it.
        >
        > I installed the latest ActiveState PERL. READONLY Module is automatically included in the latest
        > release. What I am seeing is:
        > "'perl' is not recognized as an internal or external command, operable program or batch file."
        >
        > Any help?
      • Doug Limmer
        To check/change the path: Go to Control Panel | System and Security | System, click on Advanced system settings in the left-hand list, and click on Environment
        Message 3 of 5 , Jun 8, 2013
        • 0 Attachment
          To check/change the path: Go to Control Panel | System and Security |
          System, click on Advanced system settings in the left-hand list, and
          click on Environment Variables... Find the path variable (probably a
          system variable). Edit as needed.

          [My docs for ActivePerl say the .msi installer should handle this for
          you ...]

          DS/DL

          On 6/8/2013 5:30 PM, Andrew wrote:
          >
          > Hey folks,
          >
          > My faithful Laptop is acting up, meaning I'm migrating to the Desktop
          > which has Win7 and is a x64. I
          > can't get PrettyLST to run on it.
          >
          > I installed the latest ActiveState PERL. READONLY Module is
          > automatically included in the latest
          > release. What I am seeing is:
          > "'perl' is not recognized as an internal or external command, operable
          > program or batch file."
          >
          > Any help?
          > --
          > <html>
          > <body>
          >
          > <font color="#000000 " size="+0" face="arial">
          > Andrew Maitland (LegacyKing) <br>
          > Admin Silverback - PCGen Board of Directors <br>
          > Data 2nd, Docs Tamarin, OS Lemur <br>
          > Unique Title "Quick-Silverback Tracker Monkey" <br>
          > Unique Title "The Torturer of PCGen"
          > </font>
          > </body>
          > </html>
          >
          >



          [Non-text portions of this message have been removed]
        • Andrew
          I used the installer, and it didn t work. Hence my confusion and annoyance. There is a Path in there called Perl64
          Message 4 of 5 , Jun 8, 2013
          • 0 Attachment
            I used the installer, and it didn't work. Hence my confusion and annoyance. There is a Path in there
            called Perl64

            On 6/8/2013 2:44 PM, Doug Limmer wrote:
            > To check/change the path: Go to Control Panel | System and Security | System, click on Advanced
            > system settings in the left-hand list, and click on Environment Variables... Find the path variable
            > (probably a system variable). Edit as needed.
            >
            > [My docs for ActivePerl say the .msi installer should handle this for you ...]
            >
            > DS/DL
            >
            > On 6/8/2013 5:30 PM, Andrew wrote:
            >>
            >>
            >> Hey folks,
            >>
            >> My faithful Laptop is acting up, meaning I'm migrating to the Desktop which has Win7 and is a x64. I
            >> can't get PrettyLST to run on it.
            >>
            >> I installed the latest ActiveState PERL. READONLY Module is automatically included in the latest
            >> release. What I am seeing is:
            >> "'perl' is not recognized as an internal or external command, operable program or batch file."
            >>
            >> Any help?
            >> --
            >> <html>
            >> <body>
            >>
            >> <font color="#000000 " size="+0" face="arial">
            >> Andrew Maitland (LegacyKing) <br>
            >> Admin Silverback - PCGen Board of Directors <br>
            >> Data 2nd, Docs Tamarin, OS Lemur <br>
            >> Unique Title "Quick-Silverback Tracker Monkey" <br>
            >> Unique Title "The Torturer of PCGen"
            >> </font>
            >> </body>
            >> </html>
            >>
            >>
            >
          • Andrew
            Hi David, Thanks, the direct path in the bat file did the trick. Thanks! ... -- Andrew Maitland
            Message 5 of 5 , Jun 8, 2013
            • 0 Attachment
              Hi David,

              Thanks, the direct path in the bat file did the trick. Thanks!

              On 6/8/2013 2:43 PM, David R. Bender wrote:
              > Windows 7 stinks. It does not update the variable "path" that contains
              > all the paths to all the programs that are installed. Also, it depends
              > on whether it was installed to "Program Files" or "Program Files (x86)".
              > You can manually update the "path" variable and all should be well, or
              > update the file and point directly to the perl module. I had to to this
              > for java.
              >
              > -- david
              > Papa.DRB
              >
              > My better half and me (jpg)
              > <https://picasaweb.google.com/102726903532570043857/Family#slideshow/5533056948910114610>
              >
              > Love Me If You Can by Toby Keith (video)
              > <http://www.youtube.com/watch?v=mhcfFekSbHQ&ob=av3e>
              > Word of the Day (gif) <https://dl.dropbox.com/u/38647997/Exhaustipated.gif>
              >
              > Madness takes its toll - please have exact change.
              > For those who believe, no proof is necessary, for those who don't
              > believe, no proof is possible. (Stuart Chase 1888-1985)
              > On 2013-06-08 05:30 PM, Andrew wrote:
              >> Hey folks,
              >>
              >> My faithful Laptop is acting up, meaning I'm migrating to the Desktop which has Win7 and is a x64. I
              >> can't get PrettyLST to run on it.
              >>
              >> I installed the latest ActiveState PERL. READONLY Module is automatically included in the latest
              >> release. What I am seeing is:
              >> "'perl' is not recognized as an internal or external command, operable program or batch file."
              >>
              >> Any help?
              >
              >
              >
              > ------------------------------------
              >
              > Related Lists
              > PCGen's release site: http://pcgen.sourceforge.net
              > PCGen's Mailing Lists and Links: http://wiki.pcgen.org/Mailing_Lists_and_PCGen_Links
              > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
              > PCGen's JIRA Tracker: http://jira.pcgen.org
              >
              >
              > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
              > (for assistance in creating new homebrew or official list files)
              >
              > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
              > (for new official data source development)
              > Yahoo! Groups Links
              >
              >
              >
              >

              --
              <html>
              <body>

              <font color="#000000 " size="+0" face="arial">
              Andrew Maitland (LegacyKing) <br>
              Admin Silverback - PCGen Board of Directors <br>
              Data 2nd, Docs Tamarin, OS Lemur <br>
              Unique Title "Quick-Silverback Tracker Monkey" <br>
              Unique Title "The Torturer of PCGen"
              </font>
              </body>
              </html>
            Your message has been successfully submitted and would be delivered to recipients shortly.