Loading ...
Sorry, an error occurred while loading the content.

[Eric] Re: [pcgen] Re: CMP datasets in 6.00 first impression

Expand Messages
  • rogerwllco
    ... Thank you. ... Ah. I had already tried to change that selection, as the small grey triangle indicated there were more options. I never considered
    Message 1 of 11 , Mar 16, 2013
    • 0 Attachment
      --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:
      > Hi Adriaan,
      > On 16/03/2013 1:37 PM rogerwllco wrote
      > >
      > > --- In pcgen@yahoogroups.com, Andrew <drew0500@> wrote:
      > >> Hi,
      > >>
      > >>
      > >> On 3/13/2013 8:24 PM, rogerwllco wrote:
      > >>> I'm now running PCGen for the first time after converting my CMP datasets to 6.00
      > >>>
      > >>> 1) MENUENTRY:"D&&D Forgotten Realms v3.5e" is displayed as "DD Forgotten Realms v3.5e". It seems the && is being ignored even though this used to work in earlier versions and the documentation explicitly mentions it http://www.pcgen-test.org/autobuilds/pcgen-docs/listfilepages/systemfilestagpages/gamemodemiscinfolist.html#MENUENTRY
      > Raised and fixed. See CODE-2097 <http://jira.pcgen.org/browse/CODE-2097>

      Thank you.

      > >>> 2) The source loading screen is a little awkward, as obviously PCGen suspects a different directory structure to how the CMP data is set up.
      > >> Sounds like the vendor directory isn't set up. Please confirm this.
      > >>
      > > I think it's something with CAMPAIGN, BOOKTYPE, SETTING in the .pcc in combination with directory structure.
      > >
      > > The data directories are set up like this:
      > > /vendordata/cmp/rules_system_v35e/wizards_of_the_coast/forgotten_realms/campaign_setting
      > > /vendordata/cmp/rules_system_v35e/wizards_of_the_coast/forgotten_realms/supplement
      > >
      > > The result is something like this:
      > > http://img43.imageshack.us/img43/6006/screenshot20130316at032.png
      > > What's confusing is that the column labels say [Publisher/Setting/Name][Book Type] this is not what seems to be displayed.
      > >
      > Two things to check - first change the first column by right clicking -
      > does it start to work as you expect then? We've fixed a problem with
      > that not behaving well initially in the past. The second is to look at
      > what the SETTING tag is in your sources - that is what should be being
      > displayed in the second level folder name. The actual folder names are
      > not used at all.

      Ah. I had already tried to change that selection, as the small grey triangle indicated there were more options. I never considered right-clicking though. I don't think that's a very intuitive GUI convention.

      The [Publisher/Format/Setting/Name] option gives me something that makes a lot more sense in what gets displayed:
      What it seems to do is [Publisher/Setting/Format/Name] though.

      I have this in my .pcc

      CAMPAIGN:wotc - Forgotten Realms Campaign Setting v3.5e
      BOOKTYPE:Campaign Setting
      PUBNAMELONG:Wizards of the Coast, Inc
      SETTING:Forgotten Realms
      TYPE:Wizards of the Coast.Forgotten Realms.Campaign Setting
      SOURCELONG:Forgotten Realms Campaign Setting

      > >
      > >>> 4) The initial screen I get after loading my sources looks weird.
      > >>> http://img43.imageshack.us/img43/3896/screenshot20130314at033.png
      > Yeah it wasn't designed to list that many individual sources.

      I usually run with at least 20. I considered the selection in my screenshot a small selection for testing purposes.

      > >>> 5) The GameMode/Campaign tab under Preferences only displays a single "C". http://img547.imageshack.us/img547/9038/screenshot20130314at040.png
      > Fixed.

      Thank you

      > >>> 6) Initially on setting the Point Buy method, the last ability mod fr CHA is shown incorrectly. This goes away as soon as you try to change it, so it's probably just a display issue. http://img600.imageshack.us/img600/9038/screenshot20130314at040.png
      > >>>
      > > I think I understand what's going wrong here. It seems like the redraw of the "Ability Scores" part of the screen happens each time before an update to it, instead of after it, if the update is coming from a different part of the screen. Selecting a different Race will have the same effect as selecting a different Method: the "Ability Scores" part of the screen seems to be missing the last change you did. As it fixes itself as soon as you do something else, I think some kind of redraw or refresh of that part of the GUI is done before the updating is finished.
      > Yep, we have fixed a few refresh timing issues like that already.
      This one still occurs in the latest 6.01.01 and 6.00.01RC1 that I downloaded. To test: load rsrd player, new character, select Elf as race. No racial modifiers will be shown until something else forces a refresh.

      > >>> 7) In the random name generator, the pronunciation overwrites the Adjust name label.
      > >>> http://img20.imageshack.us/img20/9038/screenshot20130314at040.png
      > >>>
      > > The problem here seems to be that the window is slightly too small and the "Adjust Name" label is connected to the bottom part of the popup screen, so when the buttons below it show up, it moves upwards to make space, covering the "Pronunciation".
      > Yes that screen needs a further tidy-up, particularly for those dynamic
      > buttons. I've raised it as CODE-2099 - Random Name Generator - Buttons
      > overlap field <http://jira.pcgen.org/browse/CODE-2099>

      Thank you. I do like the new random name generator by the way.

      > >>> 8) Is the white space on the right in the Skills selection supposed to hold anything? I really liked how in the 5.x series you could see a list of all the skills you could use, starting with those that you could use untrained and then adding those trained only skills that you bought ranks in. http://img7.imageshack.us/img7/9931/screenshot20130314at041.png
      > You need to define that in your game mode using the INFOSHEET:SKILLS
      > tag. Try adding these lines to your miscinfo:
      > PREVIEWDIR:d20/fantasy
      > PREVIEWSHEET:Standard.htm
      > INFOSHEET:SUMMARY|preview/summary/35e_info.html
      > INFOSHEET:SKILLS|preview/skills/35e_skills.html
      > You can customise them as you like.

      Thank you, that fixed the issue.

      > >>> 10) I get 7128 SEVERE errors when just loading a few sources. Maybe some people can explain what a few of these mean. (I do like that the errors mention what file they're from although I omit that here):
      > The LST error reporting in 6.0 is vastly improved over 5.16. It sounds
      > like there are some KIT entries with syntax that it does not like. In
      > most cases these will be things that never worked in previous versions
      > but were silently ignored. In particular global tags are not supported
      > in kits, only the tags specifically mentioned in the Starting Kits
      > documentation should be used.

      O.k. I never really used kits.

      > It is also calling out some issues with duplicates - you can use the
      > "Allow newer sources to override duplicate object from older sources"
      > option under Tools > Preferences > PCGen > Sources to safely suppress
      > many of these.

      That makes a huge difference. I think it's 90%% of my errors. The remaining lines in the log now do seem to be actual errors. does it use SOURCEDATE to determine this, or does it take RANK into account as well?

      > Cheers,
      > James.
      > [Non-text portions of this message have been removed]
    • rogerwllco
      Oh, and by the way: I really like how much more detailed the SEVERE errors are that get reported in the log. With file name, and line number and very often a
      Message 2 of 11 , Mar 16, 2013
      • 0 Attachment
        Oh, and by the way:
        I really like how much more detailed the SEVERE errors are that get reported in the log. With file name, and line number and very often a descriptive error message that by itself is enough to go in and fix the error without having to go on a treasure hunt in the general LST documentation.
      • rogerwllco
        I was browsing the PCGen code while trying to figure something els out and I came accross the code that seems to do this in PCGenFrame.java line 1636 What it
        Message 3 of 11 , Mar 20, 2013
        • 0 Attachment
          I was browsing the PCGen code while trying to figure something els out and I came accross the code that seems to do this in PCGenFrame.java line 1636

          What it seems to do is:
          sec15.append(readTextFromFile(ConfigurationSettings.getSystemsDir() + File.separator + "opengaminglicense.10a.txt"));

          I've checked and the opengaminglicense.10a.txt exists in the right location. My guess would be that maybe File.separator is incorrectly determined?


          Adriaan Renting/RogerWilco

          --- In pcgen@yahoogroups.com, Eric C Smith <maredudd@...> wrote:
          > Ho Folks!
          > James Dempsey wrote:
          > > >>> 3) Just like the rsrd (see my message from Jan 11), I get an empty licence screen on start up. Where should it get this licence from? I don't know if the CMP datasets provide any. I might not have put it in the right location, or it might just not be there. Maybe if it can't find a licence, it should not display the screen?
          > > >> I'll need to investigate. This may be a code UI bug/Freq - I suspect the new UI isn't hooked up for
          > > >> it any longer.
          > > > I do have LICENCE text in the .pcc files and ISLICENCED:YSE
          > >
          > > As this also happens in the rsrd, and it works for me in the Windows
          > > version, I am suspecting a Mac packaging issue. Eric, could you comment
          > > on this one please?
          > I've loaded the PFCR with the "Show OGL License" preference turned on and get a blank dialog box.
          > I then went in and added the ISLICENSED:YES and LICENSE:This is a test to the PFCR PCC and got a blank OGL dialog and a blank Special License dialog.
          > It looks like it may be a Mac issue, though I'm not sure how it could be a Mac packaging issue as I don't do an actual build from the code but use the pcgenx.x.x_full.zip file as the basic mac application and wrap the Mac app stuff around it.
          > Maredudd
        Your message has been successfully submitted and would be delivered to recipients shortly.