Loading ...
Sorry, an error occurred while loading the content.

Re: Profiling PCGen Load/Save

Expand Messages
  • gtpdspin
    Done. CODE-370
    Message 1 of 6 , Oct 30, 2010
    • 0 Attachment
      Done. CODE-370

      --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...> wrote:
      >
      > Hi,
      >
      > Yes please. Open a JIRA tracker (jira.pcgen.org) and attach the pcg file. We'll have a look at it.
      >
      >
      > On 10/28/2010 6:15 PM, gtpdspin wrote:
      > > It's a 20th level character, loading the full RSRD data set, plus two other very small datasets that I've written.
      > >
      > > There's a fair amount of equipment.
      > >
      > > I'm happy to let you have a copy of the character.
      > >
      > > --- In pcgen@yahoogroups.com, Martijn Verburg<martijnverburg@> wrote:
      > >> What datasets are loaded with your character? Is it a complex character
      > >> with lots of equipment etc?
      > >>
      > >> K
      > >>
      > >> On Sun, Oct 17, 2010 at 1:27 AM, gtpdspin<Phil@> wrote:
      > >>
      > >>>
      > >>> As another data point, I've created pcgen.l4j.ini as follows to see if it's
      > >>> a memory problem.
      > >>>
      > >>> # Launch4j runtime config
      > >>> -Xms384m
      > >>> -Xmx768m
      > >>>
      > >>> It isn't. Adding more memory to the JVM heap makes no difference - it still
      > >>> take 170 seconds to load my character.
      > >>>
      > >>>
      > >>> --- In pcgen@yahoogroups.com<pcgen%40yahoogroups.com>, "gtpdspin"<Phil@>
      > >>> wrote:
      > >>>> I'm running PCGen 5.16.3 on Windows 7 x64, with Java 6u21 (32 bit), 4G
      > >>> RAM Core2Quad, and there are parts of PCGen that seem to run incredible
      > >>> slowly.
      > >>>> If I load a previous character using Open Recent... it takes a full 170
      > >>> seconds (not a typo, just under 3 minutes) before I can click any tab.
      > >>>> Once loaded, everything works fine without obvious delays.
      > >>>>
      > >>>> When I close PCGen, if I do a Save All first, it quits immediately. If I
      > >>> don't, and it prompts to save the changed character, there is similarly
      > >>> large delay.
      > >>>> Is there something that I can do to profile the Load/Save to find out why
      > >>> it is taking so long?
      > >>>
      > >>>
      > >>
      > >> [Non-text portions of this message have been removed]
      > >>
      > >
      > >
      > >
      > > ------------------------------------
      > >
      > > Related Lists
      > > PCGen's release site: http://pcgen.sourceforge.net
      > > PCGen's Wiki: http://wiki.pcgen.org/
      > > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
      > > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
      > > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
      > > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
      > >
      > > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
      > > (for assistance in creating new homebrew or official list files)
      > >
      > > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
      > > (for new official data source development)
      > > Yahoo! Groups Links
      > >
      > >
      > >
      > >
      >
      > --
      > Andrew Maitland (LegacyKing)
      > Admin Silverback - PCGen Board of Directors
      > Data 2nd, Docs Tamarin, OS Lemur
      > Unique Title "Quick-Silverback Tracker Monkey"
      > Unique Title "The Torturer of PCGen"
      >
      >
      > [Non-text portions of this message have been removed]
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.