Loading ...
Sorry, an error occurred while loading the content.
 

Re: PCGen 5.16.1 to 5.16.2 incompatibility

Expand Messages
  • Allen C
    Glad to be of help... But I just loaded 5.16.3RC1 and it didn t load there either. Any thoughts? Is the remaining error User Error? Allen
    Message 1 of 10 , Jul 2, 2010
      Glad to be of help...

      But I just loaded 5.16.3RC1 and it didn't load there either.

      Any thoughts? Is the remaining error User Error?

      Allen

      --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...> wrote:
      >
      > Hi Allen,
      >
      > Yes, it loads in 5.16.3RC1 and 5.17.4-dev.
      >
      > There are two trackers that I created because of it; both of which have already been fixed. James
      > took used your pcg file to do those fixes.
      >
      > It was most helpful, and you just insured that people who would have encountered the same issue,
      > won't. :)
      >
      >
    • James Dempsey
      Hi Allen, The fixes were made after 5.16.3 RC1 was released, but nether of those should have stopped the load. What we couldn t reproduce was how your custom
      Message 2 of 10 , Jul 2, 2010
        Hi Allen,

        The fixes were made after 5.16.3 RC1 was released, but nether of those
        should have stopped the load. What we couldn't reproduce was how your
        custom sources affected the load. To trace what it is going on, open the
        debug console (no need to change logging level) and post what comes out
        there. If it is really long, just send it to Andrew and I directly or
        upload it as a file.

        Cheers,
        James.

        On 3/07/2010 8:15 AM Allen C wrote
        > Glad to be of help...
        >
        > But I just loaded 5.16.3RC1 and it didn't load there either.
        >
        > Any thoughts? Is the remaining error User Error?
        >
        > Allen
        >
        > --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...> wrote:
        >
        >> Hi Allen,
        >>
        >> Yes, it loads in 5.16.3RC1 and 5.17.4-dev.
        >>
        >> There are two trackers that I created because of it; both of which have already been fixed. James
        >> took used your pcg file to do those fixes.
        >>
        >> It was most helpful, and you just insured that people who would have encountered the same issue,
        >> won't. :)
        >>
      • Allen C
        Hi James, It s Greek to me...or rather Java: This is from 5.16.3RC1. Allen -- listing properties -- java.runtime.name=Java(TM) SE Runtime Environment
        Message 3 of 10 , Jul 2, 2010
          Hi James,

          It's Greek to me...or rather Java:

          This is from 5.16.3RC1.

          Allen

          -- listing properties --
          java.runtime.name=Java(TM) SE Runtime Environment
          sun.boot.library.path=C:\Program Files\Java\jre6\bin
          java.vm.version=16.3-b01
          java.vm.vendor=Sun Microsystems Inc.
          java.vendor.url=http://java.sun.com/
          path.separator=;
          java.vm.name=Java HotSpot(TM) Client VM
          file.encoding.pkg=sun.io
          java.util.logging.config.file=C:\Program Files\PCGen\PCGen5163RC1\l...
          user.country=US
          sun.java.launcher=SUN_STANDARD
          sun.os.patch.level=Service Pack 3
          java.vm.specification.name=Java Virtual Machine Specification
          user.dir=C:\Program Files\PCGen\PCGen5163RC1
          java.runtime.version=1.6.0_20-b02
          java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
          java.endorsed.dirs=C:\Program Files\Java\jre6\lib\endorsed
          os.arch=x86
          java.io.tmpdir=C:\DOCUME~1\Allen\LOCALS~1\Temp\
          line.separator=

          java.vm.specification.vendor=Sun Microsystems Inc.
          user.variant=
          os.name=Windows XP
          sun.jnu.encoding=Cp1252
          java.library.path=C:\Program Files\Java\jre6\bin;.;C:\W...
          java.specification.name=Java Platform API Specification
          java.class.version=50.0
          sun.management.compiler=HotSpot Client Compiler
          os.version=5.1
          user.home=C:\Documents and Settings\Allen
          user.timezone=America/Los_Angeles
          java.awt.printerjob=sun.awt.windows.WPrinterJob
          file.encoding=Cp1252
          java.specification.version=1.6
          user.name=Allen
          java.class.path=C:\Program Files\PCGen\PCGen5163RC1\p...
          java.vm.specification.version=1.0
          sun.arch.data.model=32
          java.home=C:\Program Files\Java\jre6
          java.specification.vendor=Sun Microsystems Inc.
          user.language=en
          awt.toolkit=sun.awt.windows.WToolkit
          java.vm.info=mixed mode, sharing
          java.version=1.6.0_20
          java.ext.dirs=C:\Program Files\Java\jre6\lib\ext;C:...
          sun.boot.class.path=C:\Program Files\Java\jre6\lib\resour...
          java.vendor=Sun Microsystems Inc.
          file.separator=\
          java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport...
          sun.cpu.endian=little
          sun.io.unicode.encoding=UnicodeLittle
          sun.desktop=windows
          sun.cpu.isalist=pentium_pro+mmx pentium_pro pentium+m...
          Memory: 211,372Kb total, 97,192.062Kb free, 506,816Kb max.
          SEVERE pcgen.core.party.Party Error loading party partyFile.
          java.lang.NullPointerException
          at pcgen.core.Globals.getSpellsIn(Unknown Source)
          at pcgen.core.PCClass.calculateKnownSpellsForClassLevel(Unknown Source)
          at pcgen.core.PCClass.setLevel(Unknown Source)
          at pcgen.io.PCGIOHandler.sanityChecks(Unknown Source)
          at pcgen.io.PCGIOHandler.read(Unknown Source)
          at pcgen.io.IOHandler.internalRead(Unknown Source)
          at pcgen.io.IOHandler.read(Unknown Source)
          at pcgen.core.party.Party.loadPCFromFile(Unknown Source)
          at pcgen.core.party.Party.loadCharacterFiles(Unknown Source)
          at pcgen.core.party.Party.load(Unknown Source)
          at pcgen.gui.PCGen_Frame1.loadPCFromFile(Unknown Source)
          at pcgen.gui.PCGen_Frame1.loadPCFromFile(Unknown Source)
          at pcgen.gui.PCGenMenuBar$1.openRecentPerformed(Unknown Source)
          at pcgen.gui.utils.JOpenRecentMenu$OpenRecentActionListener.actionPerformed(Unknown Source)
          at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
          at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
          at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
          at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
          at javax.swing.AbstractButton.doClick(Unknown Source)
          at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
          at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
          at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
          at java.awt.Component.processMouseEvent(Unknown Source)
          at javax.swing.JComponent.processMouseEvent(Unknown Source)
          at java.awt.Component.processEvent(Unknown Source)
          at java.awt.Container.processEvent(Unknown Source)
          at java.awt.Component.dispatchEventImpl(Unknown Source)
          at java.awt.Container.dispatchEventImpl(Unknown Source)
          at java.awt.Component.dispatchEvent(Unknown Source)
          at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
          at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
          at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
          at java.awt.Container.dispatchEventImpl(Unknown Source)
          at java.awt.Window.dispatchEventImpl(Unknown Source)
          at java.awt.Component.dispatchEvent(Unknown Source)
          at java.awt.EventQueue.dispatchEvent(Unknown Source)
          at pcgen.gui.PCGen_Frame1$WaitCursorEventQueue.dispatchEvent(Unknown Source)
          at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
          at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
          at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
          at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
          at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
          at java.awt.EventDispatchThread.run(Unknown Source)

          SEVERE pcgen.gui.PCGen_Frame1 Error in loadPCFromFile
        • James Dempsey
          Hi Allen. On 3/07/2010 12:33 PM Allen C wrote ... Excellent - that narrows it down to a problem with a spell, most likely that there is a spell that is not
          Message 4 of 10 , Jul 2, 2010
            Hi Allen.

            On 3/07/2010 12:33 PM Allen C wrote
            > Hi James,
            >
            > It's Greek to me...or rather Java:
            >
            > This is from 5.16.3RC1.
            >
            >
            Excellent - that narrows it down to a problem with a spell, most likely
            that there is a spell that is not loading properly when you load your
            custom sources. When you do the load there is a window that pops up
            showing the progress and any errors encountered. Do you see anything in
            that window?

            Cheers,
            James.
          • Allen C
            No, it s loading clean. But that s not to say there might be some problem with my file... I do have lots of custom spells. One of them did make the whole
            Message 5 of 10 , Jul 2, 2010
              No, it's loading clean. But that's not to say there might be some problem with my file...

              I do have lots of custom spells. One of them did make the whole system crash...that took forever to isolate the one trouble maker. I commented it out and now it loads clean. (Never could figure that one out).

              Should I migrate this querry to the LST file support group?

              Many thanks,
              Allen

              --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:
              >
              > Hi Allen.
              >
              > On 3/07/2010 12:33 PM Allen C wrote
              > > Hi James,
              > >
              > > It's Greek to me...or rather Java:
              > >
              > > This is from 5.16.3RC1.
              > >
              > >
              > Excellent - that narrows it down to a problem with a spell, most likely
              > that there is a spell that is not loading properly when you load your
              > custom sources. When you do the load there is a window that pops up
              > showing the progress and any errors encountered. Do you see anything in
              > that window?
              >
              > Cheers,
              > James.
              >
            • Andrew Maitland
              Hi, Send the problem file my way, a good sweep of prettyLst aught to find the trouble maker easy enough. ... -- Andrew Maitland (LegacyKing) Admin Silverback -
              Message 6 of 10 , Jul 2, 2010
                Hi,

                Send the problem file my way, a good sweep of prettyLst aught to find the trouble maker easy enough.


                On 7/2/2010 8:13 PM, Allen C wrote:
                > No, it's loading clean. But that's not to say there might be some problem with my file...
                >
                > I do have lots of custom spells. One of them did make the whole system crash...that took forever to isolate the one trouble maker. I commented it out and now it loads clean. (Never could figure that one out).
                >
                > Should I migrate this querry to the LST file support group?
                >
                > Many thanks,
                > Allen
                >
                > --- In pcgen@yahoogroups.com, James Dempsey<jdempsey@...> wrote:
                >> Hi Allen.
                >>
                >> On 3/07/2010 12:33 PM Allen C wrote
                >>> Hi James,
                >>>
                >>> It's Greek to me...or rather Java:
                >>>
                >>> This is from 5.16.3RC1.
                >>>
                >>>
                >> Excellent - that narrows it down to a problem with a spell, most likely
                >> that there is a spell that is not loading properly when you load your
                >> custom sources. When you do the load there is a window that pops up
                >> showing the progress and any errors encountered. Do you see anything in
                >> that window?
                >>
                >> Cheers,
                >> James.
                >>
                >
                >
                >
                > ------------------------------------
                >
                > Related Lists
                > PCGen's release site: http://pcgen.sourceforge.net
                > PCGen's Wiki: http://wiki.pcgen.org/
                > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
                > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
                > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
                > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
                >
                > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
                > (for assistance in creating new homebrew or official list files)
                >
                > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
                > (for new official data source development)
                > Yahoo! Groups Links
                >
                >
                >
                >

                --
                Andrew Maitland (LegacyKing)
                Admin Silverback - PCGen Board of Directors
                Data Chimp, Docs Tamarin
                Unique Title "Quick-Silverback Tracker Monkey"
                Unique Title "The Torturer of PCGen"


                [Non-text portions of this message have been removed]
              Your message has been successfully submitted and would be delivered to recipients shortly.