Loading ...
Sorry, an error occurred while loading the content.

Re: [Code]Can't get PCGen to work...

Expand Messages
  • djvandebrake
    Yep, that did it. Apparently I had both Sun and Open JDKs installed, so when I checked, well sure enough! I had Sun! Guess I didn t go deep enough. ;)
    Message 1 of 7 , Feb 25, 2010
    • 0 Attachment
      Yep, that did it. Apparently I had both Sun and Open JDKs installed, so when I checked, well sure enough! I had Sun! Guess I didn't go deep enough. ;) Uninstalling Open JDK has fixed the problem.

      Much gratitude!

      --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:
      >
      > Hi,
      >
      > That's no good. Two things to try:
      >
      > 1. Check that you are really using just the Sun JDK - things like
      > JAVA_HOME might still point to the Open JDK files. I have to say it does
      > sound like typical Open JDK behaviour.
      > 2. Open up the console (debug mode not necessary) before loading your
      > sources. See if any stack traces are reported there and if so post them
      > here for us to diagnose the issue with.
      >
      > Cheers,
      > James Dempsey
      > PCGen Code SB
      >
      > On 24/02/2010 12:04 PM djvandebrake wrote
      > > ...or not. PPCGen loads, and I now can select game modes. The "Load Sources" dialog seems to work in Basic Mode, so when I load a game, it loads the subfiles (takes a while, and I thought it was actually freezing for two days) but finally works. No sources show in the advanced source load dialog, however, so that's the only way to get the information in. Further, there is nothing listed on subpages, and only a few basics on the summary page - I'm using the Pathinder RPG and the races gives me a plethora of animal companions and the basic seven races, no more, and the race tab doesn't even show that. Same with classes - I get the basics, and the creature types, in the summary dropdown, but no classes at all on that tab. No equipment. I'm new to using this, but if I had to guess I'd say it only loaded stuff found in the game mode files and not anything in other sources. Which would make sense if it didn't allow me to select sources.
      > >
      > > --- In pcgen@yahoogroups.com, "djvandebrake" <djvandebrake@> wrote:
      > >
      > >> This did it! Thanks for the help!
      > >>
      > >> --- In pcgen@yahoogroups.com, "dynamotwain" <dynamotwain@> wrote:
      > >>
      > >>> PCGen locates its data files (including game modes) and additional JAR files relative to the current working directory; if you created a link directly to the JAR file, when you execute it through your menu application, the current working directory is most likely set to your home directory and not the pcgen directory.
      > >>>
      > >>> PCGen includes a pcgen.sh script that automatically `cd`s to the proper directory before launching pcgen.jar. Point your menu entry to 'pcgen.sh' instead of 'pcgen.jar' and I expect things will start working. (You may need to run `chmod +x pcgen.sh` to mark the file as executable first).
      > >>>
      > >>> --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@> wrote:
      > >>>
      > >>>> Hi,
      > >>>>
      > >>>> We get these all the time, but no worries.
      > >>>>
      > >>>> Something about the Java source is nagging me, but I can't put my finger
      > >>>> on it.
      > >>>>
      > >>>> I'll flag for code, maybe they can be a little more helpful.
      > >>>>
      > >>>> On 2/19/2010 11:34 PM, djvandebrake wrote:
      > >>>>
      > >>>>> Sorry in advance. I'm sure this kind of topic comes up all the time.
      > >>>>>
      > >>>>> I'm using Ubuntu Linux, and have made sure I am using the Sun JRE of a workable version (1.6.0.0). I unzipped PCGen into a directory of my home folder, and created a link to the JAR file in my menu to run it. This link works - PCGen opens, and it asks me for source files. The very first time, it gave me some options, but at the time I was going through the documentation - I canceled, figuring I'd come back later. Every time after that, it has given me no options on sources to load, the game mode menu does not provide any options, and when I click the preferences the program shows a "Preferences..." loading message at the bottom of the screen, but nothing ever opens.
      > >>>>>
      > >>>>> I tried deleting everything (including hidden files) and re-extracting the Zip file. It asked me where to put the .pcgen folder again, which I took to be a good sign, but then once loaded asked me about source files and gave no options for campaign modes.
      > >>>>>
      > >>>>> I'd appreciate any help on this! Thanks!
      > >>>>>
      > >>>>>
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.