Loading ...
Sorry, an error occurred while loading the content.

5.16.2 Custom Items

Expand Messages
  • George
    I m having a problem with custom items. I hope it s just me, and I m doing something wrong. I have the option to save custom equipment to the
    Message 1 of 5 , Feb 9, 2010
    • 0 Attachment
      I'm having a problem with custom items. I hope it's just me, and I'm doing something wrong.

      I have the option to save custom equipment to the customequipment.lst file turned on. When I create an item using the customizer, it works just fine. I can add it to the character without any problems. When I close PCGen, I can see that the equipment is in the customequipment.lst file as it should be.

      The next time I run PCGen, I don't see the item in the equipment list. If I go to the customequipment.lst file, it is still there (for now). If I then close PCGen, the item is deleted from the customequipment.lst file.

      It appears to me that the program is not reading customequipment.lst as it should when the data is loaded, then saving all (and only) custom equipment that was generated in the current session to customequipment.lst, wiping out anything that was already there.

      Is anyone else seeing this behavior?

      Cheers,

      Sir George Anonymous
    • Andrew Maitland
      Hi George, Hm, interesting. Well, the good news is your item(s) are stored with the character, so even if your customfile is being overwritten (which sounds
      Message 2 of 5 , Feb 9, 2010
      • 0 Attachment
        Hi George,

        Hm, interesting. Well, the good news is your item(s) are stored with the character, so even if your customfile is being overwritten (which sounds like the case) nothing is truly lost on those characters.

        I'll flag code to see if they can find an issue with the customfile.

        CODE - Sounds like the customfile isn't retaining previous data entered from previous sessions.




        ________________________________
        From: George <lpacdavis@...>
        To: pcgen@yahoogroups.com
        Sent: Tue, February 9, 2010 2:59:36 AM
        Subject: [pcgen] 5.16.2 Custom Items

        I'm having a problem with custom items.  I hope it's just me, and I'm doing something wrong.

        I have the option to save custom equipment to the customequipment.lst file turned on.  When I create an item using the customizer, it works just fine.  I can add it to the character without any problems.  When I close PCGen, I can see that the equipment is in the customequipment.lst file as it should be.

        The next time I run PCGen, I don't see the item in the equipment list.  If I go to the customequipment.lst file, it is still there (for now).  If I then close PCGen, the item is deleted from the customequipment.lst file.

        It appears to me that the program is not reading customequipment.lst as it should when the data is loaded, then saving all (and only) custom equipment that was generated in the current session to customequipment.lst, wiping out anything that was already there.

        Is anyone else seeing this behavior?

        Cheers,

        Sir George Anonymous




        ------------------------------------

        Related Lists
        PCGen's release site: http://pcgen.sourceforge.net
        PCGen's Wiki: http://wiki.pcgen.org/
        PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
        PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
        PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
        PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html

        PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
        (for assistance in creating new homebrew or official list files)

        PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
        (for new official data source development)
        Yahoo! Groups Links



        [Non-text portions of this message have been removed]
      • George
        If I remember from a similar discussion from several years ago, one of the first data files that PCGen is supposed to read is the customequipment.lst file, and
        Message 3 of 5 , Feb 9, 2010
        • 0 Attachment
          If I remember from a similar discussion from several years ago, one of the first data files that PCGen is supposed to read is the customequipment.lst file, and one of the last things that happens when the program shuts down is the customequipment.lst file is written to with all of the custom data that is in the system at the time. If the file isn't read, the data isn't in the system to get written back out.

          I'm not too concerned about it for myself, because when I use the item customizer, it is typically so that I can see exactly what equipment modifiers need to be added to a custom piece of equipment that I then put into my personal .lst files. However, this could really throw a newbie for a loop, *and* it's in the production version!

          Cheers,

          Sir George Anonymous




          --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...> wrote:
          >
          > Hi George,
          >
          > Hm, interesting. Well, the good news is your item(s) are stored with the character, so even if your customfile is being overwritten (which sounds like the case) nothing is truly lost on those characters.
          >
          > I'll flag code to see if they can find an issue with the customfile.
          >
          > CODE - Sounds like the customfile isn't retaining previous data entered from previous sessions.
          >
          >
          >
          >
          > ________________________________
          > From: George <lpacdavis@...>
          > To: pcgen@yahoogroups.com
          > Sent: Tue, February 9, 2010 2:59:36 AM
          > Subject: [pcgen] 5.16.2 Custom Items
          >
          > I'm having a problem with custom items.  I hope it's just me, and I'm doing something wrong.
          >
          > I have the option to save custom equipment to the customequipment.lst file turned on.  When I create an item using the customizer, it works just fine.  I can add it to the character without any problems.  When I close PCGen, I can see that the equipment is in the customequipment.lst file as it should be.
          >
          > The next time I run PCGen, I don't see the item in the equipment list.  If I go to the customequipment.lst file, it is still there (for now).  If I then close PCGen, the item is deleted from the customequipment.lst file.
          >
          > It appears to me that the program is not reading customequipment.lst as it should when the data is loaded, then saving all (and only) custom equipment that was generated in the current session to customequipment.lst, wiping out anything that was already there.
          >
          > Is anyone else seeing this behavior?
          >
          > Cheers,
          >
          > Sir George Anonymous
          >
          >
          >
          >
          > ------------------------------------
          >
          > Related Lists
          > PCGen's release site: http://pcgen.sourceforge.net
          > PCGen's Wiki: http://wiki.pcgen.org/
          > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
          > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
          > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
          > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
          >
          > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
          > (for assistance in creating new homebrew or official list files)
          >
          > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
          > (for new official data source development)
          > Yahoo! Groups Links
          >
          >
          >
          > [Non-text portions of this message have been removed]
          >
        • karianna03
          *Bump*
          Message 4 of 5 , Feb 15, 2010
          • 0 Attachment
            *Bump*

            --- In pcgen@yahoogroups.com, "George" <lpacdavis@...> wrote:
            >
            > If I remember from a similar discussion from several years ago, one of the first data files that PCGen is supposed to read is the customequipment.lst file, and one of the last things that happens when the program shuts down is the customequipment.lst file is written to with all of the custom data that is in the system at the time. If the file isn't read, the data isn't in the system to get written back out.
            >
            > I'm not too concerned about it for myself, because when I use the item customizer, it is typically so that I can see exactly what equipment modifiers need to be added to a custom piece of equipment that I then put into my personal .lst files. However, this could really throw a newbie for a loop, *and* it's in the production version!
            >
            > Cheers,
            >
            > Sir George Anonymous
            >
            >
            >
            >
            > --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@> wrote:
            > >
            > > Hi George,
            > >
            > > Hm, interesting. Well, the good news is your item(s) are stored with the character, so even if your customfile is being overwritten (which sounds like the case) nothing is truly lost on those characters.
            > >
            > > I'll flag code to see if they can find an issue with the customfile.
            > >
            > > CODE - Sounds like the customfile isn't retaining previous data entered from previous sessions.
            > >
            > >
            > >
            > >
            > > ________________________________
            > > From: George <lpacdavis@>
            > > To: pcgen@yahoogroups.com
            > > Sent: Tue, February 9, 2010 2:59:36 AM
            > > Subject: [pcgen] 5.16.2 Custom Items
            > >
            > > I'm having a problem with custom items.  I hope it's just me, and I'm doing something wrong.
            > >
            > > I have the option to save custom equipment to the customequipment.lst file turned on.  When I create an item using the customizer, it works just fine.  I can add it to the character without any problems.  When I close PCGen, I can see that the equipment is in the customequipment.lst file as it should be.
            > >
            > > The next time I run PCGen, I don't see the item in the equipment list.  If I go to the customequipment.lst file, it is still there (for now).  If I then close PCGen, the item is deleted from the customequipment.lst file.
            > >
            > > It appears to me that the program is not reading customequipment.lst as it should when the data is loaded, then saving all (and only) custom equipment that was generated in the current session to customequipment.lst, wiping out anything that was already there.
            > >
            > > Is anyone else seeing this behavior?
            > >
            > > Cheers,
            > >
            > > Sir George Anonymous
            > >
            > >
            > >
            > >
            > > ------------------------------------
            > >
            > > Related Lists
            > > PCGen's release site: http://pcgen.sourceforge.net
            > > PCGen's Wiki: http://wiki.pcgen.org/
            > > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
            > > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
            > > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
            > > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
            > >
            > > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
            > > (for assistance in creating new homebrew or official list files)
            > >
            > > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
            > > (for new official data source development)
            > > Yahoo! Groups Links
            > >
            > >
            > >
            > > [Non-text portions of this message have been removed]
            > >
            >
          • Andrew Maitland
            Trackered - http://jira.pcgen-test.org/browse/CODE-14 ... -- Andrew Maitland (LegacyKing) Admin Silverback, PCGen Board of Directors Data Chimp, Docs Tamarin
            Message 5 of 5 , Feb 17, 2010
            • 0 Attachment
              Trackered -

              http://jira.pcgen-test.org/browse/CODE-14

              On 2/9/2010 2:59 AM, George wrote:
              > I'm having a problem with custom items. I hope it's just me, and I'm doing something wrong.
              >
              > I have the option to save custom equipment to the customequipment.lst file turned on. When I create an item using the customizer, it works just fine. I can add it to the character without any problems. When I close PCGen, I can see that the equipment is in the customequipment.lst file as it should be.
              >
              > The next time I run PCGen, I don't see the item in the equipment list. If I go to the customequipment.lst file, it is still there (for now). If I then close PCGen, the item is deleted from the customequipment.lst file.
              >
              > It appears to me that the program is not reading customequipment.lst as it should when the data is loaded, then saving all (and only) custom equipment that was generated in the current session to customequipment.lst, wiping out anything that was already there.
              >
              > Is anyone else seeing this behavior?
              >
              > Cheers,
              >
              > Sir George Anonymous
              >
              >
              >
              >
              > ------------------------------------
              >
              > Related Lists
              > PCGen's release site: http://pcgen.sourceforge.net
              > PCGen's Wiki: http://wiki.pcgen.org/
              > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
              > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
              > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
              > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
              >
              > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
              > (for assistance in creating new homebrew or official list files)
              >
              > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
              > (for new official data source development)
              > Yahoo! Groups Links
              >
              >
              >
              >
              >

              --

              Andrew Maitland (LegacyKing)
              Admin Silverback, PCGen Board of Directors
              Data Chimp, Docs Tamarin
              Unique Title "Quick-Silverback Tracker Monkey"
            Your message has been successfully submitted and would be delivered to recipients shortly.