Loading ...
Sorry, an error occurred while loading the content.

Re: [pcgen] Re: PCGEN+JRE+WIN7 = big lags and frequent lockups

Expand Messages
  • James Dempsey
    It will only display information from when you open it up (i.e. no history display from before you opened it), would I be right in assuming this was opened
    Message 1 of 16 , Nov 10, 2009
    • 0 Attachment
      It will only display information from when you open it up (i.e. no
      history display from before you opened it), would I be right in
      assuming this was opened after you had the slow-down? If so the ideal
      would be to set the logging level to info in the menu, open the
      console and then try to display the character preview.

      Cheers,
      James.

      2009/11/11 davisb97 <williamjdavis@...>:
      > Console looks mostly empty:
      >
      > --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:
      >>
      >> Anything in the console? See my previous email for details.
      >>
      >> Cheers,
      >> James.
      >>
      >> 2009/11/11 davisb97 <williamjdavis@...>:
      >> > PCGEN v5.16.1 did a full install with no customizations
      >> > Installed the Java 6 update 17 for x86 and x64
      >> > AMD 2.2g Quad Core with 8g RAM
      >> > Had it set for debugging but that really locks it up. Whole time I have been writing this email it has been trying to switch and display a character preview...
      >> > My system status doesn't show any sort of huge loads or capacity issues that would indicate a resource bottleneck.
      >> > 1) Open PCGen
      >> > 2) Load 3.5 player dataset
      >> > 3) Load character (character displays fast)
      >> > 4) UI is totally unresponsive on displayed character for 30 to 40 seconds
      >> > 5) UI reads changes and updates that tab flawlessly and fast
      >> > 6) change tab is now fine for everything except character preview. That takes a minute or 2 when it works. about 1/2 the time it is a total lock up after 5-10 minutes when I have to hard close the app from task manager
      >> > 7) closing app even after saving a character and not getting any prompts takes 2-3 minutes after clicking exit...
      >> >
      >> >
      >> >
      >> > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
      >> >>
      >> >>
      >> >>
      >> >> --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@> wrote:
      >> >> >
      >> >> > I just upgraded to Win7 x64 and installed the newest JRE for both 64 bit and 32 bit and clean installed PCGEN. And I see some huge lag in using PCGEN.
      >> >>
      >> >> What version of PCGen are you using?
      >> >>
    • spliskamatyshak
      It seems to be a Windows 7 64-bit issue. I have experienced this with almost every Java-based application I run. The window will just freeze and if you try
      Message 2 of 16 , Nov 11, 2009
      • 0 Attachment
        It seems to be a Windows 7 64-bit issue. I have experienced this with almost every Java-based application I run. The window will just freeze and if you try anything with the window it will display not responding. No Java messages and the task manager shows 98-99% idle. It just stops and comes back after a while. I am still trying to track down what is going on and of course MS is no help.

        --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:
        >
        > It will only display information from when you open it up (i.e. no
        > history display from before you opened it), would I be right in
        > assuming this was opened after you had the slow-down? If so the ideal
        > would be to set the logging level to info in the menu, open the
        > console and then try to display the character preview.
        >
        > Cheers,
        > James.
        >
        > 2009/11/11 davisb97 <williamjdavis@...>:
        > > Console looks mostly empty:
        > >
        > > --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@> wrote:
        > >>
        > >> Anything in the console? See my previous email for details.
        > >>
        > >> Cheers,
        > >> James.
        > >>
        > >> 2009/11/11 davisb97 <williamjdavis@>:
        > >> > PCGEN v5.16.1 did a full install with no customizations
        > >> > Installed the Java 6 update 17 for x86 and x64
        > >> > AMD 2.2g Quad Core with 8g RAM
        > >> > Had it set for debugging but that really locks it up. Whole time I have been writing this email it has been trying to switch and display a character preview...
        > >> > My system status doesn't show any sort of huge loads or capacity issues that would indicate a resource bottleneck.
        > >> > 1) Open PCGen
        > >> > 2) Load 3.5 player dataset
        > >> > 3) Load character (character displays fast)
        > >> > 4) UI is totally unresponsive on displayed character for 30 to 40 seconds
        > >> > 5) UI reads changes and updates that tab flawlessly and fast
        > >> > 6) change tab is now fine for everything except character preview. That takes a minute or 2 when it works. about 1/2 the time it is a total lock up after 5-10 minutes when I have to hard close the app from task manager
        > >> > 7) closing app even after saving a character and not getting any prompts takes 2-3 minutes after clicking exit...
        > >> >
        > >> >
        > >> >
        > >> > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
        > >> >>
        > >> >>
        > >> >>
        > >> >> --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@> wrote:
        > >> >> >
        > >> >> > I just upgraded to Win7 x64 and installed the newest JRE for both 64 bit and 32 bit and clean installed PCGEN. And I see some huge lag in using PCGEN.
        > >> >>
        > >> >> What version of PCGen are you using?
        > >> >>
        >
      • thpr
        I believe this is fixed in SVN 10532, which is a newer fix than 5.16.1. We hope to be putting out a release candidate of 5.16.2 in the near future, and I d be
        Message 3 of 16 , Nov 11, 2009
        • 0 Attachment
          I believe this is fixed in SVN 10532, which is a newer fix than 5.16.1. We hope to be putting out a release candidate of 5.16.2 in the near future, and I'd be very interested if this is still a problem in that RC.

          TP.

          --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@...> wrote:
          >
          > PCGEN v5.16.1 did a full install with no customizations
          > Installed the Java 6 update 17 for x86 and x64
          > AMD 2.2g Quad Core with 8g RAM
          > Had it set for debugging but that really locks it up. Whole time I have been writing this email it has been trying to switch and display a character preview...
          > My system status doesn't show any sort of huge loads or capacity issues that would indicate a resource bottleneck.
          > 1) Open PCGen
          > 2) Load 3.5 player dataset
          > 3) Load character (character displays fast)
          > 4) UI is totally unresponsive on displayed character for 30 to 40 seconds
          > 5) UI reads changes and updates that tab flawlessly and fast
          > 6) change tab is now fine for everything except character preview. That takes a minute or 2 when it works. about 1/2 the time it is a total lock up after 5-10 minutes when I have to hard close the app from task manager
          > 7) closing app even after saving a character and not getting any prompts takes 2-3 minutes after clicking exit...
          >
          >
          >
          > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
          > >
          > >
          > >
          > > --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@> wrote:
          > > >
          > > > I just upgraded to Win7 x64 and installed the newest JRE for both 64 bit and 32 bit and clean installed PCGEN. And I see some huge lag in using PCGEN.
          > >
          > > What version of PCGen are you using?
          > >
          >
        • ovka
          I hope so. I don t know that this is restricted to Win 7. My Win XP laptop does the same thing. I thought that I needed to rework my datasets because I
          Message 4 of 16 , Nov 12, 2009
          • 0 Attachment
            I hope so. I don't know that this is restricted to Win 7. My Win XP laptop does the same thing. I thought that I needed to rework my datasets because I haven't noticed it as much with the Pathfinder datasets (except when using conditional skills), but now I'm not so sure.

            Is there a practical limitation to the number of variables, ability categories, and abilities that PCGen can handle before a slowdown? How about the number of levels of nested abilities (i.e. class C1 calls ability A1 which calls ability A2 which grants points to a pool; an ability which grants ability A2L1 at 1st level, A2L3 at 3rd, and A2L5 at 5th is selected from the pool; A2L3 selects either ability A2L3G for good characters, A2L3E for evil characters or A2LeN for neutral characters; A2L3E in combination with feat F1 and class C2 grants ability A3; which grants either A3C or A3L or A3N depending on the other alignment component; etc.)?

            I'm definately interested in trying this out.

            Cheers,

            Sir George Anonymous


            --- In pcgen@yahoogroups.com, "thpr" <thpr@...> wrote:
            >
            > I believe this is fixed in SVN 10532, which is a newer fix than 5.16.1. We hope to be putting out a release candidate of 5.16.2 in the near future, and I'd be very interested if this is still a problem in that RC.
            >
            > TP.
            >
            > --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@> wrote:
            > >
            > > PCGEN v5.16.1 did a full install with no customizations
            > > Installed the Java 6 update 17 for x86 and x64
            > > AMD 2.2g Quad Core with 8g RAM
            > > Had it set for debugging but that really locks it up. Whole time I have been writing this email it has been trying to switch and display a character preview...
            > > My system status doesn't show any sort of huge loads or capacity issues that would indicate a resource bottleneck.
            > > 1) Open PCGen
            > > 2) Load 3.5 player dataset
            > > 3) Load character (character displays fast)
            > > 4) UI is totally unresponsive on displayed character for 30 to 40 seconds
            > > 5) UI reads changes and updates that tab flawlessly and fast
            > > 6) change tab is now fine for everything except character preview. That takes a minute or 2 when it works. about 1/2 the time it is a total lock up after 5-10 minutes when I have to hard close the app from task manager
            > > 7) closing app even after saving a character and not getting any prompts takes 2-3 minutes after clicking exit...
            > >
            > >
            > >
            > > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
            > > >
            > > >
            > > >
            > > > --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@> wrote:
            > > > >
            > > > > I just upgraded to Win7 x64 and installed the newest JRE for both 64 bit and 32 bit and clean installed PCGEN. And I see some huge lag in using PCGEN.
            > > >
            > > > What version of PCGen are you using?
            > > >
            > >
            >
          • thpr
            ... It is not. It is a defect I accidentally introduced some time ago when making another bug fix. The bug introduces an assumption into our code about the
            Message 5 of 16 , Nov 12, 2009
            • 0 Attachment
              --- In pcgen@yahoogroups.com, "ovka" <lpacdavis@...> wrote:
              > I hope so. I don't know that this is restricted to Win 7.

              It is not. It is a defect I accidentally introduced some time ago when making another bug fix. The bug introduces an assumption into our code about the behavior of a portion of the class libraries (and thus the JVM). I either assumed that was harmless (hope I didn't) or completely missed that I was making a dangerous assumption (wish I hadn't!)... don't know which is true, because the bug is nearly a year old.

              The interesting part (interesting is relative, I guess) is that the dependence on the underlying JVM alters performance characteristics based upon the data and the system being used. This makes it more or less of a problem in different types of hardware/data. We first encountered it on Macs, but later found 64-bit Windows and Win 7 tended to bring out the issue. More complex characters in complex data can also bring out the problem or make it worse.

              > Is there a practical limitation to the number of variables, ability categories, and abilities that PCGen can handle before a slowdown?

              The issue should primarily one of memory. We have slowly moved our lookups away from incremental lookups toward indexed lookups, so that has help scalability. There is still additional work to do, although a lot of steps have been taken in 5.17 in that direction. If there are performance issues that are not related to memory that we haven't addressed, we're interested in looking into them.

              Nested abilities will slow things slightly in 5.16 (and even 5.17 today), but I am in the middle of a set of changes that should eliminate any performance issues from recursive object addition in the 5.17 branch.

              TP.
            • ovka
              ... LOL! As a former programmer, I found it interesting. My company promoted me out of my programming responsibilities 6 years ago and I still miss it. ...
              Message 6 of 16 , Nov 12, 2009
              • 0 Attachment
                > The interesting part (interesting is relative, I guess)

                LOL! As a former programmer, I found it interesting. My company promoted me out of my programming responsibilities 6 years ago and I still miss it.


                > The issue should primarily one of memory. We have slowly moved our lookups away from incremental lookups toward indexed lookups, so that has help scalability. There is still additional work to do, although a lot of steps have been taken in 5.17 in that direction. If there are performance issues that are not related to memory that we haven't addressed, we're interested in looking into them.
                >
                > Nested abilities will slow things slightly in 5.16 (and even 5.17 today), but I am in the middle of a set of changes that should eliminate any performance issues from recursive object addition in the 5.17 branch.

                Sweet! I can hardly wait. 5.16 is already much better than the 5.4 version I started on. Now that I understand ability objects, I probably overuse them. :)


                Kudos and thanks to the entire team for everyone's hard work.

                Cheers,

                Sir George Anonymous
              • davisb97
                So, it is a bit convoluted, but I completely resolved the issue. I went to windows.com and downloaded the free VM client and Windows XP mode and installed it
                Message 7 of 16 , Nov 21, 2009
                • 0 Attachment
                  So, it is a bit convoluted, but I completely resolved the issue. I went to windows.com and downloaded the free VM client and Windows XP mode and installed it on there. it works great after a bit of a rough set up. I can even run it "seamlessly" straight from Win7 (a bit slow to open though). Should tide me over until a version that works better on win7.

                  --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@...> wrote:
                  >
                  > I just upgraded to Win7 x64 and installed the newest JRE for both 64 bit and 32 bit and clean installed PCGEN. And I see some huge lag in using PCGEN.
                  >
                  > 1) takes about 1 minute for any UI to be usable (clicking does nothing) after loading in a screen
                  > 2) takes about 1-2 minutes to switch tabs
                  > --- after a tab loads everything is very quick/responsive -----
                  > 3) forget about loading a character preview
                  > 4) Exporting to any file type completely fails with the console giving no specifics on why.
                  >
                  > I slightly impacted these times by upping the memory used by JRE in the .bat file from 256/512 to 1028/2056. That made load in zippy for dataset but UI is still lags horribly and I still can't export anything to any file type. Sits there with zero on the status bar for about 5 minutes and then fails with a "cannot export see console for details".
                  >
                  > JRE seems to run just fine on websites, speed tests, and the Java website verification. So I thought it might have to do with PCGEN and came here.
                  > So right now I am using to get the calcs right (like jump bonuses and synergy etc) and manually transfering to hardcopy, old skool :)
                  > Any advice?
                  >
                • James Dempsey
                  Hi, Thanks for the update - that s good to know. Have you tried 5.16.2 RC1 by any chance yet? Cheers, James. On 22/11/2009 1:23 AM davisb97 wrote
                  Message 8 of 16 , Nov 21, 2009
                  • 0 Attachment
                    Hi,

                    Thanks for the update - that's good to know.

                    Have you tried 5.16.2 RC1 by any chance yet?

                    Cheers,
                    James.

                    On 22/11/2009 1:23 AM davisb97 wrote
                    > So, it is a bit convoluted, but I completely resolved the issue. I went to windows.com and downloaded the free VM client and Windows XP mode and installed it on there. it works great after a bit of a rough set up. I can even run it "seamlessly" straight from Win7 (a bit slow to open though). Should tide me over until a version that works better on win7.
                    >
                    > --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@...> wrote:
                    >
                    >> I just upgraded to Win7 x64 and installed the newest JRE for both 64 bit and 32 bit and clean installed PCGEN. And I see some huge lag in using PCGEN.
                    >>
                    >> 1) takes about 1 minute for any UI to be usable (clicking does nothing) after loading in a screen
                    >> 2) takes about 1-2 minutes to switch tabs
                    >> --- after a tab loads everything is very quick/responsive -----
                    >> 3) forget about loading a character preview
                    >> 4) Exporting to any file type completely fails with the console giving no specifics on why.
                    >>
                    >> I slightly impacted these times by upping the memory used by JRE in the .bat file from 256/512 to 1028/2056. That made load in zippy for dataset but UI is still lags horribly and I still can't export anything to any file type. Sits there with zero on the status bar for about 5 minutes and then fails with a "cannot export see console for details".
                    >>
                    >> JRE seems to run just fine on websites, speed tests, and the Java website verification. So I thought it might have to do with PCGEN and came here.
                    >> So right now I am using to get the calcs right (like jump bonuses and synergy etc) and manually transfering to hardcopy, old skool :)
                    >> Any advice?
                    >>
                    >>
                    >
                    >
                    >
                    >
                    > ------------------------------------
                    >
                    > Related Lists
                    > PCGen's release site: http://pcgen.sourceforge.net
                    > PCGen's Wiki: http://wiki.pcgen.org/
                    > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
                    > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
                    > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
                    > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
                    >
                    > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
                    > (for assistance in creating new homebrew or official list files)
                    >
                    > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
                    > (for new official data source development)
                    > Yahoo! Groups Links
                    >
                    >
                    >
                    >
                    >
                  • davisb97
                    I did try that client. and it works great. so I dumped the workaround for now.
                    Message 9 of 16 , Nov 24, 2009
                    • 0 Attachment
                      I did try that client. and it works great. so I dumped the workaround for now.

                      --- In pcgen@yahoogroups.com, James Dempsey <jdempsey@...> wrote:
                      >
                      > Hi,
                      >
                      > Thanks for the update - that's good to know.
                      >
                      > Have you tried 5.16.2 RC1 by any chance yet?
                      >
                      > Cheers,
                      > James.
                      >
                      > On 22/11/2009 1:23 AM davisb97 wrote
                      > > So, it is a bit convoluted, but I completely resolved the issue. I went to windows.com and downloaded the free VM client and Windows XP mode and installed it on there. it works great after a bit of a rough set up. I can even run it "seamlessly" straight from Win7 (a bit slow to open though). Should tide me over until a version that works better on win7.
                      > >
                      > > --- In pcgen@yahoogroups.com, "davisb97" <williamjdavis@> wrote:
                      > >
                      > >> I just upgraded to Win7 x64 and installed the newest JRE for both 64 bit and 32 bit and clean installed PCGEN. And I see some huge lag in using PCGEN.
                      > >>
                      > >> 1) takes about 1 minute for any UI to be usable (clicking does nothing) after loading in a screen
                      > >> 2) takes about 1-2 minutes to switch tabs
                      > >> --- after a tab loads everything is very quick/responsive -----
                      > >> 3) forget about loading a character preview
                      > >> 4) Exporting to any file type completely fails with the console giving no specifics on why.
                      > >>
                      > >> I slightly impacted these times by upping the memory used by JRE in the .bat file from 256/512 to 1028/2056. That made load in zippy for dataset but UI is still lags horribly and I still can't export anything to any file type. Sits there with zero on the status bar for about 5 minutes and then fails with a "cannot export see console for details".
                      > >>
                      > >> JRE seems to run just fine on websites, speed tests, and the Java website verification. So I thought it might have to do with PCGEN and came here.
                      > >> So right now I am using to get the calcs right (like jump bonuses and synergy etc) and manually transfering to hardcopy, old skool :)
                      > >> Any advice?
                      > >>
                      > >>
                      > >
                      > >
                      > >
                      > >
                      > > ------------------------------------
                      > >
                      > > Related Lists
                      > > PCGen's release site: http://pcgen.sourceforge.net
                      > > PCGen's Wiki: http://wiki.pcgen.org/
                      > > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
                      > > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
                      > > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
                      > > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
                      > >
                      > > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
                      > > (for assistance in creating new homebrew or official list files)
                      > >
                      > > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
                      > > (for new official data source development)
                      > > Yahoo! Groups Links
                      > >
                      > >
                      > >
                      > >
                      > >
                      >
                    Your message has been successfully submitted and would be delivered to recipients shortly.