Loading ...
Sorry, an error occurred while loading the content.

Re: PCGen Pauses

Expand Messages
  • kc0elg_extra
    Probably one to two minutes a part between capture. I can space it out further if you need me to. Let me know.
    Message 1 of 15 , Sep 1, 2009
    • 0 Attachment
      Probably one to two minutes a part between capture. I can space it out further if you need me to. Let me know.

      --- In pcgen@yahoogroups.com, "thpr" <thpr@...> wrote:
      >
      >
      >
      > Well, that's disturbing. Both times you caught part of the UI performing an update... which may be more expensive than it should be. Any sense of how far apart in time the two captures were?
      >
      > Either way, I have a target to look at, so thanks for the info.
      >
      > TP.
      >
      > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
      > >
      > > Thanks for the quick reply. If I did your steps correctly the trace file looks like the following: Let me know if you need something different.
      > >
      > [snip]
      >
    • thpr
      And they were the same pause? (not trying to be rude, just double checking that I m interpreting the traces correctly)
      Message 2 of 15 , Sep 1, 2009
      • 0 Attachment
        And they were the same pause? (not trying to be rude, just double checking that I'm interpreting the traces correctly)

        --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@...> wrote:
        >
        > Probably one to two minutes a part between capture. I can space it out further if you need me to. Let me know.
        >
        > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
        > >
        > >
        > >
        > > Well, that's disturbing. Both times you caught part of the UI performing an update... which may be more expensive than it should be. Any sense of how far apart in time the two captures were?
        > >
        > > Either way, I have a target to look at, so thanks for the info.
        > >
        > > TP.
        > >
        > > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
        > > >
        > > > Thanks for the quick reply. If I did your steps correctly the trace file looks like the following: Let me know if you need something different.
        > > >
        > > [snip]
        > >
        >
      • kc0elg_extra
        No problem, yes they were the same pause. Probably closer to a minute apart then two minutes. Let me know if you need anything else from me or if you would
        Message 3 of 15 , Sep 1, 2009
        • 0 Attachment
          No problem, yes they were the same pause. Probably closer to a minute apart then two minutes. Let me know if you need anything else from me or if you would like another trace.

          --- In pcgen@yahoogroups.com, "thpr" <thpr@...> wrote:
          >
          >
          > And they were the same pause? (not trying to be rude, just double checking that I'm interpreting the traces correctly)
          >
          > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
          > >
          > > Probably one to two minutes a part between capture. I can space it out further if you need me to. Let me know.
          > >
          > > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
          > > >
          > > >
          > > >
          > > > Well, that's disturbing. Both times you caught part of the UI performing an update... which may be more expensive than it should be. Any sense of how far apart in time the two captures were?
          > > >
          > > > Either way, I have a target to look at, so thanks for the info.
          > > >
          > > > TP.
          > > >
          > > > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
          > > > >
          > > > > Thanks for the quick reply. If I did your steps correctly the trace file looks like the following: Let me know if you need something different.
          > > > >
          > > > [snip]
          > > >
          > >
          >
        • kc0elg_extra
          Any update on this issue? Any thoughts?
          Message 4 of 15 , Sep 5, 2009
          • 0 Attachment
            Any update on this issue? Any thoughts?

            --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@...> wrote:
            >
            > No problem, yes they were the same pause. Probably closer to a minute apart then two minutes. Let me know if you need anything else from me or if you would like another trace.
            >
            > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
            > >
            > >
            > > And they were the same pause? (not trying to be rude, just double checking that I'm interpreting the traces correctly)
            > >
            > > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
            > > >
            > > > Probably one to two minutes a part between capture. I can space it out further if you need me to. Let me know.
            > > >
            > > > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
            > > > >
            > > > >
            > > > >
            > > > > Well, that's disturbing. Both times you caught part of the UI performing an update... which may be more expensive than it should be. Any sense of how far apart in time the two captures were?
            > > > >
            > > > > Either way, I have a target to look at, so thanks for the info.
            > > > >
            > > > > TP.
            > > > >
            > > > > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
            > > > > >
            > > > > > Thanks for the quick reply. If I did your steps correctly the trace file looks like the following: Let me know if you need something different.
            > > > > >
            > > > > [snip]
            > > > >
            > > >
            > >
            >
          • thpr
            ... The trace is showing code that really shouldn t be hit, indicating something isn t working right. Are you using data from PCGen, or custom data? Do you
            Message 5 of 15 , Sep 5, 2009
            • 0 Attachment
              --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@...> wrote:
              >
              > Any update on this issue? Any thoughts?
              >

              The trace is showing code that really shouldn't be hit, indicating something isn't working right.

              Are you using data from PCGen, or custom data? Do you define any SOURCE*: tokens in that data if it's custom data?

              When you view the Abilities (Feat) tab, and sort by Source, are there any Abilities that are not sorted under the list of sources?

              TP.
            • Andrew Maitland
              thpr wrote: BUMP Our Coder Tom is trying to resolve this. Please reply here or by private Email... whatever works best. Thanks. ... -- Andrew Maitland
              Message 6 of 15 , Sep 10, 2009
              • 0 Attachment
                thpr wrote:

                BUMP

                Our Coder Tom is trying to resolve this. Please reply here or by private
                Email... whatever works best. Thanks.


                > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@...> wrote:
                >
                >> Any update on this issue? Any thoughts?
                >>
                >>
                >
                > The trace is showing code that really shouldn't be hit, indicating something isn't working right.
                >
                > Are you using data from PCGen, or custom data? Do you define any SOURCE*: tokens in that data if it's custom data?
                >
                > When you view the Abilities (Feat) tab, and sort by Source, are there any Abilities that are not sorted under the list of sources?
                >
                > TP.
                >
                >
                >
                >
                > ------------------------------------
                >
                > Related Lists
                > PCGen's release site: http://pcgen.sourceforge.net
                > PCGen's Wiki: http://wiki.pcgen.org/
                > PCGen's Roadmap: http://wiki.pcgen.org/index.php?title=Roadmap
                > PCGen's alpha build: http://pcgen.sourceforge.net/07_autobuilds.php
                > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
                > PCGen's Backup Autobuilds and Docs: http://pcgen.akozakis.id.au/autobuilds/download.html
                >
                > PCGen List File Help: http://tech.groups.yahoo.com/group/PCGenListFileHelp/
                > (for assistance in creating new homebrew or official list files)
                >
                > PCGen Experimental: http://tech.groups.yahoo.com/group/pcgen_experimental/
                > (for new official data source development)
                > Yahoo! Groups Links
                >
                >
                >
                >
                >

                --

                Andrew Maitland (LegacyKing)
                Admin Silverback, PCGen Board of Directors
                Data Chimp, Docs Tamarin
                Unique Title "Quick-Silverback Tracker Monkey"



                [Non-text portions of this message have been removed]
              • Michael Derbort
                Sorry for the delay. Been out of town for a couple of days. What can I do to help. ________________________________ From: Andrew Maitland
                Message 7 of 15 , Sep 11, 2009
                • 0 Attachment
                  Sorry for the delay. Been out of town for a couple of days. What can I do to help.




                  ________________________________
                  From: Andrew Maitland <drew0500@...>
                  To: pcgen@yahoogroups.com
                  Sent: Thursday, September 10, 2009 9:19:49 PM
                  Subject: Re: [pcgen] Re: PCGen Pauses


                  thpr wrote:

                  BUMP

                  Our Coder Tom is trying to resolve this. Please reply here or by private
                  Email... whatever works best. Thanks.

                  > --- In pcgen@yahoogroups. com, "kc0elg_extra" <kc0elg_extra@ ...> wrote:
                  >
                  >> Any update on this issue? Any thoughts?
                  >>
                  >>
                  >
                  > The trace is showing code that really shouldn't be hit, indicating something isn't working right.
                  >
                  > Are you using data from PCGen, or custom data? Do you define any SOURCE*: tokens in that data if it's custom data?
                  >
                  > When you view the Abilities (Feat) tab, and sort by Source, are there any Abilities that are not sorted under the list of sources?
                  >
                  > TP.
                  >
                  >
                  >
                  >
                  > ------------ --------- --------- ------
                  >
                  > Related Lists
                  > PCGen's release site: http://pcgen. sourceforge. net
                  > PCGen's Wiki: http://wiki. pcgen.org/
                  > PCGen's Roadmap: http://wiki. pcgen.org/ index.php? title=Roadmap
                  > PCGen's alpha build: http://pcgen. sourceforge. net/07_autobuild s.php
                  > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
                  > PCGen's Backup Autobuilds and Docs: http://pcgen. akozakis. id.au/autobuilds /download. html
                  >
                  > PCGen List File Help: http://tech. groups.yahoo. com/group/ PCGenListFileHel p/
                  > (for assistance in creating new homebrew or official list files)
                  >
                  > PCGen Experimental: http://tech. groups.yahoo. com/group/ pcgen_experiment al/
                  > (for new official data source development)
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >

                  --

                  Andrew Maitland (LegacyKing)
                  Admin Silverback, PCGen Board of Directors
                  Data Chimp, Docs Tamarin
                  Unique Title "Quick-Silverback Tracker Monkey"

                  [Non-text portions of this message have been removed]







                  [Non-text portions of this message have been removed]
                • kc0elg_extra
                  I m using default data from PCGEn no custom data. Did not see any abilities that were not sorted under the list of sources.
                  Message 8 of 15 , Sep 11, 2009
                  • 0 Attachment
                    I'm using default data from PCGEn no custom data. Did not see any abilities that were not sorted under the list of sources.

                    --- In pcgen@yahoogroups.com, "thpr" <thpr@...> wrote:
                    >
                    > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
                    > >
                    > > Any update on this issue? Any thoughts?
                    > >
                    >
                    > The trace is showing code that really shouldn't be hit, indicating something isn't working right.
                    >
                    > Are you using data from PCGen, or custom data? Do you define any SOURCE*: tokens in that data if it's custom data?
                    >
                    > When you view the Abilities (Feat) tab, and sort by Source, are there any Abilities that are not sorted under the list of sources?
                    >
                    > TP.
                    >
                  • thpr
                    Ok, I ve got it and now reproduced it. Don t have minutes, but certainly have long pauses that I can narrow down why they are happening. TM, a Bug please to
                    Message 9 of 15 , Sep 11, 2009
                    • 0 Attachment
                      Ok, I've got it and now reproduced it. Don't have minutes, but certainly have long pauses that I can narrow down why they are happening.

                      TM, a Bug please to keep track of this work.

                      TP.

                      --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@...> wrote:
                      >
                      > I'm using default data from PCGEn no custom data. Did not see any abilities that were not sorted under the list of sources.
                      >
                      > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
                      > >
                      > > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
                      > > >
                      > > > Any update on this issue? Any thoughts?
                      > > >
                      > >
                      > > The trace is showing code that really shouldn't be hit, indicating something isn't working right.
                      > >
                      > > Are you using data from PCGen, or custom data? Do you define any SOURCE*: tokens in that data if it's custom data?
                      > >
                      > > When you view the Abilities (Feat) tab, and sort by Source, are there any Abilities that are not sorted under the list of sources?
                      > >
                      > > TP.
                      > >
                      >
                    • Michael W. Fender
                      Trackered: 2857243 - Long Pauses https://sourceforge.net/tracker/?func=detail&aid=2857243&group_id=25576&atid=384719 Accessing file 12991.12993.14839 ... --
                      Message 10 of 15 , Sep 11, 2009
                      • 0 Attachment
                        Trackered:
                        2857243 - Long Pauses
                        https://sourceforge.net/tracker/?func=detail&aid=2857243&group_id=25576&atid=384719

                        Accessing file 12991.12993.14839

                        Data from user thpr is as follows:

                        > Ok, I've got it and now reproduced it. Don't have minutes, but certainly
                        > have long pauses that I can narrow down why they are happening.
                        >
                        > TM, a Bug please to keep track of this work.
                        >
                        > TP.
                        >
                        > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@...> wrote:
                        > > I'm using default data from PCGEn no custom data. Did not see any
                        > > abilities that were not sorted under the list of sources.
                        > >
                        > > --- In pcgen@yahoogroups.com, "thpr" <thpr@> wrote:
                        > > > --- In pcgen@yahoogroups.com, "kc0elg_extra" <kc0elg_extra@> wrote:
                        > > > > Any update on this issue? Any thoughts?
                        > > >
                        > > > The trace is showing code that really shouldn't be hit, indicating
                        > > > something isn't working right.
                        > > >
                        > > > Are you using data from PCGen, or custom data? Do you define any
                        > > > SOURCE*: tokens in that data if it's custom data?
                        > > >
                        > > > When you view the Abilities (Feat) tab, and sort by Source, are there
                        > > > any Abilities that are not sorted under the list of sources?
                        > > >
                        > > > TP.
                        >
                        --
                        Fluxxdog

                        The worst crime you can commit against another human being is to make them
                        think.
                      • thpr
                        ... I have fixed this in the Trunk (to the first order) - need to backport to 5.16 so if we release a 5.16.2 it will be captured there. TP.
                        Message 11 of 15 , Sep 11, 2009
                        • 0 Attachment
                          --- In pcgen@yahoogroups.com, "thpr" <thpr@...> wrote:
                          >
                          > Ok, I've got it and now reproduced it. Don't have minutes, but certainly have long pauses that I can narrow down why they are happening.
                          >
                          > TM, a Bug please to keep track of this work.
                          >
                          > TP.

                          I have fixed this in the Trunk (to the first order) - need to backport to 5.16 so if we release a 5.16.2 it will be captured there.

                          TP.
                        Your message has been successfully submitted and would be delivered to recipients shortly.