Loading ...
Sorry, an error occurred while loading the content.

99428Re: [pcgen][Eric] Re: Problems in Vista

Expand Messages
  • Andrew Maitland
    Apr 1, 2009
      Thanks much Sean.

      Eric, do we have a note like this in the FAQ part of the docs?

      If not I can add a tracker for it's inclusion.

      Andrew Maitland (LegacyKing)
      Admin Silverback, PCGen Board of Directors
      Data Chimp, Docs Tamarin
      Unique Title "Quick-Silverback Tracker Monkey"



      Sean Riley wrote:
      > Here is the path file that I needed before. With each new Java version, I've had to update the Path.
      >
      >
      > Here's what worked for Vista x64:
      >
      > PCGen should be installed in the C:\Program Files (x86) folder
      >
      > The .bat command line in the .bat file needs to be changed and should be:
      > "C:\Program Files (x86)\Java\jre1.6.0_06\bin\java" -Dswing.aatext=true -Xms128m -Xmx256m -jar pcgen.jar
      >
      > The path in the system\advanced properties\... should be:
      > ;C:\Program Files (x86)\Java\jre1.6.0_06\bin
      > Then Restart the computer, because that is ultimately what reset the path...
      >
      > Using the .bat file then works.
      >
      > You do not need to enter the command in the command prompt manually.
      >
      > Thanks for all of the help!!!!
      >
      > I look forward to continued use of PCGen!!!!
      >
      > Sean
      >
      > ----- Original Message -----
      > From: Andrew Maitland
      > To: pcgen@yahoogroups.com
      > Sent: Tuesday, March 31, 2009 3:28 PM
      > Subject: Re: [pcgen] Re: Problems in Vista
      >
      >
      > Hm, interesting. We need to open a bug report then.
      >
      > Also, permissions to directories is an issue IIRC for vista.
      >
      > My directories are not the standard. Try changing the save directory and
      > see if that has any effect.
      >
      > Can you post the majority of the error msg so the coders can see it please.
      >
      > Thanks,
      >
      > -Andrew
      >
      > magus_knightcrawler wrote:
      > > Got it running in Vista 64 by reinstalling most recent Java. But again won't save. Console gave some of this.
      > >
      > > java.io.FileNotFoundException: C:\Program Files\PCGen\PCGen5141\characters\Lusur.pcg (Access is denied)
      > > at java.io.FileOutputStream.open(Native Method)
      > > at java.io.FileOutputStream.<init>(Unknown Source)
      > >
      > > followed by about 60-70 lines that all end with (Unknown Source). Wouldn't let me copy paste the entire thing in. Also tried installing abosultely newest Java but no change.
      > >
      > > Knightcrawler
      > > Confused Ex-Data Ape
      > >
      > >
      > >
      > > --- In pcgen@yahoogroups.com, Andrew Maitland <drew0500@...> wrote:
      > >
      > >> Hi Magus Knightcrawler,
      > >>
      > >> Welcome back.
      > >>
      > >> I personally use PCGen on a Windows Vista Home Premium (Laptop) without
      > >> any issues. However, I haven't been trying to save any characters for
      > >> awhile, so something may have gotten broken since i last tried.
      > >>
      > >> Can you post any error messages in the console window. Something like
      > >> Out Of Memory could be the issue.
      > >>
      > >> As to the Bat file. Open one of them up and double the values 128 >
      > >> 256 | 256 > 512 That normally solves any memory issues.
      > >>
      > >> The two I can remember are Low Mem and the regular PCGen bat.
      > >>
      > >> Hope that helps, if not please post specific details so we can get to
      > >> the root of the problem.
      > >>
      > >> Andrew Maitland (LegacyKing)
      > >> Admin Silverback, PCGen Board of Directors
      > >> Data Chimp, Docs Tamarin
      > >> Unique Title "Quick-Silverback Tracker Monkey"
      > >>
      > >>
      > >>
      > >> magus_knightcrawler wrote:
      > >>
      > >>> Been away for a long, long time. Started using PCGen again. Have had several problems in Vista. First I just installed PCGen on my new Vista Home Premium laptop and it won't let me save any created characters. I've checked all the directories and they all look correct.
      > >>>
      > >>> Also we haven't been able to run it at all on a Vista x64 machine and the FAQ's about this are a little to vague. As to what .bat file we are supposed to edit and what we are supposed to add or delete. Thanks for any help.
      > >>>
      > >>> Knightcrawler
      > >>> Former, Data Ape
      > >>>
      > >>>
      > >>>
      > >>>
      >
      >
      > [Non-text portions of this message have been removed]
      >
      >
      >
      > ------------------------------------
      >
      > PCGen's Release site: http://pcgen.sourceforge.net
      > PCGen's Wiki: http://pcgen.wiki.sourceforge.net/
      > PCGen's Roadmap: http://pcgen.wiki.sourceforge.net/Roadmap
      > PCGen's Alpha Build: http://pcgen.sourceforge.net/07_autobuilds.php
      > PCGen's Online Docs: http://pcgen-test.org/autobuilds/pcgen-docs/index.html
      > PCGen's Data Help Grp: http://tech.groups.yahoo.com/group/PCGenListFileHelp/Yahoo! Groups Links
      >
      >
      >
      >
      >
    • Show all 16 messages in this topic