Loading ...
Sorry, an error occurred while loading the content.

blank modal in IE6

Expand Messages
  • flattesterik
    Hi Foteos, i m having problems displaying a modal popup in IE6. It works fine in Firefox so i have no clue at this moment why it s not working. It could be a
    Message 1 of 2 , Dec 6, 2007
    • 0 Attachment
      Hi Foteos,

      i'm having problems displaying a modal popup in IE6. It works fine in
      Firefox so i have no clue at this moment why it's not working. It
      could be a CSS-thing, but after a morning of arguing with my
      stylesheet i've found nothing so far.

      This is my HTML, maybe there's a chance you could see what's wrong in
      it, cause i'm lost.

      <SCRIPT src="js/iframecontentmws.js" type=text/javascript></SCRIPT>
      <SCRIPT src="js/overlibmws.js" type=text/javascript></SCRIPT>
      <SCRIPT src="js/overlibmws_draggable.js" type=text/javascript></SCRIPT>
      <script src="js/overlibmws_modal.js" type="text/javascript"></script>
      <SCRIPT src="js/overlibmws_filter.js" type=text/javascript></SCRIPT>
      <SCRIPT src="js/overlibmws_shadow.js" type=text/javascript></SCRIPT>

      <li><a onclick="return overlib(OLiframeContent('page.php?id=19',
      600, 600, 'if2', 4, 'auto'),
      WIDTH, 510, TEXTPADDING,0, BORDER,2, STICKY, '', CLOSECLICK,
      MOUSEOFF, OFFDELAY, 99999999,CAPTIONPADDING,4, CAPTION,'Toevoegen',
      MIDX,0, MIDY,0, MODAL, STATUS,'open: Message Window!', MODALCOLOR,
      '#FF7403',MODALOPACITY, '60', BGCOLOR, '#ffffff', CGCOLOR, '#cccccc',
      FGCOLOR,'#ffffff' );" href=javascript:void(0);> Add</a></li>

      Thanks in advance for reactions!

      Regards,
      Erik
    • Foteos Macrides
      Erik, There s nothing wrong with the markup you show, and it worked fine for IE when I tried it in a test document, substituting my own URL for the first
      Message 2 of 2 , Dec 6, 2007
      • 0 Attachment
        Erik,
         
        There's nothing wrong with the markup you show, and it worked fine for IE when I tried it in a test document, substituting my own URL for the first argument in the OLiframeContent call.  If your page.php?id=19 were taking a long time to reply, the popup would stay blank during that period, but eventually should show something, be it what was sought or an error message.
         
        The iframe content should not be affected by the parent's CSS, and vise versa.  This is in contrast to AJAX content, which does use the parent's CSS.  Try temporarily putting a direct link in the parent document:
         
        <a href="php?id=19" target="_blank">test</a>
         
        so that it displays in a new window rather than an iframe child, and see if IE has any problem with that.  If not, you can rule out a CSS issue.  Otherwise, do a right-click->View source in the iframe popup and/or the new window to see what page.php is returning, and keep looking for a CSS issue.
         
        Fote
        --
         
        ----- Original Message -----
        Sent: Thursday, December 06, 2007 8:39 AM
        Subject: [OLmws] blank modal in IE6

        Hi Foteos,

        i'm having problems displaying a modal popup in IE6. It works fine in Firefox so i have no clue at this moment why it's not working. It could be a CSS-thing, but after a morning of arguing with my stylesheet i've found nothing so far.

        This is my HTML, maybe there's a chance you could see what's wrong in it, cause i'm lost.

        <SCRIPT src="js/iframecontentmws.js" type=text/javascript></SCRIPT>
        <SCRIPT src="js/overlibmws.js" type=text/javascript></SCRIPT>
        <SCRIPT src="js/overlibmws_draggable.js" type=text/javascript></SCRIPT>
        <script src="js/overlibmws_modal.js" type="text/javascript"></script>
        <SCRIPT src="js/overlibmws_filter.js" type=text/javascript></SCRIPT>
        <SCRIPT src="js/overlibmws_shadow.js" type=text/javascript></SCRIPT>

        <li><a onclick="return overlib(OLiframeContent('page.php?id=19',
        600, 600, 'if2', 4, 'auto'),
        WIDTH, 510, TEXTPADDING,0, BORDER,2, STICKY, '', CLOSECLICK,
        MOUSEOFF, OFFDELAY, 99999999,CAPTIONPADDING,4, CAPTION,'Toevoegen',
        MIDX,0, MIDY,0, MODAL, STATUS,'open: Message Window!', MODALCOLOR,
        '#FF7403',MODALOPACITY, '60', BGCOLOR, '#ffffff', CGCOLOR, '#cccccc',
        FGCOLOR,'#ffffff' );" href=javascript:void(0);> Add</a></li>

        Thanks in advance for reactions!

        Regards,
        Erik
      Your message has been successfully submitted and would be delivered to recipients shortly.