Loading ...
Sorry, an error occurred while loading the content.
 

Re: "ocaml_beginners"::[] camlp4 or camlp5?

Expand Messages
  • Phil Tomson
    ... Good to know. Thanks. ... sorry, I said that in a bought of frustration as the situation seemed rather confusing. Now that a few more people have chimed
    Message 1 of 9 , Apr 28, 2008
      On 4/28/08, Martin Jambon <martin_jambon@...> wrote:

      >
      > On Sun, 27 Apr 2008, Phil Tomson wrote:
      >
      > >> while camlp4 >= 3.10 is largely incompatible with the earlier camlp4 and
      > >> camlp5.
      > >
      > > OK. That sounds, um, confusing. Is this by design? So it's camlp4
      > >> = 3.10 that all the cool kids are using now?
      >
      > I recommend using camlp4 3.10 because it is the official version of
      > camlp4 and we can't afford to have 2.
      >
      > I also recommend professional developers to stick with the official
      > syntax, not the revised one, for the same reason.

      Good to know. Thanks.
      >

      > > It's starting to sound like I should go learn Haskell.
      >
      > Why? As far as I know, Haskell doesn't have anything like camlp4, and you
      > do not have to use camlp4 for doing great things in OCaml.

      sorry, I said that in a bought of frustration as the situation seemed
      rather confusing. Now that a few more people have chimed in it makes
      some kind of sense.

      >
      > It's "just" that camlp4 allows you to define amazing domain-specific
      > languages embedded in OCaml, that you can distribute and install just like
      > libraries.
      >

      yes, that's the reason I want to learn camlp4.

      Phil

      > Martin
      >
      > --
      > http://wink.com/profile/mjambon
      > http://mjambon.com
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.