Loading ...
Sorry, an error occurred while loading the content.

Re: "ocaml_beginners"::[] Error when compiling deriving library

Expand Messages
  • Gabriel Scherer
    Libraries should install themselves through ocamlfind: you, as a user, shouldn t have any work to do to achieve that. In principle writing a META file for a
    Message 1 of 6 , Mar 17 10:31 AM
    • 0 Attachment
      Libraries should install themselves through ocamlfind: you, as a user,
      shouldn't have any work to do to achieve that.

      In principle writing a META file for a project is rather simple, but
      here as I'm unfamiliar with the software I'll pass the bucket. Jeremy,
      Jake, Grégoire, would any of you be motivated enough to provide a META
      file and install rules for the bare deriving project?

      On Sun, Mar 17, 2013 at 3:57 PM, Jason Yeo <jasonyeo88@...> wrote:
      > On Sun, Mar 17, 2013 at 7:07 PM, Gabriel Scherer
      > <gabriel.scherer@...> wrote:
      >>
      >> Update:
      >> https://github.com/jaked/deriving
      >> builds fine under 4.00.1
      >
      > Thanks. I cloned https://github.com/jaked/deriving and it compiled but
      > I have no idea how to install it using ocamlfind.
      >
      > Are there any documentations on using ocamlfind to install libraries
      > to my system?
      >
      > Thanks!
      >
      >
      > ------------------------------------
      >
      > Archives up to December 31, 2011 are also downloadable at http://www.connettivo.net/cntprojects/ocaml_beginners
      > The archives of the very official ocaml list (the seniors' one) can be found at http://caml.inria.fr
      > Attachments are banned and you're asked to be polite, avoid flames etc.Yahoo! Groups Links
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.