Loading ...
Sorry, an error occurred while loading the content.

Re: Problem with specifying package with OASIS

Expand Messages
  • Sylvain Le Gall
    Are you really using oasis 0.2 ? If it is not the case, try to use oasisformat: 0.3 at the beginning. Send me setup.ml, _tags and myocamlbuild.ml. Regards
    Message 1 of 2 , Oct 25, 2012
    • 0 Attachment
      Are you really using oasis 0.2 ?

      If it is not the case, try to use oasisformat: 0.3 at the beginning.

      Send me setup.ml, _tags and myocamlbuild.ml.

      Regards
      Sylvain
      Le 26 oct. 2012 08:03, "Johan Mazel" <johan.mazel@...> a écrit :

      > Hi
      > I am trying to compile a tool with OASIS instead of ocamlbuild.
      >
      > My _oasis file looks like this:
      > OASISFormat: 0.2
      > Name: XML_Analyzer
      > Version: 0.1
      > Synopsis: Something is happening.
      > Authors: Me.
      > License: GPL
      > BuildTools: ocamlbuild
      >
      > Executable XML_Analyzer
      > Path: src
      > MainIs: xml_analyzer.ml
      > CompiledObject: best
      > BuildDepends:
      > threads,batteries,core,core_extended,lacaml,str,xml-light,gsl
      >
      > I am getting an "Error: Unbound module Batteries". This is caused by
      > the fact that the compilation does not include a "-package
      > core,core_extended,..." flag for ocamlfind.
      >
      > However, if I add "true:
      > package(core,core_extended,batteries,lacaml,str,xml-light,gsl),
      > thread" in the _tags file the compilation is fine.
      > In this case, the "-package" flag is present.
      >
      > I think that my _oasis file is wrongly setup but I cannot find the problem.
      > Thanks for your time.
      > Regards.
      > Johan Mazel
      >


      [Non-text portions of this message have been removed]
    Your message has been successfully submitted and would be delivered to recipients shortly.